Jump to content

[1.11] RemoteTech v1.9.9 [2020-12-19]


Recommended Posts

Hello!
I have some question about antennas. In remote tech mode you need to have large range antennas on both sides of link to connect with vessel which is far away. But in real life link depends on sum of antennas gain (in logarithmic scale). If you start to lose signal of far away vessel (like Voaygers, for example) you can build bigger and more powerfull antenna on the Earth and you get signal again.

Why  not to dosimilar in remote tech?

 

Edited by VladTs
Link to comment
Share on other sites

5 hours ago, VladTs said:

Hello!
I have some question about antennas. In remote tech mode you need to have large range antennas on both sides of link to connect with vessel which is far away. But in real life link depends on sum of antennas gain (in logarithmic scale). If you start to lose signal of far away vessel (like Voaygers, for example) you can build bigger and more powerfull antenna on the Earth and you get signal again.

Why  not to dosimilar in remote tech?

 

its an option (that i used)

Link to comment
Share on other sites

  • 4 weeks later...

I love RemoteTech but I’m having a problem I can’t seem to resolve.  

So I have a sat in solar orbit fitted with a  CommTech-1 that is pointed at another sat in a large polar orbit around Kerbin which has a Reflectron GX-128. Both have electricity and the dishes are pointed at each other.  The sat in Kerbin orbit has control as it’s pointed at multiple other relays. The sat in solar orbit has no control.  Seems like it should. What am I missing? 

Thanks in advance 

Link to comment
Share on other sites

  • 2 months later...

I have noticed that remote tech 1.9.10 (and possibly earlier?) seems to break the antenna functionality of the default actions mod by snark. I should also mention that I'm using restock plus, but having that without RT seems fine. @TaxiService or anyone got ideas on this one?

I'm pretty sure these lines from the RemoteTech_Squad_Antennas.cfg are at fault, but I have no idea how to fix it (been out of practice with ksp and mm.cfgs for a few years):

...
	@MODULE[ModuleDeployableAntenna]
	{
		%name=ModuleAnimateGeneric
		...
	{

I've been messing around with the antennas patch for default actions, but nothing I try seems to work;

 

Spoiler

// Deployable antennas get "Toggle" added to group Custom03.
@PART[*]:HAS[@MODULE[ModuleDeployableAntenna]] {
    @description ^= :(.)$:$0 Antenna toggles via action group Custom03 by default.:
    MODULE {
        name = ModuleDefaultActionGroup
        moduleSource = ModuleDeployableAntenna
        actionGuiName = Toggle Antenna
        defaultActionGroup = Custom03
    }
}

// remoteTech antennas get "Toggle" added to group Custom03.
@PART[*]:HAS[@MODULE[ModuleRTAntenna]] {
    @description ^= :(.)$:$0 Antenna toggles via action group Custom03 by default.:
    MODULE {
        name = ModuleDefaultActionGroup
        moduleSource = ModuleRTAntenna
        actionGuiName = Toggle Antenna
        defaultActionGroup = Custom03
    }
}

 

Spoiler

// Deployable antennas get "Toggle" added to group Custom03.
@PART[*]:HAS[@MODULE[ModuleDeployableAntenna]]:AFTER[RemoteTech] {
    @description ^= :(.)$:$0 Antenna toggles via action group Custom03 by default.:
    MODULE {
        name = ModuleDefaultActionGroup
        moduleSource:NEEDS[!RemoteTech] = ModuleDeployableAntenna
        moduleSource:NEEDS[RemoteTech] = ModuleRTAntenna
        actionGuiName = Toggle Antenna
        defaultActionGroup = Custom03
    }
}

 

Edited by Errol
Link to comment
Share on other sites

On 6/15/2021 at 9:19 AM, Errol said:

I have noticed that remote tech 1.9.10 (and possibly earlier?) seems to break the antenna functionality of the default actions mod by snark. I should also mention that I'm using restock plus, but having that without RT seems fine. @TaxiService or anyone got ideas on this one?

I'm pretty sure these lines from the RemoteTech_Squad_Antennas.cfg are at fault, but I have no idea how to fix it (been out of practice with ksp and mm.cfgs for a few years):

I've been messing around with the antennas patch for default actions, but nothing I try seems to work;
 

Hi, this MM patch in Antennas_in_Custom03.cfg below is as far as I can go. RemoteTech converts ModuleDeployableAntenna to ModuleAnimateGeneric in all the antennas.

Spoiler
// Deployable antennas get "Toggle" added to group Custom03.
@PART[*]:HAS[@MODULE[ModuleDeployableAntenna]] {
	@description ^= :(.)$:$0 Antenna toggles via action group Custom03 by default.:
	MODULE {
		name = ModuleDefaultActionGroup
		moduleSource = ModuleDeployableAntenna
		actionGuiName = Toggle Antenna
		defaultActionGroup = Custom03
	}
}

//For RemoteTech antennas
@PART[*]:HAS[@MODULE[ModuleDeployableAntenna]]:NEEDS[RemoteTech]
{
	MODULE
	{
		name = ModuleDefaultActionGroup
		moduleSource = ModuleAnimateGeneric
		actionGuiName = toggle //#autoLOC_6001354
		defaultActionGroup = Custom03
	}
}

 

But for unknown reason, KSP doesn't localize ModuleAnimateGeneric's localization code to "toggle" when DefaultActionGroups hooks up a new antenna in VAB/SPH.

NIfW6Hn.png

Link to comment
Share on other sites

30 minutes ago, TaxiService said:

But for unknown reason, KSP doesn't localize ModuleAnimateGeneric's localization code to "toggle" when DefaultActionGroups hooks up a new antenna in VAB/SPH.

NIfW6Hn.png

I don't understand what you mean by this.

Link to comment
Share on other sites

On 6/17/2021 at 11:42 PM, Errol said:

I don't understand what you mean by this.

I think changes are needed in DefaultActionGroups for this behaviour of ModuleAnimateGeneric. It is not possible to get this mod to work with RemoteTech.

Link to comment
Share on other sites

On 6/17/2021 at 11:09 AM, TaxiService said:

Hi, this MM patch in Antennas_in_Custom03.cfg below is as far as I can go. RemoteTech converts ModuleDeployableAntenna to ModuleAnimateGeneric in all the antennas.

  Reveal hidden contents



// Deployable antennas get "Toggle" added to group Custom03.
@PART[*]:HAS[@MODULE[ModuleDeployableAntenna]] {
	@description ^= :(.)$:$0 Antenna toggles via action group Custom03 by default.:
	MODULE {
		name = ModuleDefaultActionGroup
		moduleSource = ModuleDeployableAntenna
		actionGuiName = Toggle Antenna
		defaultActionGroup = Custom03
	}
}

//For RemoteTech antennas
@PART[*]:HAS[@MODULE[ModuleDeployableAntenna]]:NEEDS[RemoteTech]
{
	MODULE
	{
		name = ModuleDefaultActionGroup
		moduleSource = ModuleAnimateGeneric
		actionGuiName = toggle //#autoLOC_6001354
		defaultActionGroup = Custom03
	}
}

 

But for unknown reason, KSP doesn't localize ModuleAnimateGeneric's localization code to "toggle" when DefaultActionGroups hooks up a new antenna in VAB/SPH.

NIfW6Hn.png

@Snark, is any of this actionable on your end?

Edited by Errol
Link to comment
Share on other sites

RemoteTech 1.9.11 for KSP 1.11.2 released

This release is a standard update for KSP 1.11.2.

What are fixed/changed:

  • Add a new misc option of stopping time wrap when a connection is found
  • Buff RA-15 and RA-100 antennas to be more comparable with Communotron HG-55 and CommTech-1 respectively
  • Add support for a new version of HG-20 antenna in ReStockPlus KSP 1.11 update

Complete changelog is below:

Spoiler

# Version 1.9.11
**Released June 19, 2021**

What's New?
===========

* Increase the range of RA-15 antenna from 10 Gm to 20 Gm and decrease the power drain rate from 1.10 to 0.95 to be more comparable with Communotron HG-55
* Increase the range of RA-100 antenna from 100 Gm to 250 Gm to be more comparable with CommTech-1
* Add a new misc option of stopping time wrap upon reconnection
* Add support for a new restock-relay-radial-2_v2 antenna (4 HighGain5 antennae stuck together) for RestockPlus KSP 1.11 update

Detailed Changelog
==================

Fixed Issues
------------

* Issue #827: Balance: Deployable/Relay Antennas [requested by: dbackstr]

Pull Requests
-------------

* PR #825: RestockPlus antenna name fix KSP 1.11 update [PR by: Wombatlord]

If you find any bug, please report them on our github (as it is hard to keep track of bugs here). Feedback is also welcome for the next release, here or on this post.

We are in the RT 2.x branch development and continue to support the RT 1.x branch.

Link to comment
Share on other sites

  • 3 weeks later...

RemoteTech 1.9.12 for KSP 1.12.1 released

This release is a recompilation for KSP 1.12.1.

What are fixed/changed:

  • Recompiled for KSP 1.12.1
  • Fixed the misposition of the signal delay interface due to the new alarm button

Complete changelog is below:

Spoiler

# Version 1.9.12
**Released July 10, 2021**

What's New?
===========

* Recompiled for KSP 1.12.1
* Fixed the mispositon of the signal delay interface

Detailed Changelog
==================

Fixed Issues
------------

Pull Requests
-------------

If you find any bug, please report them on our github (as it is hard to keep track of bugs here). Feedback is also welcome for the next release, here or on this post.

We are in the RT 2.x branch development and continue to support the RT 1.x branch.

Link to comment
Share on other sites

Can someone confirm if the multiple antenna modifier works on the latest release? I tried different values between 0 and 1 and I can't get more range out of my omni antennas than the base rate.

Link to comment
Share on other sites

Is it possible to add a toggle/re-enable the stock CommNet Probe Control and Pilot Assistance through RemoteTech? I know the late game RCL-01 can do it if it's in a station with 6 kerbals, but that seems excessive. There are toggles for all of the other big changes in RemoteTech but this one. Leaving the RCL-01 as the only multi-hop capable controller would be fine, I just want to be able to release a probe from a parent craft with pilots in it, and be able to control it from there rather than having to wait until I build my entire comm sat constellation and have all the added up signal lag.

Link to comment
Share on other sites

On 7/12/2021 at 11:37 PM, Dwrlesky said:

Can someone confirm if the multiple antenna modifier works on the latest release? I tried different values between 0 and 1 and I can't get more range out of my omni antennas than the base rate.

Hi, I verified it is working on the latest release. With 1 Comm-16 activated, the max range is 2.5Mm. With all 4 Comm-16 activated, the max range is 10Mm.

hXMiCTm.png

Part Action Menu could need connection statistics like this. I will look into this later.

On 7/12/2021 at 11:56 PM, thescaryone said:

Is it possible to add a toggle/re-enable the stock CommNet Probe Control and Pilot Assistance through RemoteTech? I know the late game RCL-01 can do it if it's in a station with 6 kerbals, but that seems excessive. There are toggles for all of the other big changes in RemoteTech but this one. Leaving the RCL-01 as the only multi-hop capable controller would be fine, I just want to be able to release a probe from a parent craft with pilots in it, and be able to control it from there rather than having to wait until I build my entire comm sat constellation and have all the added up signal lag.

Sorry, RemoteTech and CommNet are incompatible and Remote Pilot cannot be turned on.

But you can add 1-Kerbal remote command to a probe core, say RC-001S Remote Guidance Unit, in RemoteTech_Squad_Probes.cfg. It will give your parent craft with at least 1 kerbal inside to remotely control.

Spoiler
@PART[probeStackSmall]:FOR[RemoteTech]
{
	%MODULE[ModuleSPU] {
		%IsRTCommandStation = true //HERE
		%RTCommandMinCrew = 1 //HERE
	}
	
	%MODULE[ModuleRTAntennaPassive]	{
		%TechRequired = unmannedTech
		%OmniRange = 3000
		
		%TRANSMITTER {
			%PacketInterval = 0.3
			%PacketSize = 2
			%PacketResourceCost = 15.0
		}
	}
}

 

937qiBx.png

Link to comment
Share on other sites

  • 5 weeks later...

Got a weird problem in that the X button to shut down all engines doesn't seem to work on probes when signal delay is enabled, and if mechjeb is used to do a maneuver it doesn't actually shut down the engines but leaves them at a few %.

https://oshi.at/mPzMsm

Sometimes when the throttle is very low, X..kinda works? it like flutters and you have to press it multiple times for it to actually stick.

Link to comment
Share on other sites

I've just run into an issue with the M700 Survey Scanner not working. It seems the same issue was posted a couple years ago in the old thread. Is there already a fix for this in the mod, or has this just been overlooked?

 

Link to comment
Share on other sites

  • 3 weeks later...

When using the RemoteTech Antennas as a standalone mod, I notice that the Reflectron GX-128 starts extended, which makes fairing construction somewhat hard to handle for large interplanetary probes. Here's an example:

NOTE: The GX-128 is marked as the "Tigger" because I have CommNet Extension installed.

Spoiler

ceDiTNK.jpg
Stowed away...

ULufGc0.jpg
In fairing...

K4DGYyg.jpg
And it's clipped.

 

Edited by Interplanet Janet
Link to comment
Share on other sites

  • 3 weeks later...
  • 2 weeks later...

Regarding the standalone RemoteTech Antennas, is v0.1.1 really the latest release? It seems there are a few additional antennas in RemoteTech 1.9.12 (namely LongDish1, ShortDish2, & ShortAntenna1). Are these other antennas accessible, unnecessary, or not able to be standalone/used in conjunction with CommNet Antennas Extension?

Link to comment
Share on other sites

  • 1 month later...

Hi all, sorry for my prolonged absence. My graphic card is dying since last August, and the integrated GPU in my 2015 Intel CPU is not great. I am not able to find a reasonable graphic card replacement in light of the on-going global chip shortage.

Basically, I had to pause my mod development and fixing on hold for the time being. Over this weekend, I will re-compile first against KSP 1.12.2, check if it starts with no error, and release a next official version.

I will take look at new bug reports and queries at a later point.

Thanks

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...