tomek.piotrowski

[1.7, 1.3.1] RemoteTech v1.9.2 [2019-04-14]

Recommended Posts

Posted (edited)

[EDITED: pinpointed the issue] Does anyone have a good workaround to use pistons on a probe? I need to use them just once on orbit. If I have both probe module AND command pod, pistons don't work. They only work when there's no probe control modules on ship. :/ I tried disabling RT in config, didn't help. Removing RT, leaving only parts doesn't help either as then there are missing modules.

Edited by jamqdlaty

Share this post


Link to post
Share on other sites
On 8/24/2019 at 1:16 AM, Calvin_Maclure said:

Not getting a connection at KSC for some reason. Crafts in orbit are when in view of ground stations, but nothing at KSC... Also, having depleted batteries does not seem to affect connection.

KSP 1.6.1 / RP-1 / RO...

Logs: https://www.dropbox.com/sh/fkrbiavx1c3g8u0/AABvgUGRlOCNWEzt5vZUNJ_4a?dl=0

Thanks,

Sorry, I am not able to advise as I am not familiar with RP/RO mod.

 

22 hours ago, The-Doctor said:

Ok so how do I land a probe on say Duna using remote tech? How do you do the landing burns? I'm confused and past experiences was pretty bad

There is no Flight Computer command for this automatic landing. At minimum, you need to do by hands some maths of engine deltas, gravity force, suicide burn timing and others to queue a series of individual commands to land safely.

MechJeb2 may have this functionality and you should check out. There used to be a mod (Landertrons).

There is a workaround to the problem: park a remote control station (crewed and minimum of 6 kerbals) orbiting Duna to reduce the signal delay to 0 sec so that you can remote-control the probe to land.

 

14 hours ago, jamqdlaty said:

[EDITED: pinpointed the issue] Does anyone have a good workaround to use pistons on a probe? I need to use them just once on orbit. If I have both probe module AND command pod, pistons don't work. They only work when there's no probe control modules on ship. :/ I tried disabling RT in config, didn't help. Removing RT, leaving only parts doesn't help either as then there are missing modules.

Yes, there is one workaround. Get your crew out of the manned command pod (just hug the pod) and let the vessel to be remotely-controlled. After this, you can retract/extend the piston remotely. The problem is actually a stock bug, in which targetExtension set by player via PartActionMenu is not passed to targetPosition unlike other robotic parts like hinge.

Share this post


Link to post
Share on other sites
3 minutes ago, TaxiService said:

Yes, there is one workaround. Get your crew out of the manned command pod (just hug the pod) and let the vessel to be remotely-controlled. After this, you can retract/extend the piston remotely. The problem is actually a stock bug, in which targetExtension set by player via PartActionMenu is not passed to targetPosition unlike other robotic parts like hinge.

Thanks, actually few minutes ago came up with the idea to cheat it with F12 as it was for low Kerbin orbit anyway. I just created the thing with extended pistons and teleported it to orbit. Next time I face this issue I'll try what you said.

Share this post


Link to post
Share on other sites
Posted (edited)

Ok, I connected this part to space station and all robotics stopped working. Even other parts (not only pistons). Undocked, they're still not working. I've got connection, I've got power. All that robotic thing wiggles. Hinges are loose (motors are enabled, tried disabling and enabling), pistons extend and contract with station movement. Not sure if it's caused by RT, but seeing what kind of issues there were, my bet is this is related.

EDIT: It just... fixed itself at some point. I mean I still can't move pistons, but they're retracted and I can control other robotic parts.

Edited by jamqdlaty

Share this post


Link to post
Share on other sites

Does this have any support for RPM or MAS?

I am wondering how hard it would be to implement the flight computer on a rpm screen, and also implement the signal information on a rpm screen.

Share this post


Link to post
Share on other sites

Two questions about Command Stations- firstly do they eliminate the need to connect to the launch centre entirely, or simply reduce the lag?

 

Secondly, once you have the requirements, how do you actually *set one up*?  Do you need to do anything to activate it, or...

Share this post


Link to post
Share on other sites

UPDATE: As it turns out, *something* in that save in particular was corrupted, not sure what.  At least I hadn't gotten *too* far already.  

Share this post


Link to post
Share on other sites

I guess I'm a little confused how range is calculated, maybe you guys can explain where I'm getting it wrong.

I'm using Remote Tech with the root range model activated, and as suggested, turned range of all antennae down to 0.5x.

I have a small constellation of 5 relays with Communotron 16s (range 1.25 Mm) in a pentagon around Kerbin at 1.2Mm orbital altitude. I put another satellite in a polar orbit with a Communotron 16, so it can communicate with the constellation around Kerbin, and then a Reflectron KR-7 (range 45 Mm) pointed at the Mun. I then sent out a probe to orbit the Mun, also equipped with a Communotron 16 (just for maneuvers near Kerbin) and a Reflectron Kr-7, which once I got underway I pointed back at Kerbin. The Mun is at 11.4 Mm from Kerbin, so my probe should lose connection with the pentagon contellation of omnidirectional antennae satellites at around 8.75 Mm away from Kerbin - that's given by min(45,1.25)+sqrt(45*1.25), which should be the range the Communotron 16 and Reflectron KR-7 can communicate. The probe's only connection should be with the polar orbit satellite that also has a Reflectron KR-7. But what I'm seeing is that even in orbit around the moon way out at 11.4 Mm, well past the limit of 8.75 Mm, it's still communicating with all of the omnidirectional-only satellites as well. How could that be?

Share this post


Link to post
Share on other sites

@TaxiService I'm trying to get RT working with the OctoSat command modules

The mod works fine with the patch bundled in for the dedicated antenna parts, but the three probe core parts all include integrated, deploy-able antenna, and I can't get them to actually work- here's the raw code of what I *currently* have for them.  

@PART[OctoSat_Com_HalfTop]:NEEDS[RemoteTech]
{
	!MODULE[ModuleDataTransmitter] {}
	!MODULE[SelectableDataTransmitter] {}
	@MODULE[ModuleAnimateGeneric]
	{
		%allowManualControl = false
	}
	
	%MODULE[ModuleRTAntenna] {
		%Mode0OmniRange = 0
		%Mode1OmniRange = 5000000
		%EnergyCost = 0.6
		%MaxQ = 3000
		
		%DeployFxModules = 0
		%ProgressFxModules = 0
		
		%TRANSMITTER {
			%PacketInterval = 0.3
			%PacketSize = 2
			%PacketResourceCost = 15.0
		}
	}
	
	%MODULE[ModuleSPU] {}
}

@PART[OctoSat_Com_Core]:NEEDS[RemoteTech]
{
	!MODULE[ModuleDataTransmitter] {}
	!MODULE[SelectableDataTransmitter] {}
	@MODULE[ModuleAnimateGeneric]
	{
		%allowManualControl = false
	}
	
	%MODULE[ModuleRTAntenna] {
		%Mode0OmniRange = 0
		%Mode1OmniRange = 7500000
		%EnergyCost = 0.6
		%MaxQ = 3000
		
		%DeployFxModules = 0
		%ProgressFxModules = 0
		
		%TRANSMITTER {
			%PacketInterval = 0.3
			%PacketSize = 2
			%PacketResourceCost = 15.0
		}
	}
	
	%MODULE[ModuleSPU] {}
}

@PART[OctoSat_Com_Side]:NEEDS[RemoteTech]
{
	!MODULE[ModuleDataTransmitter] {}
	!MODULE[SelectableDataTransmitter] {}
	@MODULE[ModuleAnimateGeneric]
	{
		%allowManualControl = false
	}
	
	%MODULE[ModuleRTAntenna] {
		%Mode0DishRange = 0
		%Mode1DishRange = 50000000
		%EnergyCost = 0.82
		%MaxQ = 6000
		%DishAngle = 45.0
		
		%DeployFxModules = 0
		%ProgressFxModules = 1
		
		%TRANSMITTER {
			%PacketInterval = 0.3
			%PacketSize = 2
			%PacketResourceCost = 15.0
		}
	}
	
	%MODULE[ModuleSPU] {}
}

 

Any hints on what I'm doing wrong, or is RT flat-out not made to do this?

Share this post


Link to post
Share on other sites
On 9/3/2019 at 8:39 AM, horngeek said:

@TaxiService would it be possible to make this mod compatible with Dynamic Battery Storage?  At the moment, that mod doesn't pick up RemoteTech antenna, and it'd be *really* helpful for judging whether a probe has enough storage available.  

Here you go though it is pending my minor correction on that inconsistent readings.

On 9/4/2019 at 1:38 PM, bobisback said:

Does this have any support for RPM or MAS?

I am wondering how hard it would be to implement the flight computer on a rpm screen, and also implement the signal information on a rpm screen.

Sorry, there isn't any support because it needs major amount of efforts to implement RPM interface and wire it to the component.

On 9/5/2019 at 3:57 PM, horngeek said:

Two questions about Command Stations- firstly do they eliminate the need to connect to the launch centre entirely, or simply reduce the lag?

 

Secondly, once you have the requirements, how do you actually *set one up*?  Do you need to do anything to activate it, or...

For the first question, it is both benefits. It acts as a local control point controlling nearby probes far away from home.

Second, to qualify for Command Station, any vessel needs to have min crew of 6 Kerbals, 1 or more antenna for comm and 1 giant probe core (I think it is called RC-L01 Remote Guidance Unit).

On 9/9/2019 at 8:33 AM, horngeek said:

@TaxiService I'm trying to get RT working with the OctoSat command modules

The mod works fine with the patch bundled in for the dedicated antenna parts, but the three probe core parts all include integrated, deploy-able antenna, and I can't get them to actually work- here's the raw code of what I *currently* have for them.  

<snipped>

Any hints on what I'm doing wrong, or is RT flat-out not made to do this?

Some time ago (40 page here?), I saw someone else accomplishing a similar mod (1 full-functionality part looking like an actual satellite) using this approach.

You need to combine the majority of the patches for antenna and command parts into 1 patch for the specific part. Below may look like.

@PART[probeCoreSphere]:FOR[RemoteTech]
{
  	//COMMAND
	%MODULE[ModuleSPU] {
	}
	
	%MODULE[ModuleRTAntennaPassive]	{
		%TechRequired = unmannedTech
		%OmniRange = 3000
		
		%TRANSMITTER {
			%PacketInterval = 0.3
			%PacketSize = 2
			%PacketResourceCost = 15.0
		}
	}
  
  	//ANTENNA
  	@MODULE[ModuleDeployableAntenna]
	{
		%name=ModuleAnimateGeneric
		%allowManualControl = false
		%actionAvailable = false
		%eventAvailableFlight = false
		%eventAvailableEditor = false
		%eventAvailableEVA = false
	}
	
	%MODULE[ModuleRTAntenna] {
		%Mode0OmniRange = 0
		%Mode1OmniRange = 2500000
		%MaxQ = 6000
		%EnergyCost = 0.13
		
		%DeployFxModules = 0
		
		%TRANSMITTER {
			%PacketInterval = 0.3
			%PacketSize = 2
			%PacketResourceCost = 15.0
		}
	}
}

 

Edited by TaxiService

Share this post


Link to post
Share on other sites

Hey everyone, just wondering if there's a way I can uninstall/disable this mod and use the default CommNet without killing all my existing ships? This mod seems to be costing me 15-20 FPS :(

 

EDIT: Okay, so disabling the dll and deleting all .cfg s EXCEPT the settings file disables all remotetech antennae and reverts the stock antennae to stock behaviour. Why can't I delete the settings file - why is it even being accessed? And is this a safe configuration, can I leave it like this indefinitely? Sorry if this has been discussed before. Any help would be appreciated.

Here's my mod list:

000_ClickThroughBlocker
000_Toolbar
000_USITools
001_ToolbarControl
Astrogator
B9PartSwitch
BetterBurnTime
BonVoyage
Chatterer
CommunityCategoryKit
CommunityResourcePack
CommunityTechTree
CorrectCOL
CrewRandR
CrowdSourcedScience
DeployableEngines
DistantObject
DMagicOrbitalScience
DynamicBatteryStorage
EasyVesselSwitch
EditorExtensionsRedux
EnvironmentalVisualEnhancements
HideEmptyTechTreeNodes
KAS
KerbalAtomics
KerbalChangelog
KerbalConstructionTime
KerbalEngineer
KerbalJointReinforcement
KIS
kOS
KSP-AVC
MagiCore
MemGraph
ModularFlightIntegrator
NavBallDockingAlignmentIndicatorCE
NavHud
NearFutureConstruction
NearFutureElectrical
NearFutureLaunchVehicles
NearFutureProps
NearFuturePropulsion
NearFutureSolar
NearFutureSpacecraft
NehemiahInc
Nereid
PersistentRotation
PlanetaryBaseInc
PlanetShine
PreciseNode
ProbesBeforeCrew
RealPlume
RealPlume-Stock
REPOSoftTech
RT-Stub
SCANsat
ScrapYard
Severedsolo
SmokeScreen

StageRecovery
StationPartsExpansionRedux
StockVisualEnhancements
TacFuelBalancer
TextureReplacer
ThunderAerospace
TriggerTech
UmbraSpaceIndustries
UniversalStorage2
Wwwwwwwww
XyphosAerospace

Edited by Homozygote

Share this post


Link to post
Share on other sites
2 hours ago, Homozygote said:

Hey everyone, just wondering if there's a way I can uninstall/disable this mod and use the default CommNet without killing all my existing ships? This mod seems to be costing me 15-20 FPS :(

 

EDIT: Disabling the dll and deleting the squad configs causes a couple of NREs every time I load a craft/launch a new one. Any ideas?

 

I can confirm this. After having like 5 fps on my base and removing the RT mod, it became 10fps+ :D

RT spams a lot of these:

Spoiler

[LOG 20:52:58.854] [RemoteTech] ModuleRTAntennaPassive: OnDestroy
[LOG 20:52:58.855] [RemoteTech] ModuleSPU: OnDestroy [Base Iota 1]
[LOG 20:52:58.855] [RemoteTech] SatelliteManager: Unregister(ModuleSPU(Base Iota 1, 00000000-0000-0000-0000-000000000000))
[LOG 20:52:58.856] [RemoteTech] ModuleRTAntennaPassive: OnDestroy
[LOG 20:52:58.856] [RemoteTech] ModuleSPU: OnDestroy [Base Iota 1]
[LOG 20:52:58.856] [RemoteTech] SatelliteManager: Unregister(ModuleSPU(Base Iota 1, 00000000-0000-0000-0000-000000000000))
[LOG 20:52:58.857] [RemoteTech] ModuleRTAntennaPassive: OnDestroy
[LOG 20:52:58.857] [RemoteTech] ModuleSPU: OnDestroy [Base Iota 1]
[LOG 20:52:58.857] [RemoteTech] SatelliteManager: Unregister(ModuleSPU(Base Iota 1, 00000000-0000-0000-0000-000000000000))
[LOG 20:52:58.857] [RemoteTech] ModuleRTAntennaPassive: OnDestroy
[LOG 20:52:58.858] [RemoteTech] ModuleSPU: OnDestroy [Base Iota 1]
[LOG 20:52:58.858] [RemoteTech] SatelliteManager: Unregister(ModuleSPU(Base Iota 1, 00000000-0000-0000-0000-000000000000))
[LOG 20:52:58.858] [RemoteTech] ModuleRTAntennaPassive: OnDestroy
[LOG 20:52:58.858] [RemoteTech] ModuleSPU: OnDestroy [Base Iota 1]
[LOG 20:52:58.858] [RemoteTech] SatelliteManager: Unregister(ModuleSPU(Base Iota 1, 00000000-0000-0000-0000-000000000000))
[LOG 20:52:58.859] [RemoteTech] ModuleRTAntennaPassive: OnDestroy
[LOG 20:52:58.859] [RemoteTech] ModuleSPU: OnDestroy [Base Iota 1]
[LOG 20:52:58.859] [RemoteTech] SatelliteManager: Unregister(ModuleSPU(Base Iota 1, 00000000-0000-0000-0000-000000000000))
[LOG 20:52:58.859] [RemoteTech] ModuleRTAntennaPassive: OnDestroy
[LOG 20:52:58.860] [RemoteTech] ModuleSPU: OnDestroy [Base Iota 1]
[LOG 20:52:58.860] [RemoteTech] SatelliteManager: Unregister(ModuleSPU(Base Iota 1, 00000000-0000-0000-0000-000000000000))

Mods installed:
 

Spoiler

************************************************************************

Environment Info
Win32NT 7FFFFFFFFFFFFFFF  Args: KSP_x64.exe -force-d3d11

Mod DLLs found:
// NOTE: MiniAVC entities were mostly stripped from the log
// There was a lot of them.

Stock assembly: Assembly-CSharp v0.0.0.0
ModuleManager v4.0.3.0
unBlur v0.5.0.0
000_AT_Utils v1.8.1.0
001_AnisotropicPartResizer v1.3.0.0
002_MultiAnimators v1.1.0.2
0_00_AT_Utils_UI v1.0.0.0
ConfigurableContainers v2.4.6.0
SubmodelResizer v1.0.0.0

ClickThroughBlocker v0.1.7.2 / v1.0.0.0
BlendshapeModelLoader v1.0.0.0
TexturesUnlimited v0.0.0.0

aaa_Toolbar v1.7.22.2

USITools v1.0.0.0

ToolbarControl v0.1.8.2 / v1.0.0.0
B9AnimationModules v1.5.1.0 / vv1.5.1
B9PartSwitch v2.10.0.0 / vv2.10.0
B9_Aerospace_WingStuff v0.50.0.0
BonVoyage v0.5.3.0
Chatterer v0.9.96.2332

CollisionFXUpdated v5.0.0.0
CCK v4.3.0.0 / v4.1.0.0 for KSP 1.6.0
ContractConfigurator v1.0.0.0 / v1.27.1
RemoteTech v1.9.0.0 / v1.9.3
CC_RemoteTech v1.0.0.0 / v1.27.1
DeadlyReentry v7.7.3.0
DestructionEffects v1.10.0.0

AGExt v2.3.5.0 / v1.0.0.0
DistantObject v1.9.1.14505
DMagic v1.4.2.0 / vv1.4.2.0
ProgressParser v1.0.10.0 / vv10.0
ContractParser v1.0.8.0 / vv8.0
CapCom v1.0.2.10 / vv2.10
ContractsWindow v1.0.9.3 / vv9.3
ContractsWindow.Unity v1.0.9.3
DynamicBatteryStorage v1.0.0.0
EasyVesselSwitch v1.11.7052.36539 / v1.11 for KSP v1.7+
KSPDev_Utils.1.2 v1.2.7031.33522 / v1.2 for KSP v1.6+


EditorExtensionsRedux v3.3.22.0
EngineLight v1.0.0.0
Atmosphere v1.7.3.0
CelestialShadows v1.7.3.0
CityLights v1.7.3.0
EVEManager v1.7.3.0
PartFX v1.7.3.0
PQSManager v1.7.3.0
ShaderLoader v1.7.3.0
Terrain v1.7.3.0
TextureConfig v1.7.3.0
Utils v1.7.3.0
_BuildManager v1.7.3.0
Launchpad v6.6.1.0 / v6.6.1
ModularFlightIntegrator v1.0.0.0 / v1.2.6.0
FerramAerospaceResearch v0.15.11.1
ferramGraph v1.3.0.0
Scale_Redist v1.0.0.0
Firespitter v7.3.7175.38653

FShangarExtender v3.5.5.0 / v3.5.0.0
GPPTextureChecker v0.0.0.0
KerbalRenamer v1.0.0.0
SuitProg v0.0.0.0
Sigma88LoadingScreens v0.4.0.0
GroundConstruction v2.4.1.0

HullCamera v0.1.13.0
InterstellarFuelSwitch v3.8.8.4

Scale_Redist v1.0.0.0

JanitorsCloset v0.3.6.1 / v1.0.0.0
RasterPropMonitor v0.30.6.14937

KaptainsLog v0.1.7.1 / v1.0.0.0
KAS-API-v2 v2.0.7037.1430 / vKAS API v2
KAS v1.4.7097.36908 / v1.4 for KSP 1.7.1+
KSPDev_Utils.1.2 v1.2.7031.33522 / v1.2 for KSP v1.6+


KerbalConstructionTime v1.4.6.0
KerbalEngineer v1.1.6.0
KerbalEngineer.Unity v1.0.0.0

KerbalHealth v1.3.7.0
KerbalJointReinforcement v3.4.1.0
HyperEdit v1.5.8.0 / v1.5.8
KIS v1.22.7090.200 / v1.22 for KSP 1.7+
KSPDev_Utils.1.2 v1.2.7031.33522 / v1.2 for KSP v1.6+

Kopernicus.Parser v1.0.0.0
Kopernicus v1.0.0.0

KRASH v0.5.30.2 / v1.0.0.0

KronalUtils v0.0.10.0 / v1.0.0.0
KSP-AVC v1.3.1.0
KSPWheel v0.0.0.0

MagiCore v1.3.1.6 / v1.0.0.0 / v1.3.1.0
MechJeb2 v2.5.1.0 / v / v2.8.4.0

MemGraph v1.1.3.0

NavBallDockingAlignmentIndicatorCE v1.0.5.0 / v1.0.0.0
DockingPortAlignmentIndicator v1.0.0.0
DPAI_RPM v1.0.0.0
ModuleDockingNodeNamed v1.0.0.0
NearFutureElectrical v1.0.0.0
NFPropUtils v1.0.0.0
NearFuturePropulsion v0.9.0.0
NearFutureSolar v0.4.0.0

NE_Science v0.8.3.39 / v0.8.3 for KSP 1.7+
PlanetarySurfaceStructures v1.6.9.0
RealChute v1.4.7042.4724 / v1.4.7.4
ReentryParticleEffect v1.3.0.0
RSEAudio v1.0.6941.22077
SCANsat v1.8.13.0 / vv18.13
SCANmechjeb v1.8.13.0 / vv18.13
SCANsat.Unity v1.8.13.0
scatterer v0.0.0.0

CLSInterfaces v1.2.0.0
ShipManifest v5.2.1.0

SmartParts v1.9.13.8
SmokeScreen v2.8.5.0

KSP_ColorPicker v0.0.1.0 / v1.0.0.0
KSP_Log v0.0.1.0 / v1.0.0.0
KSP_PartHighlighter v0.0.1.0 / v1.0.0.0
Stock assembly: KSPSteamCtrlr v0.0.1.35

SSTUTools v0.0.0.0

StageRecovery v1.9.1.4 / v1.8.0.0

StateFunding v0.6.17.1 / v0.5.0.0
HabUtils v1.0.0.0
StationScience v1.0.0.0
SEPScience v1.2.6.0 / v2.6
SEPScience.Unity v1.2.6.0
SurfaceExperimentPack v1.4.2.0

SurfaceLights v1.13.7052.37376 / v1.13 for KSP v1.7+
TCA.UI v1.0.0.0
ThrottleControlledAvionics v3.5.7.0
TimeControl v2.9.6.0
TrajectoriesBootstrap v1.0.0.0
KerbalAlarmClock v3.11.0.0
KSPAlternateResourcePanel v2.9.3.0
Konstruction v0.0.0.0
USILifeSupport v1.0.0.0
KolonyTools v1.0.0.0
UniversalStorage2 v1.5.1.8 / vv1.5.1.8
UniversalStorage2.Unity v1.5.1.8

VesselView v0.8.7.2 / v1.0.0.0
VesselViewPlugin v0.8.7.2 / v1.0.0.0
VesselViewRPM v0.8.7.2 / v1.0.0.0
VVDiscoDisplay v0.8.7.2 / v1.0.0.0
VVPartSelector v0.8.7.2 / v1.0.0.0
WaypointManager v1.0.0.0 / v2.7.5
BARISBridge v1.0.0.0
BARIS v1.0.0.0


KerbalActuators v1.0.0.0

Workshop v1.2.11.0 / v1.2.5

[x] Science! v5.22.7074.4176

Folders and files in GameData:
000_AT_Utils
000_ClickThroughBlocker
000_TexturesUnlimited
000_Toolbar
000_USITools
001_ToolbarControl
B9AnimationModules
B9PartSwitch
B9_Aerospace
B9_Aerospace_ProceduralWings
BLO
BonVoyage
Chatterer
CollisionFXUpdated
CommunityCategoryKit
CommunityResourcePack
CommunityTechTree
ConfigurableContainers
ContractConfigurator
ContractPacks
DeadlyReentry
DestructionEffects
Diazo
DistantObject
DMagicOrbitalScience
DMagicUtilities
DynamicBatteryStorage
EasyVesselSwitch
EditorExtensionsRedux
EngineLight
EnvironmentalVisualEnhancements
ExtraplanetaryLaunchpads
FerramAerospaceResearch
Firespitter
FShangarExtender
GPP
GroundConstruction
HullCameraVDS
InterstellarFuelSwitch
JanitorsCloset
JSI
KaptainsLog
KAS
KerbalConstructionTime
KerbalEngineer
KerbalHealth
KerbalJointReinforcement
Kerbaltek
KIS
Kopernicus
KRASH
KronalVesselViewer
KSP-AVC
KSPWheel
MagiCore
MechJeb2
MemGraph
ModularFlightIntegrator
NavBallDockingAlignmentIndicatorCE
NavyFish
NearFutureConstruction
NearFutureElectrical
NearFutureProps
NearFuturePropulsion
NearFutureSolar
NearFutureSpacecraft
NehemiahInc
Nereid
PlanetaryBaseInc
RealChute
RealPlume
RealPlume-Stock
ReentryParticleEffect
RemoteTech
RocketSoundEnhancement
SCANsat
scatterer
ScrapYard
SETIrebalance
SETIrebalanceReactionWheels
ShipManifest
SmartParts
SmokeScreen
SpaceTuxLibrary
Stock folder: Squad

Stock folder: SquadExpansion

SSTU
StageRecovery
StateFunding
StationPartsExpansionRedux
StationScience
SurfaceExperimentPackage
SurfaceLights
ThrottleControlledAvionics
TimeControl
Trajectories
TriggerTech
TweakScale
UmbraSpaceIndustries
UniversalStorage2
VesselView
WaypointManager
WildBlueIndustries
Workshop
[x] Science!
ModuleManager.4.0.3.dll
ModuleManager.Physics
ModuleManager.TechTree
ModuleManagerLicense.md
toolbar-settings.dat
unBlur.0.5.0.dll 

It seems I'll have to completely remove the mod (although I was playing with it for years). I mean come on, double FPS boost is probably worth it. *sigh* goodbye, satellites, rovers, landers and other unmanned guys! :(
*makes a save*

Oh and.. playing with:
RemoteTech 1.9.3 on KSP 1.7.3 and latest Galileo's Planet Pack (might have an issue with this)

Anyways this mod is damn great!

Edited by atomontage

Share this post


Link to post
Share on other sites

@atomontage Just in case you don't know, you may not have to remove it! Just disabling the dll will preserve the parts, they're non-functional but still there on your crafts so they don't get deleted. What I'm trying to figure out right now is whether doing that is a viable long-term solution.

Edited by Homozygote

Share this post


Link to post
Share on other sites
Just now, Homozygote said:

@atomontage Just in case you don't know, you may not have to remove it! Just disabling the dll will preserve the parts, they're non-functional but still there on your crafts so they don't get deleted.

Yeah thanks for pointing that out! I've read your comment here and I'm still thinking whether this is the right solution (for me). You see, if RT gets disabled then I have to get back to using CommNet. And that means that satellites become dead. I don't want to play without connectivity.

One of possible solutions is to remove the DLL, play without connectivity for a while until fix is out, then install RT again. :D

Thanks anyways, good idea!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.