Jump to content

[1.12.x] ResearchBodies V1.13.0 (15th May 2022)


JPLRepo
 Share

Recommended Posts

On 12/28/2021 at 11:10 AM, Sirius628 said:

Now, I do understand that logfiles are normally needed for support, but I just don't know what log to give you here.

Read the article here for the location of logs.  Post them here has a link to an uploaded file on a file sharing service, such as Dropbox, GoogleDrive, OneDrive, etc.  Don't post the entire logs as they are too long.

Are your mods installed manually or through CKAN?

I haven't experienced this error but I'm not as far in the game as most, if not all, of the posters so far.

Link to comment
Share on other sites

Quote

Are your mods installed manually or through CKAN?

Most of them through CKAN, but ResearchBodies was manual.

58 minutes ago, Brigadier said:

Read the article here for the location of logs.  Post them here has a link to an uploaded file on a file sharing service, such as Dropbox, GoogleDrive, OneDrive, etc.  Don't post the entire logs as they are too long.

Are your mods installed manually or through CKAN?

I haven't experienced this error but I'm not as far in the game as most, if not all, of the posters so far.

Here is the dropbox of my Player.log, taken at the moment of the screen freeze-up.

PS: Just added my latest quicksave as well

Edited by Sirius628
Link to comment
Share on other sites

@Sirius628The first issue I see is with Sigma Binaries.  Ensure that it and Kopernicus are installed correctly for your KSP version.  Note that there may be a version of Kopernicus  matched to your version of SD, and not necessarily the latest.  I don't know enough about SD to say.

There are 377 NREs in total that may be related to the failure of SD to load properly, but first things first.

Link to comment
Share on other sites

16 minutes ago, Brigadier said:

@Sirius628The first issue I see is with Sigma Binaries.  Ensure that it and Kopernicus are installed correctly for your KSP version.  Note that there may be a version of Kopernicus  matched to your version of SD, and not necessarily the latest.  I don't know enough about SD to say.

There are 377 NREs in total that may be related to the failure of SD to load properly, but first things first.

Sigma Binary and Kopernicus are both on the latest version available, and I don't know what SD is.

Link to comment
Share on other sites

19 hours ago, Sirius628 said:

Sigma Binary and Kopernicus are both on the latest version available, and I don't know what SD is.

Sorry, typo - SD was supposed to be SB (Sigma Binary).  The log suggests that there are missing SB files.  I would recommend reinstalling SB and run the game for the minimum practical and post another log file.  At the moment, I don't think the problem is with Research Bodies but it's early in the troubleshooting process.

After a little research, SB's latest version from last February is for KSP 1.11.  There are no guarantees under KSP 1.12.x.   Do you really need SB in your game?

Link to comment
Share on other sites

On 12/30/2021 at 1:09 PM, Brigadier said:

Sorry, typo - SD was supposed to be SB (Sigma Binary).  The log suggests that there are missing SB files.  I would recommend reinstalling SB and run the game for the minimum practical and post another log file.  At the moment, I don't think the problem is with Research Bodies but it's early in the troubleshooting process.

After a little research, SB's latest version from last February is for KSP 1.11.  There are no guarantees under KSP 1.12.x.   Do you really need SB in your game?

Nah, I can remove SigmaBinary I guess. Let's see if that actually fixes anything.

 

Edited by Sirius628
Link to comment
Share on other sites

  • 2 weeks later...

Also waiting it, but i have feeling that maybe not in this year :( Someone probably might fix in github but due to ARR license - nobody will can publish those... ;.; I can only hope that dev might decide to push current changes to github (so we can build unstable build) and let community to do fixes at least...

Edited by AlexALX
Link to comment
Share on other sites

It is on my list. But Holiday season, family things, etc have meant I didn't find the time I wanted to.

I will try to get it done as soon as I can. I know a lot of people are waiting for this.

Link to comment
Share on other sites

4 hours ago, JPLRepo said:

It is on my list. But Holiday season, family things, etc have meant I didn't find the time I wanted to.

I will try to get it done as soon as I can. I know a lot of people are waiting for this.

As usual, it comes when it comes.  Family, RL, work must come first otherwise we could lose you completely to the exigencies of life (and KSP 2:D).  Thanks for offering a little hope but I, for one, can wait for you to find the time and enthusiasm to get it done right.

Link to comment
Share on other sites

  • 2 weeks later...

I also had that issue that was brought up on the previous page, with bodies being suddenly marked as discovered and fully researched for no apparent reason.

Possibly related to that, I just added Galaxies Unbound to my game last night, and not only did several of those bodies start off as discovered and fully researched, but several of the bodies in the Kerbol system that had previously been research-complete (like Vant from MPE) suddenly changed to undiscovered and unresearched.

Edited by Silvia Dragoness
Link to comment
Share on other sites

  • 2 months later...

Welcome to the forums.

2 hours ago, Geo_kou said:

(Just made an account, sorry for repeat) Is there a way to use this on old saves?

Generally, I would say that's not advisable since research under this mod is affected by the planets you've discovered.  By design, not all of planets are visible at the outset of your game, depending on your settings.  I would suspect that on an old save, all of your planets would already be discovered/visible, thus negating the main reason for using this mod.  There are probably ways around this, but I've found that starting over is better for me.

Link to comment
Share on other sites

  • 3 weeks later...

Sorry it took like a century to update this mod. I still haven't finished fixing the visual bugs, but I figured better to get something out that functionally works.

Download links in the OP

V1.13.0 (10/04/2021) - NOTE there are still issues with the detail levels of planets and viewing them through telescopes that I need to sort out.
*Re-compile for KSP 1.12.x.
*Fix issue where CBs were becomming visible when they shouldn't be.
*Fix issue where CB visibility was not being reset when loading different save games in the same game session.
*Fix issue where errors would occur and game stuck when entering the SOI of a CB that hadn't been discovered before.
*Fix issue where Asteroids entering CBs were making them discovered.
*Fix issue with bumpmaps on CBs.
*Fix issue with lighting on CBs.
*Added setting to DAtabase.cfg file that allows the player to manually change the research percentage step for research plans. (Default 10%).
*Fix RCS FX on TRBH-75M telescope (thanks linuxgurugamer).

 

Link to comment
Share on other sites

Posted (edited)

Awesome. Just started my first ever save with ResearchBodies just a few days ago.

Edit: I don't seem to be able to use the ResearchBodie's telescope camera with TST installed. Do I need to unlock something first in the tech tree, or am I missing something very basic? @JPLRepo

Edited by Lijazos
Link to comment
Share on other sites

I've been having issues running this with JNSQ. On a fresh career save the names are hidden but the bodies themselves are visible and you can cycle through all of them. I have isolated this to just JNSQ, ResearchBodies and their respective dependencies and the issue still persists. Any help would be greatly appreciated. https://file.io/aUCrIdII8PDI here are the relevant logs. https://imgur.com/a/Oo4Hjnb here's duna when its supposed to be hidden on this save (hard settings on career mode).

Link to comment
Share on other sites

  • 4 weeks later...
15 hours ago, Snowy1237 said:

How do I get more research progress on a body? pointing a telescope at it and pressing the research button did not do much, same for starting a research plan.

Have you  tried taking a picture with your telescope?

Link to comment
Share on other sites

5 hours ago, Brigadier said:

Have you  tried taking a picture with your telescope?

with the tarsier space technologies mod? or with the basic researchbodies telescopes? because TST is broken for me due to scatterer (probably) and I do not see an option like that on the researchbodies ones.

Link to comment
Share on other sites

6 minutes ago, Fergrim said:

Go to the observatory, select the body and click research.

This should be available for any body you have discovered but not fully researched

will it add progress over time?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...