JPLRepo

[1.5.x] ResearchBodies V1.9.8 (9th Dec 2018)

Recommended Posts

Edit: Looking for confirmation that this is a known condition that I may have inadvertently caused.  If so, I am just looking for the fix.  If its not that, then I'll collect logs, mod lists, etc and properly post a bug report/request

I have the TST in orbit at 210K, with probe core, batteries and solar panels etc, its a proper satellite.  The contract "Searching the Skies with a Telescope" seems messed up - I have it with the TST active, and its at 205000 orbiting Kerbin.  I've even discovered a planet (duna) by pointing around the plane of the ecliptic and clicking the "track bodies" button. I even put the TB-75M telescope up and it doesn't change.

Is this broken in 1.5.1? (Or is it Contract Configurator?)

Quote

 

You must have a Telescope part with ModuleTrackBodies on your vessel.:Complete
    
With module Track Bodies: Incomplete
    Count At Least
1 : Incomplete

The vessel must be in orbit above 20000 meters.: Complete
    Destination: Kerbin: Incomplete
    Situation: Orbit: Incomplete
    Altitude: Above 200,000 m: Incomplete

 

2

 

 

 

Edited by Murdabenne
enter too soon

Share this post


Link to post
Share on other sites
2 hours ago, Murdabenne said:

I have the TST in orbit at 210K, with probe core, batteries and solar panels etc, its a proper satellite.  The contract "Searching the Skies with a Telescope" seems messed up - I have it with the TST active, and its at 205000 orbiting Kerbin.  I've even discovered a planet (duna) by pointing around the plane of the ecliptic and clicking the "track bodies" button. I even put the TB-75M telescope up and it doesn't change.

Is this broken in 1.5.1?

Hmmm, the problem seems to be independent of KSP version and planet pack (see my post just above yours).

I don't even know where to start looking for why this occurs.  Anybody have any hints?

Share this post


Link to post
Share on other sites
30 minutes ago, Brigadier said:

Hmmm, the problem seems to be independent of KSP version and planet pack (see my post just above yours).

I don't even know where to start looking for why this occurs.  Anybody have any hints?

Because he’s trying to run it in KSP 1.5.1. And Contract Configurator and this mod have not been updated for KSP 1.5.x yet.

  • Like 3

Share this post


Link to post
Share on other sites

@JPLRepo Thanks - I'll not bother you with logs, etc.  I'll just wait for the updates.  I just restarted playing after >1 year off (my last was 1.3.something) and decided to try this with a new career. Thanks for doing what you do!

 

Edited by Murdabenne
  • Like 1

Share this post


Link to post
Share on other sites
11 hours ago, JPLRepo said:

Because he’s trying to run it in KSP 1.5.1. And Contract Configurator and this mod have not been updated for KSP 1.5.x yet.

Ok, that makes sense.  But if it's Contract Configurator, why does it seem to be affecting my combination of KSP v1.4.5, RB v1.9.7 and CC v1.25.0?

Share this post


Link to post
Share on other sites

looking at this mod + TST + Cacteye.   so if I understand correctly the cacteye telescopes and the TST telescopes are interchangeable in most ways.  I was just wondering if there was a definitive list of what works or does not work correctly between these 3 mods?  things like a cacteye  contract will not complete with a TST telescope or some such.  A quick list without in-depth testing is fine  as I was just looing at the over all theory, not looking for bugs or what not.

can this be summarized in a quick table showing what combinations work?  or is it that the Cacteye and TST scopes should be 100% interchangeable?   I am assuming not 100% as for instance. I have a Cacteye contract and the TST scope on my craft does not seem to be able to complete it.

then the next logical question would be.  if these are not 100% could a MM patch be made that would add all TST/RB abilities to Cacteye scopes, and all Cacteye abilities to TST/RB scopes?  or are the hooks for the various UI elements and contracts hard coded to look for a specific part, and not a part module that could be copied in with MM?

 

 

 

Share this post


Link to post
Share on other sites
On 11/7/2018 at 9:04 AM, JPLRepo said:

Because he’s trying to run it in KSP 1.5.1. And Contract Configurator and this mod have not been updated for KSP 1.5.x yet.

I know we're not supposed to pester mod creators, but... could I ask, just in general, are you working on it now? Do you have a rough arrival date for 1.5.1 support?

Share this post


Link to post
Share on other sites

I'm running ResearchBodies 1.9.7 under KSP 1.4.5, and I'm getting a static portrait of Wernher overlaid on Gene in Mission Control. Is there a solution for this that I haven't been able to find here? Thank you ...

Share this post


Link to post
Share on other sites
On 11/27/2018 at 5:00 AM, avalancha said:

I know we're not supposed to pester mod creators, but... could I ask, just in general, are you working on it now? Do you have a rough arrival date for 1.5.1 support?

Did you ready the post that you quoted???? : " Because he’s trying to run it in KSP 1.5.1. And Contract Configurator and this mod have not been updated for KSP 1.5.x yet. "

  • Like 1

Share this post


Link to post
Share on other sites
8 hours ago, JPLRepo said:

Did you ready the post that you quoted???? : " Because he’s trying to run it in KSP 1.5.1. And Contract Configurator and this mod have not been updated for KSP 1.5.x yet. "

Yes exactly, therefore my question if this "yet" means:

Is the update coming? And if so, coming soon?

Sorry if that was misleading :D Just scrapping for mini pieces of information :)

Share this post


Link to post
Share on other sites
8 hours ago, avalancha said:

Yes exactly, therefore my question if this "yet" means:

Is the update coming? And if so, coming soon?

Sorry if that was misleading :D Just scrapping for mini pieces of information :)

How long is a piece of string? This mod depends on Contract Configurator which is not my mod. So when that mods author updates CC I can update this mod.

  • Like 2

Share this post


Link to post
Share on other sites

So ehh, i don't have the observatory building anywhere for some reason? (KSP 1.4.5)

 b6K5zSV.jpg

Share this post


Link to post
Share on other sites
3 hours ago, BRAAAP_STUTUTU said:

So ehh, i don't have the observatory building anywhere for some reason? (KSP 1.4.5)

maybe you havent unlocked it/upgraded ksc for iit yet? vOv

Share this post


Link to post
Share on other sites
10 hours ago, Stone Blue said:

maybe you havent unlocked it/upgraded ksc for iit yet? vOv

I remember it being always at the beginning of a career, even if you couldn't do anything with it.

  • Like 1

Share this post


Link to post
Share on other sites
On ‎11‎/‎28‎/‎2018 at 1:36 PM, JPLRepo said:

How long is a piece of string? This mod depends on Contract Configurator which is not my mod. So when that mods author updates CC I can update this mod.

Exactly!  And for all you wonderful people wondering about that, there is a fairly robust discussion just now started about forking and/or updating CC over on the CC thread which is where this discussion belongs.  Come on over!
 

 

Edited by Murdabenne
link to CC conversation added.

Share this post


Link to post
Share on other sites
1 hour ago, Murdabenne said:

Exactly!  And for all you wonderful people wondering about that, there is a fairly robust discussion just now started about forking and/or updating CC over on the CC thread which is where this discussion belongs.  Come on over!
 

 

I don’t condone this myself. I’ll wait and try to contact @nightingale

  • Like 1

Share this post


Link to post
Share on other sites
36 minutes ago, JPLRepo said:

I don’t condone this myself. I’ll wait and try to contact @nightingale

Well that's also part of the discussion - it is open source.  The problem is he's one major and more than a few minors behind (1.4.3), with no commits on GitHub in more than 6 months, and no actions in bringing this up to date (with 1.6 on the horizon), so some people have already forked it due to an incompatibility with another popular mod that needed to be fixed. My assumption is that he simply had too much RL, so maybe someone else could pick up the load.  I'd help except that I don't know the environment or toolchain, although I do know hard core low level development.  I'm not a windows guy, I was mainly C/Unix with ksh/make/Perl (later Python once it was invented) glue, basically server/daemon/system type things with not much UI other than command line switches (for init files) and ini/cfg files (for SIGHUP) - starting back when Solaris and Unix were king (and Linux was a brand new thing). However I did recommend that they PM nightingale, and at least offer fixes as PRs.

(and I think I've got the time now to actually try to learn C#/Net-Mono/Windows/Unity so I can actually *do* something).

Edited by Murdabenne
phrasing

Share this post


Link to post
Share on other sites

I've never used this mod before, and have been out of the modding loops for quite some time. I started a new career on 1.5.1 with this and Contract Configurator (And Galileo's planet pack) and everything seems to be going fine. And no, I'm not using any forks or anything, I just downloaded from the links in the first posts.

I was actually coming here to thank you for the mod and say how much fun I've been having with it, and now it appears that it shouldn't work at all? I've got the observatory and have not (yet) discovered any new worlds, but am "scanning the skies" and up until this moment fully expected to find something after the 1 year timer ended.

Edited by 5thHorseman

Share this post


Link to post
Share on other sites
10 minutes ago, 5thHorseman said:

I've never used this mod before, and have been out of the modding loops for quite some time. I started a new career on 1.5.1 with this and Contract Configurator (And Galileo's planet pack) and everything seems to be going fine. And no, I'm not using any forks or anything, I just downloaded from the links in the first posts.

I was actually coming here to thank you for the mod and say how much fun I've been having with it, and now it appears that it shouldn't work at all? I've got the observatory and have not (yet) discovered any new worlds, but am "scanning the skies" and up until this moment fully expected to find something after the 1 year timer ended.

Well, take my "defect report" with a grain of salt.  Its accurate to the best of my knowledge, but that is admittedly limited. 

Can you try this: once you get a contract for it, can you put a space telescope up into the proper orbit and see if it satisfies the conditions of the contract? I put this addons scope, and later TST's up, and the scopes work just fine (I "discovered" Duna by pointing the scope at it manually). But the contract doesn't seem to detect even that the telescope is in orbit, much less that its doing anything. I was assuming its CC that's at issue since I had issues with Tourism contract pack as well (that first tourist is still in orbit and CC doesn't see that he's even left the launch pad).  Good luck.

Edited by Murdabenne
  • Like 1

Share this post


Link to post
Share on other sites

I did start having wonkiness with Contract Configurator yesterday, though my "just find me something" contract did find Icarus in the Galileo pack. I can see the surface, though, so maybe something's wrong (or just as likely I don't understand what's supposed to happen). I can not see the orbit or parameters so that part seems to still be good.

Also Nightingale just updated Contract Configurator so @JPLRepo :):):)

 

Edited by 5thHorseman
  • Like 1

Share this post


Link to post
Share on other sites
On 12/6/2018 at 12:05 AM, 5thHorseman said:

I did start having wonkiness with Contract Configurator yesterday, though my "just find me something" contract did find Icarus in the Galileo pack. I can see the surface, though, so maybe something's wrong (or just as likely I don't understand what's supposed to happen). I can not see the orbit or parameters so that part seems to still be good.

Also Nightingale just updated Contract Configurator so @JPLRepo :):):)

 

Yep - very nice of @nightingale to do that. Looking forward to getting back to my stalled career game.  

One question if anyone knows this: Just curious - is there something difficult about 1.5.1 for mods to adapt? I don't recall so many mods lagging behind in quite a while (been playing off and on since 0.98) 

I noticed when I came back after about a year off, I had to set compatibility to 1.4 with CKAN to get a lot of things to install. I started from a scratch install with a new career just as 1.5.1 came out. And not just odds & sods in terms of mods missing, but "mainstream" vital stuff,  like the entire USI lineup (except the FTL) and Galileo/OPM, which I consider "must haves" for gameplay in career mode.  Also most of NF/Nertea's stuff, CC and contract packs (along with a healthy portion of @linuxgurugamer's Orphanage for Misfit Mods).

Was there a big API or data structure change that made this difficult, or is it the dreaded "mod maintainer/author burnout"?

Edited by Murdabenne

Share this post


Link to post
Share on other sites
5 hours ago, Murdabenne said:

One question if anyone knows this: Just curious - is there something difficult about 1.5.1 for mods to adapt? I don't recall so many mods lagging behind in quite a while (been playing off and on since 0.98
 

Actually, most mods for 1.4.5 will work on 1.5.1 without any issue

Share this post


Link to post
Share on other sites
6 hours ago, Murdabenne said:

Yep - very nice of @nightingale to do that. Looking forward to getting back to my stalled career game.  

One question if anyone knows this: Just curious - is there something difficult about 1.5.1 for mods to adapt? I don't recall so many mods lagging behind in quite a while (been playing off and on since 0.98) 

I noticed when I came back after about a year off, I had to set compatibility to 1.4 with CKAN to get a lot of things to install. I started from a scratch install with a new career just as 1.5.1 came out. And not just odds & sods in terms of mods missing, but "mainstream" vital stuff,  like the entire USI lineup (except the FTL) and Galileo/OPM, which I consider "must haves" for gameplay in career mode.  Also most of NF/Nertea's stuff, CC and contract packs (along with a healthy portion of @linuxgurugamer's Orphanage for Misfit Mods).

Was there a big API or data structure change that made this difficult, or is it the dreaded "mod maintainer/author burnout"?

That’s no the topic of this thread.

Share this post


Link to post
Share on other sites
On 12/7/2018 at 7:20 AM, JPLRepo said:

That’s no the topic of this thread.

As I stated, ("One question if anyone knows this: Just curious... ") I was just curious and hoping the well-informed people on this thread might impart some knowledge to allow me to be better informed as to what the authors are facing so I am not inadvertently asking bad/improper questions.  Where would this sort of question be appropriately asked?  I'll go there.  Thanks.  And more on-topic, thank you for this mod - it really adds to the immersion factor and I am happy to have it - it goes hand in glove with OPM.

OffTopic: Thanks for moving the off-topic posts to the proper forum thread!  I didn't even know that existed.

Edited by Murdabenne
Addendum

Share this post


Link to post
Share on other sites
On 11/1/2018 at 10:14 AM, Brigadier said:

KSP v1.4.5, ResearchBodies v1.9.7, GPP+GEP install

Two things have been bothering me for a while now.  I have multiple active RB contracts.  All show the duration decreasing in CapCom and Mission Control.  All of them show negative Advances, no rewards and double negative failures, similar to the one below, although this one has double negative advance too.

q5ZnVag.jpg

Despite my having a TST scope in orbit above 200km around Gael, the contract doesn't seem to recognize it.  Everything else appears fine and I can collect science from the 'scopes images.  Why?

GbQIdEo.jpg

Output Log here.  This log is for the in-progress game from which the screen shots were made.

Is RB compatible with GPP?  I figure I might I have to increase the orbital Ap and Pe because Gael is different from Kerbin so I'll report back when I've tried this.  If memory serves, Orbital Science experiments also needed a larger orbit to exceed their wiki's stock minima data. 

The contracts are meant to be negative ... they are meant to COST you money to discovery CBs.

See nothing in the log... but then - the screenshot doesn't show the state of the contract either.
Perhaps a save file would help. Along with the ResearchBodies log. Found in <install directory>\GameData\REPOSoftTech\ResearchBodies\Plugins\PluginData\ResearchBodies.log.

It might also help to turn on debugging in Contract Configurator (instructions can be found here https://github.com/jrossignol/ContractConfigurator/wiki/How-To)

On 11/29/2018 at 8:22 AM, BRAAAP_STUTUTU said:

So ehh, i don't have the observatory building anywhere for some reason? (KSP 1.4.5)

 b6K5zSV.jpg

See the Opening Post.. No LOGS = No Support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now