JPLRepo

[1.5.x] ResearchBodies V1.9.8 (9th Dec 2018)

Recommended Posts

Version 1.9.8 published for KSP 1.5.x.

Please make sure you have the correct version of Contract Configurator installed (v1.26.0 for KSP 1.5.x)

  • Like 6

Share this post


Link to post
Share on other sites

Thank you very much, trying it right now! :)

Edit: if I add Research Bodies to a running career, can I "re-hide" planets I've not been to yet? The dfficulty menu does not offer the starting difficulty anymore

Edited by avalancha

Share this post


Link to post
Share on other sites

I haven't played KSP for more than a year, and explicitly was avoiding playing with planet packs in the hopes that a mod would allow them (specifically their surface detail) to be hidden before discovery. Just found that this is now a feature; immense news! Thanks for the modding effort!

Share this post


Link to post
Share on other sites

Thanks for keeping a sense of discovery alive in the game, this mod with OPM is why I'm still playing (and even buying the expac) years later.

Share this post


Link to post
Share on other sites
5 hours ago, avalancha said:

Thank you very much, trying it right now! :)

Edit: if I add Research Bodies to a running career, can I "re-hide" planets I've not been to yet? The dfficulty menu does not offer the starting difficulty anymore

You can’t add the mod to an existing save.only a new game

  • Like 1

Share this post


Link to post
Share on other sites
6 hours ago, JPLRepo said:

You can’t add the mod to an existing save.only a new game

And that is why I am restarting :-), gotta run, need to go discover Moho

Edited by Murdabenne

Share this post


Link to post
Share on other sites

First, thanks for the reply and this mod.  I've enjoyed the discovery process this mod offers.  Second, I've advanced the save since my initial report so I'll have to see what, if anything, has changed and update the post.  Third, I'm away from the game for at least another week and won't be able to gather the data until then. 

On 12/8/2018 at 11:05 PM, JPLRepo said:

The contracts are meant to be negative ... they are meant to COST you money to discovery CBs.

Ok, but if that's the case, why is the advance a double negative; shouldn't it be a single negative?  And, consequently, shouldn't a failure be a positive?  A return on the investment perhaps, unless, of course, that regardless of success or failure, you pay/lose funds.

 

Share this post


Link to post
Share on other sites

FYI @JPLRepo have restarted my career in order to take advantage of the update to Contract Configurator, etc. 
I have both telescopes in orbit (one for each contract jsut to test them out), but the progress shows the following for both contracts:

You must have a  Telescope part with a ModuleTrackBodies on you vessel: Incomplete    Wrong - the telescope is on the probe.
With Module: Track Bodies: Incomplete  Wrong - I checked the persistent file, its there.

Spoiler

MODULE
{
                    name = ModuleTrackBodies
                    isEnabled = True
                    stagingEnabled = True
                    EVENTS
                    {
                    }
                    ACTIONS
                    {
                    }
                    UPGRADESAPPLIED
                    {
                    }
}
 


 

Count At least 1: Incomplete Wrong - there are 2 of them in orbit.

The vessel must be in orbit above 200,000 meters: incomplete Wrong - see below
Destination: Kerbin: Incomplete Wrong They are in the Kerbin SOI.
Situation:Orbit: Incomplete  Wrong. They are in a stable nearly equatorial (< 1.0 degree inclination) nearly circular (eccentricity < 1.0) orbit
Altitude:Above 200,000 m: Incomplete Wrong - periapsis is approximately 250,000m and apoapsis <1Km difference

Searching the Skies: 76 days, 03:11:29: Incomplete. - I think this is the initial time minus the MET.  Based on a 90 kerbin-day (19944000s) mission and subtracting the MET, this appears to be correct, and agrees with the PARAM "Duration" in the SFS file.

Apparently the contract is not recognizing the TD75m nor the Tarsier that I launched and put into orbit. 
From the Persisten.sfs: 

Spoiler

                PARAM
                {
                    name = PartValidation
                    id = PartValidation
                    state = Incomplete
                    disableOnStateChange = False
                    values = 0,0,0,0,0
                    ContractIdentifier = ResearchBodies.RB_TelescopeResearchBody
                    title = You must have a Telescope part with ModuleTrackBodies on your vessel.
                    notes = 
                    completedMessage = 
                    allowStateReset = True
                    minCount = 1
                    maxCount = 2147483647
                    FILTER
                    {
                        type = FILTER
                        partModule = ModuleTrackBodies
                    }
                    PARAM
                    {
                        name = ParameterDelegate`1
                        id = With module: Track Bodies
                        state = Incomplete
                        disableOnStateChange = False
                        values = 0,0,0,0,0
                        ContractIdentifier = ResearchBodies.RB_TelescopeResearchBody
                        title = With module: Track Bodies
                        notes = 
                        completedMessage = 
                    }
                    PARAM
                    {
                        name = CountParameterDelegate`1
                        state = Incomplete
                        disableOnStateChange = False
                        values = 0,0,0,0,0
                        ContractIdentifier = ResearchBodies.RB_TelescopeResearchBody
                        title = Count: At least 1 
                        notes = 
                        completedMessage = 
                    }
                }

 

                PARAM
                {
                    name = OrbitParameter
                    id = Orbit
                    state = Incomplete
                    disableOnStateChange = False
                    values = 0,0,0,0,0
                    ContractIdentifier = ResearchBodies.RB_TelescopeResearchBody
                    title = The vessel must be in orbit above 200000 meters.
                    notes = 
                    completedMessage = 
                    allowStateReset = True
                    situation = ORBITING
                    targetBody = Kerbin
                    minAltitude = 200000
                    minApoapsis = 0
                    minPeriapsis = 0
                    minEccentricity = 0
                    minInclination = 0
                    maxInclination = 180
                    minArgumentOfPeriapsis = 0
                    maxArgumentOfPeriapsis = 360
                    minPeriod = 0
                    displayNotes = False
                    PARAM
                    {
                        name = ParameterDelegate`1
                        id = Destination: Kerbin
                        state = Incomplete
                        disableOnStateChange = False
                        values = 0,0,0,0,0
                        ContractIdentifier = ResearchBodies.RB_TelescopeResearchBody
                        title = Destination: Kerbin
                        notes = 
                        completedMessage = 
                    }
                    PARAM
                    {
                        name = ParameterDelegate`1
                        id = Situation: Orbit
                        state = Incomplete
                        disableOnStateChange = False
                        values = 0,0,0,0,0
                        ContractIdentifier = ResearchBodies.RB_TelescopeResearchBody
                        title = Situation: Orbit
                        notes = 
                        completedMessage = 
                    }
                    PARAM
                    {
                        name = ParameterDelegate`1
                        id = Altitude: Above 200,000 m
                        state = Incomplete
                        disableOnStateChange = False
                        values = 0,0,0,0,0
                        ContractIdentifier = ResearchBodies.RB_TelescopeResearchBody
                        title = Altitude: Above 200,000 m
                        notes = 
                        completedMessage = 
                    }
                }


One thing I do note is that very last line *is* decrementing.  Does this mean that the contract is actually working even though the params are all "incomplete"? If so, then perhaps the completion criteria need to be restructured. Because I definitely have the telescopes in the proper orbit and they are operational.  If this is the case, then it is incorrect (and misleading) to tell me I don't have the scope in orbit, that its not around Kerbin, and that is also no above 200Km.   Is there a parsing issue I can look for in the logs?

 

Share this post


Link to post
Share on other sites
20 minutes ago, Murdabenne said:

FYI @JPLRepo have restarted my career in order to take advantage of the update to Contract Configurator, etc. 
I have both telescopes in orbit (one for each contract jsut to test them out), but the progress shows the following for both contracts:

You must have a  Telescope part with a ModuleTrackBodies on you vessel: Incomplete    Wrong - the telescope is on the probe.
With Module: Track Bodies: Incomplete  Wrong - I checked the persistent file, its there.

...

One thing I do note is that very last line *is* decrementing.

this tripped me up as well. I assume you are at the space center, or some other scene that is not in direct control of the satellite, but you were at one time.

The contract looks at the current situation. Are you currently on a ship with the telescope? NO. So it's incomplete. But the timer's counting, so at some point you were. When the timer compeltes, go back to the probe and the contract will complete. At least, it did for me.

  • Like 2

Share this post


Link to post
Share on other sites
12 hours ago, frozendusk said:

is this working with 1.6? i can't make it to work

Probably not since the RB v1.9.8 was released for KSP v1.5.1.  If you can't get it to work, I suggest patience and JPLRepo will get to it in due course.  He probably has his hands fully with the next KSP release.

Share this post


Link to post
Share on other sites
1 hour ago, Brigadier said:

Probably not since the RB v1.9.8 was released for KSP v1.5.1.  If you can't get it to work, I suggest patience and JPLRepo will get to it in due course.  He probably has his hands fully with the next KSP release.

Or .... he could be on holidays....

  • Like 1

Share this post


Link to post
Share on other sites
10 hours ago, JPLRepo said:

Or .... he could be on holidays....

Nah...devs and mod authors don't really take holidays.  Wait..do they?:cool:

Let me be that first to say Happy New Year, JPLRepo!

Share this post


Link to post
Share on other sites
On 12/30/2018 at 5:36 PM, frozendusk said:

is this working with 1.6? i can't make it to work

Working for me

Share this post


Link to post
Share on other sites
2 hours ago, Cristy2017 said:

Working for me

well, i must be doing something wrong then, i start a new game and i can see all the planets right away on the tracking station, no config button for the mod either

Share this post


Link to post
Share on other sites
44 minutes ago, frozendusk said:

well, i must be doing something wrong then, i start a new game and i can see all the planets right away on the tracking station, no config button for the mod either

Have you started a career or a sandbox?

Share this post


Link to post
Share on other sites
4 minutes ago, Cristy2017 said:

Have you started a career or a sandbox?

Career

Share this post


Link to post
Share on other sites
56 minutes ago, frozendusk said:

Career

you have the prerequisite mods installed?

Share this post


Link to post
Share on other sites
2 hours ago, JPLRepo said:

you have the prerequisite mods installed?

it's basically just the contract config right? it has the miniAVC and module manager included, i'm using the latest module manager and contract config

Share this post


Link to post
Share on other sites
9 hours ago, frozendusk said:

it's basically just the contract config right? it has the miniAVC and module manager included, i'm using the latest module manager and contract config

Can you upload a pic of your Gamedata folder?

Share this post


Link to post
Share on other sites
16 hours ago, frozendusk said:

it's basically just the contract config right? it has the miniAVC and module manager included, i'm using the latest module manager and contract config

Only guessing. Because no logs.

Share this post


Link to post
Share on other sites
23 hours ago, frozendusk said:

well, i must be doing something wrong then, i start a new game and i can see all the planets right away on the tracking station, no config button for the mod either

Did you look into the Difficutly Settings before you start a New Game? You have to play with the Slider there and set it on Hard if you only want to see Kerbin, Mun and Sun at the very beginning of your new career

Share this post


Link to post
Share on other sites
15 minutes ago, GerAseR said:

Did you look into the Difficutly Settings before you start a New Game? You have to play with the Slider there and set it on Hard if you only want to see Kerbin, Mun and Sun at the very beginning of your new career

apparently having several module manager versions was causing some problems, left the latest one only and its working, some old mods come with different versions 

  • Like 1

Share this post


Link to post
Share on other sites
3 minutes ago, frozendusk said:

apparently having several module manager versions was causing some problems, left the latest one only and its working, some old mods come with different versions 

Yeah, kind of tricky. Went trough this the last days too. Its just "horrible" to look and read in this forum, specially the Add On Section...
Just wanted to read some stuff about a mod and find a few others... then come back for a solution or just read my followed threads... and another one found...
Sometimes i thought: Why not vanilla... or CKAN at least... but there are reasons ("Mods") without support so we have to do it by ourselfs. 
I liked it to go through all these threads again and watch how much improvement the KSP modding scene went through since i left the game around summer/autumn 2014.
I came back here for Kerbal Alarm Clock and the NavBallDockingPortAllignmentIndicator and now... well that escalated quickly... im over 40 mods and there are only 2 (DistantObject and PlanetShine) that i would count as "visual mods". If i would have a beefy gaming PC instead of my working laptop... :cool:
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now