JPLRepo

[1.8.x] ResearchBodies V1.11.0 (19th Oct Jun 2019)

Recommended Posts

Thanks Stone! Yeah I am aware of the changes on the unity game engine and that it does require a lot of work from the modding community. Taking advantage of the new feature would be sweet for my game but not going to request any changes in the earlier version of the mod. I have a lot of respect for the modders and the work they put in.

not to mention it’s just for Minmus so I can do without it and like develop the story telling accordingly (maybe just force me to wait a month or so with a probe in the SOI before doing anything else)

I’m not sure I can try a new install though, as it would imply starting a new campaign to make sure it integrates with all mods and doing a fly by of minmus is not possible before I get a couple of hours in. That’s why I thought of asking the question here.

thanks for your quick reply bud!

Share this post


Link to post
Share on other sites
13 hours ago, IceCube said:

I’m not sure I can try a new install though, as it would imply starting a new campaign to make sure it integrates with all mods and doing a fly by of minmus is not possible before I get a couple of hours in. That’s why I thought of asking the question here.

For testing purposes, create a new install, start a new career or science game and cheat yourself the research, status and funds to get where you need to be.  Cheat craft into orbit if you need to.  All of this is available in the Alt-F12 menu.

Share this post


Link to post
Share on other sites
19 hours ago, IceCube said:

First of thank you so much for this mod! I am playing a heavily moded career mode on hard and research bodies makes it definitely more interesting in term of choices about where and when to invest in a new body.

thank you for the remote tech integration for the TB-75. Nice addition although I was just making ships as if they needed antenna anyway (unlikely to get that beast unlocked and in orbit before your comm network is in place).

I am very interested in the progressive discovery you have set for the 1.8 update. I am thinking about how to go for minmus. I am still at the early stage of the career, mainly probing the Mun. I have identified Minmus but not sure I want to invest the 300k to research it. Funds are tight and I’d rather invest into Duna, where for sure I can’t just bet on luck to get an encounter! I was considering sending a probe to Minmus but I would like to benefit from the 30% discovery increasing over time rather than have it researched right away.

would the latest update work with ksp 1.7 if I get the proper contract configurator version too?

No it won’t. As it’s targetted to .Net 4.6 which KSP 1.7.3 does not support.

Share this post


Link to post
Share on other sites

Hello there,

Ok I just tried this mod and there is a few things odd to me...

so first what I understood :

In early game you will have a telescope...
you need to put it in orbit and scan the sky randomly... ok I got a few descoveries...
hen you need to start some research to found at their orbits... fine I can work with that !

Now after a almost 50 days the search is about 10% in the observatory if that normal ? I would have expected it to be faster....
In the mission control I Have 2 missions looking like that with 2 orbits drown on the map screen but no indication about their specs... 

 

On 10/16/2019 at 12:18 AM, Brigadier said:
  Hide contents

knuNQ8p.jpg

The Only  Difference is that I got the lines :

You must have a Telescope part with MTB on your vessel => completed

with module Track Bodies => incomplete
Count at least  1 => Incomplete

The vessel must be in orbit above 200km => completed

Destination Kerbin => Incomplete
Situation Orbit => Incomplete
Altitude Above 200km Incomplete

What is the meaning of 'count at list 1' ?
- Sould I descover 1 body,
- Or should I have at least 1 telescope in orbit ?
- And If I have 2 contract asking for 1 telescope, does I need 1 or 2 ?

Usualy to put a sat in orbit you have the orbit spec
- AP/PE 
- Inclinaison
- PE argument (basicaly translated from French... using MJ2 I don't seem to be able to use it to set the orbits for my sats...but that not the problem here)
- the longitude for the Ascending mod....
- a variable that expresse the precision moderate/precise (I don't remember other options)

and when you reach the requirement for the Orbit the help trace will desapear....
but here I need to check the AP/PE then align as best as I can the healp trace and my orbit but I don't seem to be precise enogh, as the trace stay on screen... (I will do some capture I you want)

So on the default tool bar I require 3 things the Module to track the bodies, the altitude of the orbits those are checked.... then there is the time...
will the contract be succeded after the time is elapse ? if for exemple I just put the "hubble" in orbit and don't scan for new planets ?

 

On 10/19/2019 at 6:41 AM, JPLRepo said:

Update published for KSP 1.8.x

Make sure you get version 1.28.0 of Contract Configurator.

V1.11.0
*Re-compile for KSP 1.8.x
...
 

I'm on KSP 1.8

all mods installed with CKAN :
Contract Config 1.28
- ResearchBodies 1.11
 

thanks :)

 

 

 

Share this post


Link to post
Share on other sites
1 hour ago, BrettDah said:

Now after a almost 50 days the search is about 10% in the observatory if that normal ? I would have expected it to be faster....

Si je te comprend...

Unless you have a specific contract, I believe you need to take pictures of the celestial body in question with your scope and transmit the "science" (i.e. picture) to advance the Observatory research.  You might not get more science after the first 2 pictures or so, but the Observatory will show changes in the research for each body.  Each picture will cost funds, so be careful how many you take and transmit; they can be expensive.  It's been my experience that you should take pictures over a period of time, not all at once.  I'm not sure if this is absolutely necessary or a funds limitation in my game.

1 hour ago, BrettDah said:

What is the meaning of 'count at list 1' ?

This means that you need to have at least one Track Bodies module on your scope (this is a coding function, not something you need to add in the VAB).  Some scopes, i.e. stock ones, do not have this module and therefore won't met the contract's parameters.  I believe all of the Tarsier Space Technology (TST) scopes have this module and if you don't have the TST mod installed, I think you're going to have a hard time with these contracts.

1 hour ago, BrettDah said:

but here I need to check the AP/PE then align as best as I can the healp trace and my orbit

I'm not aware of any orbit requirements for this type of RB contracts, except minimum Ap/Pe.  It's not been my experience to have a target orbit line.  There are other contracts that do have these, but then the orbit parameters are listed in the contract, as you would expect.

I'm no expert so a screen shot of the contract would help me understand.

Share this post


Link to post
Share on other sites
7 hours ago, Brigadier said:

I'm no expert so a screen shot of the contract would help me understand.

Here are a few screenshot (I didn't have Tarsier Space Technology until now but it was something that I think the telescope was Laking - with a big "L" -)

(the galery integration from imgur does not seems to work as I would have expected...)

 

Has you can see in the VAB this scope have the hability to track bodies
In the screen where I show my contracts from the telescope you can see that it would only require time now, but in the mission control the sub objectives does not seems to be met...
Then the orbits yellow and purple are from REPOSoftTech as the 2 contracts that want me to scan for bodies...
The only other one from them about doing something in space is to save a Kerbal... 
else it's just :

- Search the sky (long term reasearch from the observatory)
- Research a Celestia Body from the long term task of the celestial body

 

Edited by BrettDah
Gallery from imgur isn't integrated...

Share this post


Link to post
Share on other sites
7 hours ago, BrettDah said:

(the galery integration from imgur does not seems to work as I would have expected...)

Did you insert the "direct" link?  I'm not that conversant with Imgur albums so I just add individual pictures.

7 hours ago, BrettDah said:

Has you can see in the VAB this scope have the hability to track bodies

I have RB and TST installed so it's strange that my TB-75M doesn't have a Track Bodies module.  The TB-75M cannot take pictures whereas the TST scopes can (under the TSTSpace Telescope module of the scope in the VAB).  I use this picture-taking ability to advance the research in the Observatory.  At least according to the contract, you don't need to place the scope in a specific orbit.

That said, in my game, I do see orbits that are attributed to RepoSoft contracts but I cannot determine which orbit belongs to which contract.  I have 4 RepoSoft contracts: Search the Skies, Search the Skies with a Telescope, Research a Celestial Body, and Research a Celestial Body with a Telescope.  I presume that the "with Telescope" ones are for orbital scopes, but that still leaves me with some uncertainty.  Even with no scopes in these orbits, all of the RepoSoft contracts are counting down to completion, so I'm a little at a loss.

7 hours ago, BrettDah said:

In the screen where I show my contracts from the telescope you can see that it would only require time now, but in the mission control the sub objectives does not seems to be met...

Yeah, I've seen and mentioned this odd behaviour recently, too.  Depending where you view the contract (Msn Control, Tracking Station, Contract window, the CapCom mod), the sub-tasks can be completed or not, but notice that in Mission Control, the main tasks are completed, and you just have to wait.  I'm not conversant with contract creation or Contract Configurator, so I'm no help here.

Share this post


Link to post
Share on other sites
9 minutes ago, Brigadier said:

Did you insert the "direct" link?  I'm not that conversant with Imgur albums so I just add individual pictures.

Yep... thanks for the tip I'll do that from now ;)

9 minutes ago, Brigadier said:

I have RB and TST installed so it's strange that my TB-75M doesn't have a Track Bodies module. 

It have it without the TST ;)

9 minutes ago, Brigadier said:

The TB-75M cannot take pictures whereas the TST scopes can (under the TSTSpace Telescope module of the scope in the VAB).

Ok too Bad TST doesn't had the picture hability...

9 minutes ago, Brigadier said:

  I use this picture-taking ability to advance the research in the Observatory. 

I'll try that thanks :)

9 minutes ago, Brigadier said:

At least according to the contract, you don't need to place the scope in a specific orbit.

yep that's why I foud it weird to have those Orbits...

9 minutes ago, Brigadier said:

That said, in my game, I do see orbits that are attributed to RepoSoft contracts but I cannot determine which orbit belongs to which contract.  I have 4 RepoSoft contracts: Search the Skies, Search the Skies with a Telescope, Research a Celestial Body, and Research a Celestial Body with a Telescope.  I presume that the "with Telescope" ones are for orbital scopes,

same here and I think so too, because those ask for being over 200 km ;) so you can't do it from the ground ^^

9 minutes ago, Brigadier said:

but that still leaves me with some uncertainty.  Even with no scopes in these orbits, all of the RepoSoft contracts are counting down to completion, so I'm a little at a loss.

Yeah conting down as soon as you accepted the quest... may be If you don't put a scope in orbit it will go failed at the end of the count down...
But I'm don't like to fail so did not that happen...

 

9 minutes ago, Brigadier said:

Yeah, I've seen and mentioned this odd behaviour recently, too.  Depending where you view the contract (Msn Control, Tracking Station, Contract window, the CapCom mod), the sub-tasks can be completed or not, but notice that in Mission Control, the main tasks are completed, and you just have to wait.  I'm not conversant with contract creation or Contract Configurator, so I'm no help here.

That's why I quoted you in my first post ;) since the modder said afterward that the KSP 1.8 version of its mod was out and needed the CC up to date top...

I was merly saying that even with the new version we got the same strange behaviour...

Another thing in the observatory I can't seem to move down the contract in the research body contextual area the slide bar does not want to move... or it go up as soon as it move...
Yet I just saw that it refers to the mission controle to see all contracts...

 

That said I need to send a new scope to take some pictures ;)
 

Share this post


Link to post
Share on other sites
28 minutes ago, BrettDah said:

That said I need to send a new scope to take some pictures ;)

Bonne chance!

Share this post


Link to post
Share on other sites

Out of curiosity, where is the observatory? My tracking station is level-3 and I can't find it. I am unsure as to where to locate it.
All I have installed are Snacks and Research Bodies on this instance. Oh, and I have the DLC installed as well.

 

https://imgur.com/CcK2MXZ

Spoiler

CcK2MXZ.png

 

Edited by Electr0ninja

Share this post


Link to post
Share on other sites
16 minutes ago, Electr0ninja said:

Out of curiosity, where is the observatory? My tracking station is level-3 and I can't find it. I am unsure as to where to locate it.
All I have installed are Snacks and Research Bodies on this instance. Oh, and I have the DLC installed as well.

 

https://imgur.com/CcK2MXZ

  Reveal hidden contents

CcK2MXZ.png

 

It's not there at all -- Make sure it's enabled in the settings, and also make sure any dependancies are also loaded. -- Module Manager and Contract Configurator are required.

Share this post


Link to post
Share on other sites

Oh, I didn't see contract configurator as a dependency. I will install it. Thankyou.

Edited by Electr0ninja

Share this post


Link to post
Share on other sites

Putting this here as a heads up for Kerbalism users:

If you experience a massive EC usage on all probe cores (like 12 EC/s or more), please delete the file ResearchBodiesMMRemoteTech.cfg (see this issue on GitHub for details).

Share this post


Link to post
Share on other sites

^^ Confirming 100%
 

Since RT isn't supported in Kerbalism,  those two mods + RB shouldn't be a valid combination, but this MM config loads w/o RemoteTech, and borks EC usage as stated. At the very least it can be fixed to not load w/o RT? Something in the NEEDS / FOR / WHICHEVER statement?

Share this post


Link to post
Share on other sites
4 hours ago, WarriorSabe said:

Is there somewhere I can find the 1.7 version? 

If you mean a version that is compatible with KSP 1.7, do you use CKAN?  If so, click on the Versions tab of the RB mod and select v1.10.

@JPLRepo, just a suggestion: could you update the OP to include the new log location for KSP 1.8 under your What I Mean By Logs section?

Share this post


Link to post
Share on other sites

I've got Minmus 10% research, and with a contract to explore Minmus I decide to go towards Minmus. After enter the SOI, Landed and planted the flag, I went into the map view to discover something weird: Duna, Eve, Gilly,  Ike and the rest of the planets suddenly has their orbital line appeared and with full color and detail. I have a "explore the sky" contract still going on, and my telescope can't find Eeloo, and when I decide to go into the observatory, I cannot enter the facility. Please help.

Share this post


Link to post
Share on other sites
7 hours ago, Sirius K said:

I've got Minmus 10% research, and with a contract to explore Minmus I decide to go towards Minmus. After enter the SOI, Landed and planted the flag, I went into the map view to discover something weird: Duna, Eve, Gilly,  Ike and the rest of the planets suddenly has their orbital line appeared and with full color and detail. I have a "explore the sky" contract still going on, and my telescope can't find Eeloo, and when I decide to go into the observatory, I cannot enter the facility. Please help.

Welcome to the forums.

Please read the topic at the link in my sig block below and post a link to your log file when reporting problems with modded installs.  If you have played the game since finding this problem, a log won't help in this case because it's been overwritten by subsequent sessions, but it's sound advice for the future.

Sorry for the barrage of questions but without a log...

  1. Which version of KSP and this mod are you using?
  2. When you created the career game, what RB difficulty level did you set?
  3. Do you have the Tarsier Space Telescopes mod installed?
  4. Did you set the Observatory to be available with Tracking Station at Level 1?  Have you upgraded your Tracking Station?

I might not be able to answer you question but the info may help players wiser than I am.

Share this post


Link to post
Share on other sites
On 12/2/2019 at 1:53 AM, Brigadier said:

Welcome to the forums.

Please read the topic at the link in my sig block below and post a link to your log file when reporting problems with modded installs.  If you have played the game since finding this problem, a log won't help in this case because it's been overwritten by subsequent sessions, but it's sound advice for the future.

Sorry for the barrage of questions but without a log...

  1. Which version of KSP and this mod are you using?
  2. When you created the career game, what RB difficulty level did you set?
  3. Do you have the Tarsier Space Telescopes mod installed?
  4. Did you set the Observatory to be available with Tracking Station at Level 1?  Have you upgraded your Tracking Station?

I might not be able to answer you question but the info may help players wiser than I am.

I'm playing KSP in the most recent version. I set the difficulty of research bodies to the max difficulty (Kerbin, Sun & The Mün). No, this problem was before I download Tarsier Space Telescopes. I have a level 3 tracking station before this problem occurred. But I did reinstall the mod due to the game crashing when I have to much mods.

Share this post


Link to post
Share on other sites
On 12/10/2019 at 6:29 AM, Sirius K said:

I'm playing KSP in the most recent version. I set the difficulty of research bodies to the max difficulty (Kerbin, Sun & The Mün). No, this problem was before I download Tarsier Space Telescopes. I have a level 3 tracking station before this problem occurred. But I did reinstall the mod due to the game crashing when I have to much mods.

Same here. I was hesitating if it is Minmus or the upgrade of the radar facility that causing this.

Also, entering the observatory bugs out after it: no visible window, but locks the rest of the screen. Have to kill KSP from the shell.

Linux, 1.8.1. I do not have the logs.

Share this post


Link to post
Share on other sites
1 hour ago, kubi said:

Same here. I was hesitating if it is Minmus or the upgrade of the radar facility that causing this.

Also, entering the observatory bugs out after it: no visible window, but locks the rest of the screen. Have to kill KSP from the shell.

Linux, 1.8.1. I do not have the logs.

You could use alt+f12 and remove all input locks

Share this post


Link to post
Share on other sites
On 12/9/2019 at 9:29 PM, Sirius K said:

I'm playing KSP in the most recent version. I set the difficulty of research bodies to the max difficulty (Kerbin, Sun & The Mün). No, this problem was before I download Tarsier Space Telescopes. I have a level 3 tracking station before this problem occurred. But I did reinstall the mod due to the game crashing when I have to much mods.

Post your log file so we can see what you have installed and if there are any errors.  If you're crashing because of too many mods, there may be other problems.

6 hours ago, kubi said:

Linux, 1.8.1. I do not have the logs.

Yes, you do :P. Read the link below where it says to look in  ~/.config/unity3d/Squad/Kerbal\ Space\ Program/Player.log . I don't use Linux so I can't confirm this location or offer any OS-specific help.

From the OP:

Quote

For support please ensure you are following these instructions.
From now on I will NOT respond to requests for support if you have not at least attempted to follow these simple steps.
NO LOGs = NO SUPPORT.

@JPLRepois pretty busy but if you don't follow his instructions he's apt to ignore you.  Do yourselves a favour and post your logs.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.