JPLRepo

[1.8.x] ResearchBodies V1.11.0 (19th Oct Jun 2019)

Recommended Posts

 Is there any chance that the bug that discovers all celestial bodies will be fixed in ResearchBodies for 1.9.1? 

Share this post


Link to post
Share on other sites

Can it be used on an already started save?

Share this post


Link to post
Share on other sites
On 7/19/2020 at 11:31 AM, Souptime said:

Can it be used on an already started save?

Sort of.  Success and enjoyment will depend on which planets you've already discovered and what difficulty level you set for the mod.  Don't expect a seamless addition.  If you're not very far along your current save I would suggest starting fresh with this mod.

Share this post


Link to post
Share on other sites

Hi! This mod looks really cool, and I was wondering when it will be updated to work with ksp 1.10.1? I would really like to get back into ksp later, and this mod looks like a really cool way to do that :)

Share this post


Link to post
Share on other sites
On 9/4/2020 at 2:12 AM, darkplasmaray said:

Hi! This mod looks really cool, and I was wondering when it will be updated to work with ksp 1.10.1? I would really like to get back into ksp later, and this mod looks like a really cool way to do that :)

When I get the time to update it. I had to wait for Contract Configurator to be updated to 1.10 which it looks like it now has been.

So now that it is, soon.

Share this post


Link to post
Share on other sites
On 9/6/2020 at 2:04 AM, JPLRepo said:

When I get the time to update it. I had to wait for Contract Configurator to be updated to 1.10 which it looks like it now has been.

So now that it is, soon.

Good to hear!  This is one of the last apps I was waiting for to start a new career game.

Share this post


Link to post
Share on other sites
9 hours ago, Spot2345 said:

When I reload a save all the planets become discovered and the observatory and telescopes don't work

Read the previous messages: A) the author is aware of the "discovered planet" bug, and B) A new release is pending, apparently, soon ;)

FYI, for your future use, to do anything about a bug, the author needs to know what version KSP are you using, a copy of your log files, whats your gamedata directory look like, what addons have you installed,  did you install manually or via CKAN, etc.  What I'm saying is that you need to read and follow the referenced post below; its helpful for the authors and saves them the time repeating themselves for this same data every time.  Its also pinned to the first page of this forum (hint hint :-) )

 

Edited by Murdabenne

Share this post


Link to post
Share on other sites

I have a test build here for those willing to help test it.
This is for KSP 1.10.1 and requires Contract Configurator  1.30.2.

NOTE: This is unsupported and not a final release. Don't download this and install into your main save games and then come here telling me it broke your saves. It may or will contain bugs. Those willing to help testing it can download, start a new save, report anything you find back here.

 

Share this post


Link to post
Share on other sites
6 hours ago, JPLRepo said:

I have a test build here for those willing to help test it.
This is for KSP 1.10.1 and requires Contract Configurator  1.30.2.

NOTE: This is unsupported and not a final release. Don't download this and install into your main save games and then come here telling me it broke your saves. It may or will contain bugs. Those willing to help testing it can download, start a new save, report anything you find back here.

 

If there is backward compatibility with 1.9.1, I'm game.

Share this post


Link to post
Share on other sites
9 hours ago, JPLRepo said:

I have a test build here for those willing to help test it.
This is for KSP 1.10.1 and requires Contract Configurator  1.30.2.

NOTE: This is unsupported and not a final release. Don't download this and install into your main save games and then come here telling me it broke your saves. It may or will contain bugs. Those willing to help testing it can download, start a new save, report anything you find back here.

 

Likewise if it's backwards compatible with 1.8.1.  I have CC 1.30.2.

Would you like me to give a go anyway or is it clearly not 1.8.1 compatible?

Edit 1:  Ok, I installed KSP 1.10.1 just for this testing.  Do I need TST installed as well?  Will a Sandbox game give you what you need or do you need to see the contracts develop?

Edit 2:  Loaded RB with CC and MM only.  First save is a Sandbox, with RB Option for Hard (so I can find undiscovered Minmus easily), with Extra Debug Logging.  Launched a TB75 and discovered Minmus, researched it fully in the Observatory and quit.  Player Log here.  Note the crash report exception at the very end of the log, otherwise no initial issues.

Edited by Brigadier
Initial Tests

Share this post


Link to post
Share on other sites
8 hours ago, Brigadier said:

Likewise if it's backwards compatible with 1.8.1.  I have CC 1.30.2.

Would you like me to give a go anyway or is it clearly not 1.8.1 compatible?

Edit 1:  Ok, I installed KSP 1.10.1 just for this testing.  Do I need TST installed as well?  Will a Sandbox game give you what you need or do you need to see the contracts develop?

Edit 2:  Loaded RB with CC and MM only.  First save is a Sandbox, with RB Option for Hard (so I can find undiscovered Minmus easily), with Extra Debug Logging.  Launched a TB75 and discovered Minmus, researched it fully in the Observatory and quit.  Player Log here.  Note the crash report exception at the very end of the log, otherwise no initial issues.

@JPLRepo will this support 1.9.1?  Otherwise, I guess I'll just have to go without this addon - I have already dropped several others, this and Kopernicus/OPM were the last 2 I was waiting on. Its not an insult or anything like that, please don't take it that way or as an attempt to hurry or change the development.  I want to play and I have waited for  many mods to catch up to 1.9.1.  But its at the point where I want to play even missing as good an addon as this (and realistically, it needs to be there at the start).  I'm getting the feeling that by the time everything I would like to have is ready to go in 1.10.n, everything else will probably be headed to 1.12.1 or else KSP2.0 :D and nothing will be supported.  Kind of like the jump around 1.7.3, and any of the Unity changes.

Anyway, I want to start a new career on 1.9.1 due to Kopernicus+OPM and other mods I like not yet being fully stable for 1.10.1. My hope is that installing all mods I want via CKAN into 1.9.1 will allow me to upgrade via CKAN instead of uninstalling/reinstalling for 1.10.1 and having my save broken. It does get tiresome needing to restart my career for the bazillionth time due to a key mod getting left behind.   

Bottom line: Can you support 1.9.1 as well as 1.10.1?  If so,  I will test the heck out of it.  I have a clean retail install of 1.9.1 with all the purchased content included, and nothing else.  I'll use CKAN to install ZeroAVC (to kill all the deprecated miniAVC installs), AVC main version, Kopernicus, OPM (and its dependencies),  then CC and then manually install the beta, and do a basic go from there to discover Minmus (hard mode).  I'll post any results I get, and file bugs on github, and a PR for them if I have one.  After an official or supported release for 1.9.1, I'll be playing a long career game with a ton of addons, and be more than happy to bug track, report and help troubleshoot any issues.  Otherwise, I'll revisit this in a couple of releases when there is enough reason for a career restart, even though I will miss having it in the interim.
 

Edited by Murdabenne
Things

Share this post


Link to post
Share on other sites

Note the test build is a test build. It's not a release. and no it doesn't work in 1.9.x. NOTE: it REQUIRES requires Contract Configurator  1.30.2. and that doesn't work in KSP 1.9.x either.

I have no intention of releasing a version for an old version of KSP. It's hard enough to support  one (latest) release of KSP.

Share this post


Link to post
Share on other sites
3 hours ago, JPLRepo said:

Note the test build is a test build. It's not a release. and no it doesn't work in 1.9.x. NOTE: it REQUIRES requires Contract Configurator  1.30.2. and that doesn't work in KSP 1.9.x either.

I have no intention of releasing a version for an old version of KSP. It's hard enough to support  one (latest) release of KSP.

Contract Configurator has supported KSP 1.9.x since CCv1.29.0

So, if that is your limiting requirement, I guess there should be no problem.

Share this post


Link to post
Share on other sites

I am currently testing the test build on Moderate difficulty, career mode. Been doing since yesterday. Big commitment but a good excuse to get back into some KSP. I'll update this post as I discover bodies to let you know if everything is working well or not.

EDIT 1: Well, the "search the skies for celestial bodies" works. It works with the ground telescope and the space one. The "research celestial bodies" on the other hand seems a bit buggy. I did my first one with a space telescope, it added 10% onto Moho. I did it a 2nd time, and it didn't add a percentage to anything I had discovered.

It also seems slow, 10% for each 90 days you research it? I feel like it should go up 3 times instead of percentages. So that would be going up in 33% each time, making the planet look more detailed each time it is researched, and being completed at 100% when this is done 3 times.

Edited by darkplasmaray

Share this post


Link to post
Share on other sites
25 minutes ago, Gordon Dry said:

First finding, not sure in which mod the culprit is to be found

 

Do you have a KSP.log file you can provide?  The issue could be Strategia, ResearchBodies or ContractConfigurator (which is where the bulk of the Strategia => ResearchBodies integration happens).

Share this post


Link to post
Share on other sites

- deleted -

Edited by Gordon Dry

Share this post


Link to post
Share on other sites

- deleted -

Edited by Gordon Dry

Share this post


Link to post
Share on other sites
2 minutes ago, Gordon Dry said:

@nightingale With OPM (which by default sets Sarnus as to be ignored by ResearchBodies because it's visible by the naked eye since the inception of Kerbalkind) and with the difficulty setting 'Medium' I see strategies mentioning outer planets.

And now I got it - I assumed that Strategies literally hides the strategies that are about unresearched celestial bodies.

But shows them and tells which bodies need to be researched first.

So my bug report is now to be understood as a feature request ...

Okay, we can take this off the ResearchBodies thread then, since there's no issues there.

And in principle I agree, it doesn't make sense to see the strategies for bodies that you don't "know" about yet.  But from a technical perspective I don't know how easy it is for a strategy to be hidden.  But I'll use the feature request to take a look at it.

Share this post


Link to post
Share on other sites
1 hour ago, nightingale said:

Okay, we can take this off the ResearchBodies thread then, since there's no issues there.

And in principle I agree, it doesn't make sense to see the strategies for bodies that you don't "know" about yet.  But from a technical perspective I don't know how easy it is for a strategy to be hidden.  But I'll use the feature request to take a look at it.

Allright, I delete my stuff in this thread then.

Share this post


Link to post
Share on other sites
1 hour ago, nightingale said:

Okay, we can take this off the ResearchBodies thread then, since there's no issues there.

And in principle I agree, it doesn't make sense to see the strategies for bodies that you don't "know" about yet.  But from a technical perspective I don't know how easy it is for a strategy to be hidden.  But I'll use the feature request to take a look at it.

@nightingale he made the same request of my mod Resonant Orbit Calculator.  Let me know if you figure  an easy way to do it, I'll let you know if I do.

Share this post


Link to post
Share on other sites
22 minutes ago, Gordon Dry said:

Allright, I delete my stuff in this thread then.

Umm....  I just meant that it's not an issue in Research Bodies, so we could move any additional discussion to GitHub or the Strategia thread.  Not that we needed to scrub all history.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.