Question

Hello, today I was installing some mods ( for the version 1.1.2), when i finished the installation, i run the game, when I accelerate the ship and it begins to rise, when it reaches 6,000 autitude the camera loses focus and begins to focus on the back of the ship, causing the impression that the ship is going up on the camera. I need help please. Thanks S2

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Sorry to say, but I have a similar problem with a ship in orbit...

I have version 1.1.2 also
and I installed new KAS and KIS mods recently, but I had used old KAS when my ship was built (put in the squad file by mistake) no other mods used. My rocket has been running fine for weeks until recently.

my camera has suddenly started moving incrementally away from my ship and it's affecting my old made ship. all my stock made ships are fine.
I loaded a old save that had worked to check and after a some time the camera also moved back along my orbital path, irrespective of my ship's orientation...

I know that they set/refresh the centering of coordinates when you get far enough away from planets. and time acceleration (physics off?) temporarily brings it back to the ship.

But can it be the center of mass? I fired my engines to try cause the rocket to spin around the focus but it didn't. The camera's focus seems to have an error. the focus rotates when I turn the ship, so it's position must be retaliative to the ship/CoM?

Maybe there is a value of this focus relative to CoM that gets refreshed incrementally and it's somehow picking up error or something? we need help!

Since it affects saves that had been fine, I believe it's not the craft, but the installation somehow or the mod's part that has become corrupted?

I'll try backing up and moving saves to a fresh install to see if that helps.

what mods are you using HardZiin03? I'll try share pictures or video of my problem to see if it's the same as yours. :) Good luck ^_^

P.S. I found this about the camera losing the ship on launch: https://www.reddit.com/r/KerbalSpaceProgram/comments/3isul0/bug_every_time_i_reach_6000m_the_camera_loses/

it seems that re-installation fixed his problem, so I think you and I need to try a fresh install... REMEMBER TO BACKUP YOU GAME :3

Edited by Dragonoid
To add link to similar problem solution... and spelling

Share this post


Link to post
Share on other sites
  • 0

Yep, I just did a new install, after I had cleaned up the steam KSP file (since Steam doesn't entirely remove data),

I put all my saves and mods back, and now my ships seem to be working fine! ^_^ the modded parts don't even worry that the old version of KAS mod was deleted... I hope. :P So I hope doing a drastic and ex'orbit'ant reinstall works out for you! :D

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.