Jump to content

[1.12.x] The Malemute Rover


RoverDude
 Share

Recommended Posts

I made a MM patch which turns the GeoLab data transmitter into a RemoteTech antenna.

Omni 5 Mm, 0.2 ec/s, passive 500 km.

I know a dish is visible as well but i have never seen both in a single part and didn't feel like experimenting.

I will just leave it here in case anybody else wants to use it until we get something more official and, possibly, balanced.

 

Spoiler

//RT Support for USI - Malemute Geology Lab

//USI - Malemute Geology Lab
@PART[Malemute_RoverScienceLab]:NEEDS[RemoteTech]
{
    !MODULE[ModuleDataTransmitter] {}
       
    %MODULE[ModuleRTAntenna] {
        %Mode0OmniRange =  500000
        %Mode1OmniRange = 5000000
        %EnergyCost = 0.2
                       
        %TRANSMITTER
        {
            %PacketInterval = 0.3
            %PacketSize = 2
            %PacketResourceCost = 15.0
        }
    }
    
    %MODULE[ModuleSPUPassive] {}
}

 

 

Edited by Vrana
Link to comment
Share on other sites

14 hours ago, RoverDude said:

Or you can be double awesome and get me a pull request - there will be a new update with the rest of my mods today, so now is a really good time for someone to do that.

Done.

Link to comment
Share on other sites

hey this is sort of a bug report in general for your mods, and mods that add there own categorys too the ksp parts menu, for some reason custom categorys arent showing up in the vab or sph, and i cant see the parts that would usually belong in them. i feel like im missing something,like a plugin or file, but im not sure what, or if i am. i installed filter extensions, then removed it, could that have caused this bug ? 

Link to comment
Share on other sites

3 minutes ago, RoverDude said:

You are.  Install everything in that ZIP file please.

should i get more recent versions of firespitter and/or community resource pack or is the ones already packaged updated enough?

Link to comment
Share on other sites

16 minutes ago, RoverDude said:

You are.  Install everything in that ZIP file please.

i did this, i literally dragged all the  contents of what was inside the gamedata folder in the zip file, into my gamedata folder, and i ran ksp, but the category doesent show up. this happens too all the mods that add new categorys. could it be toolbar or something? module manager? i can give u my log files if u want.

Link to comment
Share on other sites

2 minutes ago, 123nick said:

i did this, i literally dragged all the  contents of what was inside the gamedata folder in the zip file, into my gamedata folder, and i ran ksp, but the category doesent show up. this happens too all the mods that add new categorys. could it be toolbar or something? module manager? i can give u my log files if u want.

What game mode. IIRC Roverdude mentioned in his stream last night not seeing categories if you havent unlocked any of the parts in those categories yet

Link to comment
Share on other sites

sandbox, but i did have filter extensions mod at one point, and in one of the options there was a thing that allowed you too hide unpurchased parts, i turned it off though, it was on by default, but i completely removed that mod so i dont see how that could cause this problem unless it modified one of the core game files, like something not packaged with or within the mod.

Link to comment
Share on other sites

My thought - if you want to try it a moment first, before the clean install - is to try removing the MM caches and the PartDatabase.cfg.  They'll regenerate on load, and it's possible that FilterExtensions had something in there which is interfering.

Link to comment
Share on other sites

9 minutes ago, RoverDude said:

@123nick - start with a clean install and a clean save, let us know what the conflict ended up being.

you know, i cant help but feel that maybe just a simple module manager script that changes all parts with category = none too category = Utility would be alot easier and simple. sorta like how i fixed my PCs problem of BSOD if i leave it AFK for too long, i wrote a script that presses the M key every 100 seconds :D 

Link to comment
Share on other sites

7 hours ago, RoverDude said:

Except that you're masking something else that's screwing with your install.  Better to fix it, otherwise you make finding other issues down the line a lot harder.

i guess. would giving log files help finding the mod thats doing this easier?

Link to comment
Share on other sites

15 minutes ago, 123nick said:

i guess. would giving log files help finding the mod thats doing this easier?

Fastest way to find the problem mod:

1. Backup your save

2. Uninstall half your mods

3. Start a new sandbox game and see if the problem is there

4. If it is, then it's in the mods you still have installed, go to #2

5. If the problem is gone, it's in the mods you uninstalled, reinstall half of them, then go to #2

6. Repeat until you identify the problem mod.

Link to comment
Share on other sites

Just now, mcortez said:

Fastest way to find the problem mod:

1. Backup your save

2. Uninstall half your mods

3. Start a new sandbox game and see if the problem is there

4. If it is, then it's in the mods you still have installed, go to #2

5. If the problem is gone, it's in the mods you uninstalled, reinstall half of them, then go to #2

6. Repeat until you identify the problem mod.

but that takes like, forever, especially with the large ammount of mods i have. and i think i sorta know what mods are causing this already. 

 

oh, and a question. is there a file where the categorys are stored? the custom categorys? 

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...