IgorZ

[1.4+] Surface Mounted Lights - v1.8

Recommended Posts

 

2 hours ago, JadeOfMaar said:

 

@PART[X|Y|Z]:NEEDS[SurfaceLights&CommunityCategoryKit]

 

What is `X|Y|Z` ?

@PART[spotLight1,spotLight2]:NEEDS[CommunityCategoryKit]
{
  @category = none
  @tags ^= :^:cck-lights
}


@PART[*]:HAS[@MODULE[ModuleColoredLensLight]]:NEEDS[SurfaceLights&CommunityCategoryKit]
{
  @category = none
  @tags ^= :^:cck-lights
}

 Works for me, is it ok what `cck-lights` tag can be duplicated in tags string ?

How to take at MM all SomeMod's parts  inside \GameData\SomeMod\Parts\  ?

  • Like 1

Share this post


Link to post
Share on other sites

this is the patch I use that handles all parts that are put into a CCK category, which has to be done via a specific tag format so it's easy to handle

@PART[*]:HAS[~category[none],#tags[*cck*]]:FINAL
{
  @category = none
}

 

  • Like 2

Share this post


Link to post
Share on other sites

I've been looking for these parts for so long, so awesome to see them again after 0.24 :)

Share this post


Link to post
Share on other sites

@IgorZ I just created a pull request to remove the stock lights from the utility category as you were already adding them into the new lights category added in this mod. It bothered me so I fixed it.

Share this post


Link to post
Share on other sites
3 hours ago, Jalaris said:

@IgorZ I just created a pull request to remove the stock lights from the utility category as you were already adding them into the new lights category added in this mod. It bothered me so I fixed it.

Hello. Thank you for the pull request. However, the CCK categories must not be replacing the stock category - that's the concept of CCK. I've commented in the PR. Those, who want to remove the parts from the stock categories, are welcome to do it via an MM patch, but the rule of thumb is: a mod must be correctly working without CCK.

Share this post


Link to post
Share on other sites

Isn't it possible to only remove the parts from the stock category if CCK is there, using an MM patch?

Share this post


Link to post
Share on other sites
16 minutes ago, Conventia said:

Isn't it possible to only remove the parts from the stock category if CCK is there, using an MM patch?

It's not about possibility, it's about the concept. And the concept says: whatever can be found in a CCK category must also be found in a stock category. I fully support this concept. If you want to get a clue why was this decision made, I'd suggest you reading the CCK forum thread from the very beginning. It was discussing there.

Edited by IgorZ

Share this post


Link to post
Share on other sites
18 hours ago, Conventia said:

Isn't it possible to only remove the parts from the stock category if CCK is there, using an MM patch?

Yea just do this and you're good to go:

@PART[*]:HAS[~category[none],#tags[*cck*]]:FINAL
{
  @category = none
}

 

Share this post


Link to post
Share on other sites

AVC has issues with the name being so long.  

02TIcYd.png

Share this post


Link to post
Share on other sites
12 hours ago, eberkain said:

AVC has issues with the name being so long.  

02TIcYd.png

I was thinking about the name rebranding too. Any ideas for the new name?

Share this post


Link to post
Share on other sites
38 minutes ago, IgorZ said:

I was thinking about the name rebranding too. Any ideas for the new name?

"Moar Lights", just a Suggestion.

Share this post


Link to post
Share on other sites

Name is good, just a lot of it is unnecessary. Surface Mounted Lights works fine

  • Like 2

Share this post


Link to post
Share on other sites

can someone help me please.

I have a problem with the strength of the lights since i came back from a break. i use this mod in all my play through's I found it indispensable.

every mod i have installed is up to date and unedited.. this is if you think i may have edited a file to mess up some lighting.

i have Stock Visual Enhancements and through that Scatterer/EVE. Minimum ambient lighting(of which is default-no movement of slider) (the only mods i can think of that makes adjustments to lights).

Distant object enhancement also.

in the game gfx setting page the Ambient Light Boost/map/editor are all at Default 0%

i know some lights dont have 'range' but should reflect off the ground and illuminate a spot.

I tested this in the SPH/VAB outside on the runway Day and Night.

Here's a picture of the lights in action

https://imgur.com/fAjqj1G

the two lights that actually a 'light spot' are the landing gear and the mk3 mini spotlight.

surely there is something wrong with my setup. please help me.

heres my outputlog -64

https://www.dropbox.com/s/09q8j3340l5fasl/output_log.txt?dl=0

Share this post


Link to post
Share on other sites
11 hours ago, C04L said:

can someone help me please.

I have a problem with the strength of the lights since i came back from a break. i use this mod in all my play through's I found it indispensable.

every mod i have installed is up to date and unedited.. this is if you think i may have edited a file to mess up some lighting.

i have Stock Visual Enhancements and through that Scatterer/EVE. Minimum ambient lighting(of which is default-no movement of slider) (the only mods i can think of that makes adjustments to lights).

Distant object enhancement also.

in the game gfx setting page the Ambient Light Boost/map/editor are all at Default 0%

i know some lights dont have 'range' but should reflect off the ground and illuminate a spot.

I tested this in the SPH/VAB outside on the runway Day and Night.

Here's a picture of the lights in action

https://imgur.com/fAjqj1G

the two lights that actually a 'light spot' are the landing gear and the mk3 mini spotlight.

surely there is something wrong with my setup. please help me.

heres my outputlog -64

https://www.dropbox.com/s/09q8j3340l5fasl/output_log.txt?dl=0

Could you, please, make the same test without the Surface Mounted Lights mod? From what you show I don't see any problem, and how it is related to this mod. Btw, the right log to share is KSP.log.

Share this post


Link to post
Share on other sites

Thanks for replying IgorZ.

As requested here are the dropbox links to a new test: KSP.log + a screenshot of the lights turned on shining on the floor. (With & Without in their file names)

I used CKAN to add and remove my mods.

https://www.dropbox.com/s/cifc3eid8pyp37t/KSPlog with SML.log?dl=0

https://www.dropbox.com/s/yutirytziehsmx2/screenshot21WithSML.png?dl=0

https://www.dropbox.com/s/s70k0qx4ealwevd/KSPlog Without SML.log?dl=0

https://www.dropbox.com/s/5ygpkijy6ut6yn1/screenshot20withoutSML.png?dl=0

if its not SML i am so very sorry for having you put time into this.

I am in UK time but i have notify me on this page so il get told quickly if you need me to get you anything/try something

Much gratitude IgorZ /bow

Share this post


Link to post
Share on other sites
16 hours ago, C04L said:

Thanks for replying IgorZ.

As requested here are the dropbox links to a new test: KSP.log + a screenshot of the lights turned on shining on the floor. (With & Without in their file names)

I used CKAN to add and remove my mods.

https://www.dropbox.com/s/cifc3eid8pyp37t/KSPlog with SML.log?dl=0

https://www.dropbox.com/s/yutirytziehsmx2/screenshot21WithSML.png?dl=0

https://www.dropbox.com/s/s70k0qx4ealwevd/KSPlog Without SML.log?dl=0

https://www.dropbox.com/s/5ygpkijy6ut6yn1/screenshot20withoutSML.png?dl=0

if its not SML i am so very sorry for having you put time into this.

I am in UK time but i have notify me on this page so il get told quickly if you need me to get you anything/try something

Much gratitude IgorZ /bow

Aha. I think I know what's happening. SML updates all the stock light in the game to the "warm" color temperature. By default the game uses RGB(1, 1, 1), but SML uses RGB(1, 0.9, 0.8). If you familiar with this color encoding scheme, you know that the latter triplet gives less light intensity. The Unity engine should actually take care of the corrections, but it doesn't seem to happen in this specific case. If you don't like this behavior just drop the "MM-StockLights.cfg" file from the "Patches" directory.

Share this post


Link to post
Share on other sites

Thanks IgorZ. 

I drag n dropped StockLights.cfg to my desktop. The Lights intensity has returned! wonderfull. i wonder why the engine misses it in my case. i havent come across anyone else that has this problem, i posted in a couple of places and no one has said they have the same problem. i think when ksp is updated again im going to do a clean install of it.

anyway.. thanks a bunch IgorZ, you da maan.

Share this post


Link to post
Share on other sites
4 minutes ago, C04L said:

i posted in a couple of places and no one has said they have the same problem

More likely, they don't see it as a problem :)

Btw, instead of removing the file, you may simply adjust the values in it. Or, you can change the values in the editor for a specific part when the brightness is really an issue. Also, try doing your tests in the dark (this is when you really need the lights, right?). This is how I've changed my mind once. The "cold white" (stock) light temperature makes the objects to contrast and overexposed in case of multiple sources. The "warm white" temperature is more friendly to the eyes when operating in the deep dark (like on the night side of the Mun).

Share this post


Link to post
Share on other sites

Thanks! i was tempted to // in front of the lines instead of taking it out. but changing it to a warmer contrast might be an idea.

at least KSP is not in beta anymore and thus i wouldnt have to edit 'every month' hehe

Thanks again for your help, yr a star

 

Share this post


Link to post
Share on other sites

1.7 (March 8th, 2018)

  • KSP 1.4 support.

Note, that from now on the official name of the mod is "Surface Mounted Lights".

  • Like 2

Share this post


Link to post
Share on other sites

Thank you for the update, now i can start building craft again. Started a new game getting ready for MH update next week.

  • Like 1

Share this post


Link to post
Share on other sites

Hi. I have 1.6 version on 1.3.1 KSP and big lights dont work, small lights light up surface and ships around, but big ones only lights up themself, but nothing around gets lit. I have set number of pixel lights to 40.

Share this post


Link to post
Share on other sites
1 minute ago, Battou said:

Hi. I have 1.6 version on 1.3.1 KSP and big lights dont work, small lights light up surface and ships around, but big ones only lights up themself, but nothing around gets lit. I have set number of pixel lights to 40.

What are the names of those "big lights"? I'm concerned to hear plural here, since this mod offers only three parts and two of them are the spotlights - they are not designed to light anything but the surface they are mounted on.

And just to not set the false expectations: once a new KSP version is out, the support of the previous version is no more offered. You're still welcome to request an advice, but even if there is a bug, it won't be fixed. If you could reproduce the issue under the KSP 1.4, that would change the things.

Share this post


Link to post
Share on other sites
9 hours ago, IgorZ said:

What are the names of those "big lights"? I'm concerned to hear plural here, since this mod offers only three parts and two of them are the spotlights - they are not designed to light anything but the surface they are mounted on.

And just to not set the false expectations: once a new KSP version is out, the support of the previous version is no more offered. You're still welcome to request an advice, but even if there is a bug, it won't be fixed. If you could reproduce the issue under the KSP 1.4, that would change the things.

What do you mean "three parts", there are 5 parts, as in pics in first post, the one that not warking is big round and big rectangular spot lights.

Share this post


Link to post
Share on other sites
2 hours ago, Battou said:

What do you mean "three parts", there are 5 parts, as in pics in first post, the one that not warking is big round and big rectangular spot lights.

The big round and rectangular lights are the stock lights. This mod only adds a color to their lens.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now