Jump to content

1.1.2 - All rovers are turning to the right..?

Recommended Posts

I decided to try building a rover for the first time today, and I noticed that any rover I construct will turn to the right at the moment that I press W (forward). This is no matter what wheels or probe core I use. I downloaded a fresh new copy of 1.1.2 and continued to have this problem, even with some of the stock rovers like Rover + Skycrane and Prospector Rover (I don't see this problem with the Crater Crawler nor with the Bug-E Buggy).


Now, this is not a continuous turn to the right - it is only upon pressing forward. For example, from stop, I will press W and the rover will begin to move forward and turn right about 15 degrees or so, and then if I continue to have W pressed, the rover will continue straight at the new 15 deg angle. However, if instead of continuously holding W I pulse W for one second pressed, one second unpressed, one second pressed, etc., the rover will go forward-right ~15 degrees, then forward-right another ~15 degrees, then forward-right another ~15 degrees...and eventually I am traveling in a huge circle, without ever hitting any other key but forward. This will happen even if I disable steering on each of the wheels. This will also happen if I try to create a rover with awfully misaligned wheels to see if it will drive left or affect it in some way - and it doesn't. The rover does the exact same thing, with no differences. I have tried this with a 4 wheeled and a 6 wheeled rover, and the problem seems more pronounced with a 6 wheeled rover. I have tried it on completely flat terrain and I have tried to make sure the terrain was exactly the same for all wheels (driving on the runway and in the grass around the KSC).


I tried downloading a fresh new copy of 1.0.5 and this problem was no more. The rover drove as straight as could be. I even tried to create a new rover with misaligned wheels again, and even this horribly asymmetric rover ran 100% straight. So, this seems to be a problem with some release after 1.0.5 (I do not know which release because as I mentioned before, today was my first ever trial with rovers). Does anyone else have this problem with 1.1.2? This seems to me to be a pretty significant bug.


I am running Windows 10 64-bit. I've tried KSP 1.1.2 in 32-bit mode and 64-bit with the same problem.

Edited by RomanceEngineer
Link to comment
Share on other sites

  • 9 months later...

I'm glad that I'm not the only one experiencing this. I'm running 1.2.2 64-bit Windows 7.


You say that the issue occurs on short wheel base designs. and yes I can concur with this. However the rover that I'm using is a 6 wheeler on the rectangular rovemate probe core...

Edited by Vereox
Link to comment
Share on other sites

  • 1 month later...

I'm running v1.2.2, and I've got the same issues. My Rovers just curve to the left when accelerating, or rolling with sufficient speed. Guess I'll spend my research points in other categories, then...

Any word of when this issue will be tackled?

Link to comment
Share on other sites

  • 2 weeks later...

I noticed this issue with my recent RSS save... very little wheel control authority (in addition to wanting to phantom turn). Yet, in my previous build, I had none of these issues at all... I'm wondering if it isn't a conflict of sorts. That said, I wouldn't know where to begin looking as a potential culprit either.


Anyone else have any success in troubleshooting this issue?

Link to comment
Share on other sites


^ try pointing you steering wheels ever so slightly inward towards each other (toe in), I've had good luck with that, though I'll admit I haven't done much rover stuff in my latest career.  Also try turning off steering in most of your wheels if you have a lot of them on your rover.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...