Jump to content
  • 0

Adding Flags


Rolanvorxariat
 Share

Question

Hello again, Kerbonauts! I got back into KSP after watching Vaos' entire Solar Nations series(definitely worth a watch), and being myself, I had to do roleplay and Space Racey things. So, I made some nice flags, and plopped them in the >Gamedata>Squad>Flags folder. I load up KSP. No new flags, but I have all my flags I added from 1.0.5. Is there anything I'm doing wrong, or is it a bug with 1.1?

Also I have Hyperedit, CxAerospace Space Station Parts, Kerbinside/KK, Taurus 3.75M Capsule, and some other base part mods.

Edited by Rolanvorxariat
Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 1
4 hours ago, StahnAileron said:

What file format are you using? Almost all flags I've seen are in PNG format.

Also, I think it's best to not touch the Squad folder and dump your flags in a separate mod folder like Deviouz implies.

All my flags are in PNG format with the dimensions: 256x160

 

6 hours ago, Rolanvorxariat said:

Sooo... @Devious, do you just create a new folder in Gamedata and dump all the flags in?

Actually the folder was created when I added a compilation of custom flags, but the mod only contained the mentioned folder and no other files, so yea, I just dumped a folder into the GameData.
There are no other files within the flags folder besides images either (configs, dll, etc).

Link to comment
Share on other sites

  • 1
3 hours ago, Rolanvorxariat said:

Sooo... @Devious, do you just create a new folder in Gamedata and dump all the flags in?

Yes, that's what I did. This makes it easy to save and transfer the custom stuff. I have a separate folder in GameData for my flags, GameData\Crown\Flags. Some of the subfolders aren't recognised, though. I think, I will test it with another subfolder Flags.

Some of my flags have 256x160, others have 768x513, and even weirder sizes. Some are in PNG format, others in JPG format. And even some in BMP. I think, the most common picture formats work and as long as the side ratio is 1.6 it will appear in-game as a flag.

Link to comment
Share on other sites

  • 0

Annnd... Still doesn't work. I made a folder in gamedata: Gamedata/Custom Flags/ Flags but it still doesn't work. Heck, some of the flags I deleted(not agency flags, regular flags) are still there when I load the game. My mods work fine, I installed KIS and all the items are there. All my flags are 256x160 png images. What am I doing wrong? 

EDIT: It works, nvm. Solved!

Edited by Rolanvorxariat
Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...