SpannerMonkey(smce)

SM Chute NOW OBSOLETE USE THE NEW VNG

Recommended Posts

15 minutes ago, FiiZzioN said:

Any thought on adding an ejection system? That's the only thing holding me back from using this; hoping you'll into it!

Hi, yes I've looked into it, I do have half a working system, the snag is at this point I don't know enough C#  to tie all the parts together. It's not just the eject thats the easy bit , it requires an inventory and interaction with eva  kerbals, so not the easiest thing to do.  

It's on the list of things still to be done, (it's a long list btw ) That said I'm still working on bringing several other mods up to 1.1.3 spec, so wont be getting anywhere near this issue for a while yet

Share this post


Link to post
Share on other sites
10 minutes ago, SpannerMonkey(smce) said:

Hi, yes I've looked into it, I do have half a working system, the snag is at this point I don't know enough C#  to tie all the parts together. It's not just the eject thats the easy bit , it requires an inventory and interaction with eva  kerbals, so not the easiest thing to do.  

It's on the list of things still to be done, (it's a long list btw ) That said I'm still working on bringing several other mods up to 1.1.3 spec, so wont be getting anywhere near this issue for a while yet

Awesome to hear! I'll try and peek in here to see how development's going every-so-often to see how things are progressing. When this is a feature I plan to switch over to this.

Thanks for the fast response!

Share this post


Link to post
Share on other sites

make it where you press P and it deploys the chute so you don't have to right click the chute.

Share this post


Link to post
Share on other sites
1 hour ago, John The Physicist said:

Isn't space jumping awesome!? I made this video with this amazing mod.

Hiya, and thanks i think? you beat my alt record by 6500 mtrs (mind you i did use a balloon)   And while I'm well aware of the deployment issues, still not found a fix, I don't like that they are so temperamental,   I suppose though with the way other things are refusing to interact properly with EVA that we should be thankful for the odd times when they do perform as they should. (not thankful, it irritates me that it's so near and yet so far)

Share this post


Link to post
Share on other sites

i dont know why but every time i deploy chute my kerbal goes sideways like this

http://images.akamai.steamusercontent.com/ugc/275101458691716450/F90F0223566091E87DDE4BEECCB0DA38EE7BCC42/

and if i time warp x4  my kerbal shakes so much i get launched into space and on this time i ended up near the sun

http://images.akamai.steamusercontent.com/ugc/275101458691719443/980BB669DD67C3E237BCF2A82EB26C206B2FE664/

Share this post


Link to post
Share on other sites
23 minutes ago, KerbalMan23 said:

i dont know why but every time i deploy chute my kerbal goes sideways like this

http://images.akamai.steamusercontent.com/ugc/275101458691716450/F90F0223566091E87DDE4BEECCB0DA38EE7BCC42/

and if i time warp x4  my kerbal shakes so much i get launched into space and on this time i ended up near the sun

http://images.akamai.steamusercontent.com/ugc/275101458691719443/980BB669DD67C3E237BCF2A82EB26C206B2FE664/

HI, I'll check that out and fix as required. 

Share this post


Link to post
Share on other sites
2 hours ago, KerbalMan23 said:

i dont know why but every time i deploy chute my kerbal goes sideways like this

http://images.akamai.steamusercontent.com/ugc/275101458691716450/F90F0223566091E87DDE4BEECCB0DA38EE7BCC42/

and if i time warp x4  my kerbal shakes so much i get launched into space and on this time i ended up near the sun

http://images.akamai.steamusercontent.com/ugc/275101458691719443/980BB669DD67C3E237BCF2A82EB26C206B2FE664/

Hi all fixed or at least it is in my game. please test and report back

Update v0.2.3

Fixes issues caused by changes in 1.1.3 to  body lift modifier

get it here or on spacedock Link in OP

Share this post


Link to post
Share on other sites
On 7/21/2016 at 7:04 PM, SpannerMonkey(smce) said:

Hi all fixed or at least it is in my game. please test and report back

Update v0.2.3

Fixes issues caused by changes in 1.1.3 to  body lift modifier

get it here or on spacedock Link in OP

i dont know why but every time i deploy chute my kerbal goes sideways like this

http://images.akamai.steamusercontent.com/ugc/275101458691716450/F90F0223566091E87DDE4BEECCB0DA38EE7BCC42/

and if i time warp x4  my kerbal shakes so much i get launched into space and on this time i ended up near the sun

http://images.akamai.steamusercontent.com/ugc/275101458691719443/980BB669DD67C3E237BCF2A82EB26C206B2FE664/

 

it still does it! see!

 

http://images.akamai.steamusercontent.com/ugc/276228215771793820/48159A058242890FEFF7FCD124E70DFACE149DE9/

http://images.akamai.steamusercontent.com/ugc/276228215771792098/005A48CBBFB745E0531A9E3D3C5DDBEA2B360E5F/

 

 

EDIT: didnt install a new version whoops!

 

Edited by KerbalMan23
didnt install new version

Share this post


Link to post
Share on other sites
1 minute ago, KerbalMan23 said:

i dont know why but every time i deploy chute my kerbal goes sideways like this

and if i time warp x4  my kerbal shakes so much i get launched into space and on this time i ended up near the sun

it still does it! see!

HI,  I'm going to need to see a log, there's something going on there, and it has the feel of a conflict. Do you have realchute or any other chute or drag changing mods installed?

Share this post


Link to post
Share on other sites
38 minutes ago, SpannerMonkey(smce) said:

HI,  I'm going to need to see a log, there's something going on there, and it has the feel of a conflict. Do you have realchute or any other chute or drag changing mods installed?

read the bottom of my thing. there is no problem anymore

Share this post


Link to post
Share on other sites
Just now, SpannerMonkey(smce) said:

Hiya, thanks for reporting back, , much appreciated.

Your welcome!

Share this post


Link to post
Share on other sites

Thanks for the cool mod.  I'm having an issue though with clicking on the chutes to open the screen to deploy them if I'm traveling at any speed (above 15m/s say).  When my kerbal is going slow (like exiting a craft whose chutes are deployed, I can click on and open the menu fine, but if I exit an airplane (at 40m/s or up) the ability to click on the chutes just doesn't seem to be there.  Not sure if this is an issue with the mod or how it works with KIS, but it makes jumping/bailing from planes difficult/ impossible.

Share this post


Link to post
Share on other sites
58 minutes ago, Floopis said:

Thanks for the cool mod.  I'm having an issue though with clicking on the chutes to open the screen to deploy them if I'm traveling at any speed (above 15m/s say).  When my kerbal is going slow (like exiting a craft whose chutes are deployed, I can click on and open the menu fine, but if I exit an airplane (at 40m/s or up) the ability to click on the chutes just doesn't seem to be there.  Not sure if this is an issue with the mod or how it works with KIS, but it makes jumping/bailing from planes difficult/ impossible.

Hi, sadly a known and still unsolvable issue, partly due to KIS and the way it activates colliders and for the rest an eva interaction issue .  The real killer for me is that, if you clip the chute to a part it all activates just as a stock pod chute would, and thereby pointing a finger straight at the EVA interaction as the main issue. I continue to chase the problem and bide my time hoping that 1.2 can bring a fix

Share this post


Link to post
Share on other sites
On 7/6/2016 at 10:21 AM, KerbalMan23 said:

make it where you press P and it deploys the chute so you don't have to right click the chute.

I would like this to happen too because when the kerbal is moving the parachute menu won't open so i can't deploy it

Share this post


Link to post
Share on other sites
5 minutes ago, coyotepunk05 said:

I would like this to happen too because when the kerbal is moving the parachute menu won't open so i can't deploy it

yeah

Share this post


Link to post
Share on other sites
4 minutes ago, KerbalMan23 said:

yeah

 

10 minutes ago, coyotepunk05 said:

I would like this to happen too because when the kerbal is moving the parachute menu won't open so i can't deploy it

I would like it to happen without adding a plugin too, and the day that Squad fixes the EVA interaction issues it will work that way, but until that day we can wish and hope that the fix comes sooner rather than later.

Share this post


Link to post
Share on other sites

ths mod sucks pls change it to be like vanguard was

Spoiler

On a more serious note, I tried to stop FAR from breaking this mod using ModuleManager. I'm unsure if it works because it causes it's own bugs (trying to deploy a parachute results in a message saying "Cannot deploy while stowed!").


@PART[Kerbachute2]:NEEDS[FerramAerospaceResearch]:AFTER[FerramAerospaceResearch]
{
	!MODULE[GeometryPartModule]
	!MODULE[FARAeroPartModule]
	@MODULE[RealChuteFAR]
	{
		@name = ModuleParachute
	}
}

@PART[Kerbachute3]:NEEDS[FerramAerospaceResearch]:AFTER[FerramAerospaceResearch]
{
	!MODULE[GeometryPartModule]
	!MODULE[FARAeroPartModule]
	@MODULE[RealChuteFAR]
	{
		@name = ModuleParachute
	}
}

This definitely changes *something*, and results in impact glitches that (can) cause the Kerbal to survive hitting the ground at speeds that would normally kill. Mission accomplished?

 

Share this post


Link to post
Share on other sites
17 minutes ago, Kreuzung said:

ths mod sucks pls change it to be like vanguard was

  Reveal hidden contents

On a more serious note, I tried to stop FAR from breaking this mod using ModuleManager. I'm unsure if it works because it causes it's own bugs (trying to deploy a parachute results in a message saying "Cannot deploy while stowed!").



@PART[Kerbachute2]:NEEDS[FerramAerospaceResearch]:AFTER[FerramAerospaceResearch]
{
	!MODULE[GeometryPartModule]
	!MODULE[FARAeroPartModule]
	@MODULE[RealChuteFAR]
	{
		@name = ModuleParachute
	}
}

@PART[Kerbachute3]:NEEDS[FerramAerospaceResearch]:AFTER[FerramAerospaceResearch]
{
	!MODULE[GeometryPartModule]
	!MODULE[FARAeroPartModule]
	@MODULE[RealChuteFAR]
	{
		@name = ModuleParachute
	}
}

This definitely changes *something*, and results in impact glitches that (can) cause the Kerbal to survive hitting the ground at speeds that would normally kill. Mission accomplished?

 

Hi, unsure of the tone of your comment. If vangaurd was still a thing rather than  long dead,  i wouldn't be doing this.

I do have a working but troublesome version of VNG, perhaps you've commented on the VNG thread and seen my posts.

The problems with FAR and EVA interaction in general  is a known to squad issue. And if the eva interaction worked correctly then there's be no need even for VNG as these chutes function perfectly when not attached to kerbals with all context menus and auto deploy etc, but attach it to a kerbal and it stops working,

Share this post


Link to post
Share on other sites

The thing about Vanguard was a joke since I am responsible for that whole mess in the first place, look at the Username :P Sorry for that, I tend to be careless with my humour.

I'm still unsure why that fix didn't work, I thought "stowed" would mean "ready to deploy", so I don't quite understand the error. There is at least one thing I can try changing though, so I'll just do that now.

Share this post


Link to post
Share on other sites
Just now, Kreuzung said:

The thing about Vanguard was a joke since I am responsible for that whole mess in the first place, look at the Username :P Sorry for that, I tend to be careless with my humour.

I'm still unsure why that fix didn't work, I thought "stowed" would mean "ready to deploy", so I don't quite understand the error. There is at least one thing I can try changing though, so I'll just do that now.

Hi i recognized you straight away (started on the forum about the same time as you, used all your stuff prolifically), and I'm suffering sense of humor failure right now anyway so it wouldn't have helped :)

Your certainly welcome to try anything , i thought I'd tried everything, but perhaps not.

Share this post


Link to post
Share on other sites

Okay, it seems like what I'm trying to do doesn't work at all. Sorry for bothering you. There may still be ways to solve this using a custom part module...

I could help with coding an ejection system, if you want.

Share this post


Link to post
Share on other sites
26 minutes ago, Kreuzung said:

Okay, it seems like what I'm trying to do doesn't work at all. Sorry for bothering you. There may still be ways to solve this using a custom part module...

I could help with coding an ejection system, if you want.

Hi, thanks for trying anyway, re the ejections system, that would be fantastic. It was my intention to get the VNG parachute parts working which i did, and change the chute, also done, but then role the whole thing into one decent parachute mod, with the ejection and eva loading features (also works), but with the ability to use many more chutes than just the hardcoded one. I'd be very happy to get some sort of collaboration going if that interests you.

Just remembered that i have the VNG ejection system working too, the only issue being that the kerbs attache themselves to the ladder and refused to jump

Edited by SpannerMonkey(smce)

Share this post


Link to post
Share on other sites

Well, since we have KIS now, the module wouldn't have to interfere with the parachute at all (unless it somehow breaks KIS), because that could be handled through the inventory system.

The ejection itself was very crude, I think I just applied a force to the Kerbal's rigidbody. I had done some basic work to direct this force upwards (AKA playing with the vectors until it fits), but depending on the pod, it could really go anywhere (I've never seen it applied downwards though, which was the important part). I think I would now try to handle this via a PartModule applied to the Kerbal, this could also be used for other purposes, like giving the ejection seat a burn time, visual or sound effects, and to work around the issue of the missing context menu (although this could be better handled by a second part module on the parachute itself).

It's past midnight here so I will go to bed for now.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.