blackheart612

[1.4.x-1.6.x] Airplane Plus - R26.0 (A lot of fixes) (Mar 21, 2019)

Recommended Posts

Does it now relay on stock part switch?

Share this post


Link to post
Share on other sites

The Grounded relays on Stock Part Switch and you can't make Airplane Plus do it?

What exactly can't you do with it?

I guess multiple model/texture variants at the same time?

But you always can split them in diffirent parts!

Edited by Gapone

Share this post


Link to post
Share on other sites
2 minutes ago, Gapone said:

The Grounded relays on Stock Part Switch and you can't make Airplane Plus do it?

What exactly can't you do with it?

I guess multiple model/texture variants at the same time?

But you always can split them in diffirent parts!

It's not impossible, it's just more roundabout in doing things. Grounded mostly either only has textures switched or the textures switch with the mesh. It's just more intuitive right now to use FS, because it's mesh and texture are independent from each other in switching. I'd switch to stock part variant even if it's just a little more complicated if almost the entire arsenal of engines weren't dependent on Firespitter, the sounds, the engine configurations.

Aside from the fact that the stock part variant switch will take a longer time to make, contrary to FS, just check the ModulePartVariants, compare them to both FStextureSwitch2 and FSmeshSwitch. The entire two modules are shorter than a simple texture or partswitch from stock ModulePartVariants.

Don't get me wrong, I made Grounded as it is because I am devoted to using the least plug-ins as I can. Just in APP, a lot of things are just to connected to FS, it's not just the texture and mesh switching. I'd break out of FS if I could either switch to a more reliable single plug-in to replace everything it does and I've been contacted by a few mod authors already about this - I explained and nothing still so far. If stock becomes more capable, perhaps one day it's capable to be plug-in free.

Share this post


Link to post
Share on other sites

Hey all, RPM compatibility is crossed off on the front page. I like the idea of more cockpits and plane parts, but I'm trying to keep cockpits on most my crafts.  Whats the deal with the RPM thing does anyone have it working. Sorry if repost.

Share this post


Link to post
Share on other sites

Hi, I have an issue with BDArmory Continued and AP+. 

For some reason a lot of the parts from AP+ have astronomical hit point values when using BDAc.

Here is an example of what I'm talking about.

nwVNJwe.jpg

Any suggestions?

 

Edited by greydragon70

Share this post


Link to post
Share on other sites

One thing I would love for this mod would be wide body airline parts. I am a sucker for commercial aviation and have noticed how you can only build aircraft like this first picture and not longer range aircraft like the second picture as well as double Decker cabins like in the third picture.

Image result for narrow body aircraft cross section

Image result for wide body aircraft cross section

Image result for wide body aircraft cross section

Share this post


Link to post
Share on other sites
8 minutes ago, Potato flavored waffles said:

One thing I would love for this mod would be wide body airline parts. I am a sucker for commercial aviation and have noticed how you can only build aircraft like this first picture and not longer range aircraft like the second picture as well as double Decker cabins like in the third picture.

Image result for narrow body aircraft cross section

Image result for wide body aircraft cross section

Image result for wide body aircraft cross section

If only Kerbals weren't so wide :P 

Share this post


Link to post
Share on other sites

Could we have something like the Ju-88 cockpit?

Spoiler

See the source image

What do you mean there is a bombing station? It's just for taking uh... pretty pictures!

Share this post


Link to post
Share on other sites
On 11/30/2018 at 9:45 PM, HaydenTheKing said:

Hey all, RPM compatibility is crossed off on the front page. I like the idea of more cockpits and plane parts, but I'm trying to keep cockpits on most my crafts.  Whats the deal with the RPM thing does anyone have it working. Sorry if repost.

It's crossed out because it is now obsolete- it still has navballs in there while the other cockpits don't and besides, now the IVAs that come with A+ are more complex than those. If you are looking for a specific IVA, there is one for the falcon cockpit in the OP and one for the S2 Commercial Cockpit here:

 

Edited by Bottle Rocketeer 500

Share this post


Link to post
Share on other sites
13 hours ago, Potato flavored waffles said:

One thing I would love for this mod would be wide body airline parts. I am a sucker for commercial aviation and have noticed how you can only build aircraft like this first picture and not longer range aircraft like the second picture as well as double Decker cabins like in the third picture.

Try @neistridlar's NeistAir parts:

There's some pretty big fuselage pieces there, including all kinds of luggage spaces and passenger layouts, as well as some great discussion in the thread about sensible limits on the number of Kerbals that should be loaded onto a craft.

Share this post


Link to post
Share on other sites

EDIT: Hiding the post until it gets deleted or not. Reason: the bug does not belong to this mod.

Spoiler

Heio, I think i've found a bug, and since i can't find any place to report it or where it was solved i'm posting the info here (if it is solved or there is a better place to leave this i'd remove the post on demand).

So, it looks like its a problem related solely to rotors and the "hover" function.

I'm running ksp 1.5 with about 20 mods, but mostly interface or visual and the part mods do not interfere or have overlapping parts (if more precise info is required please notify and i'll provide it).

The problem starts when actually flying the craft, the editor works well with no noticeable bugs or flaws that I know of, nor missing sliders or parts. When in flying mode, rotors work fine as long as I don't use the hover button, although noticeable hard to maneuver (obviously), once I interact with both the hover button or the "assign keybindings for the hover functions" side menu, the game does: 1) stop chugging real hard  2) the craft is stuck at hover, cannot exit the hover mode or change its altitude or throttle. In addition, once i revert flight to lauch the rotors can activate but do not provide thrust (they might hover in place as far as I know) and the hover function cannot be deactivated nor I can change the keybindings from the side menu as it no longer shows more than the upper title bar (it can't be minimised or dismissed either, the menu gets stuck at this point).

If I revert to editor instead, everything is non-clickable now: not the parts, not the part menu nor the menu options like "leave the editor/exit" or "launch the vessel" (the change VAB/SPH does work, but shows the same problems funny enough). At this point, i cannot exit the game, since i cannot access the game main menu, and have to alt+f4 to kill the program. I am not aware if a crash report is generated beacause there is no actual crash, just a freeze in all the buttons, but technically the game is still running.

When i relaunch the game, the problem persists *if* I fly a craft with a rotor. It jumps into the "bugged freeze mode" straight up. If I do not use rotors, the game runs fine.

 

Thank you for your time, and if you have suggestions about what info is missing or where to post this, they would be greatly appreciated (first bug report, so I'm kinda green here).

Have a nice day.

 

Edited by MaikMakensi

Share this post


Link to post
Share on other sites
3 hours ago, MaikMakensi said:

Heio, I think i've found a bug, and since i can't find any place to report it or where it was solved i'm posting the info here (if it is solved or there is a better place to leave this i'd remove the post on demand).

So, it looks like its a problem related solely to rotors and the "hover" function.

I'm running ksp 1.5 with about 20 mods, but mostly interface or visual and the part mods do not interfere or have overlapping parts (if more precise info is required please notify and i'll provide it).

I would think the first and best place to report this would be whichever mod is giving you the Hover button, because it's not stock nor is it part of AP+. The mod listed in the OP as being helpful for hovering is outdated and has been adopted/updated by LinuxGuruGamer here: 

If that is what you've already installed, then that's where you need to report the issue. 

Share this post


Link to post
Share on other sites
3 hours ago, JH4C said:

I would think the first and best place to report this would be whichever mod is giving you the Hover button, because it's not stock nor is it part of AP+. The mod listed in the OP as being helpful for hovering is outdated and has been adopted/updated by LinuxGuruGamer here: 

If that is what you've already installed, then that's where you need to report the issue. 

I thought AP+ had this hover interface built in. I don't really have any autopilot/assist mod that i know of, including the mod you linked. I will give it a try and install this one, in the hopes that it overrides the buggy features.

Like I said, I thought this was built in the mod. My apologies, i'll remove the post (or hide it at least), thank you JH4C for your time.

 

The deleted post, just in case someone gets the same problem and does not know where to look for an answer.

Spoiler

Heio, I think i've found a bug, and since i can't find any place to report it or where it was solved i'm posting the info here (if it is solved or there is a better place to leave this i'd remove the post on demand).

So, it looks like its a problem related solely to rotors and the "hover" function.

I'm running ksp 1.5 with about 20 mods, but mostly interface or visual and the part mods do not interfere or have overlapping parts (if more precise info is required please notify and i'll provide it).

The problem starts when actually flying the craft, the editor works well with no noticeable bugs or flaws that I know of, nor missing sliders or parts. When in flying mode, rotors work fine as long as I don't use the hover button, although noticeable hard to maneuver (obviously), once I interact with both the hover button or the "assign keybindings for the hover functions" side menu, the game does: 1) stop chugging real hard  2) the craft is stuck at hover, cannot exit the hover mode or change its altitude or throttle. In addition, once i revert flight to lauch the rotors can activate but do not provide thrust (they might hover in place as far as I know) and the hover function cannot be deactivated nor I can change the keybindings from the side menu as it no longer shows more than the upper title bar (it can't be minimised or dismissed either, the menu gets stuck at this point).

If I revert to editor instead, everything is non-clickable now: not the parts, not the part menu nor the menu options like "leave the editor/exit" or "launch the vessel" (the change VAB/SPH does work, but shows the same problems funny enough). At this point, i cannot exit the game, since i cannot access the game main menu, and have to alt+f4 to kill the program. I am not aware if a crash report is generated beacause there is no actual crash, just a freeze in all the buttons, but technically the game is still running.

When i relaunch the game, the problem persists *if* I fly a craft with a rotor. It jumps into the "bugged freeze mode" straight up. If I do not use rotors, the game runs fine.

 

Thank you for your time, and if you have suggestions about what info is missing or where to post this, they would be greatly appreciated (first bug report, so I'm kinda green here).

 

Share this post


Link to post
Share on other sites
On 12/8/2018 at 6:15 PM, Murican_Jeb said:

@greydragon70 I opened an issue about this in the BDA github, they've noticed it and are looking into it :)

Thanks!

Share this post


Link to post
Share on other sites

May I suggest adding a more powerful variant of the stock J-90 Goliath engine?

Here's the thing :

The current stock Goliath engine is the -94B variant of the real-life General Electric GE90, as of it's similarities in appearance and thrust rating. Both J-90 and GE90-94B have straight blades and max. thrust of 360kN.

SVGE90.jpg

[Both photos aren't mine]

 

While the -115B is rated at 510kN and feature curved blades.

GE90_B777-200LR.JPG

Yes, the -115B is almost twice the thrust rating than the -94B and J-90.

Source Wikipedia

And also, what about adding Size 3 (3.75m, single, single w/ cargo bay & double deck) and Size 4 (5m, singe w/ cargo bay, double deck) Passenger Cabins and Cargo Fuselages? And longer cargo Fuselages variants (2x & 4x the size) just like stock cargo Fuselages, for better structural integrity, shorter building time & lower part count?

So, @blackheart612, could you add the -115B as a part of Airplane+, with the part named as J-90B Super Goliath, and parts as stated in the above paragraph?

Edited by FahmiRBLXian

Share this post


Link to post
Share on other sites

@FahmiRBLXianRight now, I am working on parts for a 3.75m 787. I disagree that we need a more powerful J-90. Why would you need it unless you are making a plane with 1,000 kerbals or something else that gigantic?

Share this post


Link to post
Share on other sites
18 hours ago, Bottle Rocketeer 500 said:

Why would you need it unless you are making a plane with 1,000 kerbals or something else that gigantic?

I actually often play with the stock J-90 and it feels underpowered IMHO. That's why I'm wishing for an even powerful variant then.

Share this post


Link to post
Share on other sites
On 12/20/2018 at 6:36 PM, Azguendare said:

Hey hey !

I just saw the 2.5m seaplane parts and they looks very cool. I hope you will add it !

Is this referring to the really old dev parts I made? I couldn't think of a better way of implementing 2.5m sized seaplane parts so that's a little bit on the negative side. But finally, KSP is in a new version. Hope this one stays. Just need to make one more model for the next release. Though I still need to texture and import them after that. :P

Share this post


Link to post
Share on other sites
22 hours ago, blackheart612 said:

Is this referring to the really old dev parts I made? I couldn't think of a better way of implementing 2.5m sized seaplane parts so that's a little bit on the negative side. But finally, KSP is in a new version. Hope this one stays. Just need to make one more model for the next release. Though I still need to texture and import them after that. :P

They plan to push out a new version of KSP every 3 months now.

Share this post


Link to post
Share on other sites
19 minutes ago, theonegalen said:

They plan to push out a new version of KSP every 3 months now.

Oh, good god. At least they don't break mods every single update. Thanks for this though, at least I'm not gonna wait indefinitely knowing that they're gonna do this.

Share this post


Link to post
Share on other sites
1 hour ago, blackheart612 said:

At least they don't break mods every single update.

I know this mod is made for 1.4.x, I have 1.5.1, however. It runs fine. Since of what @SQUAD told us on 1.6 is basically part revamps and minor bugfixes, if any, we'll be fine.

EDIT :  I thought 1.6 isn't out yet...

Edited by FahmiRBLXian

Share this post


Link to post
Share on other sites

Tried Airplane Plus with  KSP 1.6
So far so good. Seems to work well.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.