blackheart612

[1.4.x-1.6.x] Airplane Plus - R26.0 (A lot of fixes) (Mar 21, 2019)

Recommended Posts

18 minutes ago, MadmanMorton said:

@blackheart612 There's a glitch with trying to rotate the new landing gear. Whenever I turn it the opposite direction, it pops back forwards. Great update btw :)

Same thing happens with the Ospery propeller thingy (I don't know the official na-) Rotaprops!... No..... oh well; whatever its name is

 

Share this post


Link to post
Share on other sites

So I've gotten Firespitter's CoT marker working, and I've decided to test my hand with helicopters (again.) I can do perfectly balanced single-prop helicopters just fine, but I can't figure out how to get a Kitty osprey to fly.

 

I have the CoT perfectly aligned with the CoM, and yet for some reason the left engine is the one providing most of the thrust while the other one is inverted for some reason which results in the aircraft flipping instantly. I have to invert the right engine just to get it to take off, and then it spins uncontrollably for no discernible reason when I pitch forwards.

I've also tried using elevons to get the CoL to be more of a "plane" configuration; the CoL is behind the CoM and is on the same Y axis, but that results in the exact same issue.

 

crChfAI.png

Share this post


Link to post
Share on other sites
2 hours ago, blackheart612 said:

 

pqWg9az.png

 

What's that visual mod? I'd like to have some waves spice up my save :D

Share this post


Link to post
Share on other sites

@AccidentalDisassembly The Size 2 Hull has a mesh switch to have a ramp to the existing Size 2 Fuselages, as seen a few posts above.
The module in the KT6C is airbrake module, the only way I know to be able to set the angle 0-90 degrees rather than just a flip animation.
The node attach that I use is from KSP I think, at least I based it at that. It's hard to angle all these to mirror properly in SPH so I hope people understand that this is the consequence for it.

The sentence before this is precisely why the gears and the KT6C is snapping to front everytime. It's how to get them to mirror properly, plus the front is always up front, so it's a good enough compromised. ( @MadmanMorton and @DarkOwl57 ) So if the mirror doesn't work properly, that's the problem.

Also, it's the new scatterer. It's so good that I'll post this everywhere:

Eq49IXf.png

Share this post


Link to post
Share on other sites
7 minutes ago, SparkyFox said:

oh my glob...squad, hire blackheart or...or something!

Yes. Someone should Suggest that. :)

Share this post


Link to post
Share on other sites

Whew, speed data finally compiled:

Speed Tests, m/s (Test Airframe: Y2xx, airframe weight 3.141t w/o Engine)
Altitude Marlin Tornado Whirlwind Kraken Bumblebee Divine Wind Silver Crow
0.1km 164.6 163.7 183.1 165.3 211.1 149.7 193.0
2km 169.5 174.2 187.6 164.4 210.8 151.3 193.0
4km 161.7 168.9 181.5 158.4 203.2 145.4 185.7
6km 152.6 165.9 176.3 152.8 194.9 139.7 179.3
8km 170.1 178.8 181.8 155.4 197.0 146.7 181.7

For reference, this was the testbed (it's designed to fit in a zeppelin hangar):

YygfYgc.png

Edited by kiwinanday

Share this post


Link to post
Share on other sites

@kiwinanday Thanks a lot, never would have the time to do all that and record stuff. Will be a lot of help when tackling it if I decide to edit the curves in the future.

@SparkyFox Thank you for your kind words. However, I'm hugely not confident about the way I unwrap my UVs. So it may look alright from the outside but the works are a struggle. There is definitely a more efficient way of doing things than how it currently is. I could never make it as tightly packed as a squad employee. Although another part of the UV problem is I keep the mesh low poly, often having the consequence of having to compromise for less efficient spread of UV for texturing. Also I don't think most of these parts would fit stock KSP.

Edit: The UVs are especially more work for hollow parts! (Yep, I'm just complaining now :P)

Edited by blackheart612

Share this post


Link to post
Share on other sites
12 hours ago, blackheart612 said:

@kiwinanday Behind the scenes, there were no changes on configs though, I still don't have a full grasp on the power situation. I wouldn't mind some examples so that I could work around it.

Also, finished the texturing of the Size 2 cargo parts. The only unfit part for this is the cargo bay, which has a different line design due to its mechanism. Here's most of the parts' exterior texture connected to existing parts.
aED1vbh.png

Where can I get those landing gears? Thanks

Share this post


Link to post
Share on other sites

What does 'hover mode' on the control rotors mean/do?

Share this post


Link to post
Share on other sites
5 minutes ago, Skylon said:

What does 'hover mode' on the control rotors mean/do?

Nothing, it's a feature supposedly usable for main rotors too. Which maintains the vertical of the craft on where it exactly is. It's been a while since the function was working. I couldn't get the main rotor to have thrust with it so I used FSEngines instead. The control rotors just do their job passively so there's nothing else to do there.

Edited by blackheart612

Share this post


Link to post
Share on other sites

@blackheart612

Hey,

I've noticed some odd things while looking through the config files of your helicopter parts. First, some of them have the reaction wheel module, while others don't. Is this intentional, and if it is, then why? Second, why don't your parts use the FSCoolant resource like I've seen in other propeller parts packs? Lastly, some of your parts do not have an air intake module while a few do. Is that intentional?

I've also been trying to make an electric version of your coaxial helicopter part, but I've been running into some problems. The cfg file is this so far:

Spoiler

+PART[coaxialprop]
{
    @name = coaxialpropelectric
    @title = KV3-117e "Twinblade" (Electric)
    @MODULE[FSengine]]
    {
        @resources = ElectricCharge,1;IntakeAir,20
    }
    MODULE
    {
        name = ModuleResourceIntake
        resourceName = IntakeAir
        checkForOxygen = false
        area = 0.03
        intakeSpeed = 50
        intakeTransformName = thrustTransform //Intake  
    }
    !MODULE[FSalternator]
}

Module Manager throws an error at it while loading, and I assume the problem is with this line :@resources = ElectricCharge,1;IntakeAir,20 because it still uses liquid fuel instead of electric charge in the game, but everything else seems fine. Any tips/advice? I've checked with the Module Manager wiki to see if I typed something wrong, but it looks fine to me. I tried to find something about the FSengine module on a wiki/guide, but I can't find a good explanation anywhere. I'd appreciate any help. Thanks.

Share this post


Link to post
Share on other sites

Here's a small helicopter made with these delightful parts (not the new ones):

D0ZuReU.jpgvVEslS5.jpgXemlMZQ.jpg

Share this post


Link to post
Share on other sites
1 minute ago, Skylon said:

Here's a small helicopter made with these delightful parts (not the new ones):

D0ZuReU.jpgvVEslS5.jpgXemlMZQ.jpg

I'm not seeing any vertical stabilizers.. How's the Yaw control?

Share this post


Link to post
Share on other sites
1 minute ago, Skylon said:

Here's a small helicopter made with these delightful parts (not the new ones):

D0ZuReU.jpgvVEslS5.jpgXemlMZQ.jpg

Needs guns.

Share this post


Link to post
Share on other sites
Just now, DarkOwl57 said:

I'm not seeing any vertical stabilizers.. How's the Yaw control?

Doesn't the tail rotor give yaw control? you can see it in the second pic.

Share this post


Link to post
Share on other sites
1 minute ago, DarkOwl57 said:

I'm not seeing any vertical stabilizers.. How's the Yaw control?

I've got a control motor but other than that I can use reaction wheels (just the capsule one). I think it does roll a bit when it yaws though

Share this post


Link to post
Share on other sites

@Micro753 I'm not a fan of using reaction wheels for stability but the bigger rotors need them so I slapped them in. Also for the KT6C because it seemed unstable whatever setup I try. FSCoolant from what I know are used for pairing with ElectricCharge, meaning that it's like the LF-Air Intake pair or LF-O pair. I don't have electric props so it's not there. Try it instead of IntakeAir, it would make much more sense and might fix the error.

The information about air intake module is vague, some I did intentionally, and some I may have forgotten so it would help if this was more specific. This also goes for the error you encountered.

@TMasterson5 Well, the next release will be indefinite due to me trying stuff out and testing. I'm not gonna release few parts shortly, that's for sure, I want releases to have a theme or feature packed at least. Just putting it out there if you're interested on how it's going to be.

@Skylon It's pretty cute :D 

Edited by blackheart612

Share this post


Link to post
Share on other sites
7 minutes ago, blackheart612 said:

@Micro753 I'm not a fan of using reaction wheels for stability but the bigger rotors need them so I slapped them in.

@Skylon It's pretty cute :D 

Thanks :) 

Maybe the larger rotors could gimbal/tilt?

Share this post


Link to post
Share on other sites

I was wondering if you could lower the sound levels for the jet engines. They're very loud, so loud that I have to turn down the whole game less my ears bleed, and it drowns out all the other noises (staging, alarms from mods, etc.) 

I get that jet engines are supposed to be loud, but when they drown out the rest of the game, it just makes a fun experience into an ear-shattering chore.

Share this post


Link to post
Share on other sites
1 hour ago, blackheart612 said:

@Micro753The information about air intake module is vague, some I did intentionally, and some I may have forgotten so it would help if this was more specific.

blackhawkprop, chinookprop, and hipprop have

Spoiler

MODULE

{
  name = ModuleResourceIntake
  resourceName = IntakeAir
  checkForOxygen = false
  area = 0.03
  intakeSpeed = 50
  intakeTransformName = thrustTransform //Intake  
}

while the others don't (I may have missed one or two, but some definately don't).

Pretty much, this means that you have to have air intakes on the craft if the propeller doesn't have this. This would make sense because you need air intakes for the engine that runs the propeller, but some have thier own intake. Just a inconsistancey that was bugging me.

@Micro753This also goes for the error you encountered.

No, I was just being an idiot:

Spoiler

@MODULE[FSengine]]

Notice the two ] :P

I'm messing with it some more now to see if I can get it working.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.