Jump to content

[1.4.x-1.8.x] Airplane Plus - R26.4 (Fixed issues/Github is up to date) (Dec 21, 2019)


blackheart612
 Share

Recommended Posts

Does the CTT patch still work with the latest 1.3.1 version? I installed it but the prop parts and other parts were still grouped together in one tech node instead of spread out. What was the last version CTT worked for if so?

Link to comment
Share on other sites

7 hours ago, blackheart612 said:

@GDJ Well, the gears didn't work properly so there you go :P 

Well, I can't have 100% all the time, right?

:wink:

Thanks for the update. Much appreciated! :)

Link to comment
Share on other sites

Has anyone else noticed the weight discrepancy for the MK1 inline reaction wheels compared to the drone core? The drone core weighs .1 tons, and the wheels weigh .95 tons. This is good for shifting the weight of crafts, but not all that realistic.

Link to comment
Share on other sites

@TreyR9 It's typo, actually, it's supposed to be 0.095, will change it since I just noticed it.

@Bitrefresh Increase the blade "Span" in the configs, as well as power production.

@Bottle Rocketeer 500 Other crafts containing the cockpit does not steer on its own with faster time warp, if I remember correctly.

Link to comment
Share on other sites

One last thing, if it’s not too much trouble.

The Mk I nose trunk seems to have collision errors. It causes whatever craft it’s on to teleport 1000 meters into the air (debug reads [name of craft] was in the ground—moving 1000 meters up). Not a critical error, because it can be recovered from, but it then puts the craft in a perpetual state of “moving along the surface,” making it impossible to leave the flight or quicksave.

Link to comment
Share on other sites

is it normal that your craft Dodo fly without any cargo only 300km? in real life similar planes have over 3000 km range. ksp 1.4.1 , also at over 7000m if you fly level have less thrust than when incline like 20-30 degrees.

LE

i think i understand now... they're trust decrease with speed and now i saw that Dodo's radial tanks were empty so that explain low range of flight, however low range and with full fuel on board...

Edited by Acvila
Link to comment
Share on other sites

On 3/16/2018 at 4:28 PM, JANXOL said:

Where can I find up-to date RPM configs? Do the ones from january 2017 still work?

I'm doing some nice ASET ones in Warbird Cockpits. They are slowly coming along, however, because I'm also doing stock cockpits, and cockpits from other mods I love.

 

On 3/18/2018 at 6:44 AM, EleSigma said:

Does the CTT patch still work with the latest 1.3.1 version? I installed it but the prop parts and other parts were still grouped together in one tech node instead of spread out. What was the last version CTT worked for if so?

Try my UBM Extended config for APP, mod linked in my signature. It works with or without UBM, and creates a new tech branch with the early props coming off of Stability.

Edited by theonegalen
Link to comment
Share on other sites

@Bottle Rocketeer 500 Trust me, I've extensively tested it as well before, I'm still puzzled. I came to a point where I thought it was the wing parts.

@TreyR9 I haven't encountered that error yet, I have a sample craft containing it and it doesn't reproduce that error, can you detail this more?

@Acvila Yes it is normal, the engine it's using is a fuel guzzler. Though you can just keep adding fuel to it for more range. Do note that the craft files I provided aren't made to be used very long or have everything perfect and well thought out, I shared them to the public but all they are are just polished test crafts. That was made while I was trying to test the landing gears used in that craft so I used the craft relatively quickly.

 

Link to comment
Share on other sites

@blackheart612 Try using the Pioneer Drone prefab, it caused the issue for me.

Even when using launch clamps, it still teleported it up after physics loaded. (Probably stupid question) but are you playing with the latest version of KSP with the latest release of APP, and are you playing in 64-bit or 32-bit version? (I was on 64-bit)

Link to comment
Share on other sites

I recently downloaded Airplane Plus for my new install with 1.4. I’ve noticed that, if my craft has any of the landing gear from this mod, it bounces 10 m into the air upon loading into the runway. The wheels don’t seem to be too bouncy for landing, so maybe it’s just a loading issue. I have a lot of other mods installed, but they shouldn’t affect this at all. Also, when I was using the Predator prop engine, it would work perfectly fine with the advertised 70-80 kN of thrust, but then would suddenly drop down to 10 kN as I am in level flight, not even a kilometer off the ground. I can hear the sound effect for the engine throttling down, but I am not touching the throttle. If I make a steep turn, the thrust spikes back up to the higher value, but then settles low again. Is this how the engine is intended to work, or is it a bug? Any troubleshooting help for either issue is appreciated. 

Link to comment
Share on other sites

40 minutes ago, HeliosPh0enix said:

I recently downloaded Airplane Plus for my new install with 1.4. I’ve noticed that, if my craft has any of the landing gear from this mod, it bounces 10 m into the air upon loading into the runway. The wheels don’t seem to be too bouncy for landing, so maybe it’s just a loading issue. I have a lot of other mods installed, but they shouldn’t affect this at all. Also, when I was using the Predator prop engine, it would work perfectly fine with the advertised 70-80 kN of thrust, but then would suddenly drop down to 10 kN as I am in level flight, not even a kilometer off the ground. I can hear the sound effect for the engine throttling down, but I am not touching the throttle. If I make a steep turn, the thrust spikes back up to the higher value, but then settles low again. Is this how the engine is intended to work, or is it a bug? Any troubleshooting help for either issue is appreciated. 

@HeliosPh0enix Probably, this is intended. The props throttle down with speed, IIRC, so, when you turn, you slow down, and the prop powers up. When you level out, on the other hand, you quickly will speed up, and exceed the prop's intended speed of flight, so it throttles down.

@blackheart612 If you have the time, maybe try rebuilding the Emu Liner from scratch and testing it out.

Edited by Bottle Rocketeer 500
Link to comment
Share on other sites

@blackheart612 Well, it definitely seems to be this mod in particular. I tried it in another save and it worked fine. Maybe it’s an issue with the save file rather than the mod? :/ 

I can get by with just using a MK1 Cargo Bay and an advanced nose cone 1. What troubles me is that I’ve reinstalled the mod multiple times. Maybe there is a config missing in my end?

Link to comment
Share on other sites

16 hours ago, Bottle Rocketeer 500 said:

 

@blackheart612 If you have the time

That's a good joke :D

@HeliosPh0enix I'll do further testing, what is the landing gear, all of them? During my tests, there were no issues so it's very likely I can't replicate that as I tested on both 1.4 and 1.4.1 with no issues.

And

Blades lose thrust eventually, various factors in hand, speed is a large factor.

@TreyR9 My test version is from a 1.2.x save, updated and eventually updated to 1.4.x now, I don't encounter problems from the part mentioned, I currently have no idea how to replicate the issue making it impossible to debug.

Link to comment
Share on other sites

Hi, I might be missing something huge, but on using any of the props, I get 90% thrust on takeoff, then for approx 10m I get good thrust, but then any high it drops down on some cases to 10Kn. This is rectified by making sharp turns or going completely vertical. I notice the data says "Effective intake 50.0ms" however this usually only means I can get my planes up to 120ms. Is this intentional, or is it something wrong on my behalf?

Link to comment
Share on other sites

Blackheart612, I love this mod! Your cockpits and engines are exquisite, and enable warplane modeling where the planes are the spitting image of their real counterparts.

On your poll about future parts, I'm firmly in the cockpit section. If you're taking cockpit suggestions, I'd particularly like to see

  1. A short version of your MK1 Caged Inline Cockpit, particularly if it's cropped to the front 50% as in the P-40 Warhawk or P-51A Mustang.
  2. A steeper version of your MK1 Caged Inline Cockpit, closer to the angles of the F4F and F6F. MAD Aerospace has a cockpit that has the right steepness but the wrong front face called the T40. 
  3. A bubble canopy in the style the US used in WW2 and Korea, with a frontal angled cage similar to the MK1 Caged inline's in front of the pilot and then a single teardrop piece for the rest. 
    Spoiler

    p-51-361.jpg?itok=H0lRti7x

     

But I was also wondering if you would be open to making radially attached versions of cockpits. Some planes, like the P-40 Warhawk, the F-5 Freedom Fighter, the Dassault Mystere, and the Dassault Ouragon have fuselages that begin to taper underneath the cockpit - no single part can model that properly. 

Album https://imgur.com/a/K6ltO will appear when post is submitted


Some other modelers - notably strykersm of the Stryker Aerospace mod - made cockpits that attach radially, which avoids the problem altogether. Is that something you'd be interested in making in the future? I think it would be a big help!

Link to comment
Share on other sites

@moose_cannon It's near impossible to make tapered fuselages, without making it kit based, the lengths are standardized and the sizes I make are fixed with squad defaults. This is because I'm not making a kit based parts mod, I make them as modular as I can. Doesn't mean I'm stopping about thinking how I might get one to work, though. Radial Cockpit Parts are indeed planned, sooner than you might think. One more thing I pointed out before already regarding suggestions, similar looking cockpits will not be separately added, for example, your WWII cockpits which look like the Mk1 Inline, or SBD type cockpit which looks like the Zero Cockpit, etc. But radial cockpits will circumvent that problem if they work great.

@ThePowelly999 Either read the reddit thread I posted just above your post, or, I'm no expert on aerodynamics but I could simplify it for you: Blades lose thrust the faster you are. On sharp turns, you bleed speed but mostly the prop can keep up and could produce more thrust. Going vertical is a very common thing to do to get more thrust, you can do it on stock engines too. It will stall at some point, of course.
More things to be pointed out: 
Props are more limited at altitude than jets
Props are slower than almost every other jets
Props are generally more efficient than jets in fuel
Props react faster than jet spooling

 

Edit:
@DarkOwl57 Have a short footage :P 

 

Edited by blackheart612
Link to comment
Share on other sites

On 3/24/2018 at 8:54 PM, blackheart612 said:

It's near impossible to make tapered fuselages,

Heh, even making them out of parts is tough :P

On 3/24/2018 at 8:54 PM, blackheart612 said:

Radial Cockpit Parts are indeed planned, sooner than you might think. .... But radial cockpits will circumvent that problem if they work great.

That's awesome! Looking forward to it :D

On 3/24/2018 at 8:54 PM, blackheart612 said:

One more thing I pointed out before already regarding suggestions, similar looking cockpits will not be separately added, for example, your WWII cockpits which look like the Mk1 Inline, or SBD type cockpit which looks like the Zero Cockpit, etc. 

Yeah, I read a lot of this thread and I guess took away the mistaken impression that you'd relaxed that position. Ah well.

Link to comment
Share on other sites

Hmm tried this many moons ago and couldnt get any sound at all

Just tried it and still no sound.

Can't find an "issues" section or any workaround on page 1 either.

Nor any sort of workaround on the mod page on curseforge. Am i missing something? i downloaded and installed the mod via the twitch/curse client thing.

edit: just looked in gamedata, the sound files are all there, even tested to make sure i can play them on Windows Media player too

but the sound is just refusing to play in the game for some reason.

edit2: ok just realised the mod command modules and many other parts are still missing too. i also found my old post earlier in this thread and it's exactly the same issue. no command parts but they're all in gamedata too so the mod download and installation was complete.

my game is 100% on 1.4.x and i honestly have no idea what's wrong. better yet, this is now a different computer to the one i had posted about with the same issues earlier. really really confused here.

exact version:

QXAuybx.jpg

Edited by Emily King
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...