Jump to content

[1.4.x-1.8.x] Airplane Plus - R26.4 (Fixed issues/Github is up to date) (Dec 21, 2019)


Recommended Posts

18 hours ago, Jognt said:

Yup, when attached they look like they would IRL. I noticed they are by default added to the ‘brakes’ action group though, so maybe it’s just due to KSP aero working differently. 

I’ll get some screenshots later to make sure I attached them properly just in case though. :/ 

Edit: the way they work as I placed them means they do increase lift at an AoA of 30°+, but before that point they actually create downforce. 

Yeah, KSP aero does not allow them to work like in IRL. IRL they help the airflow "stick" to the upper surface of the wing at higher angle of attack, allowing them to generate more lift at low speeds. But in KSP wing parts does not interact with each other aerodynamically, so they really don't help much in slow flight at all.

Link to post
Share on other sites
4 minutes ago, neistridlar said:

Yeah, KSP aero does not allow them to work like in IRL. IRL they help the airflow "stick" to the upper surface of the wing at higher angle of attack, allowing them to generate more lift at low speeds. But in KSP wing parts does not interact with each other aerodynamically, so they really don't help much in slow flight at all.

Does FAR make them work more realistically?

Link to post
Share on other sites
On 8/12/2019 at 4:36 PM, Manul said:

Do you use TextureReplacer or Textures Unlimited? I have a 'texture not found' error with b-29 cockpit but it doesn't prevent the part from being compiled and everything seems to work.

 

Actually, I forgot to ask if the error is made by APP, it's true. Make sure you only have APP when you test again @RobertaME Usually the case is it's not APP's fault.

On 8/13/2019 at 10:16 PM, Jognt said:

Yup, when attached they look like they would IRL. I noticed they are by default added to the ‘brakes’ action group though, so maybe it’s just due to KSP aero working differently. 

I’ll get some screenshots later to make sure I attached them properly just in case though. :/ 

Edit: the way they work as I placed them means they do increase lift at an AoA of 30°+, but before that point they actually create downforce. 

What everybody said is right. It's just how KSP works. And it's not made for far. It helps you slow down a lot by deploying it and increasing engine thrust. I found it to be the optimal way to use it.

Link to post
Share on other sites

Hey @blackheart612, neither dead nor gone, just even busier in my summer off than I was while teaching in the school year. How does that happen? Not quite sure. Except I moved twice, traveled for an entire month, and began and ended the summer with extended travel for band performances. Whee.

Link to post
Share on other sites
On 8/15/2019 at 4:26 AM, blackheart612 said:

What everybody said is right. It's just how KSP works. And it's not made for far. It helps you slow down a lot by deploying it and increasing engine thrust. I found it to be the optimal way to use it.

Yeah I figured that may have been what was up (since they’re added to the brakes AG). 

If they’re in front of the CoM they also induce a strong pitch-down moment though. (Nice to keep your plane on the ground for braking admittedly)

Unrelated to the slats themselves: would you consider uploading the mod (mostly the cfgs) to GitHub? 

That way I could submit PRs for fixes like cargobay occlusion checks, the slats center of rotation, and some others I’ve collected local fixes for. 

Edited by Jognt
Link to post
Share on other sites
On 8/16/2019 at 8:15 AM, theonegalen said:

Hey @blackheart612, neither dead nor gone, just even busier in my summer off than I was while teaching in the school year. How does that happen? Not quite sure. Except I moved twice, traveled for an entire month, and began and ended the summer with extended travel for band performances. Whee.

Well, nobody is required to be active. Some things are just more important!

13 hours ago, Jognt said:

Yeah I figured that may have been what was up (since they’re added to the brakes AG). 

If they’re in front of the CoM they also induce a strong pitch-down moment though. (Nice to keep your plane on the ground for braking admittedly)

Unrelated to the slats themselves: would you consider uploading the mod (mostly the cfgs) to GitHub? 

That way I could submit PRs for fixes like cargobay occlusion checks, the slats center of rotation (node_attach was missing the -0.18 Y offset as defined for CoL/CoM), and some others I’ve collected local fixes for. 

Honestly too lazy to put it on and learn github, I did want it before but now is just, not impossible but a very distant possibility. Well, the biggest problem really is that I dont know its ins and outs. Pros and cons of how powerful it is I guess.

Link to post
Share on other sites
3 hours ago, blackheart612 said:

Pros and cons of how powerful it is I guess.

git (and by extension GitHub, BitBucket, etc.) is a swiss army chainsaw - powerful, versatile, and capable of cutting both your legs off and then sewing them back on.

Link to post
Share on other sites
7 hours ago, blackheart612 said:

Well, nobody is required to be active. Some things are just more important!

Honestly too lazy to put it on and learn github, I did want it before but now is just, not impossible but a very distant possibility. Well, the biggest problem really is that I dont know its ins and outs. Pros and cons of how powerful it is I guess.

I know the feeling :D my first use of github was a few weeks back maybe, and there’s a lot I don’t understand, but the PR thing is quite nice. (I did a grand total of three of them :D )

I understand how daunting it is though, so it’s fine either way. But if you’d ever like to do some git poking, I’m willing to share what little I know. ;) 

Link to post
Share on other sites
On 8/19/2019 at 7:51 AM, DownHereInChile said:

You may have gotten this before, but will the inclusion of turboshaft engines into "stock" (expansion needed) KSP affect this mod at all? Thanks!

 

16 hours ago, qromodynmc said:

Nope.

But KSP 2 though. Oh god.

Link to post
Share on other sites
9 hours ago, sashan said:

Anyone made a FAR config? 
Those spoilers look awesome but they don't work on my install because I use FAR...

 

Don't know how much those configs are up to date for latest APP release, some of wing parts might not work.
You can use MM patch in spoiler section to detect parts that are not compatible with FAR.
 

Spoiler
// Change Part title to make it visible in VAB/SPH if part is not compatible with FAR

@PART[*]:HAS[@MODULE[ModuleLiftingSurface],!@MODULE[FARWingAerodynamicModel]]:NEEDS[FerramAerospaceResearch]:FINAL
{
	@title ^= :$: *Non FAR*:
}

@PART[*]:HAS[@MODULE[ModuleControlSurface],!@MODULE[FARControllableSurface]]:NEEDS[FerramAerospaceResearch]:FINAL
{
	@title ^= :$: *Non FAR*:
}

 

You can create your own file with "*.cfg" extension and save it under KSP gamedata folder.

Link to post
Share on other sites

Thanks a lot!
I did quite a lot of MM configs couple years ago.  As of now I detect if the part is FAR compatible by the presence (or lack thereof) of stoch lifting surface part module.

Another issue. May be FAR related. KSP 1.7.3. Helicopter engines dont work. Helis either won't takeoff at all despite being light enough or spin in one place as if the tail rotor failed. VTOL made using those osprey-style engines has right engine thrusting in reverse be default despite being set to "normal". If I manually reverse it it works but there's no working controls and if I try to takeoff (vertically) it again spins around yaw axis and is virtually uncontrollable. Plz halp! I need to recover Bob from where he's swimming 50km out in the ocean. ;.;

Link to post
Share on other sites
2 hours ago, sashan said:

Thanks a lot!
I did quite a lot of MM configs couple years ago.  As of now I detect if the part is FAR compatible by the presence (or lack thereof) of stoch lifting surface part module.

Another issue. May be FAR related. KSP 1.7.3. Helicopter engines dont work. Helis either won't takeoff at all despite being light enough or spin in one place as if the tail rotor failed. VTOL made using those osprey-style engines has right engine thrusting in reverse be default despite being set to "normal". If I manually reverse it it works but there's no working controls and if I try to takeoff (vertically) it again spins around yaw axis and is virtually uncontrollable. Plz halp! I need to recover Bob from where he's swimming 50km out in the ocean. ;.;

That is a bit off topic for APP thread. Better to ask for help in FAR thread, but I think that new propelers need extra config info for FAR, same or similar as other wing surfaces. Without that I don't think that it work properly. I'm not experct when comes to FAR code, so, can't help with that, sorry. There was some attempts to make those working if you read posts in FAR thread:

 

Link to post
Share on other sites
2 hours ago, sashan said:

Thanks. I'd post that link under a spolier into OP. Lots of people use FAR
Sorry, I'm a bit out of loop when it comes to KSP modding as of late. 

No worries, and just recently MOPC posted updated config files for APP FAR compatibility as well as config files for new propelers. Heven't tried either though, but might be good to put link here as well, if someone else also ask for this:

 

Link to post
Share on other sites

Hey,

I'm getting this Errors in my logs:

Quote

190831T164654.887 [ERROR] [PartReader.ReadTextures] Texture 'AirplanePlus/Parts/Command/airbuscockpit/AerojetKerbodyne' not found!
190831T164654.914 [ERROR] [PartReader.ReadTextures] Texture 'AirplanePlus/Parts/Command/b29cockpit/placeholder' not found!
190831T164654.917 [ERROR] [PartReader.ReadTextures] Texture 'AirplanePlus/Parts/Command/b29cockpit/airbuscockpittex' not found!
190831T164655.031 [ERROR] [PartReader.ReadTextures] Texture 'AirplanePlus/Parts/Command/fighterinlinecockpit/AerojetKerbodyne' not found!
190831T164655.520 [ERROR] [PartReader.ReadTextures] Texture 'AirplanePlus/Parts/Command/oh6cockpit/AerojetKerbodyne' not found!
190831T164655.534 [ERROR] [PartReader.ReadTextures] Texture 'AirplanePlus/Parts/Command/oldfightercockpit/AerojetKerbodyne' not found!
190831T164655.567 [ERROR] [PartReader.ReadTextures] Texture 'AirplanePlus/Parts/Command/x1cockpit/AerojetKerbodyne' not found!
190831T164656.345 [ERROR] [PartReader.ReadTextures] Texture 'AirplanePlus/Parts/Engine/Rotorwing/powerprop/default' not found!
190831T164656.417 [ERROR] [PartReader.ReadTextures] Texture 'AirplanePlus/Parts/Payload/Mk1Door/AerojetKerbodyne' not found!

Are they a problem?

 

My Logs: https://www.tancredi.nl/downloads/logs.zip

Do you need more information?

Link to post
Share on other sites
On 8/31/2019 at 7:49 PM, N3N said:

Hey,

I'm getting this Errors in my logs:

Are they a problem?

 

My Logs: https://www.tancredi.nl/downloads/logs.zip

Do you need more information?

Hello,

 

These Errors exists, because the files aren't in the newest download-file.

So others should have the same errors, too.

 

I just wanted to help and wanted to ask, how to deal with this errors.

 

---

Sorry for my english, it's only my third language.

Edited by N3N
Link to post
Share on other sites
6 hours ago, Violet_Wyvern said:


Yes, It's possable (But not in this mod)
 

concept looks similar but quite different actually, i rather ap+ version.

Nice f16XL btw, thanks for reminding me that i should make one too, i had it  in mind but forgot it later.

Currently i got two f16 variant;

screenshot9.jpg

f16c.jpg

 

Link to post
Share on other sites
On 9/1/2019 at 1:49 AM, N3N said:

Hey,

I'm getting this Errors in my logs:

Are they a problem?

 

My Logs: https://www.tancredi.nl/downloads/logs.zip

Do you need more information?

It's normal, but not intended. I still haven't fixed it. It's an mu problem and been asked here before for a long long while now. If you need info it's basically the placeholder I used for the flag decal on cockpits which I unintentionally exported, resulting in the game trying to find them. But they aren't really needed.

On 9/3/2019 at 2:43 PM, bobisback said:

Does this support MAS or RPM?

 

 

Nope. But there were patches which are outdated now. I'm not quite sure if people have patches somewhere for it. Try asking in their respective threads perhaps?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...