Jump to content

[1.4.x-1.8.x] Airplane Plus - R26.4 (Fixed issues/Github is up to date) (Dec 21, 2019)


Recommended Posts

17 hours ago, blackheart612 said:

Is this from the github version?

-

Also, open cockpit has its own plug-in back when I saw it. Otherwise, you can't view it in first person or use it as a primary cockpit back then. I think it's doable now but no "IVA" view

Was the version I got from CKAN, there is no github, so version from spacedock I sure.

Link to post
Share on other sites

Hi I want to change the colors of this engine created from AJE ON Airplane plus mod that takes the tempest engine and makes ot realistic but with the TURD for airplane plus I only can change colors of the tempest not the Wright R-3350 duplex cyclone 

Link to post
Share on other sites
1 hour ago, BlazaPelikan said:

Hey there! I have a problem with the "Baron". I have a mod, UnKerballed start, installed, which changes the tech tree. I have this engine unlocked, but the basic plane I build with it has trouble reaching 40m/s. Any ideas why? Thanks!

It all depends on what stats it has now. It could just be too under-powered for your craft. -- or you might have some other mod interaction that's altering the engine performance.

In the SPH, I see the Baron having a stationary thrust of 25.0kN.  Using a similar engine (the Spud) upon launch, and spinning up the engine with the brakes on, it gets up to ~17kN and a bit faster once start rolling down the runway.

Check to see that the 25kN is listed, and not some much smaller number, otherwise your craft itself may just be too big/heavy to move with that small an engine--or just one of them!

Link to post
Share on other sites
On 12/14/2020 at 12:11 PM, Lumaan said:

Was the version I got from CKAN, there is no github, so version from spacedock I sure.

The spacedock version is out of date now, github version is the latest but needs manual installation, especially FS

On 12/20/2020 at 6:18 AM, BlazaPelikan said:

Hey there! I have a problem with the "Baron". I have a mod, UnKerballed start, installed, which changes the tech tree. I have this engine unlocked, but the basic plane I build with it has trouble reaching 40m/s. Any ideas why? Thanks!

Weight is most likely a problem. I made sure you can't pull much weight on early engines. A problem even for me on career, but it sets the pre-modern engines apart from early engines. Realistically you won't have much fuel and you won't be too fast, but at least it's early flight, right?

3 hours ago, superjojo2001 said:

I would really like to know how the thrust vectoring on the "Kitty" (Osprey) engines work.

I am currently trying to implement this feature to the KAX Jump jet engines.

If anyone knows please let me know.

You mean the way I did the 90 degree turn? It's quite simple, really. I took the airbreak modules (ModuleAeroSurface) which flips the flaps and basically put it on an engine, so now it flips an engine. I needed some big brain strats to make things work with stock modules so cut me some slack.

Link to post
Share on other sites
On 12/21/2020 at 3:14 AM, blackheart612 said:

The spacedock version is out of date now, github version is the latest but needs manual installation, especially FS

But CKAN's download is from spacedock. No other download (I think). I think you better tell them where they get the least version from.

Link to post
Share on other sites
Just now, memeking89 said:

could you please make an updated version of this mod I would really love to use this in the newer versions

 

 

Are you having problems using it in 1.11? I've used it in 1.10.1 and 1.11 with no noticeable issues that aren't already known.

Link to post
Share on other sites
  • 1 month later...
On 12/29/2020 at 6:45 PM, memeking89 said:

no i havent used it in 1.11 yet 

It works fine in 1.11.1. No need for it to be updated, except maybe to deal with the new cargo system, but that's such a minor quality of life thing that it's not a big concern. 

Link to post
Share on other sites

Has anyone else noticed the short tail connectors A and B are pure white, lacking any color or texture? those two are the only 2 parts from the mod missing color or texture, everything else looks fine. Unless this is how they are supposed to look?

xfuPsET.jpg

EiPtaaH.jpg

Link to post
Share on other sites
38 minutes ago, vardicd said:

Has anyone else noticed the short tail connectors A and B are pure white, lacking any color or texture? those two are the only 2 parts from the mod missing color or texture, everything else looks fine. Unless this is how they are supposed to look?

xfuPsET.jpg

EiPtaaH.jpg

That is strange. I do not have that glitch.

Link to post
Share on other sites
17 minutes ago, GoldForest said:

That is strange. I do not have that glitch.

Okay, so just me then. probably a mod conflict, no idea why those are the only 2 parts affected though.

Link to post
Share on other sites
3 hours ago, vardicd said:

Okay, so just me then. probably a mod conflict, no idea why those are the only 2 parts affected though.

Download a fresh mod zip file and delete the old one. Then copy the new one into your gamedata see if that helps

Link to post
Share on other sites
7 hours ago, vardicd said:

Has anyone else noticed the short tail connectors A and B are pure white, lacking any color or texture? those two are the only 2 parts from the mod missing color or texture, everything else looks fine. Unless this is how they are supposed to look?

3 hours ago, GoldForest said:

Download a fresh mod zip file and delete the old one. Then copy the new one into your gamedata see if that helps

This is a known bug mentioned few pages back, the path to the texture used by these connectors was changed in one of KSP updates. Change their texture path in GameData\AirplanePlus\Parts\Structure and Fuel\ShortBoom\part.cfg and \ShortBoom2\part.cfg to this to fix:

	texture = placeholder , Squad/Parts/Aero/cones/Assets/Cones
Edited by MOPC
Link to post
Share on other sites
4 hours ago, MOPC said:

This is a known bug mentioned few pages back, the path to the texture used by these connectors was changed in one of KSP updates. Change their texture path in GameData\AirplanePlus\Parts\Structure and Fuel\ShortBoom\part.cfg and \ShortBoom2\part.cfg to this to fix:

	texture = placeholder , Squad/Parts/Aero/cones/Assets/Cones

yep that did it 

Link to post
Share on other sites

I tried searching through the topic, and I don't see anything.  Perhaps this is related to the 1.11 update (sorry, haven't been playing for a few years so it's all new to me), but the passenger door Mk1 doesn't seem to work.  I have it set up as indicated, but I get the "Hatch is obstructed, can't exit" error.  I'm not entirely surprised, I imagine this is a tight fit, but I definitely like the idea and if I can get it working I'd really like to.

eAoDBIN.png

Link to post
Share on other sites

@Hyomoto!  You're back!  Good to see you dude.

I've been away from KSP since August and not done a lot since the start of 2020.  Just started getting back in yesterday, so I'm just learning about all the changes still.

Sorry I can't assist with the hatch obstruction issue.  Can't remember for sure or find by searching a general issue.

I wonder if @linuxgurugamer knows about any issue related to hatches that I can't remember.  Otherwise I'd suggest trying to rebuilt it in the version you're using from scratch, at least to test the hatch with less plane around it.

Edited by Jacke
Link to post
Share on other sites
4 hours ago, Jacke said:

I wonder if @linuxgurugamer knows about any issue related to hatches that I can't remember.  Otherwise I'd suggest trying to rebuilt it in the version you're using from scratch, at least to test the hatch with less plane around it.

No I don't, sorry.

You can use a couple of other mods to see the colliders, the following two can be useful for this:

 

Link to post
Share on other sites
5 hours ago, Hyomoto said:

I tried searching through the topic, and I don't see anything.  Perhaps this is related to the 1.11 update (sorry, haven't been playing for a few years so it's all new to me), but the passenger door Mk1 doesn't seem to work.  I have it set up as indicated, but I get the "Hatch is obstructed, can't exit" error.  I'm not entirely surprised, I imagine this is a tight fit, but I definitely like the idea and if I can get it working I'd really like to.

eAoDBIN.png

It's not just you, actually. I've always attributed to it that the minimum exit space should be a little more than half of the standard smallest Aircraft 1.25m Fuselage in KSP. I don't perfectly recall but the colliders don't really clip. There's no basis to it and I don't exactly know how it works but I think the Kerbals require a certain amount of space to exit, even if it's part the same craft. That's why my sample crafts actually never have the passenger door alone:

jiio25W.png8uPSSRS.png

 

Link to post
Share on other sites
7 minutes ago, blackheart612 said:

It's not just you, actually. I've always attributed to it that the minimum exit space should be a little more than half of the standard smallest Aircraft 1.25m Fuselage in KSP. I don't perfectly recall but the colliders don't really clip. There's no basis to it and I don't exactly know how it works but I think the Kerbals require a certain amount of space to exit, even if it's part the same craft. That's why my sample crafts actually never have the passenger door alone:

jiio25W.png

 

In that first plane it appears you are using a smaller spacer, do you recall what the name of that part is?  Also, thank you for the feedback.  I tried moving some stuff around and deleting parts, but it seems like the space is too tight.  I'll have to give LGG's topic a try at some point, but if it's as simple as adding a spacer I'm not going to be upset.

Edit: And yeah, adding a cargo tube seems to have added the necessary space.  Apparently that part by itself is just a wee bit too small.  If it's possible to tweak it, that would be awesome, but I'm glad it's functional nonetheless.

Edited by Hyomoto
Link to post
Share on other sites
3 minutes ago, Hyomoto said:

In that first plane it appears you are using a smaller spacer, do you recall what the name of that part is?  Also, thank you for the feedback.  I tried moving some stuff around and deleting parts, but it seems like the space is too tight.  I'll have to give LGG's topic a try at some point, but if it's as simple as adding a spacer I'm not going to be upset.

Of course, I recall it's the Structural Fuselage Offset. It should be the smallest fuselage part I made which tilts the fuselage when you place it. I basically alternate with another one of it to tilt it back down so it's just adding a really small part on the fuselage and I repeat it until it's no longer obstructed. This'll make your craft extremely weak so I recommend having advanced settings on so you can turn on autostrutting from the game.

As for the reason why I didn't just make the passenger door of this length when it wouldn't function alone... it's because of the set cuts the stock game has. So it's just half of the regular fuselage and Im sticking to that theme.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...