Jump to content

[1.11.2] B9PartSwitch v2.18.0 (March 17)


blowfish
 Share

Recommended Posts

50 minutes ago, JcoolTheShipbuilder said:

Yes i do have kspie installed

Thanks, another user recently reported that issue on the Kopernicus Bleeding Edge thread and it is caused by an interaction between Near Future Solar, KSPIE, and Kopernicus, but the fix will need to go through Kopernicus.  I supplied the solar panel patch in the later versions of Kopernicus and think that the solution shouldn't be too hard, just never tested it with KSPIE.   

Link to comment
Share on other sites

2 hours ago, JcoolTheShipbuilder said:

hmm... i got the new 1101 version, and.... hmm... ok no more partswitch errors in loading, but still some spam
https://drive.google.com/file/d/1zXI1AW3J5lBkCJ_eXG9BoyRzhVY9jYCM/view?usp=sharing
 

You will need to make sure to set the permission on the file so it is visible, I can't access the log file currently. If the log spam was from Kopernicus, that may have been a separate bug, but think @R-T-B has fixed that in an updated release

Edited by hemeac
Link to comment
Share on other sites

12 hours ago, hemeac said:

You will need to make sure to set the permission on the file so it is visible, I can't access the log file currently. If the log spam was from Kopernicus, that may have been a separate bug, but think @R-T-B has fixed that in an updated release

wait what? oh...... hmm.... ill do that

Link to comment
Share on other sites

1 hour ago, FleeBeeGamer said:

Hey! Need Help Has few things missing it looks like reinstalled moudle manger and b9 twice so idk 

https://uploadhub.co/66e4f21f48aa6f4de47f2484c34bba84/KSP.log  there is the logs

@FleeBeeGamer, You have a very outdated version of the Module Manager.  Updating that to the newest version might solve the errors that you are experiencing.

Link to comment
Share on other sites

3 hours ago, FleeBeeGamer said:

hey I installed it from ckan then from github im almost certain I have the newest one!

Actually, it looks like you don't have ModuleManager installed at all. There's a directory "ModuleManager-2.1.5" (which is a rather old version) containing some "MMTest" configs that appear to be for debugging purposes. but no ModuleManager DLL was loaded by KSP. It would show up in the "Mod DLLs found" section of the log.

I'd suggest to delete the ModuleManager-2.1.5 directory (you don't need those tests and they'll probably just cause confusion) and install MM via CKAN. There should be a ModuleManager.4.1.4.dll (or newer) in the GameData directory afterwards.

(One odd thing is that "ProceduralParts" comes with a directory called "ModuleManager" which would throw off the :NEEDS[!ModuleManager] tests. Those won't work without MM, anyway, so it's also a bit moot :))

Edited by HansAcker
Link to comment
Share on other sites

On 11/10/2020 at 8:47 PM, HansAcker said:

Actually, it looks like you don't have ModuleManager installed at all. There's a directory "ModuleManager-2.1.5" (which is a rather old version) containing some "MMTest" configs that appear to be for debugging purposes. but no ModuleManager DLL was loaded by KSP. It would show up in the "Mod DLLs found" section of the log.

I'd suggest to delete the ModuleManager-2.1.5 directory (you don't need those tests and they'll probably just cause confusion) and install MM via CKAN. There should be a ModuleManager.4.1.4.dll (or newer) in the GameData directory afterwards.

(One odd thing is that "ProceduralParts" comes with a directory called "ModuleManager" which would throw off the :NEEDS[!ModuleManager] tests. Those won't work without MM, anyway, so it's also a bit moot :))

hey thanks for the help helped me alot!

Link to comment
Share on other sites

@sniperplane, the log file that you posted looks like it was just a stock install with no mods installed so it doesn't really show much, but if you were having the same issue as @code99, that looks like it could be an issue with BDB and Kerbalism, or alternatively slightly older versions of BDB and Kopernicus  with JNSQ.  The first is a known issue and a believe a solution is being worked on, and the second has been fixed in updates, so I don't think that would be the issue if you are using CKAN.   If you don't have Kerbalism or JNSQ, you may want to post the issue on the BDB thread.

Link to comment
Share on other sites

@hemeac I dont recognize what mod you are refering to "BDB" and "JNSQ". Sorry, ive been away from ksp and its modding community for a long time. 

I dont have kopernicus installed but i did have Kerbalism installed, i removed it and its working fine now, thanks.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...