Jump to content

[1.11.2] B9PartSwitch v2.18.0 (March 17)


blowfish
 Share

Recommended Posts

  • 2 weeks later...
12 hours ago, Irfan Saf said:

Hi guys, I have the different issue with @N3N, installed from CKAN too

Thats most likely not a problem with B9 itself... Its just warning you, by design.

Looks like you have a missing dependency somewhere, that defines those recources, or module names. First one i would check, is if you might be missing Community Resource Pack... unless you can identify specifically what mod uses those exact resources.

The 'RR' prefix on some of them, leads me to believe they are Rational Resources related, and RR *does* indeed require Comm. Res. Pack as a dependency.
 

Edited by Stone Blue
Link to comment
Share on other sites

15 hours ago, Stone Blue said:

Thats most likely not a problem with B9 itself... Its just warning you, by design.

Looks like you have a missing dependency somewhere, that defines those recources, or module names. First one i would check, is if you might be missing Community Resource Pack... unless you can identify specifically what mod uses those exact resources.

The 'RR' prefix on some of them, leads me to believe they are Rational Resources related, and RR *does* indeed require Comm. Res. Pack as a dependency.
 

I Installed CSR Already, sir.  yes i believe RR is related to Rational Resources. but i dont know how to identify this problem.

Link to comment
Share on other sites

Hello, I keep encountering this issue and I have no idea how on earth to fix it.

I have my log and entire KSP folder structure here: https://1drv.ms/u/s!AlqfjkpGLMMhhZYxxueY1mQW7d2imQ?e=McRp8S

I really need help with this, I have spent far too long trying to dissect it myself. Also, I am using CKAN.

In the OneDrive folder there is also an image of the errors I am seeing.

I really need some help with these so thanks in advance.

Edited by XBOX-KERBAL1
Spelling and grammar mistakes
Link to comment
Share on other sites

9 minutes ago, XBOX-KERBAL1 said:

Hello, I keep encountering this issue and I have no idea how on earth to fix it.

I have my log and entire KSP folder structure here: https://1drv.ms/u/s!AlqfjkpGLMMhhZYxxueY1mQW7d2imQ?e=McRp8S

I really need help with this, I have spend far too long tring to disect it myself. Also I am using CKAN.

In the Onedrive doler there is also an image of the errors I am seeing.

I really need some help with this so thanks in advance.

I think you need this https://spacedock.info/mod/31/Community Resource Pack

Link to comment
Share on other sites

  • 3 weeks later...

is ModuleControlSurface compatible?

I have a main airliner wing. I want to have a variant with and without elevons.

If it is compatible, please give me the config part of it. Names can be whatever you want, it should just work, as i never got it to work. (Or extend MODULE documentation in wiki)

 

Thanks in advance, your KerbMario

 

Link to comment
Share on other sites

  • 2 weeks later...

Trying to add some NearFuture fuels to the partswitch in CryoEngines.

1.) I've made new tank type definitions
2.) Added them as subtypes to the cryotanks patch that already does all their own fuels

Game starts up fine, no fatal error message, but also no extra fuel types in the tanks.  Am I missing a step somewhere, like the tank type colors etc?


nvm, stock tanks all take the patch, just bdb tanks arenot taking the config somewhere... I know where to look now.

 

Spoiler

// added at the end of  CryoTanksFuelTankTypes.cfg
// Tank type config
B9_TANK_TYPE
{
    name = Li
    tankMass =  0.000278904
    tankCost = 0

    RESOURCE
    {
        name = Lithium
        unitsPerVolume = 2    // not sure yet, need to balance
    }
}
 

//added to existing configs in  CryoTanksFuelTankSwitcher.cfg
        SUBTYPE
        {
            name = Lithium
            title = Lithium
            tankType = Li
            addedMass = #$../../massOffset$
            addedCost = #$../../costOffset$
        }
 



 

Edited by Jimbodiah
Link to comment
Share on other sites

  • 4 weeks later...

After installing the mod Buffalo2 I get the following errors; 

TphHoWN.png

and the game cannot be played. 

I have checked the logs and it seems related to the following  parts; 

[ERR 22:04:54.476] [ERROR] [Part wbiLogisticsModule] [ModuleB9PartSwitch 'fuelSwitch'] must have at least one subtype without tech restrictions, removing tech restriction on first subtype
[ERR 22:04:54.502] [ERROR] [Part wbiLogisticsModule(Clone)] [ModuleB9PartSwitch 'fuelSwitch'] must have at least one subtype without tech restrictions, removing tech restriction on first subtype
[ERR 22:04:54.730] [ERROR] [Part wbiShortLogisticsModule] [ModuleB9PartSwitch 'fuelSwitch'] must have at least one subtype without tech restrictions, removing tech restriction on first subtype
[ERR 22:04:54.746] [ERROR] [Part wbiShortLogisticsModule(Clone)] [ModuleB9PartSwitch 'fuelSwitch'] must have at least one subtype without tech restrictions, removing tech restriction on first subtype
[ERR 22:04:54.759] [ERROR] [Part wbiStorageWedge] [ModuleB9PartSwitch 'fuelSwitch'] must have at least one subtype without tech restrictions, removing tech restriction on first subtype
[ERR 22:04:54.770] [ERROR] [Part wbiStorageWedge(Clone)] [ModuleB9PartSwitch 'fuelSwitch'] must have at least one subtype without tech restrictions, removing tech restriction on first subtype

These cause B9PartSwitch.ModuleB9PartSwitch to throw exceptions and stop. 

I have included the player.log, the ksp.log, and the .cfg files of the parts that are causing the errors and exceptions in the following zip file: https://drive.google.com/file/d/1hbpcvm8ja3Qi9AalWT0V9I79W4js_pNZ/view?usp=sharing

Any assistance in resolving this issue would be appreciated.  

 

Link to comment
Share on other sites

  • 1 month later...

So in my pursuits to find why im missing parts in the Vapor Vent mod Linux was able to help me identify an issue with B9PartSwitch. Im not sure where to start in terms of trouble shooting. Here are my logs.

KSP.log

Player.log

Mod List

Some relevant lines pointed out by Linux.

PartLoader: Compiling Part 'VaporVent/parts/Vent1/part/vent' 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

PartLoader: Encountered exception during compilation. System.NullReferenceException: Object reference not set to an instance of an object
  at B9PartSwitch.ColorPropertyModifierInfo+<CreateModifiers>d__4.MoveNext () [0x00050] in <a3c2951fc74e4639820ef37d2d29f386>:0 
  at B9PartSwitch.MaterialModifierInfo+<CreateModifiers>d__8.MoveNext () [0x001dd] in <a3c2951fc74e4639820ef37d2d29f386>:0 
  at B9PartSwitch.PartSubtype.Setup (B9PartSwitch.ModuleB9PartSwitch parent, System.Boolean displayWarnings) [0x00383] in <a3c2951fc74e4639820ef37d2d29f386>:0 
  at B9PartSwitch.ModuleB9PartSwitch.InitializeSubtypes (System.Boolean displayWarnings) [0x0005b] in <a3c2951fc74e4639820ef37d2d29f386>:0 
  at B9PartSwitch.ModuleB9PartSwitch.OnIconCreate () [0x00006] in <a3c2951fc74e4639820ef37d2d29f386>:0 
  at PartLoader.CreatePartIcon (UnityEngine.GameObject newPart, System.Single& iconScale) [0x0005c] in <39c0323fb6b449a4aaf3465c00ed3c8d>:0 
  at PartLoader.ParsePart (UrlDir+UrlConfig urlConfig, ConfigNode node) [0x00ff2] in <39c0323fb6b449a4aaf3465c00ed3c8d>:0 
  at PartLoader+<CompileParts>d__56.MoveNext () [0x00685] in <39c0323fb6b449a4aaf3465c00ed3c8d>:0  
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

PartCompiler: Cannot compile part 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

My suspicions are with mods that add menu functionality on parts. So the IVA switcher ( Reviva ) and Simple Repaint.

Edit: It was Simple Repaint. Functionality was restored with its deletion.

Edited by Motokid600
Link to comment
Share on other sites

On 8/20/2022 at 7:33 AM, kerbmario said:

is ModuleControlSurface compatible?

I have a main airliner wing. I want to have a variant with and without elevons.

If it is compatible, please give me the config part of it. Names can be whatever you want, it should just work, as i never got it to work. (Or extend MODULE documentation in wiki)

 

Thanks in advance, your KerbMario

 

Also can someone give an example with Module configs?

Link to comment
Share on other sites

On 8/20/2022 at 1:33 AM, kerbmario said:

is ModuleControlSurface compatible?

I have a main airliner wing. I want to have a variant with and without elevons.

If it is compatible, please give me the config part of it. Names can be whatever you want, it should just work, as i never got it to work. (Or extend MODULE documentation in wiki)

 

Thanks in advance, your KerbMario

 

Sometime ago I asked Blowfish about ModuleLiftSurface (just to have static wing sizes in one part) and they gave me a pretty solid no for that so I expect nothing will be provided for any use cases with ModuleControlSurface.

On 10/29/2022 at 12:43 PM, kerbmario said:

Also can someone give an example with Module configs?

Feel free to dig through my mods: Rational Resources and OPT Reconfig. In there you'll see B9PS configs for:

  • Fuel switching on engines, RCS thrusters and fuel cells;
  • Thrust & Isp switching on engines, with tooltips that show accurate and different values per subtype;
  • Upgradeable heatshield properties;

Hopefully these are useful to your plans.

Link to comment
Share on other sites

  • 2 weeks later...
4 hours ago, lucius57 said:

Please help! I keep getting b9partswitch serious warning and I don't know why? I'm aware it's not necessarily a problem but if it could be fixed that would be greatly appreciated! Here is my ksp log as well as a picture of the problem. 

https://www.dropbox.com/scl/fo/zda3och22fhxcf09j1syc/h?dl=0&rlkey=5vll2dnaeud6kxzf3gbzrp0lj

Share your GameData/ModuleManager.ConfigCache. The cockpits are supposed to have a module in them that's influenced by B9 but another mod is renaming or deleting that module.

If this file does not exist then share a copy of your Logs/ModuleManager/ directory. (Some mod would then have bad patches that cause the cache to not be saved.)

Link to comment
Share on other sites

1 hour ago, lucius57 said:

Sorry. I'm not seeing the discontinuity I was expecting (in the cache, anyway) and I don't know what else to look for in this case. The module in question is "HitpointTracker" which is associated with the weapons mods. It's there in the part so B9PS shouldn't be complaining. :/

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...