Jump to content

[1.11.2] B9PartSwitch v2.18.0 (March 17)


blowfish
 Share

Recommended Posts

  • 2 weeks later...
12 hours ago, Irfan Saf said:

Hi guys, I have the different issue with @N3N, installed from CKAN too

Thats most likely not a problem with B9 itself... Its just warning you, by design.

Looks like you have a missing dependency somewhere, that defines those recources, or module names. First one i would check, is if you might be missing Community Resource Pack... unless you can identify specifically what mod uses those exact resources.

The 'RR' prefix on some of them, leads me to believe they are Rational Resources related, and RR *does* indeed require Comm. Res. Pack as a dependency.
 

Edited by Stone Blue
Link to comment
Share on other sites

15 hours ago, Stone Blue said:

Thats most likely not a problem with B9 itself... Its just warning you, by design.

Looks like you have a missing dependency somewhere, that defines those recources, or module names. First one i would check, is if you might be missing Community Resource Pack... unless you can identify specifically what mod uses those exact resources.

The 'RR' prefix on some of them, leads me to believe they are Rational Resources related, and RR *does* indeed require Comm. Res. Pack as a dependency.
 

I Installed CSR Already, sir.  yes i believe RR is related to Rational Resources. but i dont know how to identify this problem.

Link to comment
Share on other sites

Hello, I keep encountering this issue and I have no idea how on earth to fix it.

I have my log and entire KSP folder structure here: https://1drv.ms/u/s!AlqfjkpGLMMhhZYxxueY1mQW7d2imQ?e=McRp8S

I really need help with this, I have spent far too long trying to dissect it myself. Also, I am using CKAN.

In the OneDrive folder there is also an image of the errors I am seeing.

I really need some help with these so thanks in advance.

Edited by XBOX-KERBAL1
Spelling and grammar mistakes
Link to comment
Share on other sites

9 minutes ago, XBOX-KERBAL1 said:

Hello, I keep encountering this issue and I have no idea how on earth to fix it.

I have my log and entire KSP folder structure here: https://1drv.ms/u/s!AlqfjkpGLMMhhZYxxueY1mQW7d2imQ?e=McRp8S

I really need help with this, I have spend far too long tring to disect it myself. Also I am using CKAN.

In the Onedrive doler there is also an image of the errors I am seeing.

I really need some help with this so thanks in advance.

I think you need this https://spacedock.info/mod/31/Community Resource Pack

Link to comment
Share on other sites

  • 3 weeks later...

is ModuleControlSurface compatible?

I have a main airliner wing. I want to have a variant with and without elevons.

If it is compatible, please give me the config part of it. Names can be whatever you want, it should just work, as i never got it to work. (Or extend MODULE documentation in wiki)

 

Thanks in advance, your KerbMario

 

Link to comment
Share on other sites

  • 2 weeks later...

Trying to add some NearFuture fuels to the partswitch in CryoEngines.

1.) I've made new tank type definitions
2.) Added them as subtypes to the cryotanks patch that already does all their own fuels

Game starts up fine, no fatal error message, but also no extra fuel types in the tanks.  Am I missing a step somewhere, like the tank type colors etc?


nvm, stock tanks all take the patch, just bdb tanks arenot taking the config somewhere... I know where to look now.

 

Spoiler

// added at the end of  CryoTanksFuelTankTypes.cfg
// Tank type config
B9_TANK_TYPE
{
    name = Li
    tankMass =  0.000278904
    tankCost = 0

    RESOURCE
    {
        name = Lithium
        unitsPerVolume = 2    // not sure yet, need to balance
    }
}
 

//added to existing configs in  CryoTanksFuelTankSwitcher.cfg
        SUBTYPE
        {
            name = Lithium
            title = Lithium
            tankType = Li
            addedMass = #$../../massOffset$
            addedCost = #$../../costOffset$
        }
 



 

Edited by Jimbodiah
Link to comment
Share on other sites

  • 4 weeks later...

After installing the mod Buffalo2 I get the following errors; 

TphHoWN.png

and the game cannot be played. 

I have checked the logs and it seems related to the following  parts; 

[ERR 22:04:54.476] [ERROR] [Part wbiLogisticsModule] [ModuleB9PartSwitch 'fuelSwitch'] must have at least one subtype without tech restrictions, removing tech restriction on first subtype
[ERR 22:04:54.502] [ERROR] [Part wbiLogisticsModule(Clone)] [ModuleB9PartSwitch 'fuelSwitch'] must have at least one subtype without tech restrictions, removing tech restriction on first subtype
[ERR 22:04:54.730] [ERROR] [Part wbiShortLogisticsModule] [ModuleB9PartSwitch 'fuelSwitch'] must have at least one subtype without tech restrictions, removing tech restriction on first subtype
[ERR 22:04:54.746] [ERROR] [Part wbiShortLogisticsModule(Clone)] [ModuleB9PartSwitch 'fuelSwitch'] must have at least one subtype without tech restrictions, removing tech restriction on first subtype
[ERR 22:04:54.759] [ERROR] [Part wbiStorageWedge] [ModuleB9PartSwitch 'fuelSwitch'] must have at least one subtype without tech restrictions, removing tech restriction on first subtype
[ERR 22:04:54.770] [ERROR] [Part wbiStorageWedge(Clone)] [ModuleB9PartSwitch 'fuelSwitch'] must have at least one subtype without tech restrictions, removing tech restriction on first subtype

These cause B9PartSwitch.ModuleB9PartSwitch to throw exceptions and stop. 

I have included the player.log, the ksp.log, and the .cfg files of the parts that are causing the errors and exceptions in the following zip file: https://drive.google.com/file/d/1hbpcvm8ja3Qi9AalWT0V9I79W4js_pNZ/view?usp=sharing

Any assistance in resolving this issue would be appreciated.  

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...