blowfish

[1.7.3] B9PartSwitch v2.10.1 (Sep 30) - module switching!!!

Recommended Posts

16 hours ago, blowfish said:

No ... in general things inside of module can't be changed ... yet.  Might be some work on that in the near future.

You are talking about code injection? That would be fun! :) 

Share this post


Link to post
Share on other sites
On 2/7/2019 at 8:16 AM, Lisias said:

You are talking about code injection? That would be fun! :) 

No, just loading new data into existing modules.

Share this post


Link to post
Share on other sites

Hey, I'm having a similar problem as the person on the previous page. The parts it lists are from Near Future Construction.

 

iky36Dh.png

Share this post


Link to post
Share on other sites
3 hours ago, Morbanth said:

Hey, I'm having a similar problem as the person on the previous page. The parts it lists are from Near Future Construction.

Can you post your log?  Most likely a dependency for one of your installed mods is missing or something.

Edited by blowfish

Share this post


Link to post
Share on other sites
On 1/15/2018 at 9:03 PM, blowfish said:

I could think about adding some way to fuzzily match nodes.  Other than this one particular case though, I haven't seen many places that would benefit from it.  The old fuzzy matching was really doing more bad than good.

@blowfish Hi,

You never added any kind of fuzzy logic for node naming comparison back into the mod did you? (just asking to know what should I do, came back to modding my parts after a long time)

Share this post


Link to post
Share on other sites
5 hours ago, Jiraiyah said:

@blowfish Hi,

You never added any kind of fuzzy logic for node naming comparison back into the mod did you? (just asking to know what should I do, came back to modding my parts after a long time)

I didn't.  I could pretty easily though.  Maybe create a Github issue so it doesn't fall of my radar this time.

Share this post


Link to post
Share on other sites
On 2/15/2019 at 10:19 PM, Morbanth said:

A clean install fixed it. Thanks for the great mod! :)

What exactly did you do to fix it? I'm having the same problem with OPT parts installed through CKAN.

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, DownHereInChile said:

What exactly did you do to fix it? I'm having the same problem with OPT parts installed through CKAN.

Hey,

I completely re-installed the game and all the mods. Make sure to nuke your game directory as well so nothing remains, don't just uninstall.

Edit: Also, make sure you install OPT Legacy, the other ones don't work.

Edited by Morbanth

Share this post


Link to post
Share on other sites
On 3/12/2019 at 9:00 AM, CyclonicTuna said:

I'm having a fatal error too, but I think its for a different reason. 

81e34cd0e5bc3fedc35e227dc63f74f8.png

I'm not sure what it means by "Two modules cannot manage the same resource".

Log: https://drive.google.com/open?id=13vWV57Cywwo4xBOxJyentQdJGnvkcBQJ

You have a GameData in your GameData. That usually causes trouble.

There are numerous errors generated by the Mk2Expansion patches.

Folders and files in GameData:
AirplanePlus
B9PartSwitch
CommunityResourcePack
Firespitter
GameData             <-----------------------------------
KerbalKonstructs
Mk2Expansion
Mk3Expansion
QuizTechAeroContinued
..snip..

 

2 hours ago, DownHereInChile said:

I'm still getting the same fatal error during the loading of Legacy OPT Parts. I reinstalled the game twice, deleted all mods, and still no luck. I hope the log helps shed some light!

Log: https://docs.google.com/document/d/1OziAAkGm108tPqaF12UnPQ_WTNR4Z8T7e-uVHgVfqJ4/edit?usp=sharing

Check you have all the required dependencies. I'm not familiar with the mod, but you don't have Community Resource Pack installed. It's looking for resources that don't exist.

Share this post


Link to post
Share on other sites
11 hours ago, Jso said:

Check you have all the required dependencies. I'm not familiar with the mod, but you don't have Community Resource Pack installed. It's looking for resources that don't exist.

That fixed it! Thank you so much <3

Share this post


Link to post
Share on other sites
On 3/14/2019 at 4:48 AM, Jso said:

You have a GameData in your GameData. That usually causes trouble.

There are numerous errors generated by the Mk2Expansion patches.

 

Indeed I have! Thank you for the clarification. This was sloppyness on my part. 

Share this post


Link to post
Share on other sites

Hello @blowfish. Thank you very much for your efforts dedicated to KSP modding.

I'm curious, is it possible to use B9PartSwitch to handle Missing History parts and backport them to KSP 1.3.1 ?

Share this post


Link to post
Share on other sites
2 hours ago, evileye.x said:

Hello @blowfish. Thank you very much for your efforts dedicated to KSP modding.

I'm curious, is it possible to use B9PartSwitch to handle Missing History parts and backport them to KSP 1.3.1 ?

It should be possible to do most of what's possible with the stock switcher with B9PartSwitch, yes.  It's just a question of someone writing the configs.  The one thing I know isn't possible is switching the fairing textures.

Share this post


Link to post
Share on other sites

@blowfish

Hi! I'm from Brazil, and translated your mod to pt-br, how can I send you the file, to make official?
 

Thanks in advance.

Share this post


Link to post
Share on other sites
1 hour ago, Kastruss said:

@blowfish

Hi! I'm from Brazil, and translated your mod to pt-br, how can I send you the file, to make official?
 

Thanks in advance.

If you're not familiar with Github, you can just share the file via pastebin, or even post the contents in a code block here since it's pretty small (maybe use spoiler tags to avoid cluttering the thread)

Share this post


Link to post
Share on other sites
Posted (edited)

@blowfish I'm having an odd problem with the B9PartSwitch module.  

I'm using it to pick one of two transforms in a .mu file.  It works, but when it does, the part in the parts list in the editor is blank.  If I only have one subtype active (I commented the other out), then it shows up in the parts list correctly, but both transforms are shown when the part is picked.

Here is the config file and the .mu: https://www.dropbox.com/s/4dcxykbc45k6yhx/B9SwitchProblem.zip?dl=0

Here is the relevant part of the config:

   	MODULE
	{
		name = ModuleB9PartSwitch
		moduleID = Shape
		switcherDescription = Shape
        switcherDescriptionPlural  = Shapes
        affectDragCubes  = false
		SUBTYPE
		{
			name = Left
			transform = obj_ctrlSrf_R
		}
		SUBTYPE
		{
			name = Right			
			transform = obj_ctrlSrf_L
		}
	}

and here are a few images showing the problem

This first image shows the missing part in the parts list:

TbOC6uB.png

 

This second image shows the part as it was placed on the plane:

ZclgE1L.png

Finally, this picture shows what happens when I comment out one of the subtypes:

7mHQEns.png

 

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

Strangely enough, it started working.

So all I need to know now is what would cause the thumbnail from being displayed while the part itself works?

Share this post


Link to post
Share on other sites
Posted (edited)

@linuxgurugamer obj_ctrlSrf_R has the Icon_Hidden tag.  So that's hiding that subtype (which is the default) in the part icon.

Edited by blowfish

Share this post


Link to post
Share on other sites

@blowfish I finally figured out why I'm having such a difficult time.

This part was made for the FSmeshSwitch module, and the one thing the FSmeshSwitch does which this doesn't is an option to updateSymmetry;  it's false on this part, so when one part in a mirrored set gets  changed, the other doesn't.

I took a fast look at the code,  and it doesn't seem to be more than a few lines of code here: https://github.com/blowfishpro/B9PartSwitch/blob/f0efe3e43627024bf811b4c5be61f1370a37fcd6/B9PartSwitch/PartSwitch/ModuleB9PartSwitch.cs#L584-L595

which would need an option to say whether to disable symmetry or not.

For now, I'm going to have to stay with the FSmeshSwitch, otherwise it's unusable for this part.

If I get some time, I may download and see if it's a simple as I think, if so, I'll submit a PR.

Share this post


Link to post
Share on other sites
Posted (edited)

@blowfish  I cloned the repo, made the change and it works. 

It was about 5-6 lines of code

I've submitted a PR on Github

I'd appreciate knowing if you will accept this, and if so, when a new release will be made with it, so that I can do a good release of the mod.  If it will be a while, I'll release it now with the FSmeshSwitch, and change later, but would rather not need to do a switch

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

B9PartSwitch v2.7.0 for KSP 1.7.0

  • Compile for KSP 1.7.0
  • Remove ModuleB9PropagateCopyEvents from parts since KSP handles this correctly now
    • Leave empty class so that KSP doesn't complain when loading craft/vessels
  • Subtype initialization errors now warn the user but allow the game to continue
  • Add fuzzy matching for attach node toggling
    • ? will match any one character, * will match anything (or nothing)
    • All matching nodes will be switched
  • Allow moving and rotation of transforms
    • Subtypes can now have TRANSFORM nodes
      • Each one should nave a name which is the name of the transform
      • Each one can have a positionOffset = x, y, z which is a local offset for that transform
        • Any number of modules can modify a transform's position (it's additive)
      • Each one can have a rotationOffset = x, y, z which is a local rotation offset
        • Only one module can modify a transform's position
  • Remove KSP localization debug logging
  • Add Brazilian Portuguese localization
  • Localize switch subtype button
  • Fix texture switches incorrectly saying the current texture wasn't found when really the new texture wasn't found
  • Use more correct part names in some log messages
  • Allow subtypes to specify a mirror symmetry counterpart
    • Subtypes now accept a mirrorSymmetrySubtype value which is the subtype name of the mirror symmetry subtype
    • When placing the part in mirror symmetry, the symmetry counterpart will use this mirror symmetry subtype, otherwise it will use the normal subtype

I'm pretty sure this will also work with KSP 1.6.x but no explicit guarantees

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.