blowfish

[1.7.3] B9PartSwitch v2.10.1 (Sep 30) - module switching!!!

Recommended Posts

Please help. Im trying to get OPT but it keeps saying "B9 part switch- Fatal Error" What do i do? I really want to play with this mod but i cant if it keeps saying that.

 

Share this post


Link to post
Share on other sites
21 minutes ago, Alex Miller said:

Please help. Im trying to get OPT but it keeps saying "B9 part switch- Fatal Error" What do i do? I really want to play with this mod but i cant if it keeps saying that.

 

Do you have Community Resource Pack? OPT Reconfig (which gives B9 options to OPT) requires it. If you have that, zip up your KSP.log and share it somewhere so I can see.

Share this post


Link to post
Share on other sites
23 minutes ago, JadeOfMaar said:

Do you have Community Resource Pack? OPT Reconfig (which gives B9 options to OPT) requires it. If you have that, zip up your KSP.log and share it somewhere so I can see.

How do i do that

 

Share this post


Link to post
Share on other sites
Posted (edited)

it says "b9 part switch fatal error" for 1.7.2!

How can i fix it?

 

Edited by siklidkid
e

Share this post


Link to post
Share on other sites
14 minutes ago, siklidkid said:

it says "b9 part switch fatal error" for 1.7.2!

How can i fix it?

 

Does the mod still work despite the message?

I’m still on 1.7.1 so I haven’t seen this issue.

Share this post


Link to post
Share on other sites

@Nightside The Fatal Error is a complaint about a part configuration from a mod, and not a problem with B9PS. It's only "fatal" in the sense that B9PS may not work correctly on the part causing the error message.

The errors have always been there, but just dumped in the log where no one noticed. A recent (3 months ago?) change now displays the error to the user and it seems to panic people that don't understand what the message really means.

Share this post


Link to post
Share on other sites

Hi all,

 

I posted in Scatterer thread but did not get any reply so thought I would ask here: does anyone else have issues (for instance with the sunflare) using the latest Scatterer and B9PartSwitch?

 

Cheers

 

Share this post


Link to post
Share on other sites
2 hours ago, nmc said:

Hi all,

 

I posted in Scatterer thread but did not get any reply so thought I would ask here: does anyone else have issues (for instance with the sunflare) using the latest Scatterer and B9PartSwitch?

 

Cheers

 

I have noticed the sunflare failing to show while use both mods, but I hadn’t been able to track it down.

Share this post


Link to post
Share on other sites
On 6/19/2019 at 7:26 AM, Nightside said:

Does the mod still work despite the message?

I’m still on 1.7.1 so I haven’t seen this issue.

its near future tech.

It works if i remove it, i just can't change the part subtypes.

Share this post


Link to post
Share on other sites

Thanks @Nightside for confirming the issue!

 

@blowfish I see you already discussed the issue in the Scatterer thread, something related to RenderProceduralDragCubes, did anything come out of that?

 

Share this post


Link to post
Share on other sites
Posted (edited)
9 hours ago, nmc said:

@blowfish I see you already discussed the issue in the Scatterer thread, something related to RenderProceduralDragCubes, did anything come out of that?

It didn't.  I'm really mostly just using KSP's methods of rendering procedural drag cubes, but I know there ends up being some weirdness when that happens in the flight scene, especially when the part in question is the root part of the vessel.  Just to narrow it down, does it still happen even if there's no part switch on the root part (but there is on other parts)?

Edited by blowfish

Share this post


Link to post
Share on other sites

Thanks @blowfish for the reply (indeed, I think all my affected vessels had a B9PartSwitch on the root part, so this is possible)

 

Well, your question inspired me to try and reproduce the issue and... I could not

I am in the process of creating my own visual pack, taking assets and configs from various mods; I had disabled the Scatterer sunflare to work around the issue

So I tried re-enabling the Scatterer sunflare: now the flare (Scatterer default, or other such as Sunflares of Maar) is shown properly with all new and existing vessels, regardless of B9PartSwitch

I did not update either KSP, B9PartSwitch or Scatterer in the meantime, so not sure what changed...

 

I will keep tweaking my visual config and post back if the problem resurfaces, but for the moment I am going to take a few screenshots of my Laythe space station!

Share this post


Link to post
Share on other sites

@blowfish

Wondering if you can give a big of help (anybody else is welcome to help as well)

The B9 Shuttle style wings is really a single wing.  When I look at it in Blender, it's just a single wing, with the main transform called Shuttle_wing_R.  Somehow, when in the SPH, and mounted with symmetry, the bottom of the wing has a dark texture on both sides, and the top is the white stockalike.  I have to assume that one side is the top (I'm guessing the negative Y, based on what I see in Blender).  I'd like to have the top & bottom controlled by B9PartSwitch and not the game;  this is significant when a shuttle is vertical.

So as a test, I added the following to the config:

Spoiler

	MODULE
	{
		name = ModuleB9PartSwitch
		moduleID = TopBottom
		switcherDescription = Shape
		switcherDescriptionPlural = Shapes
		updateSymmetry = true
		SUBTYPE
		{
			name = Right 
			TRANSFORM
			{
				name = Shuttle_wing_R
				rotationOffset = 0,0,0
			}
		}
		SUBTYPE
		{
			name = Right +x
			TRANSFORM
			{
				name = Shuttle_wing_R
				rotationOffset = 180,0,0
			}
		}
		SUBTYPE
		{
			name = Right -y
			TRANSFORM
			{
				name = Shuttle_wing_R
				rotationOffset = 0,180,0
			}
		}
		SUBTYPE
		{
			name = Right -z
			TRANSFORM
			{
				name = Shuttle_wing_R
				rotationOffset = 0,0,180
			}
		}
	}

 

This actually rotates the wing as I move through the different subtypes.

However, what is configured in the .mu as the wing top doesn't seem to be affected;  in other words, the problem with the wings using the wrong texture is still there, the game is still setting the wing configuration based on it's position in the editor.

This wouldn't be quite that bad except that the wing is contoured differently on top and bottom, so when it uses the wrong texture, it's actually using the model upside down.  I haven't been able to find any sort of documentation about the MODEL stanza in the config file which relates (still looking, though)

 

Share this post


Link to post
Share on other sites
14 hours ago, Mircea The Young said:

So, I'm getting a fatal error message, but this one's fatal for real as it closes the game. It seems to be an issue with the liquid fuel resource not being loaded properly. I'm getting similar errors with IFS.

Log:

https://www.dropbox.com/s/yppt5ztvttttery/output_log.txt?dl=0

Yes, it appears that a big part of your GameData/Squad folder is missing.  I recommend deleting it entirely and having Steam reinstall it.

On 6/25/2019 at 6:47 PM, linuxgurugamer said:

@blowfish

Wondering if you can give a big of help (anybody else is welcome to help as well)

The B9 Shuttle style wings is really a single wing.  When I look at it in Blender, it's just a single wing, with the main transform called Shuttle_wing_R.  Somehow, when in the SPH, and mounted with symmetry, the bottom of the wing has a dark texture on both sides, and the top is the white stockalike.  I have to assume that one side is the top (I'm guessing the negative Y, based on what I see in Blender).  I'd like to have the top & bottom controlled by B9PartSwitch and not the game;  this is significant when a shuttle is vertical.

So as a test, I added the following to the config:

  Reveal hidden contents


	MODULE
	{
		name = ModuleB9PartSwitch
		moduleID = TopBottom
		switcherDescription = Shape
		switcherDescriptionPlural = Shapes
		updateSymmetry = true
		SUBTYPE
		{
			name = Right 
			TRANSFORM
			{
				name = Shuttle_wing_R
				rotationOffset = 0,0,0
			}
		}
		SUBTYPE
		{
			name = Right +x
			TRANSFORM
			{
				name = Shuttle_wing_R
				rotationOffset = 180,0,0
			}
		}
		SUBTYPE
		{
			name = Right -y
			TRANSFORM
			{
				name = Shuttle_wing_R
				rotationOffset = 0,180,0
			}
		}
		SUBTYPE
		{
			name = Right -z
			TRANSFORM
			{
				name = Shuttle_wing_R
				rotationOffset = 0,0,180
			}
		}
	}

 

This actually rotates the wing as I move through the different subtypes.

However, what is configured in the .mu as the wing top doesn't seem to be affected;  in other words, the problem with the wings using the wrong texture is still there, the game is still setting the wing configuration based on it's position in the editor.

This wouldn't be quite that bad except that the wing is contoured differently on top and bottom, so when it uses the wrong texture, it's actually using the model upside down.  I haven't been able to find any sort of documentation about the MODEL stanza in the config file which relates (still looking, though)

 

Let's take this to DMs again

Share this post


Link to post
Share on other sites

B9PartSwitch v2.8.1 for KSP 1.7.3

  • Recompile against KSP 1.7.3

 

I'm working on some major overhauls to the UI right now.  The new switching UI is based on the stock variant selector (not exactly the same, and hopefully better in some ways).  This will pave the way some other big planned/in progress features, such as tech unlocks and switching data on other modules.

Share this post


Link to post
Share on other sites
1 hour ago, MIRROR said:

how do i Install this

Either:

  1. Manually. Download the .zip from the link on the OP.  Extract the GameData folder from the .zip into your KSP install directory, or extract the .zip file's B9PartSwitch folder into your <KSP install>/GameData folder.
  2. CKAN. Install and use CKAN.

 

Share this post


Link to post
Share on other sites
2 hours ago, MIRROR said:

how do i Install this

And you most probably not have any direct benefit from this mod. It is more intended for mod developers as dependency/supportive mod for other mod parts.
Part developer use this mod to have ability to change some part 3D visual mesh apearance, different texture, fuel tank or other resource configuration etc. All that available just from one part in SPH/VAB part menu. Once suchj part is attached to craft, you don't need to deattach it from craft, just choose from PAW what configuration you want/need from certain part on your craft.

Part developers who use it, probably have this mod packed with their archive, or in case of CKAN install, it will automatically install if it is required.

Share this post


Link to post
Share on other sites

 

On 6/10/2019 at 3:43 PM, JadeOfMaar said:

Do you have Community Resource Pack? OPT Reconfig (which gives B9 options to OPT) requires it. If you have that, zip up your KSP.log and share it somewhere so I can see.

can you give me a link for a version of the community resource pack that works with 1.7+, i can't seem to find one. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.