Nansuchao

Interstellar Extended for Dummies

Recommended Posts

Interstellar Extended is one of the most beautiful and addictive mods ever made for Kerbal Space Program, but it's also one of the most complicated creation of this awesome community. It adds A LOT of parts, and very little info

on what to do to make them work correctly.

Here we'll see hot to make the Interstellar Extended engines work.

The firsts Interstellar Extended engines you will unlock in your save (except in sandbox mode), are very easy to use.

The models comes from the beautiful Atomic Rocket by Porkjet (link), but are modified to respect the realism profile

of Interstellar Extended.

VX4J4IY.png

 

CANDLE

YJc8MC9.png

This tiny engine is very useful for light probes. It has a built in power generation, so it will provide energy to your ship and a decent ratio thrust/ISP for such a little thruster. It works with many different propellants, so it's up to you to choose which one is better suited for your mission. On late game, is also good just as power generators for motherships, instead as thruster.

SOLID CORE

Sx4CXft.png

This is a medium-sized alternative to the CANDLE, for medium sized ships. This one too has a built-in power generator, so you have not to worry about solar panels. I suggest this engine for early career long-range probes and light landers. It is difficult to use for a lander because it takes 10 seconds to fully throttle up, which adds difficulty but is still doable.

With the right propellant, this is very good also for manned missions and landers on light planets-moons (Duna, Dres...)

CLOSED CYCLE GAS CORE

tovDKPJ.png

This 2.5m beast is very powerful and very efficient. It is scalable from 2.5m to 3.75m by clicking in the bar and has a wonderful ISP/thrust ratio.

It is expensive but can easy launch 100t into space in one stage, and the cost can be recovered using stage recovery and a flip and burn after separation.

Perfect for motherships and manned missions all around the Kerbol system. Due to his shape, it's not so suited for landers, but with some creativity...

THERMAL TURBOJET

JsTZ1lp.png

This is one of the first less complicated engines to use. It takes air from intakes and thermal power from a reactor to create thrust.  It NEEDS a reactor to work. The best solution is to attach it directly to a reactor, but if needed you can put some parts between the reactor and the engine, at the costs of some loss of thrust.

The engine is scaleable and it can change to other propellants while in flight with very good results. When you unlock it in your career, it can only use Atmosphere as propellant, so you can use it just on Kerbin or other atmospheric bodies (Eve included).

With a powerful reactor attached, this is perfect for SSTOs and spaceplanes of all sorts. It is suggested to use a pre-cooler in order to use it at high atmospheric speed.

THERMAL LAUNCH NOZZLE

3lUcRSG.png

This rocket engine is designed to launch from the ground. It works similarly to the Thermal Turbojet, so it needs a reactor. Its ISP is not so high in respect to other Interstellar engines, but it's main advantage is that it can afterburn oxygen into a propellant after it’s run through the reactor, effectively increasing thrust enough to lift off the ground with a heavy reactor. Can launch a molten salt reactor, with the advantage of not connecting directly to the reactor without much power loss..

THERMAL RAMJET NOZZLE

T52dFui.png

This is the rocket version of the Thermal TurboJet and has very similar specs. This nozzle is also essential if you want to maximise Isp in vacuum which is especially relevant for the Open Cycle Gas Core reactor and antimatter reactors.  The name can be a bit deceptive.  It’s primary use is not atmospheric, but instead in space for high thrust and good ISP.

This is perfect for heavy rockets.

ATTILA THRUSTER

ue72jEz.png

This is your first taste of high ISP thrusters from KSPI, getting about double the fuel efficiency that thermal thrusters can get.  The thrust is much lower than a thermal solution, and will never have high acceleration.  It doesn’t accelerate so much if the power comes from an onboard molten salt reactor.  Performance is amazing with beamed microwave power.   This engine is also radially attachable, so it's very good for V-TOL.  Its low profile shape makes it also very good for landers.

PLASMA THRUSTER

sf5mT3w.png

The Plasma Thruster is one of the best vacuum engine you'll ever see. It needs energy in order to provide thrust, a lot of energy. It must not be attached directly to a reactor or, in case you have built a very good Microwave web, you don't need a reactor at all, just energy. It has an incredible ISP and low thrust, perfect for long range probes.  About thrust, it depends on how much power you provide to it. The energy it can use is capped depending on his size, so you need to scale it up in order to gain better thrust. This engine also produce a lot of Waste Heat when accelerating, so some radiators are required for long burns. When upgraded in the tech tree or in sandbox, the Plasma Engine will become a Quantum Vacuum thruster. It means it will provide thrust without propellant at all, if you give it energy.

MAGNETIC NOZZLE

VrgrM2v.png

5HE5fqf.png

This engine use charged particles and needs Hydrogen to work, so it needs a good reactor producing Charged Particles to provide thrust. It will work only in the vacuum of space. To note that the ISP of the engine change depending on throttle.  Lower the thrust, higher the ISP, so it's very useful for long range probes, to a near star too, in theory, thanks to the ability to accelerate during TimeWarp at low throttle.

MAGNETO INERTIAL FUSION

AeV56tF.png

This engine has a built-in fusion reactor. This means it doesn't need to be attached to a reactor to work, but it needs a reactor in the ship or Beam Power to maintain the fusion reactions active.  This pulse engines is for vacuum and not for atmospheric-ground operations and it use Lithium as propellant.

TOKAMAK FUSION ENGINE

86x8ETn.png

The Tokamak is a more specialized version of Magnetic Confinement Fusion reactor which excels in high Isp High efficient propulsion.The engine combines a reactor and integrated magnetic nozzle. To start it needs some capacitors. The engine’s reactor can only be connected to either a thermal generator or direct energy converter.

D/T VISTA

OACaaiX.png

Vista is practically an open fusion reactor. It burns Hydrogen, Deuterium and Tritium and it needs 2.5 GW of energy in order to work.  It will provide a very good thrust when fully upgraded with a marvelous ISP that you can change in the editor and in flight too,  from 15544s to 27544s.  Note that higher the ISP, higher the Waste Heat this engine will produce, so you'll need a good amount of radiators to not melt your ship.  This engine is very good for long range motherships.  Note that the VISTA engine will not work if in the physical range is present a Kerbal not inside the Vista's ship for safety reason,  due to the highly radioactive exhaust. you can disable the safety shutdown, but beware that near Kerbals will easily die.

VASIMR

aQ7Yk5V.png

The VASIMR engine is another Plasma-like thruster. It needs energy to work and it will use more or less every propellant, providing a very good ISP and a good thrust. Scaled up to 2.5 m (max size), it is very good for long range ships. Note that the ISP of the VASIMR change depending on the throttle. Lower the throttle, higher the ISP, so it will be able to thrust your Grand Tour ships without issues.

TORY NUCLEAR RAMJET

7cbfUiP.png

The TORY is another spaceplane/SSTO engine. In atmospheric mode it provide a very good thrust at high speed. It has a built-in reactor, so it just need air intakes and pre-coolers to work properly. It is also suited for vacuum flight, due to the ability to switch propellant in flight.

 

This guide was written four-hand with @Liquid5n0w

Thanks to @FreeThinker for maintaining and constantly upgrading this marvelous mod.

 

Edited by Nansuchao
  • Like 17

Share this post


Link to post
Share on other sites

Thanks for the writing! 

That cleared up some engines which i never dared to use because of the unknown effects :) 

  • Like 2

Share this post


Link to post
Share on other sites

Thanks for posting this. I'm very curious about Interstellar now that I've filled out the tech tree and am thinking about combining it with OPM to take things to the next level :)

  • Like 2

Share this post


Link to post
Share on other sites

Well, to completely unlock the Interstellar Tech Tree you need A LOT of Science, but the reward is great!

Share this post


Link to post
Share on other sites
On 6/15/2016 at 4:02 PM, Nansuchao said:

Well, to completely unlock the Interstellar Tech Tree you need A LOT of Science, but the reward is great!

Excellent! I've built up quite the surplus so far. 

  • Like 1

Share this post


Link to post
Share on other sites

i have massive problems in making the magneto inertial fusion engine work. Even building a ship similar to the one in the pic, I get an ISP near 3000 in the VAB, but when the ship is in orbit, the engine does not actually produce any thrust. Also, I see the options to start "EMI", start "Pulse", and activate engine - do I need to perform those steps in any particular order? thanks for this guide, and to anybody who could help me.

Share this post


Link to post
Share on other sites
6 minutes ago, jjlehto said:

i have massive problems in making the magneto inertial fusion engine work. Even building a ship similar to the one in the pic, I get an ISP near 3000 in the VAB, but when the ship is in orbit, the engine does not actually produce any thrust. Also, I see the options to start "EMI", start "Pulse", and activate engine - do I need to perform those steps in any particular order? thanks for this guide, and to anybody who could help me.

Can you upload a pics of your ship? What version of KSP?

Share this post


Link to post
Share on other sites

thanks, i'm having trouble uploading a pic, but it consist simply of a pod(with an antenna), a molten salt reactor, two radiators (have green thermal results in vab), and the fusion engine. I'm running KSP 1.12

Share this post


Link to post
Share on other sites
18 minutes ago, jjlehto said:

thanks, i'm having trouble uploading a pic, but it consist simply of a pod(with an antenna), a molten salt reactor, two radiators (have green thermal results in vab), and the fusion engine. I'm running KSP 1.12

And where is the Lithium?

Share this post


Link to post
Share on other sites
2 hours ago, Nansuchao said:

And where is the Lithium?

the engine contains 1000 units of it. Anyway, I tried adding 6 containers of it just in case, but no luck..

Share this post


Link to post
Share on other sites
2 hours ago, jjlehto said:

the engine contains 1000 units of it. Anyway, I tried adding 6 containers of it just in case, but no luck..

Currently I'm far from my home. Can you make a try for me? Add a generator to the engine, probably the Charged Particle one and tell me the results.

If the Molten Salt gives enough energy to sustain the fusion, maybe a generator attached to the engine can help.

I'm sorry but I did few tests with this new engines, so I can be wrong someway.

Share this post


Link to post
Share on other sites
18 hours ago, jjlehto said:

i have massive problems in making the magneto inertial fusion engine work. Even building a ship similar to the one in the pic, I get an ISP near 3000 in the VAB, but when the ship is in orbit, the engine does not actually produce any thrust. Also, I see the options to start "EMI", start "Pulse", and activate engine - do I need to perform those steps in any particular order? thanks for this guide, and to anybody who could help me.

I have used the engine with probes without issue, just had enough power and turned on the engine through staging. Clicking activate engine would have the same effect. When you have it trying to run what does the reactor control window say? 

Share this post


Link to post
Share on other sites

ok, here's a pic containing some info:

http://imgur.com/31j3Elp

I've been testing it a little, tried to attach a particle generator to it but still nothing. 

When I activate the engine, it basically "pulses", at a rate of maybe 1 pulse per second. At every pulse, it releases a reddish flame. Both in VAB and in flight, I can see that the engine has an ISP (~3000), but no thrust.

Edited by jjlehto

Share this post


Link to post
Share on other sites
4 hours ago, jjlehto said:

ok, here's a pic containing some info:

http://imgur.com/31j3Elp

I've been testing it a little, tried to attach a particle generator to it but still nothing. 

When I activate the engine, it basically "pulses", at a rate of maybe 1 pulse per second. At every pulse, it releases a reddish flame. Both in VAB and in flight, I can see that the engine has an ISP (~3000), but no thrust.

Wait a second, you have thrust there in the picture, 0.2 Kn. But no charged particle and that's weird. Are you in career, science or sandbox?

Share this post


Link to post
Share on other sites
6 hours ago, Nansuchao said:

Wait a second, you have thrust there in the picture, 0.2 Kn. But no charged particle and that's weird. Are you in career, science or sandbox?

I am in career. 0.2 kn is quite null, but I believe the value it's extrapolated from when the engine "pulses" for a fraction of second. I tested  the engine with a dusty plasma reactor, with a dusty attached to a fusion reactor, and with a dusty, fusion, and particles electric generator attached. No luck, it keeps behaving like described.

Share this post


Link to post
Share on other sites
34 minutes ago, jjlehto said:

I am in career. 0.2 kn is quite null, but I believe the value it's extrapolated from when the engine "pulses" for a fraction of second. I tested  the engine with a dusty plasma reactor, with a dusty attached to a fusion reactor, and with a dusty, fusion, and particles electric generator attached. No luck, it keeps behaving like described.

In this case, only the magic of FreeThinker can help you.

Summoning @FreeThinker

 

Meanwhile @jjlehto, please upload your output log to a place like Dropboxe and share the link here.

Share this post


Link to post
Share on other sites
47 minutes ago, jjlehto said:

I am in career. 0.2 kn is quite null, but I believe the value it's extrapolated from when the engine "pulses" for a fraction of second. I tested  the engine with a dusty plasma reactor, with a dusty attached to a fusion reactor, and with a dusty, fusion, and particles electric generator attached. No luck, it keeps behaving like described.

Could you post a sceendump of the vessel, then I will be able to reproduce the problem and can determine what is going wrong

  • Like 1

Share this post


Link to post
Share on other sites

ok, I prepared a simple test vehicle and saved the logs.

The ship:

http://imgur.com/HrP80Pb

Log files:

https://mega.nz/#!NohVSZ7R!zihppBNNGhK5LuGdK2X1WWC1pqM8j39HXYqot6nE9js  KSP.log
https://mega.nz/#!MwBkWIqa!_406KDq9qYuPHwOcY3-igbP3SIPJXX8aGjpbFnL5VqM  Output_log.txt

I looked at what happens in the engine right-click menu through mission, what I observed is that the engine steadily builds up charged particles and thermal power from mission start. When reaching orbit, and activating it (either through staging or using the contextual buttons), those resources are nullified istantly, their values going to null and not increasing anymore.

Also, pls pardon my ignorance, how do I take a screendump of the vessel? 

Edited by jjlehto

Share this post


Link to post
Share on other sites
On 28-6-2016 at 9:24 AM, jjlehto said:

I've made a short movie, displaying what happens when the engine is started:

https://vid.me/c6hO

hope it can be of some help.

What are you using to power it? Seems to me, nothing is powering it. The Dusty plasma reactor cannot produce any power unless comnected to an electric generator. I suggest you replace it with a downsized molten salt reactor and attach a few radiators, then it should work.

Edited by FreeThinker

Share this post


Link to post
Share on other sites

I recently installed IE, and for some reason, I'm able to use the DT thruster and Plasma thruster without any reactor/power at all.  I just strap a liquid H2 tank to it, and I'm done, I have amazing ISP with no fuss (so something is clearly wrong).   I mean, it's nice making a reusable SSTO a 3-person capsule, liquid H2 tank, and 4 thrusters, but it feels seriously like cheating.

 

On another point, I can't figure out reactors- the tutorial videos say strap a reactor to a generator, some radiators for the waste heat, and the thing should generate power.  It doesn't, it just sits there, says thermal output is zero, no electrical output.  I have tried with various fission and fusion reactors (I recall one video talking about having to 'jump start' a fusion reactor with another reactor, so I switched to try fission reactors.  Nada, nothing.   
 

I am running no other mods other than MechJeb and IE.

Share this post


Link to post
Share on other sites
2 hours ago, sdrevik said:

I recently installed IE, and for some reason, I'm able to use the DT thruster and Plasma thruster without any reactor/power at all.  I just strap a liquid H2 tank to it, and I'm done, I have amazing ISP with no fuss (so something is clearly wrong).   I mean, it's nice making a reusable SSTO a 3-person capsule, liquid H2 tank, and 4 thrusters, but it feels seriously like cheating.

 

On another point, I can't figure out reactors- the tutorial videos say strap a reactor to a generator, some radiators for the waste heat, and the thing should generate power.  It doesn't, it just sits there, says thermal output is zero, no electrical output.  I have tried with various fission and fusion reactors (I recall one video talking about having to 'jump start' a fusion reactor with another reactor, so I switched to try fission reactors.  Nada, nothing.   
 

I am running no other mods other than MechJeb and IE.

For the engines, it seems a bug. Please post some screenshots of the ships and of the "bugged" engines.

About reactors, I plan to include them in this guide (soon). You must look in the editor what kind of energy (thermal power or charged particle) that reactor will produce and then attach to it the right generator (thermal or charged particle). Fusion reactors needs another source of energy to start the reaction (Omega) and/or to sustain it (Tokamak, Quantum).

Share this post


Link to post
Share on other sites
2 hours ago, Nansuchao said:

For the engines, it seems a bug. Please post some screenshots of the ships and of the "bugged" engines.

About reactors, I plan to include them in this guide (soon). You must look in the editor what kind of energy (thermal power or charged particle) that reactor will produce and then attach to it the right generator (thermal or charged particle). Fusion reactors needs another source of energy to start the reaction (Omega) and/or to sustain it (Tokamak, Quantum).

I loaded the new update, and the engines and reactors seem to behave per the videos now.  It's too bad, I was loving having a simple SSTO using plasma thrusters.

Share this post


Link to post
Share on other sites
46 minutes ago, sdrevik said:

I loaded the new update, and the engines and reactors seem to behave per the videos now.  It's too bad, I was loving having a simple SSTO using plasma thrusters.

Well, you will achieve it with a good Microwave Web. The way you experienced is a little "cheaty" :wink:

Share this post


Link to post
Share on other sites
28 minutes ago, Nansuchao said:

Well, you will achieve it with a good Microwave Web. The way you experienced is a little "cheaty" :wink:

Well, as it turns out, I back-loaded 1.9.4 to land all my 'invalid' designs and get my $$ back, then I reloaded 1.9.5, and.... it behaves the same.  No reactor control panel, no need for power for plasma and DT drives.  I had it running, all I did was copy the 1.9.5 files on top of the 1.9.4 files earlier.   Why would it not do it this time?

 

Here's a link to an image of the "bugged" SSTO.    I can send the reactors with no control panels, too, if you wish:

bus.jpg

 

 

 

Here's the ship with the reactor that doesn't generate- not the batteries almost discharged.  When I had it working, right-clicking the reactor gave me a whole control panel that I no longer see anymore:
reactor.jpg

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now