• 1
Majorjim!

Z-fighting shadows

Question

Hi all,

 It is knows that the move to Unity 5 has caused a bug with the shadows. It is a kind of striping bug that is very noticeable and ugly.

Does anyone know if this is being looked at or if a fix is even possible because I have heard little from the devs on it. And I know it is a minor bug but it would be nice to know its going to be addressed.

Thanks for reading and let me know here if you hear anything about this.

MJ

UPDATE: Here is the state of shadows in KSP unity 5.

 

 

 

Edited by Majorjim
  • Like 4

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0
2 hours ago, Majorjim said:

I cannot view those.

What prevents viewing? Format, or are they not accessible somehow? All seems ok here.

I tried encoding as animated GIF but they end up being way too big and Imgur truncates them (~20-25MB), or they end up too small/low quality to really see the effect.

 

2 hours ago, Majorjim said:

Do you have a YT account?

I don't. Not sure how that would help though, since the video format is the exact same as it would be if uploaded to YT.

Edited by swjr-swis

Share this post


Link to post
Share on other sites
  • 0
8 hours ago, swjr-swis said:

What prevents viewing?

My Macbooks old software maybe. Will check from my PC later.

Share this post


Link to post
Share on other sites
  • 0

For those of you that don't know the issue Majorjim is talking about,  good.  Keep it that way.  Ignorance is bliss.  Once it's seen it cannot be unseen lol

  • Like 3

Share this post


Link to post
Share on other sites
  • 0
Just now, Berlin said:

For those of you that don't know the issue Majorjim is talking about,  good.  Keep it that way.  Ignorance is bliss.  Once it's seen it cannot be unseen lol

I'm amazed more haven't noticed it. It's so obvious and off putting.. It is slightly less visible at lower shadow settings but low settings look crappy and make almost zero difference to the performance.

  • Like 2

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, Berlin said:

For those of you that don't know the issue Majorjim is talking about,  good.  Keep it that way.  Ignorance is bliss.  Once it's seen it cannot be unseen lol

lol @ this...
Yeah...for me, I build a 2.5m rocket, and sitting on the pad in the middle of the day, there is Zfighting along every part joint, from top to bottom on the rocket... Looks like there is a cylinder inside the whole rocket, that is slowly spinning, and is slightly larger than the diameter of the rocket, causing Zfighting... Its ovious and annoying as heck...

I thought it was a mod doing something, and even went as far as to do a fresh clean KSP install... Luckily I found this thread soon after, so I know its just not me, or a mod issue...

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I've noticed these "moving shadows", but I'm not playing with full specs.

So people who use high resolution also see this ?

 

Edited by Triop

Share this post


Link to post
Share on other sites
  • 0
8 hours ago, Triop said:

So people who use high resolution also see this ?

Yes.

Share this post


Link to post
Share on other sites
  • 0
11 hours ago, Triop said:

I've noticed these "moving shadows", but I'm not playing with full specs.

So people who use high resolution also see this ?

 

Even more so.

Share this post


Link to post
Share on other sites
  • 0
40 minutes ago, Majorjim said:

Even more so.

Maybe thats why mine is so bad all of a sudden... The install its happening on is a lighhtly modified install, with higher graphics settings than I usually play with, as I am using this install for parts mod development.

Share this post


Link to post
Share on other sites
  • 0
17 hours ago, Majorjim said:

I'm amazed more haven't noticed it. It's so obvious and off putting.. It is slightly less visible at lower shadow settings but low settings look crappy and make almost zero difference to the performance.

I have this too, but did not report anything as I thought its a bug of scatterer. But now that I went to check it is definitely present in a completely stock install too.

Thanks for bringing this up, it is quite ugly and I hope there is a fix.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Here we are chaps, the state of KSP shadows in unity 5 raw in tooth and claw. This video is running in realtime, not sped up.

 

 

This really should be looked into.

Edited by Majorjim
  • Like 1

Share this post


Link to post
Share on other sites
  • 0
5 minutes ago, Majorjim said:

Here we are chaps, the state of KSP shadows in unity 5 raw in tooth and claw. This video is running in realtime, not sped up.

This really should be looked into.

That's because the florescent bulb starter in Kerbol is burnt out... Just replace the starter and ballast - flickering gone! :D

In all seriousness, I thought it was just me...

  • Like 3

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, Majorjim said:

Here we are chaps, the state of KSP shadows in unity 5 raw in tooth and claw. This video is running in realtime, not sped up.

Yup... This is EXACTLY what I'm seeing... Though mine is slower... I have 25-33FPS... :P

Share this post


Link to post
Share on other sites
  • 0

Wow, just noticed it today when I was posing Bill for a photo.  Yikes now I see it everywhere dang :( .

Edited by kBob

Share this post


Link to post
Share on other sites
  • 0
16 hours ago, Majorjim said:

Here we are chaps, the state of KSP shadows in unity 5 raw in tooth and claw. This video is running in realtime, not sped up.

That's mild compared to what I get...

https://vid.me/tzoW (video I posted in the support thread linked above)

It reminds me of what hunting cuttlefish do: https://youtu.be/YcpzubpIhtI

...so maybe it's just the Kraken's latest attempt to lure us into being its prey? :lol:

Share this post


Link to post
Share on other sites
  • 0

On some of my latest craft this ugly shadow flickering is very severe, up to the point where it spoils the whole experience.

Do you guys have an idea what graphic settings I can try to make this a bit better?  I play completely stock at the moment, and I feel the graphics were somewhat smoother for me before 1.1.over all.

Thanks

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
14 hours ago, Dafni said:

On some of my latest craft this ugly shadow flickering is very severe, up to the point where it spoils the whole experience.

Do you guys have an idea what graphic settings I can try to make this a bit better?  I play completely stock at the moment, and I feel the graphics were somewhat smoother for me before 1.1.over all.

Thanks

Setting the shadows lower reduces it somewhat but it never goes away. 

 I have heard no word on this from Squad so I may submit a bug report. I have never seen a fully released game with shadows this bugged..

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
On 21 June 2016 at 5:23 AM, Berlin said:

For those of you that don't know the issue Majorjim is talking about,  good.  Keep it that way.  Ignorance is bliss.  Once it's seen it cannot be unseen lol

And now I have seen it. :( I play on very low settings, as the laptop I use can barely play the game. This does somewhat seem to reduce the effect, but I'm going to be noticing it for a while now.

Share this post


Link to post
Share on other sites
  • 0
Guest

Has anyone tried to change the render quality level to see what effect that has?

Rendering

  • Render Quality Level
    • Sets the quality of Unity's rendering. See Unity documentation for more details.
    • Available Settings: Fastest, Fast, Simple, Good, Beautiful, Fantastic
    • Default: Fantastic

 

Share this post


Link to post
Share on other sites
  • 0
59 minutes ago, anarkhon said:

its not a bug,maybe the staff need to alter the shadow system.
same bug in skyrim:

so is it a bug or not? :D

29 minutes ago, Otis said:

Has anyone tried to change the render quality level to see what effect that has?

Rendering

  • Render Quality Level
    • Sets the quality of Unity's rendering. See Unity documentation for more details.
    • Available Settings: Fastest, Fast, Simple, Good, Beautiful, Fantastic
    • Default: Fantastic

i have it running on fantastic -> same problem; not tried to lower it.

Share this post


Link to post
Share on other sites
  • 0
41 minutes ago, Otis said:

Has anyone tried to change the render quality level to see what effect that has?

Rendering

  • Render Quality Level
    • Sets the quality of Unity's rendering. See Unity documentation for more details.
    • Available Settings: Fastest, Fast, Simple, Good, Beautiful, Fantastic
    • Default: Fantastic

 

Yes. In point of fact I mentioned that earlier in this thread. Lower shadow details lessen the issue but it still remains across all shadow settings. Everyone has this issue. 

Share this post


Link to post
Share on other sites
  • 0

I play other games that use Unity and have upgraded to 5. I notice the same issue with those games as well, with Banished being nearly as bad at times as KSP. I am under the belief that it is a Unity issue and may require at least some patch from them before this issue goes away.

By the way, Banished is back in BETA mode... getting ready for a new release... :cool:

Edited by adsii1970
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now