Jump to content

[1.4.X] SM Marine, Version 0.9.9.3 KSP xx PSA important


Recommended Posts

1 hour ago, SpannerMonkey(smce) said:

The mod also now contains EN_US localization this is shared across the whole SM group of mods and only one copy of SM_Industries is ever required .  Find the link for the SM_Industries Dictionary below the 1.3 download link below.     YOU DO NEED IT. Failure to not install the dictionary will result in part titles and part description being rendered as #autoloc xxxx , it's not a bug.    Due to the localization this mod is no longer backwardly compatible 

 

17 minutes ago, Cdodders said:

Part descriptions and names such as on structural parts are slightly off...

Have you installed according to the rather lengthy release post?

https://github.com/SpannerMonkey/SMIndustries/files/1119854/SM_Industries.zip

Link to comment
Share on other sites

47 minutes ago, Cdodders said:

A little bug report on the new update (Awesome btw)

 

Part descriptions and names such as on structural parts are slightly off...

WZrC31P.jpg

 

Did you download and install the SM Industries file as well? It includes all the localization definitions which should fix that.

 

Edit: Spanner beat me to it. :)

Edited by XOC2008
Link to comment
Share on other sites

Where are the prebuilt boats included with this mod located. I would love to use them and I could not find them when I downloaded the mod. Amazing mod though thanks so much for updating it and adding new parts to make the mod even better.

Link to comment
Share on other sites

1 hour ago, jrf said:

Where are the prebuilt boats included with this mod located. I would love to use them and I could not find them when I downloaded the mod. Amazing mod though thanks so much for updating it and adding new parts to make the mod even better.

There are none. Yet. Though if @SpannerMonkey(smce) wants, I'll throw a few together and put them up on KerbalX in a few days. Most of the pictures you've seen are snaps that us testers have taken, and some during and after Spanner's own testing.

Link to comment
Share on other sites

And if there's a part that seems to be missing tweakscale you either have something installed incorrectly or it was accidentally missed and with 200 some odd parts it's easy to miss the odd part here or there. But if you go into the MM patch you can always add in the missing part.

Link to comment
Share on other sites

13 hours ago, SpannerMonkey(smce) said:

it's already done via a rather large MM patch

 

12 hours ago, XOC2008 said:

And if there's a part that seems to be missing tweakscale you either have something installed incorrectly or it was accidentally missed and with 200 some odd parts it's easy to miss the odd part here or there. But if you go into the MM patch you can always add in the missing part.

Ah right, I was wanting to play around with the CK and T45 parts, didnt notice any rescale options, Ill have another look

Link to comment
Share on other sites

2 hours ago, Cdodders said:

 

Ah right, I was wanting to play around with the CK and T45 parts, didnt notice any rescale options, Ill have another look

They all have tweakscale here , and the release is exactly the same as the copy I'm currently running. I can also confirm that there are a total of 17 tweakscale modules applied to the Type 45 parts plus those for ancillary items such as Radar and antenna

Spoiler

1e88bVf.png

IERrs2T.png

Edited by SpannerMonkey(smce)
Link to comment
Share on other sites

52 minutes ago, Cdodders said:

Ok noticed the tweakscale bar, is it possible to scale the weapons themselves? Turrets and missiles etc?

There's no tweakscale patch for the weapons themselves. I tweak my own weapons, but I tend to like my stuff real scale vs Kerbal scale, so I add my own modules when there are none.

Link to comment
Share on other sites

30 minutes ago, XOC2008 said:

There's no tweakscale patch for the weapons themselves. I tweak my own weapons, but I tend to like my stuff real scale vs Kerbal scale, so I add my own modules when there are none.

Ah right, I remember seeing something, I think on the BDAC thread, about weapon tweakscale. Cant remember or find what though

Link to comment
Share on other sites

Just now, Cdodders said:

Ah right, I remember seeing something, I think on the BDAC thread, about weapon tweakscale. Cant remember or find what though

The problem with tweakscaling, for example, a missile, is that you change the weight when you make it larger or smaller. So if you double the size of a missile, you've doubled its weight, but not the thrust, nor have you adjusted the aerodynamics to compensate for the size.

I do a lot of scale work in my game for real scale weapons, very little of it has to do with tweakscale, and a lot has to do with adjusting model scale through the configs, and adjusting aero, weight etc. So just be warned that tweakscale will HEAVILY affect weapon performance.

Link to comment
Share on other sites

Evening all just a little warning ahead of time that due to intensive and extensive behind the scenes activity, the goalposts are moving a little too quickly, and there is a danger that things if left will get badly out of sync.

So sometime in the next few days there will very likely need to be another update, not a big one ,but an important one for a lot of the very new very on the edge of whats possible things. Torpedoes etc and such like . and a new thing or two.

AaqgPhC.gif

Link to comment
Share on other sites

2 minutes ago, colfighter said:

How come the name of every part installed as "autolock...."

On 03/07/2017 at 6:05 PM, SpannerMonkey(smce) said:

The mod also now contains EN_US localization this is shared across the whole SM group of mods and only one copy of SM_Industries is ever required .  Find the link for the SM_Industries Dictionary below the 1.3 download link below.     YOU DO NEED IT. Failure to not install the dictionary will result in part titles and part description being rendered as #autoloc xxxx , it's not a bug.    Due to the localization this mod is no longer backwardly compatible 

Link to comment
Share on other sites

May be stupid question, but is anyone else having issues placing missile(s) inside of the VLS hulls for the sub? I cannot seem to get anything to attach to the actual VLS node, am I just missing something? 

EDIT: Still literally cannot get any missile to actually click to the node I want it to, pretty much have to give up on VLS subs until I figure out what I'm doing wrong.

EDIT 2: ...probably should have considered using ALT to place...

Edited by Swordmaster
Solution found
Link to comment
Share on other sites

6 hours ago, Swordmaster said:

having issues placing missile(s)

HI. due to the confined nature of the vls any missile that has surface attach still enabled with show a distinct tendency to stick anywhere except it's proper location.   To successfully attach a missile surface attach must be disabled, I think it fairly certain that most users of SMM et al use a mod that provides advanced editor functions to do this , I favor Editor Extensions Redux but there are others. 

I advise all users to save loaded VLS and missile launchers as  sub assemblies, even I'll agree that the filling of missile bays in particular is no fun and borders on the tedious with a good dollop of frustration thrown in.

Link to comment
Share on other sites

I'm playing the 1.2.2 version. This part of SternGearType1.cfg and ZDriveNozzle.cfg kinda makes it impossible to play:
MODULE
{
    name = ModuleGenerator
    isAlwaysActive = true
    OUTPUT_RESOURCE
    {
       name = LiquidFuel
       rate = 45.5
       DrawGauge = True
    }    
    OUTPUT_RESOURCE
    {
       name = ElectricCharge
       rate = 50.5
       DrawGauge = True
    }    
}

I removed it myself, but how the hell did that find its way into the final release? It's clearly a development thing!

Edited by AtomicBlastPony
Link to comment
Share on other sites

6 hours ago, AtomicBlastPony said:

I'm playing the 1.2.2 version. This part of SternGearType1.cfg and ZDriveNozzle.cfg kinda makes it impossible to play:
MODULE
{
    name = ModuleGenerator
    isAlwaysActive = true
    OUTPUT_RESOURCE
    {
       name = LiquidFuel
       rate = 45.5
       DrawGauge = True
    }    
    OUTPUT_RESOURCE
    {
       name = ElectricCharge
       rate = 50.5
       DrawGauge = True
    }    
}

I removed it myself, but how the hell did that find its way into the final release? It's clearly a development thing!

Whats the problem you have with that, doesn't do any harm, not pretty , but not really an issue

Also not present in 1.3 versions

Also worth mentioning, is that in this mod there are 247  individual part cfgs (310 .mu files which is more than the amount of parts supplied in base game) , and some of those cfgs' have 8 cfg's within in them, combine that with another 800 cfg's and you have an idea of the amount of work it takes to get the whole SMI lot released, Given that a professional company like Squad is still chasing bugs in the core game after all these, years, i don't think one cooky module out of several thousand in the mod  could be considered in anyway game breaking.

Edited by SpannerMonkey(smce)
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...