Jump to content

[1.4.X] SM Marine, Version 0.9.9.3 KSP xx PSA important


Recommended Posts

3 hours ago, GoldenKraken said:

I Have a bug I'm able to open all the VLS Launchers in the SPH  but i cant when its been launched any help?

You have to select the missile loaded in the VLS tube in the weapon selector in BDA's weapon manager.

Link to post
Share on other sites
  • 2 weeks later...
On 9/3/2018 at 7:15 AM, Pistache said:

Hi. So, uhh, I got this mod and I notice that the only hulls I have are the zed hulls. I'm not sure of what to do.

 

Hi all the SM Marine partts can be found in the SM Marine category which will be created if all parts of the mod are installed correctly. If you do not have an SM Marine category please review your install and if all appears correct,  supply a zipped copy of your KSP.log  which will allow me to diagnose your issue.   SM Marine parts are configured so that they do not clutter stock categories,  If the unique category is not present the parts will be difficult if not impossible to find.

Link to post
Share on other sites
  • 1 month later...
On 10/31/2018 at 12:23 AM, Catatau_27 said:

All Bridges are broken on Ksp 1.5.1, maybe a Update can be fixed, By the way, probably all SM mods need a update to work on 1.5.1, i will wait =)

Hi, can you give me a few details on the issue. I have them loaded up right now, but don't immediately see a problem.

Link to post
Share on other sites
3 hours ago, TheKurgan said:

Hi, can you give me a few details on the issue. I have them loaded up right now, but don't immediately see a problem.

Well, in part I have managed to solve half, but I believe that Tweakcable is breaking the operation of some mods as happened with me with ASET, my last mods added were Tweakcable, Blue_Hawk_Industries and ZZZ_Flags. 

I am not using the FAR for lack of updating, my problem starts when in the tireless quest for mods for aircraft carriers something stops working, the only mod that is working for aircraft carriers is ACA and anyway I use version 1.5.1 of the game I use the 1.4.x version of the mod and it is working fine but it does not come with any mounted aircraft, so I am forced to use other mods to compensate for it, until then I failed miserably. Even if I look for an aircraft carrier in Kerbal x there are mods I do not have, and these mods are mostly outdated and this breaks my whole game. DDD: I really need help, I'm going to remove all the mods that are apparently causing the problem and see if it revolves.

Link to post
Share on other sites
  • 2 weeks later...
5 hours ago, MD5Ray01 said:

So, I found myself wondering if it would be possible to make a nose variant of the Typhoon hull that doesn't have the torpedo tubes (or if there was one, where was it)?

There is not, and doubtful one will be made any time soon. Spanner has been busy with real life, and he has previously stated most of his mods won't be touched/updated until well after the bugs have been worked out of KSP 1.5/6/7/etc.

Link to post
Share on other sites
8 hours ago, XOC2008 said:

There is not, and doubtful one will be made any time soon. Spanner has been busy with real life, and he has previously stated most of his mods won't be touched/updated until well after the bugs have been worked out of KSP 1.5/6/7/etc.

That's understandable.  The thought had crossed my noggin last night when I tried using the Typhoon hull parts to make an explorer sub.

Link to post
Share on other sites
  • 1 month later...

hey, how do i get the IR cranes is SM Marine to work

Link to post
Share on other sites
5 hours ago, OPBlue said:

hey, how do i get the IR cranes is SM Marine to work

Hi, I think most are still listed as broken,  due to issues, i've been out of it for a bit, just getting back up to speed .  As far as i'm aware there's no current suitable IR for them to work,  they will not work with newer IR version.  If they can be repaired  I'll get to it in time ,  but with over 300 parts in SMM alone and hundreds in the other mods, all of which need checking and/or  updating , it's going to be a while.

Link to post
Share on other sites

understood, modding games isn't easy. hope you get the cranes working again.

 

Link to post
Share on other sites

I installed fresh KSP 1.5.* with some light mods to test SM Marine, as it wasn't working with my heavily modded stuff. I loaded Type.45 SS Basic with two JclassGearType1 and two LDRudder to test. I tested with FAR Lighthill installed and not installed

When I use SM Marine with FAR, the boat was very unstable (very being an understatement). The propulsion is fine, but she wobbles all over the place, spins out, and capsises.

When I DON'T use FAR, the boat doesn't even want to go forward. At full throttle, it produdes 2000kN, but doesn't go forward. So I can't test how she does in speed.

Since SM is now back at the game, will this be fixed soon?

Link to post
Share on other sites
7 hours ago, byong614 said:

I installed fresh KSP 1.5.* with some light mods to test SM Marine

Hi  firstly  I have no  real 1.5 comparisons to draw as apart from a quick test install ( which i hated) i  did not use any of the KSP 1.5.screwed versions.   I think they're terrible versions of the game and as such cannot realistically provide  any solution encountered using my mods in those versions.  KSP 1.6 is my current development version and depending on what happens in other projects I'll be forced to move to KSP 1.6.1 very shortly. Due to the time required too update the mod suite I unable to provide retrospective fixes or solutions (unless of course it was a known issue that had been dealt with)

j Class stern gear  requires the use of the Jclass steam turbine and the fitting of the Jclass tanks etc , the drives are set up to use the exhaust from the turbine as fuel. without the turbines they will be ineffective .

I don't use FAR. FAR changes the stock buoyancy  which  works just fine as it is , Far scraps  the stock drag cube system and installs it's own which affects all parts of the mod . I am not prepared to retune all the parts to work within the changed non stock  buoyancy and drag system, SM Marine has never been claimed to be  FAR compatible

I've not noticed the problems  you describe  in 1.6 though I have not built a steam powered J as yet in 1.6 , I will do so and report my results

EDIT

sometime later....
Tested all those parts you mention and find them all working well ,  built and checked out a Type 45  and still find it to be a well behaved craft.   As mentioned J Class drives need to be supplied with steam from the steam turbines which is stored in the J class fuel tanks .
All of these parts can easily be fitted within a type 45.     Two JClass drives are only just enough for the type 45, 3 is much better. If you dont want to mess with all that,  you can use the  standard  stern gear type 1 which uses LF EC and IA  all of which are dealt with within the storage modules contained within the Type 45 hull.  Depending on drives and ancillaries fitted  the Type  45 is expected to achieve between  24 and 32 ish m/s . All drives are velocity curve controlled and more drives don't necessarily mean it'll go faster, only that it'll reach it's top speed faster  and regain speed quicker after maneuvering.

Images from testing
 

Spoiler

B1e3HEC.png

Below Type 45 engine space with J class tanks clipped into the hull below engine space floor and Steam turbines

Hmc9H42.png

Below J class hull with with drives and 4 turbines

NXDTsFd.png

NOTE TO ALL USERS OF SM MARINE
There are issues in 1.6 with certain parts containing  multiple animations . These issues display as broken information in the PAW (right click menu) and the animations being inoperative . The fix is fairly simple but time consuming to do   and will be dealt with in a small update shortly.  This and the broken IR aside  all parts appear to be working  well and fully functional in 1.6.x

Edited by SpannerMonkey(smce)
Link to post
Share on other sites

hey, is there a way you could add a spawnpoint or 2 with infinite length and height, i want to be able to spawn a aircraft carrier but its too big. 

Link to post
Share on other sites
13 hours ago, SpannerMonkey(smce) said:

Hi  firstly  I have no  real 1.5 comparisons to draw as apart from a quick test install ( which i hated) i  did not use any of the KSP 1.5.screwed versions.   I think they're terrible versions of the game and as such cannot realistically provide  any solution encountered using my mods in those versions.  KSP 1.6 is my current development version and depending on what happens in other projects I'll be forced to move to KSP 1.6.1 very shortly. Due to the time required too update the mod suite I unable to provide retrospective fixes or solutions (unless of course it was a known issue that had been dealt with)

j Class stern gear  requires the use of the Jclass steam turbine and the fitting of the Jclass tanks etc , the drives are set up to use the exhaust from the turbine as fuel. without the turbines they will be ineffective .

I don't use FAR. FAR changes the stock buoyancy  which  works just fine as it is , Far scraps  the stock drag cube system and installs it's own which affects all parts of the mod . I am not prepared to retune all the parts to work within the changed non stock  buoyancy and drag system, SM Marine has never been claimed to be  FAR compatible

I've not noticed the problems  you describe  in 1.6 though I have not built a steam powered J as yet in 1.6 , I will do so and report my results

EDIT

sometime later....
Tested all those parts you mention and find them all working well ,  built and checked out a Type 45  and still find it to be a well behaved craft.   As mentioned J Class drives need to be supplied with steam from the steam turbines which is stored in the J class fuel tanks .
All of these parts can easily be fitted within a type 45.     Two JClass drives are only just enough for the type 45, 3 is much better. If you dont want to mess with all that,  you can use the  standard  stern gear type 1 which uses LF EC and IA  all of which are dealt with within the storage modules contained within the Type 45 hull.  Depending on drives and ancillaries fitted  the Type  45 is expected to achieve between  24 and 32 ish m/s . All drives are velocity curve controlled and more drives don't necessarily mean it'll go faster, only that it'll reach it's top speed faster  and regain speed quicker after maneuvering.

Images from testing
 

  Hide contents

B1e3HEC.png

Below Type 45 engine space with J class tanks clipped into the hull below engine space floor and Steam turbines

Hmc9H42.png

Below J class hull with with drives and 4 turbines

NXDTsFd.png

NOTE TO ALL USERS OF SM MARINE
There are issues in 1.6 with certain parts containing  multiple animations . These issues display as broken information in the PAW (right click menu) and the animations being inoperative . The fix is fairly simple but time consuming to do   and will be dealt with in a small update shortly.  This and the broken IR aside  all parts appear to be working  well and fully functional in 1.6.x

I have tested with 3 J Class drives and two steam turbines. It needed a minute to go over 1m/s but it worked in the end. For the time being, I won't use FAR (Not working on any aircraft at this moment anyway), but it would be great if it works with it in future.

For the time being, I'll tweak the cfg to double the thrust on the Jclass gears and raise the issue to the current FAR developers and see if he has a solution on his end. Thanks a lot for testing it out for me @SpannerMonkey(smce)!

EDIT: May I suggest adding ballast to the destroyer? I don't like seeing the gears above the waterline. Thanks!

EDIT 2: I've been meaning to ask about this for a while. When BD Armory weapons manager use guard mode, it doesn't seem to launch Aster missiles from T45 VLS to intercept incoming missiles. The radar tracks the missile perfectly and if I fire it manually, it intercepts the missile. What am I doing wrong, or was this issue raised earlier?

 

PS: is SMI Small Arms a dead project?

Edited by byong614
Link to post
Share on other sites
5 hours ago, OPBlue said:

hey, is there a way you could add a spawnpoint or 2 with infinite length and height, i want to be able to spawn a aircraft carrier but its too big. 

@SpannerMonkey(smce) - with recent updates to Kerbal Konstructs, spawn point cfgs use the "height" and "width" fields to limit the size of the vehicle that can be spawned there, just as in the stock launch pads.

Link to post
Share on other sites
10 hours ago, byong614 said:

EDIT: May I suggest adding ballast to the destroyer? I don't like seeing the gears above the waterline. Thanks!

Most of the hulls in SMM have a built in ballast water storage, this is provided so that hulls can be trimmed to suit once completed,  most if not all SMM bridge units have a trim pump included,  simply activate trim down to add ballast, and trim up to remove ballast.  The mass is added this way because everyone builds things a different way , I build heavy so  on completion most ships sit pretty close to ideal,  a simply built ship, just enough parts for combat will by design be a lot lighter than my couple of hundred parts builds
 

10 hours ago, byong614 said:

EDIT 2: I've been meaning to ask about this for a while. When BD Armory weapons manager use guard mode, it doesn't seem to launch Aster missiles from T45 VLS to intercept incoming missiles. The radar tracks the missile perfectly and if I fire it manually, it intercepts the missile. What am I doing wrong, or was this issue raised earlier?

BDA bug unfortunately  affecting most VLS units

15 hours ago, OPBlue said:

hey, is there a way you could add a spawnpoint or 2 with infinite length and height, i want to be able to spawn a aircraft carrier but its too big. 

Possibly :)

 

Link to post
Share on other sites
  • 5 weeks later...

Recently I've been making a combat submarine which I've dubbed the EUAV Spearfish (Experimental Underwater Assault Vehicle). But i wanted to see if you could make something to where i can jump the craft out of the water and land back in without breaking the sub. also cheats don't work sometimes and there's a large lag spike when i land. I understand if you don't have the time to do so but it would be nice to make it breach the water and land with no lag spike.

 

Edited by OPBlue
Link to post
Share on other sites
47 minutes ago, OPBlue said:

But i wanted to see if you could make something to where i can jump the craft out of the water and land back in without breaking the sub.

Hi. it's obviously going to depend on the size of the sub, and how much power it has .  I've had versions of the Dallas and Typhoon clear of the water without too much trouble and no lag spike that I've ever noticed and no explosions on landing (I do use KJR) ,  not that its something i make a habit of, mainly due to the fact there's little value to be gained, especially with a large sub it takes a while for things to settle down afterward , during which time the sub is horribly vulnerable to the very efficient surface ships it usually fights.  Our little dev sub can jump around like a flying fish,  but again it's just for lols, it does this mainly by having a surplus of power that allows the engine to overcome the many tonnes of ballast, and by being quite small.  A video of the dev sub  using TheKurgans patent water propulsion sytem below. 

As for making something that can do this at will as part of the mod, I don't think it'd be too wise, I spend a lot of time making sure these things don't or can't fly, and you can take it from me and the team that some of them really want to. I've no real wish to have the thread full of "my sub/ship is in space" bug reports like the bad old days of ksp1.1x etc.

 

Link to post
Share on other sites

Its okay. the sub i made is 1.25m using the high drag rudder as wings and the minisub rudder as a tail. but it acts like a plane in water which makes it really good and thats why i wanted it to be able to jump. i wanted to make it able to jump out of the water and fly around then dive back underwater. but i did have that bug when i scaled up the high drag rudder so i could make a MK2 version. even if i cant nosedive into the water i could still land regularly. sorry if what i wrote is out of order im not that good at grammar and my mind tends to wander at times.

Link to post
Share on other sites
1 hour ago, MD5Ray01 said:

I can land aircraft on the ships in this mod

Hi i haven't put any aircraft carriers in SM Marine, non of the craft in the mod are large or heavy enough to take aircraft landings (IMO) , and I've never tested any of them in such a role. The bouncing is because the hulls have been pushed into the water beyond the point of maximum buoyancy, if the load continues to be applied a viscous cycle starts that will not stop until the  excess load is removed . Aircraft carriers need some special tweaks and colossal mass, so that suddenly adding tonnes of weight doesn't result in the bouncing cycle.

Link to post
Share on other sites
3 minutes ago, SpannerMonkey(smce) said:

Hi i haven't put any aircraft carriers in SM Marine, non of the craft in the mod are large or heavy enough to take aircraft landings (IMO) , and I've never tested any of them in such a role. The bouncing is because the hulls have been pushed into the water beyond the point of maximum buoyancy, if the load continues to be applied a viscous cycle starts that will not stop until the  excess load is removed . Aircraft carriers need some special tweaks and colossal mass, so that suddenly adding tonnes of weight doesn't result in the bouncing cycle.

It was a helicopter off of the Cruiser Kit setup (I probably should have clarified that in the beginning.  My bad).

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...