IgorZ

[1.7.1] Kerbal Attachment System (KAS) v1.4 - NOT COMPATIBLE WITH KSP 1.7.0

Recommended Posts

The better solution is to have the objects creator list both it's compact and expanded volumes as part of the objects config. Then only when this data is absent attempt to use an algorithm to calculate a substitute. Otherwise, this will always be an issue no matter the formula used. 

Share this post


Link to post
Share on other sites
4 minutes ago, Redacted said:

The better solution is to have the objects creator list both it's compact and expanded volumes as part of the objects config. Then only when this data is absent attempt to use an algorithm to calculate a substitute. Otherwise, this will always be an issue no matter the formula used. 

It's already implemented. "ModuleKISItem" module allows setting the part volume. However, for some reason, modders around the globe don't use this module to properly define their parts volume :( 

Share this post


Link to post
Share on other sites
Posted (edited)
6 minutes ago, IgorZ said:

It's already implemented. "ModuleKISItem" module allows setting the part volume. However, for some reason, modders around the globe don't use this module to properly define their parts volume :( 

That's sad... While I've been out of the modding scene for a few years, i can totally understand your frustration.

In the short term I'll ask the mods author to support ModuleKISItem.

 

Side note: Tried making a screenshot of the volume notice only to discover that the text is an overlay and doesn't show on the screenshot. Also the compact volume is the same as the expanded volume within the VAB. (at least for this one item)

 

-Redacted

Edited by Redacted

Share this post


Link to post
Share on other sites

@IgorZ

Looked over the Wiki for the ModuleKISItem and was wondering if you could please provide an example for how this could be correctly applied to the following NFS snippet?

Keep in mind that it's been ages since i last modded. Even had to reinstall my editors to open the .cfg !

// Near Future Solar 0.8.0
// Solar Panel - SpaceX ITS
PART
{
	// --- general parameters ---
	name = solarpanel-blanket-4
	module = Part
	author = ChrisAdderley

	// --- asset parameters ---
	MODEL
	{
		model = NearFutureSolar/Parts/SolarPanels/solarpanel-blanket/solarpanel-blanket-4
		scale = 1.0,1.0,1.0
	}
	rescaleFactor = 1

	TechRequired = specializedElectrics
	entryCost = 17600

	// --- node definitions ---
	// definition format is Position X, Position Y, Position Z, Up X, Up Y, Up Z
	node_attach = 0.0, 0.0, 0.0, 1.0, 0.0, 0.0

	// --- editor parameters ---
	cost = 18223


	category = Electrical
	subcategory = 0
	title = #LOC_NFSolar_solarpanel-blanket-4_title
	manufacturer = #LOC_NFSolar_manufacturer_okeb_title
	description = #LOC_NFSolar_solarpanel-blanket-4_description
	// attachment rules: stack, srfAttach, allowStack, allowSrfAttach, allowCollision
	attachRules = 0,1,0,0,1

	// --- standard part parameters ---
	mass = 0.7625


	dragModelType = default
	maximum_drag = 0.2
	minimum_drag = 0.2
	angularDrag = 1
	crashTolerance = 7
	maxTemp = 1200
	thermalMassModifier = 2.0
	emissiveConstant = 0.95
	heatConductivity = 0.04 // 1/3 the default
	bulkheadProfiles = srf

	tags = #LOC_NFSolar_solarpanel-blanket-4_tags

	MODULE
	{
		name = ModuleDeployableSolarPanel
		animationName = PanelsExtend
		sunTracking = true
		raycastTransformName = Suncatcher
		pivotName = pivot
		isBreakable = true
		resourceName = ElectricCharge
		chargeRate = 75
		extendActionName = #autoLOC_6001805 //#autoLOC_6001805 = Extend <<1>>
		retractActionName = #autoLOC_6001806 //#autoLOC_6001806 = Retract <<1>>
		extendpanelsActionName = #autoLOC_6001807 //#autoLOC_6001807 = Toggle <<1>>
			
	}
		
}

 

Share this post


Link to post
Share on other sites
7 hours ago, Redacted said:

That's sad... While I've been out of the modding scene for a few years, i can totally understand your frustration.

In the short term I'll ask the mods author to support ModuleKISItem.

Side note: Tried making a screenshot of the volume notice only to discover that the text is an overlay and doesn't show on the screenshot. Also the compact volume is the same as the expanded volume within the VAB. (at least for this one item)

-Redacted

Before you do - make sure it's actually needed.  In most cases, the KIS code does a good job of calculating a reasonable volume.  I know of a few mods that are designed to work with KIS, and implement ModuleKISItem on several parts.

In this case, since the part changes volume quite dramatically when unfolded, and ModuleKISItem is only a static value (can't do both deployed and not-deployed, at least as far as I can see...) the KIS code actually does a *better* job than specifying it manually.  The only issue is that it's read in the wrong state when pulled directly from the parts list in the VAB - but there's an easy if manual fix for that, and I know other parts which actively make use of being able to change their setup in the VAB for KIS.  (Notably MKS and Pathfinder - which allow you to reconfigure parts in the VAB for free, then stow them in KIS containers.)

Share this post


Link to post
Share on other sites
Posted (edited)
14 hours ago, DStaal said:

Before you do - make sure it's actually needed.  In most cases, the KIS code does a good job of calculating a reasonable volume.  I know of a few mods that are designed to work with KIS, and implement ModuleKISItem on several parts.

In this case, since the part changes volume quite dramatically when unfolded, and ModuleKISItem is only a static value (can't do both deployed and not-deployed, at least as far as I can see...) the KIS code actually does a *better* job than specifying it manually.  The only issue is that it's read in the wrong state when pulled directly from the parts list in the VAB - but there's an easy if manual fix for that, and I know other parts which actively make use of being able to change their setup in the VAB for KIS.  (Notably MKS and Pathfinder - which allow you to reconfigure parts in the VAB for free, then stow them in KIS containers.)

The parts volume is wrong, folded or unfolded, confirmed this earlier today. The value is so large I'd need a whole nother ship just to deliver a single PV panel !

Edited by Redacted

Share this post


Link to post
Share on other sites
Posted (edited)
16 hours ago, Redacted said:

@IgorZ

Looked over the Wiki for the ModuleKISItem and was wondering if you could please provide an example for how this could be correctly applied to the following NFS snippet?

Create your own patch file somewhere under GameData. I use GameData/ZZZ_PersonalPatches. Create a text file with the .cfg extension and insert the following. You don't want to just edit the NFS config files as any changes you make would be overwritten on an update. I checked a couple solar panels and saw several that were out of whack. The OKEB-500 was around 3 million liters. I think volumeOverride is the attribute you need to set from ModuleKISItem:

@PART[solarpanel-blanket-4]:HAS[!MODULE[ModuleKISItem]]:FINAL	//OKEB-75
{
	MODULE
	{
		name = ModuleKISItem
		volumeOverride = 200	// Or whatever makes sense
   	}
}
Edited by Tonka Crash
Improved syntax of patch

Share this post


Link to post
Share on other sites
Posted (edited)

Ahh so i get the gist, its similar the Mod work i did several years back. Except in this case we are defining blueprints, categories, strings and variables used by the loaded scripts / functions. Should be easy enough to make a custom file to maintain the original mods integrity now that the format is clear.

Edited by Redacted

Share this post


Link to post
Share on other sites

Is this mod working in KSP 1.6.1?  I see that spacedock and ckan both show this mod as outdated.  I have however heard that many outdated mods still work you just have to manually install them.  Thanks for the help.

 

Share this post


Link to post
Share on other sites
2 hours ago, William516 said:

Is this mod working in KSP 1.6.1?  I see that spacedock and ckan both show this mod as outdated.  I have however heard that many outdated mods still work you just have to manually install them.  Thanks for the help.

 

Yes it works, and most mods compiled for 1.4 or later work in the latest KSP. In CKAN go up to Settings->Compatible KSP Versions and set the check boxes for 1.4, 1.5, and 1.6 and it will allow mods from these versions to be installed  without needing to do it manually.

Share this post


Link to post
Share on other sites
Posted (edited)
6 hours ago, Tonka Crash said:

Yes it works, and most mods compiled for 1.4 or later work in the latest KSP. In CKAN go up to Settings->Compatible KSP Versions and set the check boxes for 1.4, 1.5, and 1.6 and it will allow mods from these versions to be installed  without needing to do it manually.

Careful with that. Part-based mods with no dependencies will work so long as they aren't using stock textures, or version specific coding to work. Function-based mods (KJR, IR, Cact-eye) may not work if not compiled for 1.6.X, as they might try and call a function that has changed or has been removed all together.

More of a PSA, than being directed at you, @Tonka Crash.

 

Edit, and if you do list 1.4-1.6, ensure you are paying attention to versions. I've seen multiple versions of the same mods. Just be attentive to what you are downloading.

Edited by sharpspoonful

Share this post


Link to post
Share on other sites
Posted (edited)

@William516@sharpspoonful,

In case of KAS you may trust @Tonka Crash, who is an advanced user of this mod. And if it's not enough, I can assure you myself that KAS v1.1 works fine with KSP 1.6.1, even though it complains about incompatible version. Btw, it was stated earlier in this forum thread ;) 

Edited by IgorZ

Share this post


Link to post
Share on other sites

@IgorZ, oh I know. I just would hate to see someone break their game using that to DL other old and decrepit mods. 

Share this post


Link to post
Share on other sites
On 1/13/2019 at 6:18 PM, infinite_monkey said:

I'm not sure what exactly you are trying to achieve. The W-50 Winch is not compatible with the CH-1, only with the JS-1, which seems to work in your video. As for KIS: are you able to attach other parts using H? If not, you should ask in the KIS thread.

I've encountered same trouble. What is compatible with CH-1 hook? It says cable in description, but only source of cables are winches and you say they aren't compatible. Can't find anything I may attach to that hook.

Share this post


Link to post
Share on other sites
8 minutes ago, Mystique said:

I've encountered same trouble. What is compatible with CH-1 hook? It says cable in description, but only source of cables are winches and you say they aren't compatible. Can't find anything I may attach to that hook.

CH-1 is compatible with PCB-1.

Share this post


Link to post
Share on other sites
9 minutes ago, Mystique said:

I've encountered same trouble. What is compatible with CH-1 hook? It says cable in description, but only source of cables are winches and you say they aren't compatible. Can't find anything I may attach to that hook.

The CH-1 Cable Hook is used with the PCB-1 Portable Cable Brace. All other KAS 1.0+ parts use the JS-1 socket. You can see it under the Yellow hose for the RTS-1.

cwqR7In.jpg

 

 

Share this post


Link to post
Share on other sites
31 minutes ago, IgorZ said:

CH-1 is compatible with PCB-1.

 

29 minutes ago, Tonka Crash said:

The CH-1 Cable Hook is used with the PCB-1 Portable Cable Brace. All other KAS 1.0+ parts use the JS-1 socket. You can see it under the Yellow hose for the RTS-1.

 

Strange how I managed to miss that part, thanks :)

As I understood, this cable connection is viable for towing stuff? And the only way to connect stuff for better structural integrity (like legacy struts) is using those fancy short joints+ports?

Share this post


Link to post
Share on other sites

I've never tried using a cable connection for towing. Its main purpose is to act as a wire brace under tension. One of the short linkages is a dedicated tow bar.

Share this post


Link to post
Share on other sites

 

Click "Grab connector" and "Y key" but I can not grab the winch rope. Can operate the winch with "Show GUI". Other attach is also possible. I want to grab a winch.


 


 

Share this post


Link to post
Share on other sites
33 minutes ago, UresiiZo said:

Click "Grab connector" and "Y key" but I can not grab the winch rope. Can operate the winch with "Show GUI". Other attach is also possible. I want to grab a winch.

Are you sure you're using the new KAS winch, not the legacy one? Their models look very similar. In order to use "Y" key you need to stay close to the dropped connector, it must glow with cyan color, and there must be a caption saying you can hit "Y". If everything of these is satisfied, but you still cannot perform the action, please attach the logs and couple for screenshots. See how to find the right logs here.

Share this post


Link to post
Share on other sites
9 hours ago, IgorZ said:

Are you sure you're using the new KAS winch, not the legacy one? Their models look very similar. In order to use "Y" key you need to stay close to the dropped connector, it must glow with cyan color, and there must be a caption saying you can hit "Y". If everything of these is satisfied, but you still cannot perform the action, please attach the logs and couple for screenshots. See how to find the right logs here.

It was  legacy winch. I did not notice the difference. Thank you.


 

Share this post


Link to post
Share on other sites

This may be a stupid question, but I’m confused on the use of the parts in this mod. 

I’m attempting to use this mod to recover a capsule by picking it out of the water and onto my recovery vessel. I know I’m attempting the impossible trying to lift a 22 metric ton capsule with a crane, but I’ve using the hw-80 winch and the HE-03 magnet. My problem arises when the magnet breaks off from the socket. Is there a better part for this or is there values I can change so that the magnet will not break off of the socket?

Share this post


Link to post
Share on other sites
Posted (edited)
On 3/17/2019 at 5:27 PM, Vobaseball12 said:

This may be a stupid question, but I’m confused on the use of the parts in this mod. 

I’m attempting to use this mod to recover a capsule by picking it out of the water and onto my recovery vessel. I know I’m attempting the impossible trying to lift a 22 metric ton capsule with a crane, but I’ve using the hw-80 winch and the HE-03 magnet. My problem arises when the magnet breaks off from the socket. Is there a better part for this or is there values I can change so that the magnet will not break off of the socket?

This is the code-snipplet i used in 1.3.1 as i had problems with the IR grasper foot as well as weak magnets.

I made a textfile in; GameData/ZOwnMods/my-mm-mods.cfg

Spoiler

// KAS
@PART[KAS_Hook_Magnet]
{
    
    @MODULE[KASModuleMagnet] 
    {
        @partBreakForce = 999
    }
    
    @MODULE[KASModulePort]
    {
        @breakForce = 999
    }

}
    
@PART[KAS_Hook_Harpoon]
{
    
    @MODULE[KASModuleHarpoon] 
    {
        @partBreakForce = 999
        @staticBreakForce = 999
    }
    
    @MODULE[KASModulePort]
    {
        @breakForce = 999
    }

}
    
@PART[KAS_Hook_GrapplingHook]
{
    
    @MODULE[KASModuleHarpoon] 
    {
        @partBreakForce = 999
        @staticBreakForce = 999
    }
    
    @MODULE[KASModulePort]
    {
        @breakForce = 999
    }
    
}    
    
@PART[KAS_Hook_Anchor]
{
    
    @MODULE[KASModulePort]
    {
        @breakForce = 999
    }
    
}

 

I believe these are the value you should be looking for in KAS1.1 with HW-80,

\GameData\KAS\Parts\Winch2\part.cfg

Spoiler

    breakingForce = 300
    breakingTorque = 300

Spoiler

    MODULE
    {
        name = KASJointCableBase

        // AbstractJoint
        jointName = mediumCableJoint
        anchorAtSource = 0, 0, -0.1490
        anchorAtTarget = 0, 0, 0.1490
        maxLinkLength = 80
        linkBreakForce = 400

        // KASJointCableBase
        cableSpringForce = 2000
        cableSpringDamper = 1
        allowDockingAtZeroDistance = true
    }

The "breakingForce" and "breakingTorque" (for the winch) as well as "linkBreakForce" (for the connector)

 

And now: SAFTEY NOTICE: I'm not all very familiar with the newest KAS. The first snipplets is from my modded IR/pre-KAS0.6  in 1.3.1 and modifies the breaking values as the joints of my IR-crane simply broke almost at any loads.

 

But as with all modulemanager configs, it will tell you if something is wrong.

38 minutes ago, elbuglione said:

There is a chance to see the 1.6.x version mod?

or they just jump to the 1.7 version?

I use the current KAS in 1.6.1 withou any (obvius for my usage) problems. It just tells abit about version mismatch, but still works.

 

EDIT: Link to posts which led me to breaking joints solution in IR-thread. Just for reference from above code origins.

 

Edited by mrstoned
Added link

Share this post


Link to post
Share on other sites

@IgorZ Would it be possible to dampen the Winch’s cable as its being retracted? Currently the Harpoons I’ve used (legacy) spin / flail wildly when pulled back in. (Its as if physics is being overdone) Be aware that this can often detach both the harpoon & winch if left in this state unattended. To correct it i need to send a Kerbal out to grab and rebuild the them before performing other actions. Which to be honnest, sucks... I’ve lost track of the number of times I’ve grappled to an asteroid, fired both for extra stabilization and had one or both fail / flail.

Side note: I have yet to try the non-legacy harpoons as i can’t find them using the VAB filtering.

-Redacted

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.