IgorZ

[1.7.1] Kerbal Attachment System (KAS) v1.4 - NOT COMPATIBLE WITH KSP 1.7.0

Recommended Posts

@Redacted There are no non-legacy harpoons yet. But even when connecting a v1.1 winch to a socket the physics sometimes seem overdone. A little like the legs that tended to make the ship jump higher and higher... Might be a Unity problem?

Share this post


Link to post
Share on other sites
1 minute ago, infinite_monkey said:

@Redacted There are no non-legacy harpoons yet. But even when connecting a v1.1 winch to a socket the physics sometimes seem overdone. A little like the legs that tended to make the ship jump higher and higher... Might be a Unity problem?

Well the legs can be dampened and offer setting to do so. The harpoons on the other hand are awesome, if they work.

Share this post


Link to post
Share on other sites

@Redacted, Harpoons are not implemented in the new KAS yet, and old KAS is not maintained anymore. Moreover, the next version of KAS won't have the legacy parts. However, the problem may be still relevant when I start om the new implementation. Could you please make a short video to demonstrate it?

@infinite_monkey Could you please make a demo video?

Share this post


Link to post
Share on other sites
Posted (edited)

@IgorZ 

Here you go: https://youtu.be/7fzpDxWvbJY

(May take a few minutes to upload and process)

Notice that both the Harpoons disconnect all on their own and that they refuse to re-connect with the winch. It's almost as if the mechanics behind the Harpoon / Wench rely on this being used on a body with gravity. If so then this makes them all but unusable anywhere but high gravity environments such as Kerbin.  Even then, they still can misbehave, making their use undependable in the best of situations.

Edited by Redacted

Share this post


Link to post
Share on other sites
6 hours ago, Redacted said:

@IgorZ 

Here you go: https://youtu.be/7fzpDxWvbJY

(May take a few minutes to upload and process)

Notice that both the Harpoons disconnect all on their own and that they refuse to re-connect with the winch. It's almost as if the mechanics behind the Harpoon / Wench rely on this being used on a body with gravity. If so then this makes them all but unusable anywhere but high gravity environments such as Kerbin.  Even then, they still can misbehave, making their use undependable in the best of situations.

So, the only real problem I see here is that the ejected harpoons have not attached to the asteroid and bounced back. Obviously, the harpoon logic is broken (but it won't be fixed). Everything else you see is an expected behavior of a physical object on cable in zero-G. KAS winches were always working like this on orbit. Btw, the normal pattern is ejecting and hocking to the asteroid (that is broken). When you need to detach, you either go EVA or use "Unplug" remote command and loose harpoon. In real life you'd also loose the cable :) 

Share this post


Link to post
Share on other sites

@IgorZ

1) The Harpoons did initially stick but came off without any external force being applied. More to the point they self-detached at a rather high velocity considering that the cable was slack.

2) The expected cable behavior as you call it makes them all but unusable. Besides I didnt ask you to kill the physics just provide dampening so it does swing wildly forever. 

3) Theres no reason not to fix the Harpoon logic as it will only save you time having to respond to those reporting the error. Keep in mind that the Harpoons are a major selling point of why people find KAS interesting.

Share this post


Link to post
Share on other sites
25 minutes ago, Redacted said:

1) The Harpoons did initially stick but came off without any external force being applied. More to the point they self-detached at a rather high velocity considering that the cable was slack.

What I see in the video is "bouncing". The harpoons hit the asteroid and bounce back instead of making a rigid joint. What makes you think they actually attached and then detached? I see no evidence on the video.

26 minutes ago, Redacted said:

2) The expected cable behavior as you call it makes them all but unusable. Besides I didnt ask you to kill the physics just provide dampening so it does swing wildly forever. 

PhysX joint dampening is not what can help here. Any other form of "dampening" would be artificial. I'm not saying it's not possible, it's just not (and never was) implemented. The bare Unity physics gives what you observe. The distant (a.k.a. "cable") joints by design cannot damper rotations around any axis. They can only damper the linear oscillations, given there is a constant force (e.g. gravity) applied.

33 minutes ago, Redacted said:

3) Theres no reason not to fix the Harpoon logic as it will only save you time having to respond to those reporting the error

Indeed, there is no reason for it to not be fixed. Does it mean everything that can be fixed will be fixed? There is no reason to believe so.

30 minutes ago, Redacted said:

Keep in mind that the Harpoons are a major selling point of why people find KAS interesting.

I'd say, it's a highly subjective conclusion, but, indeed, there are people who use KAS only for this.

Share this post


Link to post
Share on other sites

@IgorZ

Fine, continue to dodge the issue...

I have to ask, If your not going to provide support or address the error then why bother with this mod at all?

Share this post


Link to post
Share on other sites
Posted (edited)
34 minutes ago, Redacted said:

I have to ask, If your not going to provide support or address the error then why bother with this mod at all?

I didn't say I'm not going to address it. And I haven't promised to drop whatever I do right now to address this issue as soon as possible, which you probably expected to hear. Anyways, thank you for reporting the issue.

Edited by IgorZ

Share this post


Link to post
Share on other sites

@IgorZ

Your prior posts stated otherwise but whatever, wait and see I guess

Share this post


Link to post
Share on other sites

Hi there 

Are you aware of this problem? (the wich housing not showing)

 Hdp4hl5.pngEer05l8.png

Share this post


Link to post
Share on other sites
53 minutes ago, Nucluer said:

Are you aware of this problem? (the wich housing not showing)

Indeed. It looks weird. Are you using the stock parts only? Can you make a short video and attach the logs from this video (here is how to get them)? Can you reproduce the issue on a pristine game?

Share this post


Link to post
Share on other sites

Is this compatible with 1.6? I noticed it's not availabe in CKAN, despite the GAP (Giving Aircraft Purpose) contract pack suggesting it.

Share this post


Link to post
Share on other sites

It does work, you need to tellCKAN that 1.5 is compatible 

Share this post


Link to post
Share on other sites
9 minutes ago, linuxgurugamer said:

It does work, you need to tellCKAN that 1.5 is compatible 

And how would I do that?

Also thanks ahead of time! You seem to be quite helpful around the forum!

Share this post


Link to post
Share on other sites
39 minutes ago, Rabblerouser said:

And how would I do that?

Also thanks ahead of time! You seem to be quite helpful around the forum!

In CKAN select  Settings-> Compatible KSP Versions. Check 1.5. You could also select 1.4 as most, but not all mods compiled for 1.4 or later work just fine in the latest releases of KSP. The only way to know if a mod works is to try it.

Share this post


Link to post
Share on other sites

Ah, it seems a bit messy for th end-user that way, but I guess that makes sense so a mod dev doesn't have to republish their mod for every major version.

Share this post


Link to post
Share on other sites

Hi, in the older versions of KAS you were able to control multiple winches at the same time by using the numpad hot keys (5 up, 2 down) is there a way to do this in the newest version?

I have a medium sized rover that is docked to a VTOL and would like to have 4x winches, one on each corner lowering and lifting at the same time so that i can fly to a location drop the Rover, drive around, pick it up again and fly to another location or moon. 

Thanks for keeping this mod alive.

Share this post


Link to post
Share on other sites
1 hour ago, Getsome2030 said:

Hi, in the older versions of KAS you were able to control multiple winches at the same time by using the numpad hot keys (5 up, 2 down) is there a way to do this in the newest version?

The old KAS approach to hotkeys will not be repeated. However, there is an issue pending to support action groups. You'll be able to use them to achieve what you need. I was thinking about upgrading Winch GUI to allow the same, but this improvement was put on hold for now.

Share this post


Link to post
Share on other sites
On 3/22/2019 at 6:45 PM, IgorZ said:

Indeed. It looks weird. Are you using the stock parts only? Can you make a short video and attach the logs from this video (here is how to get them)? Can you reproduce the issue on a pristine game?

 

Just did a fresh reinstall of KSP using CKAN to install KAS and that fixed problem.

Share this post


Link to post
Share on other sites
4 minutes ago, Nucluer said:

Just did a fresh reinstall of KSP using CKAN to install KAS and that fixed problem.

Good to know. Thanks!

Share this post


Link to post
Share on other sites
19 hours ago, IgorZ said:

The old KAS approach to hotkeys will not be repeated. However, there is an issue pending to support action groups. You'll be able to use them to achieve what you need. I was thinking about upgrading Winch GUI to allow the same, but this improvement was put on hold for now.

Thanks for the heads up and I look forward to the action groups or better sill the upgraded GUI when you get time.

Cheers 

Share this post


Link to post
Share on other sites

I am using KSP version 1.6.1 and i installed KIA and KAS. KIS works but KAS does'nt attach to the hooks. It also wont let me use it in EVA. It would be great if you updated this mod to the current version, as there may be multiple people with the same, annoying issue. Glad to hear from you, great sir!

 

Have a great day.

Share this post


Link to post
Share on other sites
1 hour ago, boomboomtime said:

I am using KSP version 1.6.1 and i installed KIA and KAS. KIS works but KAS does'nt attach to the hooks. It also wont let me use it in EVA. It would be great if you updated this mod to the current version, as there may be multiple people with the same, annoying issue. Glad to hear from you, great sir!

 

Have a great day.

Well, if you want to install a car into a spaceship you need the SpaceY mod! :)

Share this post


Link to post
Share on other sites
12 minutes ago, Loren Pechtel said:

Well, if you want to install a car into a spaceship you need the SpaceY mod! :)

how do you know what i am planning on doing with the KAS mod....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.