IgorZ

[1.7.1] Kerbal Attachment System (KAS) v1.4 - NOT COMPATIBLE WITH KSP 1.7.0

Recommended Posts

@Lisias He has some logs from above when the problem was happening. And he doesn't have Tweakscale installed. This was some other negative mass problem.

Share this post


Link to post
Share on other sites
19 hours ago, Tonka Crash said:

And he doesn't have Tweakscale installed. This was some other negative mass problem.

What makes the thing yet more important to be analysed by me.

TweakScale currently complains about negative mass, but doesn't know when this happens due a TweakScale patch or not. If there're more situations where this happens, I want to give a peek on them to be able to know when I should intervene and when I don't.

Supporting my own Add'Ons is already work enough, I don't plan to support other people's work. ;) 

Share this post


Link to post
Share on other sites

Does this version finally fix the "old part / new part" replacement issues?

I'm not sure why the old parts, like the CC-2R, needed replacing but...if this version makes my ships unusable again, I'll ignore it.

Share this post


Link to post
Share on other sites

@Victor3 There is a wiki that explains what happens when you upgrade. The legacy parts have been deleted from 1.2+, so if they are critical to your game the best option for you may be to wait until you start a new game. I've also read people have had some success copying the Legacy directory from KAS 1.1 to newer versions.

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, Victor3 said:

Does this version finally fix the "old part / new part" replacement issues?

I'm not sure why the old parts, like the CC-2R, needed replacing but...if this version makes my ships unusable again, I'll ignore it.

KAS 1.2 and higher doesn't have legacy parts. If you really need them, you may try bringing them from v1.1 (LEGACY folder). To prevent the new KAS doing upgrading on load, you'll also need to drop "COMP-LegacyParts.cfg" file from Patches. However, keep in mind that the legacy parts already have compatibility issues with the new KSP game. With time it will only get worse.

Edited by IgorZ

Share this post


Link to post
Share on other sites
11 hours ago, Tonka Crash said:

@Victor3 There is a wiki that explains what happens when you upgrade. The legacy parts have been deleted from 1.2+, so if they are critical to your game the best option for you may be to wait until you start a new game. I've also read people have had some success copying the Legacy directory from KAS 1.1 to newer versions.

 

10 hours ago, IgorZ said:

KAS 1.2 and higher doesn't have legacy parts. If you really need them, you may try bringing them from v1.1 (LEGACY folder). To prevent the new KAS doing upgrading on load, you'll also need to drop "COMP-LegacyParts.cfg" file from Patches. However, keep in mind that the legacy parts already have compatibility issues with the new KSP game. With time it will only get worse.

I don't necessarily want to keep the legacy parts...as long as there is a new part that will perform the same function. For example, my biggest concern is my Dres mining facility. The various ships use a lot of the CC-R2 connector ports. In past versions of KAS these legacy parts were supposed to be easily replaced with the new parts...but according to some, this function didn't work so I stayed with KAS 0.6.4.

So my question really is...can KAS 1.3 easily replace my existing parts (the CC-R2's, as an example), with a new part, on my ships that are in use and my saved VAB craft? Waiting until I "start a new game" may well be years away as I have just started my Jool system exploration.

Share this post


Link to post
Share on other sites

So happy that KAS is getting so much time and effort put into it, it really is such an essential concept and this new version is looking really good. 
Only just started playing with it but I'm liking it!

Got a couple Qs:
- Will the harpoon and grappling hook eventually get ported into this version?
- On the TB-60 towbar, locking it just seems to lock the "yaw" movement of one of the joints, but the "pitch" remains unlocked on both joints. Is there a way to completely lock straight one of the joints? I'd like to be able to have small 2 wheeled trailers (or truck style trailers with only rear wheels) but so far I can't figure out how to do that with this tow bar.

Example: I got this little science trailer and I can hook up with the trailers jokey wheel down, but when I raise the jokey wheel the font of the trailer drags along the ground (and explodes!)
PLeZ2N7.pngtqUDsot.png

Share this post


Link to post
Share on other sites
Posted (edited)

@Victor3 There aren't one-for-one replacements for every part and function, so parts disappear with no replacement (harpoon, grappling hook). The CC-R2 get replaced with JS-1 connectors, but two connectors can't form a pipe like before. You need a connector at one end and a RTS-1 hose reel at the other end. If you are using the old KAS struts the new TJ struts and cables can replace them but are shorter and again it's a different part for each end of the connection. A couple pages back is a discussion on increasing the length of these parts.

If it were me, I'd bite the bullet and spend a day upgrading just to stay on a supported version of KAS, but then I haven't used legacy parts since last June. The Legacy parts really haven't been updated since 1.4.3 and later KSP versions have been reported to break some of the parts and I'd only expect that to get worse. From a user perspective, I prefer the RTS-1 hose reel over the old pipes. Every time I had a base with pipes it seemed like half of them would break on load. The new KAS allow these connections to be flexible. I can't remember the last time I had one break on a ground base. 

  1. Backup everything and make sure you understand the wiki I linked to above.
  2. Turn on cheats ("act of god") and use HyperEdit to move engineers from site to site or ship to ship.
  3. Get in the habit of saving often. I use KISS (Kerbal Improved Save System) to generate timestamped saves.
  4. Increase the KIS grab distance to make life easier. I've had it as high as 500m. A kerbal can basically hang on a hatch and reach anywhere on a base or station
  5. Easy Vessel Switch (also by IgorZ) makes it easier to focus on specific parts at high grab distances.
  6. Use the KIS debug option which lets you spawn or destroy parts directly into a Kerbal inventory.
  7. Don't dock or grab probes en-route to avoid disturbing the trajectory. MechJeb has an RCS function to hold a position near a target vessel. Just get close and start swapping parts. You might need to do a correction burn if it looks like swapping parts did perturb the trajectory.

Another thing to consider is support in other mods. Do you use a mod with a KAS dependency? Most of these rely on Legacy KAS. Of these I only know that the latest KPBS is fully compliant with KAS 1.2+. Extraplanetary Launchpads has legacy stuff embedded in code. Other mods with flexible corridors/tubes/whatever are usually based on the old KAS pipes. They're relatively easy to fix by changing a .cfg file, but the mod authors have not updated yet. 

10 minutes ago, katateochi said:

So happy that KAS is getting so much time and effort put into it, it really is such an essential concept and this new version is looking really good. 
Only just started playing with it but I'm liking it!

Got a couple Qs:
- Will the harpoon and grappling hook eventually get ported into this version?
- On the TB-60 towbar, locking it just seems to lock the "yaw" movement of one of the joints, but the "pitch" remains unlocked on both joints. Is there a way to completely lock straight one of the joints? I'd like to be able to have small 2 wheeled trailers (or truck style trailers with only rear wheels) but so far I can't figure out how to do that with this tow bar.

Example: I got this little science trailer and I can hook up with the trailers jokey wheel down, but when I raise the jokey wheel the font of the trailer drags along the ground (and explodes!)
PLeZ2N7.pngtqUDsot.png

Can you rotate it 90 degrees so yaw becomes pitch?

EDIT: The harpoon and grappling hook are on IgorZ's to do list. No ETA

Edited by Tonka Crash

Share this post


Link to post
Share on other sites
On 5/12/2019 at 9:01 AM, katateochi said:

On the TB-60 towbar, locking it just seems to lock the "yaw" movement of one of the joints, but the "pitch" remains unlocked on both joints. Is there a way to completely lock straight one of the joints? I'd like to be able to have small 2 wheeled trailers (or truck style trailers with only rear wheels) but so far I can't figure out how to do that with this tow bar.

The initial TB-60 design was made for towing the two-axles vehicles. Alas, this concept had too many issue (see Wiki). So I think I'll make a part for one-axle version, with "pitch" locked as well. Created an enhancement to not forget.

Share this post


Link to post
Share on other sites
8 hours ago, IgorZ said:

The initial TB-60 design was made for towing the two-axles vehicles. Alas, this concept had too many issue (see Wiki). So I think I'll make a part for one-axle version, with "pitch" locked as well. Created an enhancement to not forget.

Awesome! That will be a great enhancement to the Kerbal Truck Simulator! Don't know why (maybe 'cos I do a lot of towing in RL) but there is something oddly satisfying about having a rover towing a trailer in KSP.

Share this post


Link to post
Share on other sites

@katateochi I had an idea on towing and it worked.  I use three links: 2xTJ-2 outer links and the TB-60 center link, but I think all three could be TJ-2 in this configuration. The links on the rover are all in the same vertical plane so they can pivot in pitch. The TB-60 is offset vertically on the trailer to triangulate the linkages and lock out droop at trailer side. Since all the links can free pivot the rover can turn with the trailer following.

 

Share this post


Link to post
Share on other sites
Posted (edited)

Nothing works-help! I made sure to get the KAS & CCK folders out, but nothing works! (on mac btw)

Edited by HansonKerman

Share this post


Link to post
Share on other sites
16 minutes ago, HansonKerman said:

Nothing works-help! I made sure to get the KAS & CCK folders out, but nothing works! (on mac btw)

Need more info than this. How about we start with a screenshot of your GameData folder

Share this post


Link to post
Share on other sites
Posted (edited)

Ops! I did the same mistake as many other players did. I confused KAS and KIS topics :) Please, disregard this post.

Edited by IgorZ

Share this post


Link to post
Share on other sites

Hey @IgorZ I would like to do a german translation if you would be so kind and readd the harpoons and so on in the next update.

Signed: long time KAS user

Bjoern Schnabel

Share this post


Link to post
Share on other sites
On 5/16/2019 at 6:35 PM, ExplorerKlatt said:

Need more info than this. How about we start with a screenshot of your GameData folder

Here: Lj8ujiM.png 

Pls help this seems like a pretty cool mod

Share this post


Link to post
Share on other sites

@HansonKerman  It helps to provide some symptoms of what problems you have encountered instead of just Nothing works-help! 

Also we need logs to troubleshoot what's wrong. Info on where they are in the following link:

@ExplorerKlatt A screenshot of GameData doesn't tell you much at all. Anything there can be found in the proper logs.

Share this post


Link to post
Share on other sites
Posted (edited)
48 minutes ago, Tonka Crash said:

@HansonKerman  It helps to provide some symptoms of what problems you have encountered instead of just Nothing works-help! 

Also we need logs to troubleshoot what's wrong. Info on where they are in the following link:

Well... When I right click, there's only an aim camera option, no pick up cable, no connect cable, etc. Basically, none of the right-click menus work except for the recourse transfer station, but I can't connect the cable to anything so...

Not sure how else to explain it. I'm finding the log, so that'll come soon

EDIT: I'm not sure how to upload the log as a file, so it might take longer than expected.

Edited by HansonKerman

Share this post


Link to post
Share on other sites
16 minutes ago, HansonKerman said:

EDIT: I'm not sure how to upload the log as a file, so it might take longer than expected.

Upload it to Google Drive or Microsoft's OneDrive, You probably have access to one of these even if you've never used it if you have a Windows 10 PC or a gmail address. There are tons of sites offering similar services. Once it's up there will be an option to get a shareable link for the file and just paste the link here.

22 minutes ago, HansonKerman said:

Well... When I right click, there's only an aim camera option, no pick up cable, no connect cable, etc. Basically, none of the right-click menus work except for the recourse transfer station, but I can't connect the cable to anything so...

I'd guess you have the wrong version of KAS installed for your version of KSP.

KAS 1.2 or lower for KSP 1.6 or lower

KAS 1.3 for KSP 1.7

Share this post


Link to post
Share on other sites
Posted (edited)
5 minutes ago, Tonka Crash said:

KAS 1.3 for KSP 1.7

So basically re download the mod? If so, I went through a huge dropbox hassle for nothing?

Edited by HansonKerman

Share this post


Link to post
Share on other sites
Just now, HansonKerman said:

So basically re download the mod?

That was by guess based on your symptons without seeing a log. If you already have KAS 1.3 on KSP 1.7 I really need to see a log.

Share this post


Link to post
Share on other sites

@HansonKerman I'm not seeing anything really obvious. You're on a Mac which I have zero experience with. It can't find a stock library during load. If you got KSP off steam you could try validating your install (something I've heard about, but have zero experience with) or reinstall manually. Save your old directory tree and move the saves from one save to the other after a reinstall.

Spoiler

Couldn't open /Applications/KSP_osx 1.7/KSP.app/Contents/Plugins/3DConnexionWrapperU5.bundle/Contents/MacOS/3DConnexionWrapperU5, error: dlopen(/Applications/KSP_osx 1.7/KSP.app/Contents/Plugins/3DConnexionWrapperU5.bundle/Contents/MacOS/3DConnexionWrapperU5, 2): Library not loaded: /Library/Frameworks/3DconnexionClient.framework/Versions/A/3DconnexionClient
  Referenced from: /Applications/KSP_osx 1.7/KSP.app/Contents/Plugins/3DConnexionWrapperU5.bundle/Contents/MacOS/3DConnexionWrapperU5
  Reason: image not found
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/3DConnexionWrapperU5
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/lib3DConnexionWrapperU5.dylib
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/lib3DConnexionWrapperU5.so
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/lib3DConnexionWrapperU5.bundle
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/3DConnexionWrapperU5.dylib
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/3DConnexionWrapperU5.so
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/./3DConnexionWrapperU5
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/./lib3DConnexionWrapperU5.dylib
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/./lib3DConnexionWrapperU5.so
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/./lib3DConnexionWrapperU5.bundle
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/./3DConnexionWrapperU5.dylib
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/./3DConnexionWrapperU5.so
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/3DConnexionWrapperU5
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/lib3DConnexionWrapperU5
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/lib3DConnexionWrapperU5.dylib
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/lib3DConnexionWrapperU5.so
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/lib3DConnexionWrapperU5.bundle
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/./lib3DConnexionWrapperU5
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/./lib3DConnexionWrapperU5.dylib
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/./lib3DConnexionWrapperU5.so
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/./lib3DConnexionWrapperU5.bundle
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/lib3DConnexionWrapperU5

 

The only other thing I saw was Dynamic Battery Storage is installed, but I don't think it needs to be. It's normally a dependency for Near Future Electrical which you don't have. It has an issue as it was compiled against the wrong .NET version, but this really shouldn't be a problem. <rant on> I hate it because is spams the log with useless messages constantly. It bugged me enough I downloaded the source code and got rid of that crap locally<rant off>

I can see you add an RTS-1 in the editor and  Bill grab the RTS-1 connector once you launch, so KAS seems to be working. I don't see a connector unless it was already installed on your ship. I don't want to sound rude, but do you know how to use KAS? The video below uses the winch, but it's essentially the same thing. You have to have a socket to plug into. To plug it in you have to be pretty close to the socket. I think I saw 2 meters in the code. Once it's connected you have to switch to the vessel the RTS-1 is attached to or move your Kerbal close to the RTS-1 to get it's GUI to activate to transfer resources.

 

Share this post


Link to post
Share on other sites
Posted (edited)
12 hours ago, Tonka Crash said:

@HansonKerman I'm not seeing anything really obvious. You're on a Mac which I have zero experience with. It can't find a stock library during load. If you got KSP off steam you could try validating your install (something I've heard about, but have zero experience with) or reinstall manually. Save your old directory tree and move the saves from one save to the other after a reinstall.

  Reveal hidden contents


Couldn't open /Applications/KSP_osx 1.7/KSP.app/Contents/Plugins/3DConnexionWrapperU5.bundle/Contents/MacOS/3DConnexionWrapperU5, error: dlopen(/Applications/KSP_osx 1.7/KSP.app/Contents/Plugins/3DConnexionWrapperU5.bundle/Contents/MacOS/3DConnexionWrapperU5, 2): Library not loaded: /Library/Frameworks/3DconnexionClient.framework/Versions/A/3DconnexionClient
  Referenced from: /Applications/KSP_osx 1.7/KSP.app/Contents/Plugins/3DConnexionWrapperU5.bundle/Contents/MacOS/3DConnexionWrapperU5
  Reason: image not found
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/3DConnexionWrapperU5
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/lib3DConnexionWrapperU5.dylib
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/lib3DConnexionWrapperU5.so
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/lib3DConnexionWrapperU5.bundle
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/3DConnexionWrapperU5.dylib
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/3DConnexionWrapperU5.so
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/./3DConnexionWrapperU5
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/./lib3DConnexionWrapperU5.dylib
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/./lib3DConnexionWrapperU5.so
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/./lib3DConnexionWrapperU5.bundle
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/./3DConnexionWrapperU5.dylib
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/./3DConnexionWrapperU5.so
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/3DConnexionWrapperU5
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/lib3DConnexionWrapperU5
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/lib3DConnexionWrapperU5.dylib
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/lib3DConnexionWrapperU5.so
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/lib3DConnexionWrapperU5.bundle
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/./lib3DConnexionWrapperU5
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/./lib3DConnexionWrapperU5.dylib
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/./lib3DConnexionWrapperU5.so
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/./lib3DConnexionWrapperU5.bundle
Fallback handler could not load library /Applications/KSP_osx 1.7/KSP.app/Contents/Frameworks/MonoEmbedRuntime/osx/lib3DConnexionWrapperU5

 

The only other thing I saw was Dynamic Battery Storage is installed, but I don't think it needs to be. It's normally a dependency for Near Future Electrical which you don't have. It has an issue as it was compiled against the wrong .NET version, but this really shouldn't be a problem. <rant on> I hate it because is spams the log with useless messages constantly. It bugged me enough I downloaded the source code and got rid of that crap locally<rant off>

I can see you add an RTS-1 in the editor and  Bill grab the RTS-1 connector once you launch, so KAS seems to be working. I don't see a connector unless it was already installed on your ship. I don't want to sound rude, but do you know how to use KAS? The video below uses the winch, but it's essentially the same thing. You have to have a socket to plug into. To plug it in you have to be pretty close to the socket. I think I saw 2 meters in the code. Once it's connected you have to switch to the vessel the RTS-1 is attached to or move your Kerbal close to the RTS-1 to get it's GUI to activate to transfer resources.

 

Ah. Thx. I'm thankful for the help, as I haven't used KAS in a long time and I'm  a bit rusty, I only normally use it for bases as it's much cleaner with one vessel connecting with pipes when a bunch of other vessels.

Anyway, I'll uninstall DBS and relaunch and try to do this again.

BTW the connector was not installed on my ship, it was a separate vessel I pulled out using KIS. Again, thx for the help!

EDIIT: :D I just was stupid!!!! I just didn't know how to use KAS (which makes sense, because the last version of KAS I used was the one where KIS was still part of KAS so...

Edited by HansonKerman

Share this post


Link to post
Share on other sites

Maybe I'm missing something, but I'm looking for a way to attach base modules.

A while ago (couple years back) I was using the cables to attach my modules together, but...that system is now obsolete with the ports becoming legacy and gone.

I see the hose/cable/pipe setup, but none offer the same function.

MKS/USI had the FlexOTube, but apparently those are broken right now, so that's not going to work.

So, I'm looking for an interim solution.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.