IgorZ

[1.7.3] Kerbal Attachment System (KAS) v1.4 - NOT COMPATIBLE WITH KSP 1.7.0

Recommended Posts

45 minutes ago, IgorZ said:

Not by using KAS. It's possible to modify a part configuration so that it could be equipped via KIS. However, in the most cases the physics acts crazy. The parachutes are more or less usable, but highly unlikely you'll be able to stabilize the flight with an externally attached thruster.

Not to waste your time, but how might I go about making a patch to add that "equip module" on the parachute

Edited by Yoshidude

Share this post


Link to post
Share on other sites
4 hours ago, Yoshidude said:

Not to waste your time, but how might I go about making a patch to add that "equip module" on the parachute

I never did it, but there are pople in this thread who did. In nutshell, you need to add a `ModuleKISItem`module to the part, and specify `equipMode = physics`. See more details on the module's settings in the Wiki.

Edited by IgorZ

Share this post


Link to post
Share on other sites
15 hours ago, IgorZ said:

I never did it, but there are pople in this thread who did. In nutshell, you need to add a `ModuleKISItem`module to the part, and specify `equipMode = physics`. See more details on the module's settings in the Wiki.

Thanks mate. c:

Share this post


Link to post
Share on other sites

Before you've asked:

NO, the current versions of KIS & KAS don't work with KSP 1.3 yet.

I'm working on the resolution but I only have one evening to get it done. On Saturday a long local weekend starts, and I'll be out of the town. So, if the re is no update on Friday night, then Tuesday is the best bet.

Plus, `ModuleManager v2.7.6` doesn't work as well. For KIS it's critical, for KAS it's just an little inconvinince.

Share this post


Link to post
Share on other sites

MM has updated to 2.8.0.  I am still experiencing an issue similar to the one I originally reported to Sarbian, but it is occurring at a slightly later point (the text on the loading bar now says something about parts, and the bar has progressed beyond where it gets before it jumps back to take care of stuff it moves forward from after the loading screen).

Share this post


Link to post
Share on other sites

Module Manager 2.8.0 Came out, Just so you know :wink:

So good luck with update!

 

Edited by Starslinger999

Share this post


Link to post
Share on other sites
40 minutes ago, Starslinger999 said:

Module Manager 2.8.0 Came out, Just so you know :wink:

So good luck with update!

In fact I was able to "fix" MM locally yesterday :) MM is not a blocker, the KSP 1.3 chages are. I was able to make KAS compiling but the attacable things for the winch are not working properly. If I'm not able to have it done today, I'll make a pre-release version without the winches.

Share this post


Link to post
Share on other sites

Wouldn't that mean visiting any of my bases where winches are present would cause the connections to break (or perhaps something even worse like being unable to load my save)?  I do have a mission in progress that could advance without worrying about winches, but to start my next planned mission (or if I discover I need to launch a fuel tanker to support the current mission), I would need to visit one such base.

Share this post


Link to post
Share on other sites
28 minutes ago, cgwhite4 said:

Wouldn't that mean visiting any of my bases where winches are present would cause the connections to break (or perhaps something even worse like being unable to load my save)?  I do have a mission in progress that could advance without worrying about winches, but to start my next planned mission (or if I discover I need to launch a fuel tanker to support the current mission), I would need to visit one such base.

Sorry for being not clear. I meant there wil be a build where the winches don't work as designed. I'll give more details when I'm back from the work. In the best case I'll just release a fully functional version.

Share this post


Link to post
Share on other sites

KAS v0.6.3

@ihsoft ihsoft released this 3 minutes ago

0.6.3 (May 26th, 2017)

  • [Fix] Show detach button when harpooned to a part (asmigala).
  • [Change] Support a new format of the OnKISAction parameter.
  • KSP 1.3 support.

Known issue. In the tests I've found out that in EVA the harpoons and magnets are attaching to the winches in the reversed direction. I thought it's a KSP 1.3 consequence, but it looks it's a KIS issue that was around for a while. Anyways, if you attach any of the mentioned parts and they attach in the reversed direction, don't get frustrated. Just extend the cable, and let the gravity to pull the attached object out.

Edited by IgorZ

Share this post


Link to post
Share on other sites

Updating KAS and KAS Beta cleared the issue I was having, despite EL being yet to update (same situation with KJR, but KJR does not add parts).

Share this post


Link to post
Share on other sites

The newest file on kerbal.curseforge.com still says KAS v0.6.2 so now there's 2 of them...

Is this really 0.6.3 or a copy of the old one?

kQ9Ev8Z.jpg

Share this post


Link to post
Share on other sites
On 5/27/2017 at 1:18 AM, IgorZ said:

KAS v0.6.3

@ihsoft ihsoft released this 3 minutes ago

0.6.3 (May 26th, 2017)

  • [Fix] Show detach button when harpooned to a part (asmigala).
  • [Change] Support a new format of the OnKISAction parameter.
  • KSP 1.3 support.

Known issue. In the tests I've found out that in EVA the harpoons and magnets are attaching to the winches in the reversed direction. I thought it's a KSP 1.3 consequence, but it looks it's a KIS issue that was around for a while. Anyways, if you attach any of the mentioned parts and they attach in the reversed direction, don't get frustrated. Just extend the cable, and let the gravity to pull the attached object out.

YAY!!!! Thank you! 

Share this post


Link to post
Share on other sites
15 hours ago, lexderus said:

KAS is not displayed in the CKAN (1.22.3) mods list. This is normal?

I have never heard of KSP 1.22.3. Is it a secret release? :D

Share this post


Link to post
Share on other sites

Is the latest version backwards compatible to 1.2.2?

Share this post


Link to post
Share on other sites
3 hours ago, TheRagingIrishman said:

I have never heard of KSP 1.22.3. Is it a secret release? :D

Pretty sure that's the current CKAN version, not KSP version

Share this post


Link to post
Share on other sites
On 5/27/2017 at 8:20 AM, jrolson said:

The newest file on kerbal.curseforge.com still says KAS v0.6.2 so now there's 2 of them...

Is this really 0.6.3 or a copy of the old one?

kQ9Ev8Z.jpg

Thanks, I've fixed the typo.

On 5/27/2017 at 10:53 PM, lexderus said:

KAS is not displayed in the CKAN (1.22.3) mods list. This is normal?

My bad, I forgot to update the netkan file. It should show up in the next 24 hours.

23 hours ago, dlrk said:

Is the latest version backwards compatible to 1.2.2?

I never tried it. No new KSP 1.3 functionality is used in the current KAS version, so in theory it should work.

Share this post


Link to post
Share on other sites
8 hours ago, IgorZ said:

My bad, I forgot to update the netkan file. It should show up in the next 24 hours.

Thank you, it's ok now. 

Share this post


Link to post
Share on other sites

Hello guys.
Today I wanted to refuel two space crafts on orbic of the moon by using two conector ports. Unfortunately I was able to pump monopropelant only. Finaly I have crafted 2 truck with many different fuel tanks, connector ports and even winch. I tried to connect everything with everything to check if it will be posible to pump liquid fuel, unfortunately no. Linking, pluging, dock pluging there is no way to pump fuel. I have recorded movie please check it and tell me what it is wrong, maybe I do somethong wrong but I do not think so. I remember that one year ago I was able to pump fuel but now it is not posible only I can pump monopropelant.

Mods:
KAS_v0.6.3
KIS_v1.5.0

Thank you for answer and help in advance.

Edited by Fair_Player[PL]

Share this post


Link to post
Share on other sites
5 hours ago, Fair_Player[PL] said:

Hello guys.
Today I wanted to refuel two space crafts on orbic of the moon by using two conector ports. Unfortunately I was able to pump monopropelant only. Finaly I have crafted 2 truck with many different fuel tanks, connector ports and even winch. I tried to connect everything with everything to check if it will be posible to pump liquid fuel, unfortunately no. Linking, pluging, dock pluging there is no way to pump fuel. I have recorded movie please check it and tell me what it is wrong, maybe I do somethong wrong but I do not think so. I remember that one year ago I was able to pump fuel but now it is not posible only I can pump monopropelant.

Mods:
KAS_v0.6.3
KIS_v1.5.0

Thank you for answer and help in advance.

Hi,

I have the same problem, I cannot transfer my fuel through a pipe between two tanks.

Thanks for the help.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.