IgorZ

[1.7.3] Kerbal Attachment System (KAS) v1.4 - NOT COMPATIBLE WITH KSP 1.7.0

Recommended Posts

4 minutes ago, KerbMav said:

I then quicksaved and disconnected while sitting in the cockpit - not with EVA tools that is - to check the dV after fuel transfer. After reloading said quicksave the Teles were disconnected and going EVA again I could not reconnect them again, no matter where I clicked.

  • Did you disconnect before the quick save?
  • Do you have mods that improves saving and loading process in the game? I remember there were couple on the market.
  • Please, reproduce the issue and then capture "KSP.log" file from the game's root. It will help debugging the issue.
7 minutes ago, KerbMav said:

I also cannot detach the Tele, because it has become the root part of the vessel.

Detach the vessel instead.

Share this post


Link to post
Share on other sites
1 hour ago, IgorZ said:
  • Did you disconnect before the quick save?
  • Do you have mods that improves saving and loading process in the game? I remember there were couple on the market.

1. No, they were detached after I reloaded. (connected - saved - disconnected - reloaded -> found them disconnected)

2. Not that I know of, but KAC seems to make additional saves. Save in question was made by me pressing quicksave button.

3. Reproducable. You even have an error message for it it seems. (upper right in red)

https://www.dropbox.com/sh/t8ydpjaka3prhse/AAAAmC9mlvJyA2tf_rdDI5FUa?dl=0

KAS test 2 is the save that fails to reload, the other is before connecting them all.

4. Detaching the Tele by detaching its parent works, but it is still broken and cannot be reattached, even after de-re-attaching both parts (Tele and Socket).

4b. Save/Load once more makes reconnecting possible again.

4c. Reloading while connected leads to the same error again. (KAS test 4)

Edited by KerbMav

Share this post


Link to post
Share on other sites

@KerbMav, I was able to reproduce the issue. I will take a look at it. Thank you for reporting and providing the logs!

Share this post


Link to post
Share on other sites

I seem to remember you could pull pipes from surface attached valves to one another at some point.

Also there were harpoons and magnets, winches - or was that IR?

Share this post


Link to post
Share on other sites
27 minutes ago, KerbMav said:

I seem to remember you could pull pipes from surface attached valves to one another at some point.

No idea what it is.

28 minutes ago, KerbMav said:

Also there were harpoons and magnets, winches - or was that IR?

This stuff is available in the old KAS only (0.6.3). As far as I understood from your previous report, you use KAS 1.0 Beta, and it doesn't have these parts yet. Btw, for the Beta there is a dedicated page. It describes what functionality is ready and what is planned.

 

Share this post


Link to post
Share on other sites
2 hours ago, IgorZ said:

No idea what it is.

 

KAS_CPort1

At least it should be. Building pipes from (right clicking) an attached thingy pulled to another thingy.

Spoiler

MODULE
    {
        name = KASModuleStrut
        nodeTransform = plugNode
        type = PipeSize1    
        maxLenght = 20
        maxAngle = 100
        breakForce = 600
        allowDock = true
        allowPumpFuel = true
        hasCollider = false
        tubeScale = 0.15
        jointScale = 0.15
        textureTiling = 1
        tubeSrcType = Joined
        tubeTgtType = Joined
        evaStrutPos = (0.05, 0.059, -0.21)
        evaStrutRot = (190.0, 0.0, 0.0)
        tubeTexPath = KAS/Textures/pipe
    }

Guess it will be your RTS-1 later?

Also: I totally overlooked that there are two versions, two threads, two files in my mod storage folder ... :D

Edited by KerbMav

Share this post


Link to post
Share on other sites
7 minutes ago, KerbMav said:

KAS_CPort1

At least it should be. Building pipes from (right clicking) an attached thingy pulled to another thingy.

  Reveal hidden contents

MODULE
    {
        name = KASModuleStrut
        nodeTransform = plugNode
        type = PipeSize1    
        maxLenght = 20
        maxAngle = 100
        breakForce = 600
        allowDock = true
        allowPumpFuel = true
        hasCollider = false
        tubeScale = 0.15
        jointScale = 0.15
        textureTiling = 1
        tubeSrcType = Joined
        tubeTgtType = Joined
        evaStrutPos = (0.05, 0.059, -0.21)
        evaStrutRot = (190.0, 0.0, 0.0)
        tubeTexPath = KAS/Textures/pipe
    }

Guess it will be your RTS-1 later?

"Pipes from nowhere" is a concept of old KAS, it's banned in KAS 1.0. The closest equivalent in the new KAS will be RTS-1, but it's a part which has a flexible pipe reserve. It's not the same as in the old KAS where you can bring two small things (cPort's) and then establish a 30 meters rigid link.

Share this post


Link to post
Share on other sites
Just now, IgorZ said:

"Pipes from nowhere" is a concept of old KAS, it's banned in KAS 1.0. The closest equivalent in the new KAS will be RTS-1, but it's a part which has a flexible pipe reserve. It's not the same as in the old KAS where you can bring two small things (cPort's) and then establish a 30 meters rigid link.

Ah, ok. So the pipe will be more of a hose with limited length?

Do you plan to have some ways of connecting (for refueling) without making it one vessel - like DMagics EVA Fuel Transfer?

Share this post


Link to post
Share on other sites
1 minute ago, KerbMav said:

Ah, ok. So the pipe will be more of a hose with limited length?

Correct. It will b a hose.

1 minute ago, KerbMav said:

Do you plan to have some ways of connecting (for refueling) without making it one vessel - like DMagics EVA Fuel Transfer?

It was the plan for RTS-1. I haven't started R&D on this part yet. There are some technical issues on transferring resources between two vessels. The problem can be solved when user does a manual transfer, but for the automatic resources distribution (e.g. when a converter or a drill is working) it's tricky. RTS-1 is next in the list after the winch which is half-done at the moment.

Share this post


Link to post
Share on other sites
17 minutes ago, IgorZ said:

The problem can be solved when user does a manual transfer, but for the automatic resources distribution (e.g. when a converter or a drill is working) it's tricky

Roverdude does something similar in his MKS/USI LS, where vessels in a certain distance - without even being connected - share resources, but I guess it works completely different from what you want to do.

Share this post


Link to post
Share on other sites
12 minutes ago, KerbMav said:

Roverdude does something similar in his MKS/USI LS, where vessels in a certain distance - without even being connected - share resources, but I guess it works completely different from what you want to do.

Yeah, I had a plan to investigate his code if I don't find a simple solution on my own :)  Last time I did deep game core investigation it was 1.1.2. They've improved it a lot since then.

Share this post


Link to post
Share on other sites

Found an important step to remember. Shut off drills and retract them before attaching to the ship. I left my harvester running and attempted to connect to it with a cargo drone and I summoned the Kraken. Only six pieces were left and were going on an interstellar trajectory. Luckily no Kerbals were involved. 

Share this post


Link to post
Share on other sites
4 minutes ago, NNYGamer said:

Found an important step to remember. Shut off drills and retract them before attaching to the ship. I left my harvester running and attempted to connect to it with a cargo drone and I summoned the Kraken. Only six pieces were left and were going on an interstellar trajectory. Luckily no Kerbals were involved. 

Was it old KAS (0.6.3) or the Beta one?

Share this post


Link to post
Share on other sites
4 minutes ago, memes in space said:

Anyone know how to download this without getting a virus? Specifically, has anyone put it on SpaceDock instead of CrapForge?

Virus? You can also download both 0.6.3 and 1.0beta through the GitHub releases tab. GitHub link is at the bottom of the OP if you wish to avoid Curse.

Share this post


Link to post
Share on other sites
1 minute ago, Aelfhe1m said:

Virus? You can also download both 0.6.3 and 1.0beta through the GitHub releases tab. GitHub link is at the bottom of the OP if you wish to avoid Curse.

Ah, should have been more visible. Thank you!

EDIT: Ah crap, you can only get releases of 1.0 beta. Whatever, stability isn't a thing to me. Should have put releases of stable versions on github but what can you do eh? :/ 

Edited by memes in space

Share this post


Link to post
Share on other sites
2 hours ago, memes in space said:

Anyone know how to download this without getting a virus? Specifically, has anyone put it on SpaceDock instead of CrapForge?

Why do you think Curse Forge infects the binaries? If you're so suspicions there is an MD5 hash for every release. Download the release and check the hash on your side before the installation.

2 hours ago, memes in space said:

Ah, should have been more visible. Thank you!

EDIT: Ah crap, you can only get releases of 1.0 beta. Whatever, stability isn't a thing to me. Should have put releases of stable versions on github but what can you do eh? :/ 

Beta is significantly different from the non-beta. You may think it's another mod.

As of which platform to use for the binary releases, this question has been discussed several times already. I put binaries only to Curse Forge. Anyone is free to grab a binary from there (or build from the sources to guarantee there are no viruses inside) and put the resulted binaries somewhere else.

Share this post


Link to post
Share on other sites
17 hours ago, IgorZ said:

Why do you think Curse Forge infects the binaries? If you're so suspicions there is an MD5 hash for every release. Download the release and check the hash on your side before the installation.

I don't like going on a site with download timers and advertisements. Most other sites that have that usually inject viruses (Download.com)

17 hours ago, IgorZ said:

Beta is significantly different from the non-beta. You may think it's another mod.

As of which platform to use for the binary releases, this question has been discussed several times already. I put binaries only to Curse Forge. Anyone is free to grab a binary from there (or build from the sources to guarantee there are no viruses inside) and put the resulted binaries somewhere else.

¯\_(ツ)_/¯

 You should try SpaceDock. It's like curse but is actually good.

Share this post


Link to post
Share on other sites
10 minutes ago, memes in space said:

I don't like going on a site with download timers and advertisements.

Then use the kerbal.curseforge.com version instead of default Curse. Same content but no adverts or timers.

Share this post


Link to post
Share on other sites
1 hour ago, Aelfhe1m said:

Then use the kerbal.curseforge.com version instead of default Curse. Same content but no adverts or timers.

Ooh yay it's still supporting a shady company. No thanks, I'll stick with people who have morals like not trying to give your users viruses. *cough*spacedock.info*cough*

Share this post


Link to post
Share on other sites

How to increase the strength of fastening parts to the planet surface? Attached the part to the surface - it breaks off at the slightest jerk. I want the detail to be held so tightly.

Share this post


Link to post
Share on other sites
53 minutes ago, Oyster said:

How to increase the strength of fastening parts to the planet surface? Attached the part to the surface - it breaks off at the slightest jerk. I want the detail to be held so tightly.

What part do you use? The strength is controlled by the part's value "staticAttachBreakForce":

	MODULE
	{
		name = ModuleKISItem
		volumeOverride = 100
		stackable = true
		allowPartAttach = AllowedWithKisTool
		allowStaticAttach = AllowedAlways
		staticAttachBreakForce = 200
	}

 

Share this post


Link to post
Share on other sites
12 minutes ago, IgorZ said:

What part do you use? The strength is controlled by the part's value "staticAttachBreakForce":


	MODULE
	{
		name = ModuleKISItem
		volumeOverride = 100
		stackable = true
		allowPartAttach = AllowedWithKisTool
		allowStaticAttach = AllowedAlways
		staticAttachBreakForce = 200
	}

 

Pylon. Thanks for the info.

After some update, the parts ostensibly are attached to the glue PVA.I try change this parameter strongly for other parts.For example, ports KAS sometimes break away from ships when they exit the warp.And if you attach the pylon to the ground - it will come off if it is touched by the kerbal.
Sorry for the errors, I'm using google translator. 

Edited by Oyster

Share this post


Link to post
Share on other sites
On 6/23/2017 at 1:21 AM, IgorZ said:

Was it old KAS (0.6.3) or the Beta one?

I have both running with no problems. I was using the beta to attach the two ships. It's not the mods fault, I had my drill unit disappear on me again without it being attached to anything but it was mining at the time. I've left it with drills deployed but not running and it seems fine. There's just too much bouncing with the drills that make them unstable. There needs to be some kind of flexible but solid ground mount, like pneumatic air bags used in car suspensions. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.