IgorZ

[1.8] Kerbal Attachment System (KAS) v1.5 - INCOMPATIBLE WITH KSP 1.7

Recommended Posts

7 minutes ago, icedown said:

I wasn't meaning use the arm directly, but allow a part to be grabbed and attached using KAS with a kerbal as long as the kerbal is in range of both the part and the attachment point, one idea would be putting a small part on the end of the arm that tells KAS that there are a couple more kerbals there to help.  All of my kerbals carry ladders and attach them where they are working, but they float off the ladders after a part or two.

KIS/KAS allows third-party mods to use their modules. It's possible to create a non-kerbal based part that will be able to attach/detach parts of any size and mass (e.g. a robotic arm). Such part was on the radar one year back but it's not anymore. If someone decides to create such an "arm" I'll be happy to help with advice, but creating one in scope of KIS (or KAS) doesn't seem feasible at the moment. These two mods are already heavy enough, and there is just one person supporting them :(

As a last resort you may simple increase mass/range limits in KIS to build huge things without bringing a team of kerbals :)

Share this post


Link to post
Share on other sites
38 minutes ago, IgorZ said:

KIS/KAS allows third-party mods to use their modules. It's possible to create a non-kerbal based part that will be able to attach/detach parts of any size and mass (e.g. a robotic arm). Such part was on the radar one year back but it's not anymore. If someone decides to create such an "arm" I'll be happy to help with advice, but creating one in scope of KIS (or KAS) doesn't seem feasible at the moment. These two mods are already heavy enough, and there is just one person supporting them :(

I'm wondering... Would that mean that it may be technically possible to make a part that could do this without a kerbal? I'm now imagining an arm that would work with a tiny command pod such as something from RoverDude's Exploration Pack to make something like a little powered suit, where a kerbal is in a tiny command pod can use KIS/KAS like a normal kerbal, but with greater reach/higher mass restriction.

If something like this is potentially possible, I now have a project for my next set of days off: teach myself to mod so I can make a KIS/KAS Kerbal Mech.

Share this post


Link to post
Share on other sites
2 hours ago, IgorZ said:

As a last resort you may simple increase mass/range limits in KIS to build huge things without bringing a team of kerbals :)

I'll look into it.  Is KIS or KAS where the checks for kerbals and mass limits get modified?

Share this post


Link to post
Share on other sites
4 hours ago, icedown said:

I'll look into it.  Is KIS or KAS where the checks for kerbals and mass limits get modified?

KIS. The value can be modified in one of the cfg files. Probably settings. 

Share this post


Link to post
Share on other sites

Is it possible to attach decouplers eith kas? I want to build a shuttle to launch to laythe, and then attach new boosters built with EL to come home.

Share this post


Link to post
Share on other sites
22 hours ago, Merkov said:

I'm wondering... Would that mean that it may be technically possible to make a part that could do this without a kerbal? I'm now imagining an arm that would work with a tiny command pod such as something from RoverDude's Exploration Pack to make something like a little powered suit, where a kerbal is in a tiny command pod can use KIS/KAS like a normal kerbal, but with greater reach/higher mass restriction.

If something like this is potentially possible, I now have a project for my next set of days off: teach myself to mod so I can make a KIS/KAS Kerbal Mech.

Not exactly like this. You can create a part that increases abilities (e.g. mass and distance limit) via "KISModulePickup" module, but you'll still need an EVA kerbal to operate.

 

Share this post


Link to post
Share on other sites

Hi all, I am very sorry if this was outlined already, but was curious is someone could overview for me if there is a 'beta' for 1.2 of KAS/KIS?  Can I help?  I have a 1.1.3 historical career that is using both and would like to contribute if I can.

Thank you

Share this post


Link to post
Share on other sites
2 hours ago, Senior Slaphead said:

Thanks KAS for saving my posterior...

Nice! But I'd use a couple of tiny ports and MechJeb to do the docking :)

Share this post


Link to post
Share on other sites

Maby im missing something but i cant seem to connect struts or fuel lines using KAS. I can place both ends of a strut but if i right click one of them there is no popup window. I first encountered this in 1.1.3 but i was running a lot of other mods so i figured it was probably some sort of mod conflict. But i just started updating to 1.2 pre-release and im still having the same issue even with only KIS and KAS installed. Any ideas? 

Share this post


Link to post
Share on other sites
1 hour ago, brandon3055 said:

Maby im missing something but i cant seem to connect struts or fuel lines using KAS. I can place both ends of a strut but if i right click one of them there is no popup window. I first encountered this in 1.1.3 but i was running a lot of other mods so i figured it was probably some sort of mod conflict. But i just started updating to 1.2 pre-release and im still having the same issue even with only KIS and KAS installed. Any ideas? 

KAS doesn't have fuel lines as a designated part. What part do you use as "a fuel line"? And do you use KAS provided strut parts? Stock struts and fuel lines will not work.

Share this post


Link to post
Share on other sites

Ok i feel kinda dumb now lol. I knew about the kas fuel connector but somehow missed the kas strut. Guessing stock struts were supported in an older version because i have seen several videos using them... atleast i think they were using the stock struts... May have to go back and recheck now lol. Sorry about that and thanks for the help.

Share this post


Link to post
Share on other sites
On 29.9.2016 at 4:19 PM, Errol said:

Is it possible to attach decouplers eith kas? I want to build a shuttle to launch to laythe, and then attach new boosters built with EL to come home.

Yes you should be able too, issue with radial decoplers is to get symmetry, its the same with all radial parts. 
Never used radial like this but has used the stack decoplers to make multi staged crafts. 
 

Share this post


Link to post
Share on other sites

Thread still says "Last updated June 27th, 2016 - v0.5.9 for KSP 1.1.3" whilst linked version is actually already v0.6.0 for KSP 1.2. Just for those looking for the update... It's already there :D

Share this post


Link to post
Share on other sites
16 minutes ago, DragonsForce said:

Thread still says "Last updated June 27th, 2016 - v0.5.9 for KSP 1.1.3" whilst linked version is actually already v0.6.0 for KSP 1.2. Just for those looking for the update... It's already there :D

Yeah, I was updating binaries in the middle of the night, so haven't fixed forum threads. All my mods are compatible with 1.2 as for now.

Share this post


Link to post
Share on other sites

Will not use this mod (unfortunately) until the nyan cat is removed from Module manager.

Edited by Devric

Share this post


Link to post
Share on other sites
21 minutes ago, Devric said:

Will not use this mod (unfortunately) until the nyan cat is removed from Module manager.

keep on trying to make us all care

Share this post


Link to post
Share on other sites
41 minutes ago, Devric said:

Will not use this mod (unfortunately) until the nyan cat is removed from Module manager.

KAS doesn't need ModuleManager to work.

Share this post


Link to post
Share on other sites
6 hours ago, KerbalXcer said:

Can somebody tell me how to install this?

I've added a section "How to install" to the topic starter message. Please, let me know if it helps.

Share this post


Link to post
Share on other sites

I had an issue with KAS struts that you may like to set me straight on.

Basically I had a docked payload that I had secured with additional KAS struts due to the weight (about 60 tons of gold). Obviously I'm used to struts between two docked craft just disappearing when you undock, but in this instance the struts remained in place so I could not maneuver the vessels away from each other.  The struts were evidently still in place although the visual effect had gone... I also had to disconnect the struts at both ends before it finally separated the craft (actually, as you can see, only two of the four struts... weird, eh?).

I don't know whether this is a thing or not... maybe they just have to work this way and if that is the case it's not that much of a problem in most situations (where you have kerbals to EVA and unlink stuff and there is no time imperative)... but all feedback welcome.

 

Edited by Senior Slaphead

Share this post


Link to post
Share on other sites
On 14/10/2016 at 7:57 PM, Senior Slaphead said:

I had an issue with KAS struts that you may like to set me straight on.

Basically I had a docked payload that I had secured with additional KAS struts due to the weight (about 60 tons of gold). Obviously I'm used to struts between two docked craft just disappearing when you undock, but in this instance the struts remained in place so I could not maneuver the vessels away from each other.  The struts were evidently still in place although the visual effect had gone... I also had to disconnect the struts at both ends before it finally separated the craft (actually, as you can see, only two of the four struts... weird, eh?).

I don't know whether this is a thing or not... maybe they just have to work this way and if that is the case it's not that much of a problem in most situations (where you have kerbals to EVA and unlink stuff and there is no time imperative)... but all feedback welcome.

 

Hi, I also had a problem similar to this. I have a Base on the Mun Surface, and I use a ship to transfer the fuel produced from the base on the Mun to the Space Station in orbit. I usually connect this ship to the Base on the surface with the pipes from KAS. The game and the mods were updated to the 1.2 version while the ship was landed and connected to the base through the KAS pipes. When I opened the game, the pipes visually weren't in place, but the entire Assembly (Base+Ship) were considered as one entity, as like the connection pipe was still in place. I tried to connect a new pipe and then detach it to see if I could undock the ship from the base, but it didn't work. Now I'll try to delete the connection ports both on the base and the ship and I'll edit the post with the result. If you have any other suggestions they would be very appreciated.

EDIT:
When I tried to detach the connection ports I discovered that all the inventories of the containers/seats on the base were empty. They weren't before the update (I had drills and other useful stuff in it). Now I'm sending the tools back up with another ship and I'll try again to detach the connection ports.

Edited by Luke Duckwalker
Update on the situation

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.