Jump to content

[Minimum KSP version - 1.11] Kerbal Attachment System (KAS) v1.10


IgorZ
 Share

Recommended Posts

8 hours ago, memerman02 said:

unrelated topic

but i was wondering why you removed the harpoons and the other items alike and the features that came with them and if you would be willing or have plans to add them back in for 1.12.2

There was no intent to remove them altogether. About that time Squad started adopting the newer Unity versions that changed physics a lot, and made many of the KAS harpoon parts not working properly. The idea was to get back to it when KAS 1.0 is fully done and re-design the parts on the new codebase. However, I didn't find time for that. If there will be enough people who chime in for this feature, I may reconsider the priority. So far there were may be 4-5 inquires with regard to these parts in a timespan of about 3 years.

Link to comment
Share on other sites

13 hours ago, IgorZ said:

, I didn't find time for that. If there will be enough people who chime in for this feature, I may reconsider the priority. So far there were may be 4-5 inquires with regard to these parts in a timespan of about 3 years

+1 chime! 

Link to comment
Share on other sites

I have used the winch, with a high ejection force and length,  to shoot the grappling hook to a mountain climb that my rover wasn't capable of ascending.  I have also connected the grappling hook to the edge of a cliff and winched my rover down to the bottom.  I have built major Rovers with trailers, cranes as well as all manor of winching needs.  How ever without the grappling hook I would have to get out, climb the cliff, attach a pilon, attach the winch to pilon to get my rovers up the mountains.  I NEED THE GRAPPLE HOOK good sir.   :)  One last thing PLEASE, could you bring back the insitu struts.  I always put them on my ships that have docking ports.  3-4 way placement with the same on the intended docking craft.  EVA out and link them up.  It gave me one more reason, thing to do while building and flying.

Edited by ArkaelDren
Link to comment
Share on other sites

6 hours ago, ArkaelDren said:

I have used the winch, with a high ejection force and length,  to shoot the grappling hook to a mountain climb that my rover wasn't capable of ascending.  I have also connected the grappling hook to the edge of a cliff and winched my rover down to the bottom.  I have built major Rovers with trailers, cranes as well as all manor of winching needs.  How ever without the grappling hook I would have to get out, climb the cliff, attach a pilon, attach the winch to pilon to get my rovers up the mountains.  I NEED THE GRAPPLE HOOK good sir.   :)  One last thing PLEASE, could you bring back the insitu struts.  I always put them on my ships that have docking ports.  3-4 way placement with the same on the intended docking craft.  EVA out and link them up.  It gave me one more reason, thing to do while building and flying.

I didn't get into KSP until late 1.8xx or early 1.9.xx and these mythical tales of the GRAPPLE HOOK make it sound so great.  It sounds like a ton of fun, even if not a completely necessary item.  What are the reasons that it was dropped?  Was it kraken prone? [edit] I just read back into the thread a bit and see the history.  I'm chiming in.  I'm also pretty sure that when I went looking for the grapple a few years back I did ask about it in either KIS/KAS/other forum on this site and only got crickets

Edited by darthgently
Ackshully read the thread
Link to comment
Share on other sites

Knowing that is not exactly easy to get those items back, I didn't wanted to pest about it. I didn't used harpoon that much, but I miss magnet, though (those use similar base code, I assume ?).
Take your own time and priority, no pressure from users side, no matter how much would all like to have those parts back.

Link to comment
Share on other sites

And now we have +4 "chime ins".  Which totals to 6 per a year, which is an absolute record this far! I heard you ladies and gentlemen. Once KISv2 is in beta, I'll get back to the "ejecting things" in KAS.

Link to comment
Share on other sites

I used the grapple and the magnet all the time, for collecting large debris in orbit.  I used the magnet for a lot of other things, as well.  When they disappeared I b*tched and moaned to myself - "Why?? How cruel!  How unfair!  Waaaaaah!" - but I didn't say anything on the forum because 'mod authors are volunteers and busy with their own lives and they probably dropped them for... reasons.'  But if, indeed, you could see your way to bringing them back, I would sing your praises to the heavens. 

Edited by wreckreation
Link to comment
Share on other sites

Another +1. I also used to 'shoot' magnets and harpoons to attach to vessels and the ground. In some of my craft I have a moveable firing arm with a light or even camera attached to make targeting easy (in zero g) or interesting (on the ground).

Link to comment
Share on other sites

Okay, it seems the "harpoon" topic gets the audience. So, let me share some insights. Here is the plan that I've made when working on the KAS v1 design (and this plan didn't become live):

  1. "HP-01 Harpoon" only attaches to asteroids and celestial bodies surface. You cannot hook a kerbal (it's a live being) or a part (it's metal and sturdy). Attaches at impact. EVA is required to detach the harpoon from the asteroid/surface.
  2. "HG-02 Grappling Hook" only attaches to the solid parts (no kerbals allowed). Attaches at impact. EVA is required to detach the hook from the part.
  3. "HE-03 Electro-Magnet" only attaches to the solid parts (no kerbals allowed). Attaches to the nearest part in range (limited) once the electricity supply is provided. No EVA required, it can detach from the winch action by just deactivating the electricity supply.

#1 and #2 don't require significant mod changes. I think I can make it pretty quick (given KISv2 is in beta). #3 is a different story - it will require the core changes.

You're free to throw your ideas and suggestions before the actual work has started.

Link to comment
Share on other sites

So, main difference between #2 and #3 (beside different part mesh) is that #2 require EVA to deattach hook and attachment is on impact. Both interact with solid parts. Assuming that it is easier and faster to code and deliver, I suppose that people could live without magnet for a bit longer time. So, maybe to ship KAS with functional harpoon and grappling hook first and create magnet later on when there is more time for it.

Unless, mentioned core changes to make functional magnet could break harpoon and grappling hook later on. In that case might be worthwile to wait a bit longer for all things to be available.

Gameplay wise, each part have it's own purpose to be in game. Long, long time ago, when I was learning docking maneuver, KAS with magnet was essential to me. Because it allowed me to get close enough with another ship in orbit, fire a magnet and attach two ships and get them closer to each other without actually docking two ships. Today, with multiple KSP and KAS versions later, when I got more efficient with docking (and creating personal kOS scripts for it), I no longer need magnet that much, but it still have some purpose when creating cranes and similar auxiliary crafts.

To summarise, while it would be nice to have functional magnet, I could live without it a bit longer if that means that harpoon and grappling hook can be recreated much sooner. Still, take your time with it when you can.

Link to comment
Share on other sites

Chime!

Sounds like the harpoon and grapple are pretty close to the same thing. I reckon just make the grapple attach to anything solid and be able to be fired like the harpoon and you are covered all in 1 part.

Link to comment
Share on other sites

The Harpoon and Grappling Hook distinction is definitely a good idea; I'm hoping for a decently lightweight Harpoon (+ operating infrastructure) to build cool unmanned asteroid missions. Could do it with the claw Jr., but Harpoon is cooler.
I'm not entirely sure if the Magnet v Grappling Hook distinction is actually valuable enough to justify the effort of implementing an additional part (instead of just the magnet); but that's your call. Of course the magnet could also have other advantages like increased link strength and lower weight; and if I understand it correctly, the plan is also to have it attach more easily (how many times has the claw failed to grab for me...).
Inability to grapple Kerbals is reasonable, but I predict that someone will come up with a whacky fun contraption that requires grabbing Kerbals, and they will be very disappointed.

Link to comment
Share on other sites

16 hours ago, DragonsForce said:

Of course the magnet could also have other advantages like increased link strength and lower weight

The magnet can be used on the unmanned crafts. All the other parts require a kerbal EVA.

Link to comment
Share on other sites

Just an FYI, I just installed KSP 1.12.2 and installed KIS/KAS from CKAN and KAS failed as KSPDevUtils was not installed/loaded, so maybe it needs to be in CKAN requirements/dependency list for KAS.  If I'm missing something, like KAS is no longer required separate from KIS, then please let me know.  Currently I just installed KSPDevUtils separately on CKAN and it so far has made it into the meat of the loading process

Edited by darthgently
Link to comment
Share on other sites

8 hours ago, darthgently said:

Just an FYI, I just installed KSP 1.12.2 and installed KIS/KAS from CKAN and KAS failed as KSPDevUtils was not installed/loaded, so maybe it needs to be in CKAN requirements/dependency list for KAS.  If I'm missing something, like KAS is no longer required separate from KIS, then please let me know.  Currently I just installed KSPDevUtils separately on CKAN and it so far has made it into the meat of the loading process

How exactly did the KAS failed and how you knew it was indeed KAS? Was it a record in the logs?

Just to clarify, the following record from the game's log doesn't indicate a real error.

[ERR 14:57:18.948] ADDON BINDER: Cannot resolve assembly: KSPDev_Utils.2.6-KAS, Culture=neutral, PublicKeyToken=null

 

Link to comment
Share on other sites

5 hours ago, IgorZ said:

How exactly did the KAS failed and how you knew it was indeed KAS? Was it a record in the logs?

Just to clarify, the following record from the game's log doesn't indicate a real error.

[ERR 14:57:18.948] ADDON BINDER: Cannot resolve assembly: KSPDev_Utils.2.6-KAS, Culture=neutral, PublicKeyToken=null

 

It was a CKAN error, as I recall.  I couldn't successfully install KAS until I selected KSPDevUtils in CKAN 

Link to comment
Share on other sites

18 hours ago, darthgently said:

It was a CKAN error, as I recall.  I couldn't successfully install KAS until I selected KSPDevUtils in CKAN 

Could you please try reproducing the error and attaching the logs? There is no any dependency on KSPDev in CKAN config. I wonder how CKAN could even match KAS and KSPDev.

Link to comment
Share on other sites

Wow, when I attempt to put a solar panel on a vessel in orbit, the vessel starts acclerating (no engines on and no RCS) and I can't control it.  Not using the KAS functions to attach the solar panel (it is stored in a stock inventory store) so I have no idea what is causing the actual issue. KSP 1.12.2, Breaking Ground, Making History, KAS, KIS, EPL, MechJeb2 and others installed.  Is this some kind of known issue?  I guess I need to look at some logs or go back to using just KAS to put parts on.  Issue is recreatable at this point.   When I quit the game it notifies me that the vessel is under accleration and that it will revert to the last save game (so glad I saved before attempting to put parts on).

 

This maybe a KSPIE issue.  This is the only log entry that suggests something is causing accleration. From player.log:

[KSPI]: FNSolarPanelWasteHeatModule Force Activated  solarPanels4 

Edited by pmoffitt
Added KIS to installed mods.
Link to comment
Share on other sites

On 11/25/2021 at 5:38 AM, darthgently said:

It was a CKAN error, as I recall.  I couldn't successfully install KAS until I selected KSPDevUtils in CKAN 

There is a lot reports lately that some mod become a victim of previously not properly installed and loaded plugin. When it happens, all other plugins fail to load properly after that one. It can be your case too, but can only guess without full logs. @Lisiashave dealed a lot of those lately trough TS support, he can tell more detail about it than I'm able to tell.

Link to comment
Share on other sites

2 hours ago, pmoffitt said:

Not using the KAS functions to attach the solar panel (it is stored in a stock inventory store)

To start with, KAS doesn't deal with attaching parts. It's KIS that does. And you say you haven't used KIS to attach the panel. So, what part of KIS or KAS have you used? Why do you believe any of these mods are related to the issue you observe?

Link to comment
Share on other sites

3 hours ago, pmoffitt said:

Wow, when I attempt to put a solar panel on a vessel in orbit, the vessel starts acclerating (no engines on and no RCS) and I can't control it.  Not using the KAS functions to attach the solar panel (it is stored in a stock inventory store) so I have no idea what is causing the actual issue. KSP 1.12.2, Breaking Ground, Making History, KAS, KIS, EPL, MechJeb2 and others installed.  Is this some kind of known issue?  I guess I need to look at some logs or go back to using just KAS to put parts on.  Issue is recreatable at this point.   When I quit the game it notifies me that the vessel is under accleration and that it will revert to the last save game (so glad I saved before attempting to put parts on).

 

This maybe a KSPIE issue.  This is the only log entry that suggests something is causing accleration. From player.log:

[KSPI]: FNSolarPanelWasteHeatModule Force Activated  solarPanels4 

hi, i ve got same issue. I not using kis or kas for the moment. i ve got mechjeb2. When Eva and trying to attach part from inventory. I ve got several issues, not always occuring :

If i stay attache to the vessel (sorry don t remember the good word but it s with F key) sometimes the vessel and i begins to shake badly and it happens once the part i try to attach becomes duplicate.

More often, when in pure EVA (i m not attach to the vessel) it comes that when i move i realize that me and the vessel move. i nearly lost my space station around Mun, cause the periapis was descending constantly (and rapidly) to zero. The only solution for me was to use hyperedit to make a new orbit. At this moment my kerbinaut was far away (other side of Mun) of the station. I don 't know what is causing this issue, but it s definitivly not KIS or KAS.

Edited by LTQ90
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...