Jump to content

[Minimum KSP version - 1.11] Kerbal Attachment System (KAS) v1.12


IgorZ
 Share

Recommended Posts

I did a test base on kerbin, and so far so forth I have encountered a problem with some part from various mods (will cp on their respective therads)

- KAS:

  1. pipe texture (hose-d70-1k.dds) on folder, but still getting a message (IG) that texture is missing.
  2. Docking 2 pylons on steroids with 3 gold diggers and a Radioisotope with a joint socket and a Telescopic fixed join works well until I attach something else using Pathfinder piping. Something randomly explodes or the pylon that where attached to the ground get thrown up and detached.
  3. If leaving something unattached to the base (but still bolted on ground) and coming back (back to Space Center and launch a new vessel to continue building) the unlinked unlocked part is nowhere to be found. Don't know which mod is responsible but I think it may be basic KAS behaviour?.

- Universal Storage 2:

  1. The Universal Storage Alkaline Cell consumes O2 and H2 and produces H2O as intended, but the Elecktron does not consumes water, nor it transforms it on H2 and O2.
  2. The US2 Battery does not have any charge in it when I launch my vessel (same with the Pathfinder chasis). It shows electricity function on building menu but when launch it does not contain any electricity (like there is not electrical function)

- Pathfinder:

  1. Batteries on Buffalo chassis does not works as intended. It shows electricity function on building menu but when launch it does not contain any electricity (like there is not electrical function)
  2. Docking 2 pylons on steroids with 3 gold diggers and a Radioisotope with a joint socket and a Telescopic fixed join works well until I attach something else using Pathfinder piping. Something randomly explodes or the pylon that where attached to the ground get thrown up and detached.
  3. If leaving something unattached to the base (but still bolted on ground) and coming back (back to Space Center and launch a new vessel to continue building) the unlinked unlocked part is nowhere to be found. Dont know which mod is responsible but I think it may be basic KAS behaviour?.

Edit: Yes, I have reinstalled and checked if everything is where it should be (by comparign CKAN downloaded rar with folders in Game Data). Still, problems persist.

I use nearly 100 mods in total.

Thank you guys for your amazing mods (that totally should be stock).

Edited by Zankastia
Stuff
Link to comment
Share on other sites

10 hours ago, Zankastia said:

pipe texture (hose-d70-1k.dds) on folder, but still getting a message (IG) that texture is missing.

Could you, please, share the log? Dos the RTS-1 part works fine? It's the only part that uses this texture for now.

10 hours ago, Zankastia said:

Docking 2 pylons on steroids with 3 gold diggers and a Radioisotope with a joint socket and a Telescopic fixed join works well until I attach something else using Pathfinder piping. Something randomly explodes or the pylon that where attached to the ground get thrown up and detached.

Pathfinder uses old KAS to make connections. In spite of I'd expect the old KAS and the new KAS do not affect each other, it seems there are edge cases. Most of the exploding and jumping issues in the old KAS are a result of making rigid joints (the stock game never does it unless configured it via the part config). And it was one of the reasons to create a new KAS, which pays much more attention to the joints settings. That said, it's not going to be fixed. The old KAS is a legacy.

10 hours ago, Zankastia said:

If leaving something unattached to the base (but still bolted on ground) and coming back (back to Space Center and launch a new vessel to continue building) the unlinked unlocked part is nowhere to be found. Don't know which mod is responsible but I think it may be basic KAS behaviour?.

Which launchpad are you using? The VAB's one has a bogus setup, and small parts fall thru it pretty frequently. I'd suggest you doing experiments on the runway. Anyways, this is a generic game issue. It's not related to any mod.

Link to comment
Share on other sites

@IgorZ Just to see what would happen I did something stupid that goes onto the "Never do that again" list. Do not board a vessel while you have the hose from an RTS-1 attached to your Kerbal. While I was outside of a base the thought crossed my mind, "I wonder what happens if I do this." So I grabbed a connector and stepped inside. It does very bad things. I had debug messages being displayed on the screen and exceptions were being thrown. The hose was left hovering next to the hatch the Kerbal entered with no connector on the end. I could not lock the connector to retract the hose. I sent the same Kerbal back outside, took the RTS-1 off the parent part (the hose still appeared extended, clipped into the ground) and finally attempted to put the RTS-1 into the KIS inventory of the Kerbal to see if that would reset it. At this point KSP crashed to desktop. 

I don't know how frequently something like this might happen, and really there is no reason someone should do it, but you can't prevent players from doing stupid things. :) I thought it should be brought to your attention. I didn't capture a log since the steps to repeat the issue were easy to define.

Link to comment
Share on other sites

4 hours ago, Tonka Crash said:

@IgorZ Just to see what would happen I did something stupid that goes onto the "Never do that again" list. Do not board a vessel while you have the hose from an RTS-1 attached to your Kerbal. While I was outside of a base the thought crossed my mind, "I wonder what happens if I do this." So I grabbed a connector and stepped inside. It does very bad things. I had debug messages being displayed on the screen and exceptions were being thrown. The hose was left hovering next to the hatch the Kerbal entered with no connector on the end. I could not lock the connector to retract the hose. I sent the same Kerbal back outside, took the RTS-1 off the parent part (the hose still appeared extended, clipped into the ground) and finally attempted to put the RTS-1 into the KIS inventory of the Kerbal to see if that would reset it. At this point KSP crashed to desktop. 

Thanks for reporting. I've actually found it myself, and had it fixed :) It's KSP 1.5 issue. This case was explicitly handled and everything was working fine in 1.4 (when I last time tested it).

Link to comment
Share on other sites

Will there ever be consideration for a "less realism" option or version that supports the old simpler functionality (all pipes/connectors work with all connection points)?  There are times where simpler is simply better for gameplay.   Not everyone wants to be Scott Manley :D

Link to comment
Share on other sites

23 minutes ago, Murdabenne said:

Will there ever be consideration for a "less realism" option or version that supports the old simpler functionality (all pipes/connectors work with all connection points)?  There are times where simpler is simply better for gameplay.   Not everyone wants to be Scott Manley :D

I don't plan to make and support such parts. However, the new KAS is an open platform, so any part, including the legacy "pipes-from-nowhere" one, can be done on top of it.

Link to comment
Share on other sites

3 hours ago, IgorZ said:

Was playing with KSP shaders and found this. A glass pipe!

GSmFBhH.jpg

Any design ideas on a part which can use it?

Clean rooms, science areas, that sort of thing?  Could be glass, could be clear plastic. Also sets up the tech to make things like Thrimm's glass domes be more inter-connective,

Link to comment
Share on other sites

16 hours ago, IgorZ said:

Was playing with KSP shaders and found this. A glass pipe!

Any design ideas on a part which can use it?

Transparent Aluminum, cool :wink:.  Observation domes, habitats, hydroponics/agroponics, underwater facilities, tubes and corridors, science experiments requiring windows, fish tanks (aquaculture parts??).  If you can change the opacity, sun screens.  Not so much "flexible" anything, though; too rigid for expanding parts.

Edited by Brigadier
Link to comment
Share on other sites

@IgorZ I was thinking about KAS Pipes and avoiding pipes from nowhere. How hard would it be to create a part to be the pipe material. Disconnected it looks like a coil of hose a Kerbal would carry, attach it to a connector and it's still a coil. When a Kerbal grabs the end and the coil disappears and from then it behaves like an old pipe with a ghosted line from the connector to the Kerbal until you connect the other end and it becomes a flexible hose between two connectors. Disconnect an end and the hose reappears as a coil attached at the other end.  It would only function in docked mode with no gui.

Edited by Tonka Crash
Link to comment
Share on other sites

5 hours ago, Tonka Crash said:

@IgorZ I was thinking about KAS Pipes and avoiding pipes from nowhere. How hard would it be to create a part to be the pipe material. Disconnected it looks like a coil of hose a Kerbal would carry, attach it to a connector and it's still a coil. When a Kerbal grabs the end and the coil disappears and from then it behaves like an old pipe with a ghosted line from the connector to the Kerbal until you connect the other end and it becomes a flexible hose between two connectors. Disconnect an end and the hose reappears as a coil attached at the other end.  It would only function in docked mode with no gui.

I was thinking about a coil with the hose/wire reserve too. The main question here is how to to make this new part usable and which changes will be needed to the existing KAS design. It can be a KIS item, but this will bind KAS to KIS which I'm trying to avoid. Or it can be a separate part which does what you have described, but this will require significant changes into the existing KAS design.

There is a small part in development to solve the issue for the electricity transferring: it will be a variation of RTS-1, but with the option to automatically transfer electricity charge between the vessels when the vessel is loaded and unpacked (that's a limitation). For now it's in a very early stage, I don't even have a model for it.

For now I'm not actively working on anything described above (that's why I was not announcing it). My top priority for now is finalizing and releasing the Bezier pipes + a fix to have K&K and Pathfinder flexible corridors unblocked. And given the incoming US holidays there will be a delay :)

Link to comment
Share on other sites

Perhaps another compromise?

You include the components in KAS, but they only display in partlist if KIS is also present?

 

For myself i usually make exits and corridors with the hard struts/connectors from mks.

Or i have a rover docked for easy transportation. Standardlized roverdockingports helps the rovers to move around different bases.

Link to comment
Share on other sites

@IgorZ How do you decide where the line is between KIS and KAS.  I get that KAS deals with transfers and has parts to support that, while KIS handles the mechanic for attaching/detaching parts and has tools too support that function, but where the line is drawn has always been a little fuzzy to me especially when both have a ground pylon/base that originally just seemed to differ in appearance. From what I can tell KAS cannot be used without KIS while KIS can exist without KAS you just lose resource transfer and KAS specific parts.

Edited by Tonka Crash
Link to comment
Share on other sites

4 minutes ago, Tonka Crash said:

@IgorZ How do you decide where the line is between KIS and KAS.  I get that KAS deals with transfers and has parts to support that, while KIS handles the mechanic for attaching/detaching parts and has tools too support that function, but where the line is drawn has always been a little fuzzy to me especially when both have a ground pylon/base that originally just seemed to differ in appearance. From what I can tell KAS cannot be used without KIS while KIS can exist without KAS you just lose resource transfer and KAS specific parts.

Both KIS and KAS deal with attachments, it just presented in a different way. The main difference is the inventory. If the part's use case assumes it must be carried/equipped on, then it's 100% KIS part. It doesn't necessarily mean this part should be released in the KIS mod, it means that KIS for this part is a hard dependency. Many mods provide parts that can be used without KIS, but with KIS installed some extra ability appears - it's a soft dependency.

KAS, as of now, doesn't have any dependency on KIS. You can install KAS alone and start connecting vessels in flight - simply equip the ports and winches/rts on the vessels in the editor. However, if we design a "pipe reserve" part that needs to be held in the kerbals backpack, then there will be a hard dependency, since without KIS this part won't be usable at all.

26 minutes ago, mrstoned said:

You include the components in KAS, but they only display in partlist if KIS is also present?

It would improve UI, but won't fix the main issue with the dependency. Btw, hiding a part depending on the mods installed in the game is a challenging task.

Link to comment
Share on other sites

I don't suppose anyone happens to know any way to replace every instance of Part A with Part B across a save file, since if those legacy parts actually get removed every single vessel in my career save will disappear? ^_^;

 

Meanwhile I've been wondering how I can possibly get modular stations built without the Portable Strut.  Would it perhaps be possible to allow the tension cable and hook parts to have a connector node on the base as well as surface attach capability?  (Then I could build station parts with pre-placed 'Tweakscaled' Radial Attachment Nodes, and have a Kerbal in EVA with a pocket full of cables and hooks bolt everything in place as required, without having to do surface attachment to a curved, clipping-prone surface in zero gravity...)

Link to comment
Share on other sites

On 11/26/2018 at 1:04 AM, ChrisF0001 said:

I don't suppose anyone happens to know any way to replace every instance of Part A with Part B across a save file, since if those legacy parts actually get removed every single vessel in my career save will disappear? ^_^;

I doubt there is a way to do such replacement automatically. Every part has different modules with different settings. Not to mention the saved internal state and MM patches. Plus, only few new KAS parts can be more or less mapped to the old parts. Btw, in order to have the save game loaded you only need the part configs, not the DLL that implements the active logic. Of course, without DLL the loaded vessel will not be fully operational, but at least you'll get c chance to remove the deprecated parts witt KIS (or just leave the non-functional parts on the vessel).

On 11/26/2018 at 1:04 AM, ChrisF0001 said:

Meanwhile I've been wondering how I can possibly get modular stations built without the Portable Strut.  Would it perhaps be possible to allow the tension cable and hook parts to have a connector node on the base as well as surface attach capability?

Interesting idea. It can actually work. A new model will be needed, though. Recorded it just for the memory.

Link to comment
Share on other sites

  • 2 weeks later...

I tried connecting 2 ships on Minmus, but when I right click on JS-1 Joint Socket I don't get options for linking, however if I try the same with CS-R2 portable strut, I do get Link option. What am I doing wrong?

Attached pictures to try and explain better

 

cOgd32J.jpg

S7AiQdD.jpg

UOLd3LX.jpg

 

thank you

Link to comment
Share on other sites

8 hours ago, te45a said:

I tried connecting 2 ships on Minmus, but when I right click on JS-1 Joint Socket I don't get options for linking, however if I try the same with CS-R2 portable strut, I do get Link option. What am I doing wrong?

Attached pictures to try and explain better

cOgd32J.jpg

thank you

Looks like you're pretty far away. Does it also happen when you get closer using the jetpack?

Link to comment
Share on other sites

12 hours ago, infinite_monkey said:

Looks like you're pretty far away. Does it also happen when you get closer using the jetpack?

yes, no mater how close I am same thing happens, when I step back then I get a warning saying I'm too far away

Link to comment
Share on other sites

On 12/11/2018 at 9:40 AM, Brimarx said:

A big thank you for KIS/KAS! They make base and station building so much more enjoyable and help my Kerbals feel useful again :)

You're welcome! Couple of years ago it became a deal breaker for me as well. That's how I've ended up maintaining these mods :) 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...