Jump to content

[Minimum KSP version - 1.11] Kerbal Attachment System (KAS) v1.12


IgorZ
 Share

Recommended Posts

2 hours ago, Rodger said:

The resource processors would need a small holding tank on the isru craft, then you can transfer the resources out of that tank into the main tanks.

Oh, that's disappointing.. When I connect with a claw it works to directly refill the tanks of the connected craft, instead of having to transfer resources myself.

Link to comment
Share on other sites

8 hours ago, Folkhoer said:

Just installed KiS and KaS. When I right click a joint socket I don't seem to get the option to link them. Is this a known bug?
 

Your kerbal has to be carrying a hose end and close enough to the connector. The old connector-connector functionality is long gone. As for why, one of the reasons is documented in section 4.2.1 here (I wrote that section shortly after figuring out the nature of the base Kraken, but long after @IgorZ made the change: with respect to KAS, it's more an explanation of why the old functionality invited trouble, and why leaving the current hose functionality in docked mode can be trouble).

 

Link to comment
Share on other sites

On 7/6/2022 at 3:04 AM, TanoPrime said:

Would an ISRU setup still work without docking? The drills and converter are on one craft, the fuel tanks to be filled are on the other craft.

ISRU only works with the parts in the same vessel. That being said, the vessel attached in undocked mode won't get resources automatically. When you need to build a factory from multiple vessels, detach wheels and legs from them before docking. And in general, avoid building too spread bases. Btw, this docking issue usually happens on the small gravity planets. I guess it's due to imbalanced reaction of the wheel/legs.

Link to comment
Share on other sites

On 5/29/2022 at 3:03 AM, IgorZ said:

Yes, it's KISv2. This functionality is already available in the alpha version. It really helps doing the test job :) 

How do I install the new KISv2 from the massive code library you got in GitHub?

Link to comment
Share on other sites

On 7/11/2022 at 4:53 AM, IgorZ said:

ISRU only works with the parts in the same vessel. That being said, the vessel attached in undocked mode won't get resources automatically. When you need to build a factory from multiple vessels, detach wheels and legs from them before docking. And in general, avoid building too spread bases. Btw, this docking issue usually happens on the small gravity planets. I guess it's due to imbalanced reaction of the wheel/legs.

I will try it with legs and wheels detached.

Link to comment
Share on other sites

On 7/7/2022 at 5:14 PM, TanoPrime said:

Does the ground anchor allow for docking craft to planetary bodies?

Ex, placing a ground anchor plus a docking port on Gilly, docking an ISRU craft to it to refuel.

?

Link to comment
Share on other sites

@IgorZ Why can I only attach the Grappling Hook to another part ONLY when I eject the winch cable? I even changed the <forceNeeded> from the cfg  to = 0.01, yet it won't attach when only extending pacefully the winch... 
I have a problem with ejecting, as when it lands on the part, it just won't attach to the point I want (the very center of mass). It will grapple a few cm away. I tried checking and unchecking "Align to hit normal" and many other things in the KAS Part Adjustment tool but it just won't work.

Any ideas?

Link to comment
Share on other sites

On 7/12/2022 at 7:51 AM, adriangm44 said:

How do I install the new KISv2 from the massive code library you got in GitHub?

https://github.com/ihsoft/KIS2/releases
Pick a release and have fun.

10 hours ago, adriangm44 said:

@IgorZ Why can I only attach the Grappling Hook to another part ONLY when I eject the winch cable? I even changed the <forceNeeded> from the cfg  to = 0.01, yet it won't attach when only extending pacefully the winch... 
I have a problem with ejecting, as when it lands on the part, it just won't attach to the point I want (the very center of mass). It will grapple a few cm away. I tried checking and unchecking "Align to hit normal" and many other things in the KAS Part Adjustment tool but it just won't work.

Any ideas?

The hooks attach on impact. Period. They are designed this way. If you want them get attached, make the impact. There is no any other way you can achieve it.

Quote

it just won't attach to the point I want (the very center of mass)

All ejectable parts attach to the point they hit. If it's not the point "you want", then try aiming better before ejecting.  And I don't see any realistic scenario when the ejected part attaches at CoM. Simply because CoM is usually located inside the part< and the harpoons attach at the surface of the part.

On 7/14/2022 at 4:38 AM, Alexsys said:

How does the grappling hook / harpoon work? ive got no idea how to use em :)

Have you read this?

 

Link to comment
Share on other sites

1 hour ago, IgorZ said:

https://github.com/ihsoft/KIS2/releases
Pick a release and have fun.

The hooks attach on impact. Period. They are designed this way. If you want them get attached, make the impact. There is no any other way you can achieve it.

All ejectable parts attach to the point they hit. If it's not the point "you want", then try aiming better before ejecting.  And I don't see any realistic scenario when the ejected part attaches at CoM. Simply because CoM is usually located inside the part< and the harpoons attach at the surface of the part.

Have you read this?

 

grapple hook is awesome

Link to comment
Share on other sites

5 hours ago, IgorZ said:

All ejectable parts attach to the point they hit. If it's not the point "you want", then try aiming better before ejecting.

Actually I tried with the Harpoon (Tweaked the cfg file and allowed part attach), and this one indeed attaches to wherever it lands. The Grappling Hook, instead, does but manages to drift to the side before attaching, no matter how close you are when ejecting (I tried dozens of times and it only works with the Harpoon). Anyways, that's sorted, Harpoon works just as I wanted.

This is my concern now, remember this? -->

On 1/24/2022 at 12:01 PM, adriangm44 said:

There’s a payload on top of a landed rocket, I deploy a built-in crane, then dock the winch on the payload, decouple payload from beneath and then off to the ground with the winch.

On 1/25/2022 at 2:55 AM, IgorZ said:

I think I get it now. Are you looking for a feature to "pre-attach" the winch connector in the editor with the cable deployed? If yes then, this feature is unlikely to be made anytime soon. I considered it once, but implementation complications made me give up.

With the Harpoon and Grappling Hook this is totally fixed, but my aim is still the same: DELIEVER HEAVY PAYLOADS FROM THE TOP OF ROCKETS (specially Starship), ONTO GROUND LEVEL. And I'm still running into some problems that you can see in this video:

Spoiler

- The crane deploys automatically with the KAL sequencer. Once it's at the top, I manually adjust the height so it can be closer to the payload in order to not crush it into the walls when I lift it up. 
- Manually, I have to eject the winch, stretch the cable, separate the payload, and then retract the cable until it's docked.
- Then gargo moves along the rail, separating from the ship, and once it's further enough, I can then slowly extend the winch cable until the payload is on the ground.

PROBLEM 1: Theres no action group for Eject, nor Instant Stretch in the action group pannel, so I cannot automatically sequence the lifting of the payload.
PROBLEM 2: The integrity of the winch and the harpoon (when the plug is docked) seems to be VERY weak and wobbly. As you can see, when the winch is being retracted, the integrity and stability seems to be not perfect but good enough, I could then move it move it away like this but I really need it to be docked to ensure the payload doesn't get stuck with anything in the way. It is only after it's almost retracted, when I get the red message "Cannot lock the connector: not aligned", that the winch starts drifting down from it's top attach point. And as you can see, it gets worse when the plug docks into the winch: both winch and Harpoon are so wimpy and it's like they're about to come apart. 
PROBLEM 2.1: As a result from the previous issue, after the cargo deployment onto the ground and retracting the plug into the winch, this one completely looses it's initial integrity, making it impossible to fit into the ship when I undeploy the crane, because the part has drifted away from it's attach point so much.

REQUESTS
- Possibility of having more action groups for the winch that can be sequenced, such as Eject, Stretch, Release...
- This is not a request (kind of), but a question. How can I make this not happen? It feels so discouraging honestly. I could get along with it if the drifted part just came back to it's original position after loading out the vessel and then back in, but it won't happen, as you saw in the video. Help with this please.

Thank you very very much!

Edited by adriangm44
Link to comment
Share on other sites

Posted (edited)
19 hours ago, adriangm44 said:

- Possibility of having more action groups for the winch that can be sequenced, such as Eject, Stretch, Release...

This can be done. I've created feature request.

19 hours ago, adriangm44 said:

- This is not a request (kind of), but a question. How can I make this not happen? It feels so discouraging honestly. I could get along with it if the drifted part just came back to it's original position after loading out the vessel and then back in, but it won't happen, as you saw in the video. Help with this please.

This one is much more tricky. In fact, it's not even about KAS. That part misaligning thing is a consequence of using a weak PhysX joint. The cable joint is equal to the game's "tiny" connection. Try attaching  your big vessel with the tiny docking port and you'll see more or less same picture. If KSP's physics engine was perfect, the cable connection would just get broken in your case due to it's simply not strong enough. However, in KSP most of the physics is arcade, and what you see is a simulation. That being said, this problem simply cannot be fixed. The only way to go around it is creating the reinforced joints as KSP does for the medium and large nodes. Even though it's technically doable, there are too many edge cases to address. Let's say I reinforce the cable, and you'll stop seeing the "gap" between connector and the winch. The very next thing would be misaligning the winch from its parent because this connection is not strong enough now. And even if this joint is fixed, the other one will fail up in the hierarchy, etc. Like it or not, but this game has its limits. And building a solid structure that respects all the physical forces is not something you can achieve. I did try to fix it locally for just one part (winch), and eventually gave up. I can cover a couple of cases, but at the cost of a significant code complexity.

As for the harpoon vs grapple hook alignment. The latter adjusts to the normal at the hit point, and given its shape, the contact point is not that narrow as with the harpoon. That's why the actual attach point may not look aligned perfectly. Imagine dropping a square 1m x 1m plate on the ground: no matter how you try, you never make all points on its surface to contact with the ground simultaneously. Same here. Some parts of the grapple collider get into contact with the target sooner than the others, and the approximation/aligning logic goes from it. The rule of thumb: avoid edges and try to eject at the angles close to 90 degrees. This way the result and the expectation will differ much less.

Edited by IgorZ
Link to comment
Share on other sites

  • 3 weeks later...

Am i crazy or is there a detach option missing from the connector/winch AG options in the VAB/SPH ? Highly useful, especially for cinematics. I see it when its already attached as a right-click option on the winch, which is unfortunately not as useful. Like if it was available as an AG just on the winch (all the time) that would work just fine.

Link to comment
Share on other sites

On 8/4/2022 at 3:02 PM, achroma said:

Am i crazy or is there a detach option missing from the connector/winch AG options in the VAB/SPH ? Highly useful, especially for cinematics. I see it when its already attached as a right-click option on the winch, which is unfortunately not as useful. Like if it was available as an AG just on the winch (all the time) that would work just fine.

Could you please be more specific on the "detach option"? KAS parts are not designed to be connected in the editor. The only exception is the JS1 part. You can attach to it a KAS compatible part, and it will be "adopted" in flight. In nut shell, if you expect any active functionality from the context menu of a KAS part in the editor, then this expectation is wrong. The parts are completely passive in this mode.

Link to comment
Share on other sites

@IgorZ

Hi. Do you have a tether where if you winch in with a Kerbal on the end of the cable, the Kerbal gets pulled in, rather that the craft being pulled in to the Kerbal?

Link to comment
Share on other sites

On 8/8/2022 at 7:28 AM, IgorZ said:

Could you please be more specific on the "detach option"? KAS parts are not designed to be connected in the editor. The only exception is the JS1 part. You can attach to it a KAS compatible part, and it will be "adopted" in flight. In nut shell, if you expect any active functionality from the context menu of a KAS part in the editor, then this expectation is wrong. The parts are completely passive in this mode.

Ah nuts. Guess i meant "Unplug". I pulled an old version of KSP (Like KSP 1.1) and an old version of KAS to grab these shots:

ew0fdgq.jpg

Edited by achroma
Link to comment
Share on other sites

  • 2 weeks later...
On 8/8/2022 at 9:23 PM, achroma said:

Ah nuts. Guess i meant "Unplug". I pulled an old version of KSP (Like KSP 1.1) and an old version of KAS to grab these shots:

Now I get it. You need the action group and not the actual "action" in the editor. I think this feature request covers the case. Feel free to add there any details you believe are valuable.

On 8/8/2022 at 5:09 PM, ColdJ said:

Hi. Do you have a tether where if you winch in with a Kerbal on the end of the cable, the Kerbal gets pulled in, rather that the craft being pulled in to the Kerbal?

Last time I checked, a kerbal could get attached to a winch without Kraken awake. However,  it usually ends bad. The kerbal model is heavily animated today, so the normal Unity physics is not working there. A more or less stable behavior can be achieved if the rope is released at a significant distance so that the rope joint could consume random momentums from the kerbal ragdoll.  No guarantees though. If kerbal hits anything, it's absolutely our of KAS control what will happen next.  I was thinking about a "tether" part (in scope of KIS), and came to conclusion that it cannot relay on the PhysX engine. I.e. a physical joint is a bad answer to solve the task. It has to be an "arcade physics".

Link to comment
Share on other sites

Might have missed the answer to this, but how do you get the harpoon or grappling hook attached to the winch? Is it any winch? Am I supposed to attach it in the editor or flight? Banging my head on this one.

Link to comment
Share on other sites

21 hours ago, KSPMoose said:

Might have missed the answer to this, but how do you get the harpoon or grappling hook attached to the winch? Is it any winch? Am I supposed to attach it in the editor or flight? Banging my head on this one.

  1. You can attach those parts to any winch.
  2. You can also attach those parts to ANY other part, but they will NOT work as harpoons in this case. The "harpooning feature" only activates when ejected from a winch.
  3. You can attached them in the editor or in EVA via KIS.
  4. Tbh, I didn't test if they can attach via the stock inventory mode. If it doesn't work, it's a bug which I will fix.

A special note. Those parts in the older KAS used to have KIS extension module that allowed them to be attached/detached in EVA without using tools (like the portable storage). It's not the case for the current implementation.  There are reasons for this, and I hope to address all the issues in KISv2.

Link to comment
Share on other sites

20 hours ago, IgorZ said:
  1. You can attach those parts to any winch.
  2. You can also attach those parts to ANY other part, but they will NOT work as harpoons in this case. The "harpooning feature" only activates when ejected from a winch.
  3. You can attached them in the editor or in EVA via KIS.
  4. Tbh, I didn't test if they can attach via the stock inventory mode. If it doesn't work, it's a bug which I will fix.

A special note. Those parts in the older KAS used to have KIS extension module that allowed them to be attached/detached in EVA without using tools (like the portable storage). It's not the case for the current implementation.  There are reasons for this, and I hope to address all the issues in KISv2.

I must be missing the attachment point then because every single time I try the cable shoots out but the harpoon tip/grappling hook just stays there. I'll try EVA and see if my luck is better. 

Link to comment
Share on other sites

4 minutes ago, KSPMoose said:

But now, new issue, the grappling hook has disappeared

As usual, I need the details. Logs and (optional, but highly appreciated) a video.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...