Jump to content

[Minimum KSP version - 1.8] Kerbal Attachment System (KAS) v1.7


Recommended Posts

2 hours ago, IgorZ said:

How do you do refueling? Which parts and what's the sequence?

In both circumstances I’ve seen the error I’m connecting a line from the RTS-1 from the refueling base to a JS-1 on the target craft and then turning on docking mode. Usually then I go fly other crafts / do other things while the docked craft fills up on ore and fuel. Are there more specifics I can  offer?

Link to post
Share on other sites
On 1/10/2021 at 6:46 PM, zabcheckmate said:

In both circumstances I’ve seen the error I’m connecting a line from the RTS-1 from the refueling base to a JS-1 on the target craft and then turning on docking mode. Usually then I go fly other crafts / do other things while the docked craft fills up on ore and fuel. Are there more specifics I can  offer?

So, I've built a similar design on the launch pad and played around. The issue doesn't reproduce. Unless I have a reliable way to reproduce the problem, it's very unlikely it will be fixed. Could you please try reproducing it on the launchpad with only KIS/KAS installed? The code that is involved in the RTS docking/undocking action is the same as in the stock (de)coupling, I don't see any difference that could trigger the cross-feed issue.

Btw, which other mods do you have in your setup? One thing that happens when vessels separate is crossfeed re-calculation, but it's an internal stock functionality. Maybe some mod in your setup blocks it under some edge conditions?

Link to post
Share on other sites
3 minutes ago, IgorZ said:

So, I've built a similar design on the launch pad and played around. The issue doesn't reproduce. Unless I have a reliable way to reproduce the problem, it's very unlikely it will be fixed. Could you please try reproducing it on the launchpad with only KIS/KAS installed? The code that is involved in the RTS docking/undocking action is the same as in the stock (de)coupling, I don't see any difference that could trigger the cross-feed issue.

Btw, which other mods do you have in your setup? One thing that happens when vessels separate is crossfeed re-calculation, but it's an internal stock functionality. Maybe some mod in your setup blocks it under some edge conditions?

My mod list is pretty long, but I can't figure out why any of them might interfere. My CKAN list is:

BreakingGround-DLC (BreakingGround-DLC (unmanaged))
CapCom - Mission Control On The Go (CapCom 2.11)
Chatterer (Chatterer 0.9.99)
Community Category Kit (CommunityCategoryKit v5.2.0.0)
Contract Parser (ContractParser 9.0)
Contracts Window + (ContractsWindowPlus 9.4)
Draggable Navball (DraggableNavball v1.0.12)
Easy Vessel Switch (EVS) (EasyVesselSwitch 2.1)
Environmental Visual Enhancements (EnvironmentalVisualEnhancements 3:1.10.1-3)
Environmental Visual Enhancements - Stock Planet Config files (EnvironmentalVisualEnhancements-HR 2:EVE-1.2.2-1)
Kerbal Alarm Clock (KerbalAlarmClock v3.13.0.0)
Kerbal Attachment System (KAS 1.7)
Kerbal Engineer Redux (KerbalEngineerRedux 1.1.8.3)
Kerbal Improved Save System (KerbalImprovedSaveSystem v2.4.2)
Kerbal Inventory System (KIS 1.27)
Kerbal Joint Reinforcement Continued (KerbalJointReinforcementContinued v3.5.2)
Making History (MakingHistory-DLC 1.11.0)
Module Manager (ModuleManager 4.1.4)
Progress Parser (ProgressParser 11.0)
Trajectories (Trajectories v2.3.4)
Transfer Window Planner (TransferWindowPlanner v1.7.2.0)
TriggerAu Flags (TriggerAu-Flags v2.10.0.0)
 

I've played with essentially this list previously without running into the error until after I installed Breaking Ground and Making History. Do you have those installed in your copy where you're trying to replicate this? The error actually has occurred only in craft with Making History or Breaking Ground parts, come to think of it, and only when those parts were either attached to or hosting the decoupler. Both of the craft in the albums I linked here use the S4-512 Tank in the center, and the decoupler with the issue was radially attached to that part, and the third craft I had this error on had FL-TX900s or FL-TX1800s  attached via radial decouplers to a Hitchhiker Storage Container. I can try to replicate without the DLC running at some point, but I'm totally swamped at work right now and don't know when I can help.

Link to post
Share on other sites
2 minutes ago, zabcheckmate said:

Do you have those installed in your copy where you're trying to replicate this?

No, and in general I'm not going to do that. Testing for compatibility with all the mods in the world is beyond my capacity. However, I may try to solve conflicts with a particular popular mod if one  was identified.

As for the mods list, I'd point at these two: "Kerbal Improved Save System" and "Kerbal Joint Reinforcement Continued". The first one mangles with the save state, and it may be incompatible to the KAS behavior. The other one reacts on joints creation/destroying, and this is what happens when you dock/undock a KAS link.

Could you please share your vessel file? I'll try my ground tests with it.

Link to post
Share on other sites

To be clear, I was asking about the Breaking Ground and Making History DLCs. Not expecting compatibility with every mod, not expecting anything really! This is super nice of you to run and help out with. 

Here are some of the craft files I've had issues with. I've included two fueling bases and two ships that I've had the error with when refueling.

https://drive.google.com/file/d/14iX8Ipyps3ePfboRabzX_nlhAuz1aa74/view?usp=sharing, https://drive.google.com/file/d/19OGFuvIprhlg2UNhZIQQWnYtrAyqtFJW/view?usp=sharing, https://drive.google.com/file/d/1KFvT4R8JOB7JOPgFXvnSZ3IJXDv7RSUK/view?usp=sharing, https://drive.google.com/file/d/1yy-OznF9fkO4G6JMhEdDPTqRaWjKqG3B/view?usp=sharing

Link to post
Share on other sites
23 minutes ago, zabcheckmate said:

To be clear, I was asking about the Breaking Ground and Making History DLCs

Ah, my bad! I thought you want me installing all your mods :D

Thanks for the crafts designs. I'll try playing with them... right after I solve some issues with KIS.

Link to post
Share on other sites

So I did some testing today with these craft on the Mun, and what triggers the error is switching the link mode to docked. As soon as that happens, you can no longer transfer resources within the target craft through the substack that the JS-1 is on. Something about the way the mod changes crossfeed rules upon docking so that crossfeed across the link between the RTS-1 and JS-1 works seems to be the issue. The effect doesn't happen on both craft, just the one with the JS-1. It doesn't happen across the craft with the JS-1: it happens only between the substack with the JS-1 node and the rest of the craft. Within the substack, crossfeed rules still work.

I uninstalled "Kerbal Improved Save System" and "Kerbal Joint Reinforcement Continued" and that had no effect on the issue.  To further test, I removed all my mods other than KIS, KAS, "TriggerAu Flags",  and their dependencies, which all have parts on my test craft. The error still occurred so it's not about interaction between my mods. Given that I haven't had this issue on any craft w/o Making History parts and it's not a mod interaction problem, my strong suspicion is that there's some kind of subtle compatibility issue with Making History parts and the "docking" mode between the RTS-1 and JS-1 link.

I've tried a couple workarounds.  The bug does not appear to occur when the JS-1 link is on the central stack of a target craft. Other tests, like disabling crossfeed on the decoupler before linking the craft and enabling it after they are "docked" or removing symmetry on the decoupler before linking the craft don't have any effect.  The tradeoff is that whatever part has the JS-1 on it, even if it's the central stack, seems to have some issues. I can't directly transfer fuel from the refueling base to the central stack when docked unless I turn off "resource transfer obeys crossfeed rules". This is largely irrelevant though: I'm never launching a craft linked by a JS-1 and I can always use the Resource Transfer GUI on the RTS-1 to transfer resources between the craft after undocking them.

For now, I'm going to stick my JS-1 links on the central stack of the craft and that will work (at least temporarily), so no rush on this at all. With my craft files shared, this should be easy to replicate but let me know if there are issues on your end.

Edited by zabcheckmate
Link to post
Share on other sites

Hi, I've played KSP before at a friends and got it for myself now with 1.11. Now I know, in the VAB, you got the option to toggle crossfeed on and off by right-clicking on the decoupler. But now there's no such option even though it says it can but is turned off by default.

 My aim is to used side decouplers as drop tanks, like Ive done in the past, but now i cant making my ship designs VERY limited and, imo, less fun to play.

Is this a bug or deleted feature? If so, can i rollback to a previous ver that can do that? I'm running no mods so its a new clean install.

Any help would be great, thanks.

Link to post
Share on other sites
10 hours ago, RuFLaSH said:

Hi, I've played KSP before at a friends and got it for myself now with 1.11. Now I know, in the VAB, you got the option to toggle crossfeed on and off by right-clicking on the decoupler. But now there's no such option even though it says it can but is turned off by default.

 My aim is to used side decouplers as drop tanks, like Ive done in the past, but now i cant making my ship designs VERY limited and, imo, less fun to play.

Is this a bug or deleted feature? If so, can i rollback to a previous ver that can do that? I'm running no mods so its a new clean install.

Any help would be great, thanks.

Pretty sure this should go in the gameplay questions and tutorials section of the forum, not the addon discussion section, but eh. I can't think of any reasons why it isn't showing up, but you can just use fuel ducts instead.

Link to post
Share on other sites
11 hours ago, The-Doctor said:

@IgorZ is it possible to use kas to for example, make a square in orbit out of structural beams? Like attach a part to itself ?

You can't attach a part to itself, but I think you mean you would like to attach two identical parts together?  If that's the case, then, yes, you can attach two parts together, although I think you'll find precise angles difficult, but not impossible, to achieve.  It will depend on what part.

Edited by Brigadier
Link to post
Share on other sites
On 1/16/2021 at 4:17 AM, zabcheckmate said:

Something about the way the mod changes crossfeed rules upon docking so that crossfeed across the link between the RTS-1 and JS-1 works seems to be the issue

Thing is, the mod doesn't deal with any rules at all. It uses the stock ability to initiate vessels coupling or decoupling. Since you have a working testbed already, could you please do another test? Try replacing JS/RTS pair with a couple of docking ports and dock/undock in usual way. Can be technically tricky, though. The port undocking sequence is exactly what RTS does when switching from the docked mode.

On 1/17/2021 at 1:33 AM, RuFLaSH said:

Now I know, in the VAB, you got the option to toggle crossfeed on and off by right-clicking on the decoupler. But now there's no such option even though it says it can but is turned off by default.

This feature is the stock one. It's irrelevant to KAS. IIRC, in order to see the setting in flight you need to enable "advanced tweakable". However, in the editor it should be always visible.

On 1/17/2021 at 3:29 AM, The-Doctor said:

@IgorZ is it possible to use kas to for example, make a square in orbit out of structural beams? Like attach a part to itself ?

KAS is a set of parts, you cannot attach beams using it. In general, the game doesn't support parts cycles in vessels, but KAS parts can simulate it. E.g.  you can create a "square" from TJ parts. Then, if you disconnect any of the links, the vessel will stay whole instead of separating into two. It works the same way for the other links, given they are in state "docked".

Link to post
Share on other sites

I have used KAS in a 1.11 game and experiencing issues like RUDs upon an attachment. Not all the times and not all parts but enough to make this a gameplay issue. Any timeline for releasing a 1.11 game version compatible mod ? 

 

 

Edited by pp3d
Link to post
Share on other sites

I'm trying to connect 2 tanks with KAS. The only parts that seem to do the job are the RTS-1 Resource Transfer Station that connects to JS1-Joint socket. I dislike the RTS-1 isn't other way to connect sockets?
In a youtube video I've seen a bigger pipe from CC-R2 connector port, is this still available? Because video is from 2015.
I see no other parts apart some cables, hook, tow bar, pylons and winch. I'm near the end of tech tree (CTT).

Edited by alphaprior
Link to post
Share on other sites
3 hours ago, alphaprior said:

I'm trying to connect 2 tanks with KAS.

Is it a part of the craft design to balance the fuel between the tanks in flight? Or is it just your way to transfer fuel manually? In the first case I'd recommend using the stock fuel pipe.

3 hours ago, alphaprior said:

I dislike the RTS-1 isn't other way to connect sockets?

There are rigid connectors TJ-1 and TJ-2. They provide limited length though. If you need an old behavior back, you may activate MM patch in your mod's directory: MM-LegacyKASPipesPart.txt.

Link to post
Share on other sites

They are 2 different modules will be landed on Mun separately  so I can't use stock pipe. I'll have to use RTS-1 although I'd like something smaller or at least re-texture something other than red/white stripes.

Link to post
Share on other sites
9 hours ago, alphaprior said:

They are 2 different modules will be landed on Mun separately  so I can't use stock pipe. I'll have to use RTS-1 although I'd like something smaller or at least re-texture something other than red/white stripes.

Heh. Never thought that texture design can be a deal breaker when choosing parts in KSP :)  Anyway, if you make some and would like to share, I'll add it to the part variants.

Link to post
Share on other sites
50 minutes ago, EnderKid2 said:

I do agree that the current RTS-1's texture is a bit garish, but it's ok.

I'm a programmer, not a designer :(  I'd be glad to use other textures if any will be offered. And to be honest, many textures in the new stock parts I don't like too. Today they look too similar for the different parts. I used to recognize part by their look, but now I need to remember names.

Link to post
Share on other sites
3 minutes ago, EnderKid2 said:

we got Restock for that issue...

I like this mod a lot! As well as Restock+. If they restock the KAS parts design, I'd be happy :) 

Link to post
Share on other sites

Okay. Here is an update on the KAS compatibility. I've spent more time testing it (and thanks to those who helped me on Github!). In nutshell, it's not that easy to make KAS compatible :(  Here is the bug list I have so far. All of these bugs are not trivial and require a lot of investigation. I wish there were events notifying when a part is being picked up in EVA, but for now I don't see any. Also, it's not possible to block the EVA construction UI, so many KAS functionality interferes with the stock game and needs to be disabled when the construction mode is activated. That being said, do not expect quick fixes. I still appreciate bug reports, but, please, in the bug report clearly state that you're testing and not using KAS in 1.11.

I'll repeat myself: KAS v1.7 is not compatible with the stock cargo system in KSP 1.11. It should be safe to use KIS+KAS pair in KSP 1.11 - I haven't found any obvious problems. But do not use the stock cargo system and KAS in your carrier games. Not just yet.

Link to post
Share on other sites

I have a ship with a "resource transfer station" on it, and I would like to use the 1.11 construction method to remove it and place it on a different ship. But it seems this is an unremovable part? Is that correct?

(Oops, I see that maybe the post above this one answers the question already.)

Edited by mikegarrison
Link to post
Share on other sites
12 hours ago, IgorZ said:

Okay. Here is an update on the KAS compatibility. I've spent more time testing it (and thanks to those who helped me on Github!). In nutshell, it's not that easy to make KAS compatible :(  Here is the bug list I have so far. All of these bugs are not trivial and require a lot of investigation. I wish there were events notifying when a part is being picked up in EVA, but for now I don't see any. Also, it's not possible to block the EVA construction UI, so many KAS functionality interferes with the stock game and needs to be disabled when the construction mode is activated. That being said, do not expect quick fixes. I still appreciate bug reports, but, please, in the bug report clearly state that you're testing and not using KAS in 1.11.

I'll repeat myself: KAS v1.7 is not compatible with the stock cargo system in KSP 1.11. It should be safe to use KIS+KAS pair in KSP 1.11 - I haven't found any obvious problems. But do not use the stock cargo system and KAS in your carrier games. Not just yet.

What is the difference between testing and using?
 

 

21 minutes ago, mikegarrison said:

I have a ship with a "resource transfer station" on it, and I would like to use the 1.11 construction method to remove it and place it on a different ship. But it seems this is an unremovable part? Is that correct?

(Oops, I see that maybe the post above this one answers the question already.)

To make it "compatible" with the stock construction method and inventory, you need to add the cargoPart module.

MODULE
    {
        name = ModuleCargoPart
        packedVolume = 80
    }

is what I used

Link to post
Share on other sites
33 minutes ago, EnderKid2 said:

What is the difference between testing and using?
 

 

To make it "compatible" with the stock construction method and inventory, you need to add the cargoPart module.

MODULE
    {
        name = ModuleCargoPart
        packedVolume = 80
    }

is what I used

Cool thanks. I guess I'll try that. Did you just make the change directly or did you write a small module manager patch?

(I imagine the difference between "testing" and "using" is that you don't blame @IgorZ if your ship explodes and it kills Jeb and now Bill is stranded on Duna with no way home, etc.)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...