Jump to content
  • 0

Cannot Undock


PhatZilla
 Share

Question

The issue I am having is with the docking ports. I brought up a small tug to use to place future modules and re-arrange them. After bringing up a module, I went to undock the tug, and the option was there, but it didn't seem to actually undock. I tried again and theoption simply isn't there. I've tried controlling from both vehicles, manned and unmanned and even remade the tug entirely and added it to the station, but the same thing happened. The only part mods I'm using are KIS/KAS(but none of those parts are aboard) and NF Solar.

rO7k1SJ.pngrO7k1SJhttp://imgur.com/rO7k1SJ

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

I had the same problem a couple of days ago. After clicking undock or decouple the docking ports where still attached.

I found this old bug and could fix my quicksave:

Here is what I did:

1. Name the undockable Docking Ports to find them in the quicksave file (Port1 and Port2 maybe)

2. Make a quicksave and open the quicksave-file in your saves folder with Notepad++ (make a backup first ;-))

3. Find the state-variable for both Docking Ports (search for Port1/Port2 and scroll up, it's right at the start of the Module-Declaration)

4. Change the one that is not docked (dockee/er) to docked (dockee) or docked (docker), it depends on which state the Docking-Port which looks ok has

5. Now Port1 is docked (dockee) and Port2 is docked (docker) or the other way around

6. Save the file in NP++ and load the quicksave in ksp

After these steps I was able to undock my crafts.

 

I hope this was helpful and you can keep playing your game

Edited by aerowook
typo
Link to comment
Share on other sites

  • 0
On 6/29/2016 at 11:23 AM, aerowook said:

Here is what I did:

1. Name the undockable Docking Ports to find them in the quicksave file (Port1 and Port2 maybe)

I just ran into this bug today and am attempting to fix using your method, but I cannot find an option to rename a specific part like that in-game. I can only rename entire vessels.

I solved the problem, or rather found a solution someone else made that worked well.

I used the save file editor posted by Mythos, "KML," found here on the forums:

Once I loaded my quicksave in this editor, it saw the problem automatically and gave a visual warning for it. I was able to double-click the warning, right-click the highlighted attribute, and select the option to fix it. I loaded the save and the problem was indeed fixed. This man deserves a medal.

Edited by Pirwzy
Found Solution
Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...