Talavar

game players, Is 1.1.3 stable?

Recommended Posts

No crashes here, although I haven't had many in any of the versions. Only have about 20 mods though. 

Been around since 0.25

Also it would probably help you to know what OS people are talking about when adding whether or not they have crashes. 

Windows 10 64 bit for me now but on older versions I used Windows 7 64 bit. Played mostly 32 bit KSP until 64 bit became available again with Unity update and 64 bit since.

Edited by Bigbootie

Share this post


Link to post
Share on other sites

Lots of good info. Thanks guys. THink I'll give it a bit longer, till it's a complete game again, (wheels included). Don't want to start a campaign and end up frustrated because something isn't working correctly. That was my main problem before (wheels), then 3 mod-less crashes in a row within 15 minutes sent me off the deep end.. (queue angry  forum comments) lol

Edited by Talavar

Share this post


Link to post
Share on other sites

For me, it crashes. I'd say less than 1.1.2, but still does. On stock install, completely free of mods, it takes the longest to crash, but it does. Mostly in VAB, when trying to do something. With mods, and I only have a few, like KJR, KER and KAC, it crashes more often, after about 1-2 hours of game play.

For instance, I was in VAB yesterday, trying to remove one LV-T45 engine from my tourist shuttle, and the game crashed to windows, the kind of crash that doesn't generate a crash report folder, I see those almost exclusively, to the point that I was surprised when I had a plain old regular crash yesterday, that actually generated the crash report folder

xD

All in all, it's playable, in stock. I miss a bunch of mods, since I like playing with life support and cryoengines and similar stuff, but... well, it's still a great game!

Share this post


Link to post
Share on other sites

YMMV. For me, 1.0.5 crashes once per 6 hours of playing or so.

1.1.2 crashes about once per minute.

1.1.3 crashes about once per 10 minutes of playtime.

Share this post


Link to post
Share on other sites

I believe those who are reporting lots of crashes. They wouldn't get so angry or frustrated when telling us about it. That said, it has not been my experience.

I have a five year old HP laptop that I bought at Walmart. It has integrated graphics and runs 64 bit Windows 8.0 (with classic desktop to make it usable). Due to internet problems I never got to download 1.1, 1.1.1, or 1.1.2, as such I know nothing other than what has been stated on the forum. I do now have 1.1.3. I run it in 64 bit and have it substantially modded with beautification mods - SVE/Scatterer/Planetshine/DOE along with the indispensable Chatterer, Texture Replacer to change suits, OPM (along with a cloud pack), Xen's Planet Pack, and some various Navball enhancements.

The game feels faster than it did in 1.0.5. It also feels very stable. Doesn't mean it won't go wonky next mission, but so far I haven't crashed once. Jeb on the  other hand has littered the place up pretty well.

   

Share this post


Link to post
Share on other sites

I had one CTD within 10 mins of install, pure stock, but now many hours no problems. But I can't seem to land a plane with the new gear. Pilot error no doubt

Share this post


Link to post
Share on other sites
18 minutes ago, Jetski said:

.... Pilot error no doubt

No, no it isn't. In this case, the workman who blames his tools is right to do so. Personally I'm not touching anything HOTOL until 1.2. Which is rather sad because that's what I like most :( 

Share this post


Link to post
Share on other sites

I deeply envy you bugless guys. I just had another crash and decided to call it a day. I wish I could find what the catch was. I tried changing resolution, detail level, GPU drivers, chipset drivers, I updated my BIOS to the latest version, verified game files (it always find some two files that are bad and redownloads them...) and still the game crashes. The only thing I haven't done yet, was to try it on a different system. I'm on 8.1 x64 currently.

Share this post


Link to post
Share on other sites

Mine's been crashing from the VAB a lot, completely shutting the computer down.  I think that's because it tends to make my computer run hot, though, and the computer shuts down if it thinks that things are getting too warm.

Share this post


Link to post
Share on other sites

I have another question: Does 1.1.3 become much more unstable after transfering save files from 1.1.0? I plan to do that, but I have a suspicion this might cause more bugs than the 1.1.0-1.1.3 updates have fixed.

Share this post


Link to post
Share on other sites
46 minutes ago, Nikolai said:

Mine's been crashing from the VAB a lot, completely shutting the computer down.  I think that's because it tends to make my computer run hot, though, and the computer shuts down if it thinks that things are getting too warm.

Have you tried to turn off crew details and dynamic lights in VAB/SPH ? It should be option for that somewhere in game menu or trough ALT+F12 debug menu.
That should help with CPU overheating.

Although, I would rather recommend to invest some money for additional case fans if you use desktop PC or if you use laptop, use additional mount stand.
Even makeshift laptop mount stand that raise laptop for ~2 cm above desk can help a lot with cooling.

If cooling/venting is properly done, you should be able to run CPU at 100% for hours without influence on overheating that leads to shutdown.
I usualy do test with 7zip benchmark with increased word size, so both, memory and CPU is used at max capacity for hour or so, to test heating stability.

Share this post


Link to post
Share on other sites

It still crashes quite a lot here.
I am using the Linux version on Ubuntu 14.04 with 8GB RAM and with 68 mods.

With 1.1.2 I had a lot of crashes in the VAB and also a couple during staging in flight and these seem to be fixed.

With 1.1.3 it pretty much only crashes when I change scenes, going back to the Space center, switching to crafts in the Tracking station, stuff like that... This happens like maybe every 5 to 10 scene changes I would guess. 

Share this post


Link to post
Share on other sites
2 hours ago, Nikolai said:

Mine's been crashing from the VAB a lot, completely shutting the computer down.  I think that's because it tends to make my computer run hot, though, and the computer shuts down if it thinks that things are getting too warm.

If your PC is shutting down due to heat, you have bigger problems, which have nothing to do with KSP. KSP is not a very hardware intensive game, and NO software should be pushing your PC to the point where it shuts itself down to protect itself from heat damage.

Assuming it's a desktop, you need to clean all your fans (including your GPU if applicable) with compressed air, and reapply thermal paste to your cooler. If it's a laptop, there isn't so much you can do, but I'd at least give it a ruddy good clean (again using compressed air).

Share this post


Link to post
Share on other sites
2 hours ago, Nikolai said:

Mine's been crashing from the VAB a lot, completely shutting the computer down.  I think that's because it tends to make my computer run hot, though, and the computer shuts down if it thinks that things are getting too warm.

Turn off the show crew option in settings

Share this post


Link to post
Share on other sites

Only a few crashes for me, and it's really good to see the VAB/SPH crash issue fixed from 1.1.2—that was a pain. I believe they were not bugs or anything of that nature but simply because I'm running out of memory with these 190 or so mods.

I don't even know how I managed to stock up that many mods. :D

Share this post


Link to post
Share on other sites

My 5 cents:

Squad: Forget that ""upgrade"" with rover wheels, it just ruined a perfect game. Nobody cares about skidding rovers on the surface of far distant worlds, this is not a race game, this is a spaceflight game. 1.1.3 would be excellent if not for the damn wheels... Just scrap friction and get the wheels to where they were. I've been unable to upgrade my game since 1.0.4 because 1.0.5 crashed for unknown reasons and 1.1.x is a disaster due only to the damn wheels. Scrap them! Get back to original wheels....

 

 

 

Share this post


Link to post
Share on other sites
On 7/4/2016 at 3:01 PM, kcs123 said:

Although, I would rather recommend to invest some money for additional case fans if you use desktop PC or if you use laptop, use additional mount stand.
Even makeshift laptop mount stand that raise laptop for ~2 cm above desk can help a lot with cooling.

Thanks.  I'll give that a try.  I've seen those things, but didn't know if they actually did any good.

On 7/4/2016 at 4:30 PM, severedsolo said:

Assuming it's a desktop, you need to clean all your fans (including your GPU if applicable) with compressed air, and reapply thermal paste to your cooler. If it's a laptop, there isn't so much you can do, but I'd at least give it a ruddy good clean (again using compressed air).

... And this, too, of course.

Share this post


Link to post
Share on other sites

I haven't played since 1.1 release because the game is a buggy mess and half of my ship designs run into major problems with wheels. Customers still are having to ask in forums "is Kerbal even stable enough to play?".

And yet the big news is the game's release on PS4... :rolleyes:

Share this post


Link to post
Share on other sites

I get a crash almost everytime I enter a facility if it is the first time since I started the Computer. After that, it is pretty ok, only one or two crashes every day.

Share this post


Link to post
Share on other sites

I've had some serious amount of crashes with 1.1.3 all while I'm in VAB/SPH, with 100+ mods installed, somewhere around 1 crash every hour or so. But definitely way better than what we had in 1.1.2.
I have watercooled Intel i5 4670 + watercooled GTX 980 Ti.

Edit: Serious amount considering I spends the whole hour making some crafts, and poof there goes the volatile memory, cause I don't save cause I'm an idiot.

Edited by Blastard

Share this post


Link to post
Share on other sites

Very stable.  I've only had issues with pre 1.1 64-bit windows and Linux (I'm blaming nVidia drivers).

Crashing isn't the problem: everything else is.  Expect phantom torques to make docking anywhere from difficult to impossible (it turns out retracting the landing wheels (due to a stupid contract) removed plenty of phantom torque).  Struts still mysteriously disappear and are shown radiating out from the rocket on the pad.  Weirder bugs like quickload loading with the engines off, once physics goes online the engines fire.  Sometimes the rocket will destroy itself thanks to those sudden forces (and continue doing so on every reload).

If you like smaller vessels and didn't need multi-threading, I'd recommend 1.0.4

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.