FreeThinker

The KSP Interstellar Proxima Centauri Challenge

Recommended Posts

11 hours ago, pmborg said:

@FreeThinker

Heads up that this didn't ended well... because the factory once created... slipped way to ocean... and gone... :(

So basically without factory to construct the Colony they will die... :(

Any ideas @allista about how to avoid this?

Pretty Hilarious way to die, but have you tried save and reload after restart of KSP? I notice the wheel sing into the surface somewhat. Looks like a floating point issue, where can get worse after traveling long distances.

Edited by FreeThinker

Share this post


Link to post
Share on other sites
21 hours ago, pmborg said:

After 63 years, finally at target planet:

<snip>

- I am now trying to understand where I lose so many time...

In Theory 4.367 light years away is relatively at reach of this InterStellarShip that do 0.41c cruise... which should be in theory 10.65 years... but this don't count with time to accelerate,decelerate and maneuvers.

First congratulation, this is officially a record for achieving Proxima Centauri challange and entering the hall of Fame! For the record, exactly how much time did it take to accelerate, cruise and decelerate and orbit your destination? Also can wait to see you final Cinematic Youtube trip of the entire trip :D

The longer than expected travel problem is kind of similar to High Speed trains between cities that are reasonably close. It takes a very long distance before there are at full speed and brake to a full stop. The distance that they can cruise at full speed it often remarkably short. You quickly run into diminishing return problem when going faster. Going double at speed does not translate into 50% the time saving but at best only 25% reduction. That 0.41c start to become interesting when traveling longer distances, like to  TRAPPIST-1 system that is 40 light-years away. THe Fact that this system has much more potential habitable planets makes it a good candidate for colonization.  I believe the Real Exoplanets mod has  the TRAPPIST-1 covered. ;)

If you could make it work, it would be interesting to hear how long it would take you to land on any of its planets. Sounds like a challenge?

Edited by FreeThinker

Share this post


Link to post
Share on other sites

Hello (from cellphone), yes later on, at night I will bring more details about time spent where and how.

 

 

Share this post


Link to post
Share on other sites

Resume of main steps:

  • 0y to Lift-off zero fuel on 4 main tanks.
  • After 402d arrive at Jupiter orbit 2000km
  • 6y+380d all refuel is done at Jupiter, get out of Jupiter SOI and do the main acceleration.
  • 13y+232d speed 125,000km/s
  • 47y+46d Start the main speed break
  • 59y+294d break the last 500,000 m/s to Begin the final star approach to enter in a inner star orbit
  • 63y+225d start the target planet re-entry

 

1 Kerbin year = 0.29 Earth years

 

Which is 18 earth years and 55 days and 17h, to travel from "Earth" to "Alpha Centauri" with a potential crew of 50.

Edited by pmborg

Share this post


Link to post
Share on other sites

About  

About Real Exoplanets yes for sure I will test it

But first I need to update some things and do some workarounds, to make it work, that I detected, in the cfg files that prevents to test it a latest version of Kopernicus.

Today I fixed the "Systems\AlphaCentauriSystem\Proxima Centauri.cfg" but to sleepy to go further more today.

[1] This:
semiMajorAxis = 40151340125629704     ( at least don't work for me...)
semiMajorAxis = 4.0151340125629704e+16     ( fixed in my system... )

I need to go deeper in order to have conclusions and make an official statement about this.

more things are needed...

Edited by pmborg

Share this post


Link to post
Share on other sites

Hey @FreeThinker,

About Real Exoplanets v0.9  change it in-order to have default stock planets and is working now in 1.7.3:

PJA8mmA.png

Next step 1.8.1...

 

Edited by pmborg

Share this post


Link to post
Share on other sites

And Bingo!!!

ERROR 1 Fixed: for 1.7.3
--------------
Today I fixed the "Systems\AlphaCentauriSystem\Proxima Centauri.cfg" but to sleepy to go further more today.
[1] This:
semiMajorAxis = 40151340125629704     ( at least don't work for me...)
semiMajorAxis = 4.0151340125629704e+16     ( fixed in my system... )

KSP LOG:
--------
[EXC 19:11:14.254] Exception: Failed to load Body: AlphaCentauri
        Kopernicus.Configuration.Loader.Kopernicus.ConfigParser.Interfaces.IParserEventSubscriber.PostApply (.ConfigNode node)
        Kopernicus.ConfigParser.Parser.LoadObjectFromConfigurationNode (System.Object o, .ConfigNode node, System.String configName, Boolean getChildren)
        Kopernicus.ConfigParser.Parser.CreateObjectFromConfigNode[Loader] (.ConfigNode node, System.String configName, Boolean getChildren)
        Kopernicus.Injector.Awake ()
        UnityEngine.Debug:LogException(Exception)
        Kopernicus.Injector:Awake()
        UnityEngine.GameObject:AddComponent(Type)
        AddonLoader:StartAddon(LoadedAssembly, Type, KSPAddon, Startup)
        AddonLoader:StartAddons(Startup)
        AddonLoader:OnLevelLoaded(GameScenes)
        AddonLoader:OnSceneLoaded(Scene, LoadSceneMode)
        UnityEngine.SceneManagement.SceneManager:Internal_SceneLoaded(Scene, LoadSceneMode)

AlphaCentauri.Body.log:
-----------------------
[LOG 19:11:14]: Exception Was Recorded: The requested value 'SKIP' was not found.
  at System.Enum.Parse (System.Type enumType, System.String value, Boolean ignoreCase) [0x00000] in <filename unknown>:0
  at System.Enum.Parse (System.Type enumType, System.String value) [0x00000] in <filename unknown>:0
  at ConfigNode.ParseEnum (System.Type enumType, System.String vectorString) [0x00000] in <filename unknown>:0
  at Kopernicus.ConfigParser.BuiltinTypeParsers.EnumParser`1[Kopernicus.Configuration.PropertiesLoader+RnDVisibility].SetFromString (System.String s) [0x00000] in <filename unknown>:0
  at Kopernicus.ConfigParser.Parser.ProcessValue (System.Type targetType, System.String nodeValue) [0x00000] in <filename unknown>:0
  at Kopernicus.ConfigParser.Parser.LoadObjectMemberFromConfigurationNode (System.Reflection.MemberInfo member, System.Object o, .ConfigNode node, System.String configName, Boolean getChildren) [0x00000] in <filename unknown>:0
  at Kopernicus.ConfigParser.Parser.LoadObjectFromConfigurationNode (System.Object o, .ConfigNode node, System.String configName, Boolean getChildren) [0x00000] in <filename unknown>:0
  at Kopernicus.ConfigParser.Parser.LoadObjectMemberFromConfigurationNode (System.Reflection.MemberInfo member, System.Object o, .ConfigNode node, System.String configName, Boolean getChildren) [0x00000] in <filename unknown>:0
  at Kopernicus.ConfigParser.Parser.LoadObjectFromConfigurationNode (System.Object o, .ConfigNode node, System.String configName, Boolean getChildren) [0x00000] in <filename unknown>:0
  at Kopernicus.Configuration.Loader.Kopernicus.ConfigParser.Interfaces.IParserEventSubscriber.PostApply (.ConfigNode node) [0x00000] in <filename unknown>:0

ERROR 2: for 1.7.3
--------
Fixed RealSolarSystem: Removing Stock Planet Pack

[WRN 19:17:21.097] [ROCManager]: Invalid CelestialBody Name Eeloo on ROC Definition EelooBerg. Removed entry.
[ERR 19:17:21.098] Exception handling event OnPSystemReady in class ROCManager:System.ArgumentOutOfRangeException: Argument is out of range.
Parameter name: index
  at System.Collections.Generic.List`1[RocCBDefinition].get_Item (Int32 index) [0x00000] in <filename unknown>:0
  at ROCManager.ValidateCBBiomeCombos () [0x00000] in <filename unknown>:0
  at ROCManager.GetROCControlFromCB () [0x00000] in <filename unknown>:0
  at EventVoid.Fire () [0x00000] in <filename unknown>:0

[EXC 19:17:21.098] ArgumentOutOfRangeException: Argument is out of range.
Parameter name: index
        System.Collections.Generic.List`1[RocCBDefinition].get_Item (Int32 index)
        ROCManager.ValidateCBBiomeCombos ()
        ROCManager.GetROCControlFromCB ()
        EventVoid.Fire ()
        UnityEngine.Debug:LogException(Exception)
        EventVoid:Fire()
        <Start>c__Iterator0:MoveNext()
        UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)


ERROR 3: for 1.8.1
--------
Convert Textures:
Donloaded: https://github.com/microsoft/DirectXTex/releases
K:\SteamLibrary\steamapps\common\Kerbal Space Program_1.8.1.dev\GameData\REX-Textures\PluginData>texconv.exe -f DXT5 *.dds -y

 

Working on 1.8.1:

9c13GM0.png

 

Share this post


Link to post
Share on other sites

Hello @AndrewDraws,

Today I adapted the real-exoplanets-v09 for 1.7.3 and 1.8.1 (Kopernicus Beta version), based on a challenge from @FreeThinker, let me know if you are interested on it.

YTUUb68.png

The solution of the fixes are posted above, but for convenience or whatever I can make a zip for you.

I love your work Andrew this is the minimum that I can do :)

 

Cheers!

Edited by pmborg

Share this post


Link to post
Share on other sites
4 hours ago, pmborg said:

Hello @AndrewDraws,

Today I adapted the real-exoplanets-v09 for 1.7.3 and 1.8.1 (Kopernicus Beta version), based on a challenge from @FreeThinker, let me know if you are interested on it.

YTUUb68.png

The solution of the fixes are posted above, but for convenience or whatever I can make a zip for you.

I love your work Andrew this is the minimum that I can do :)

 

Cheers!

I released v0.9.1 the other day which is compatible with 1.7.3

Share this post


Link to post
Share on other sites
6 hours ago, AndrewDraws said:

I released v0.9.1 the other day which is compatible with 1.7.3

Yes indeed is new didn't noticed :), was not there when I checked it was only 1.6.1, I would say that no need to upload/download any zip then.

Cheers.

Share this post


Link to post
Share on other sites

I am tweaking now the light that comes out, from these new stars to Kerbin.

Because by default Kerbin became awful at some periods of the day... or is just me? Do you have a picture from KSC after install real-exoplanets@FreeThinker

W15axYi.png

I had to fix this by disabling:

REX_RSS.cfg_

REX_RSSVE.cfg_

Because the light was added instead of replaced.

URqxYBb.png

 

Edited by pmborg

Share this post


Link to post
Share on other sites


- In the last 2 days, I was setting up my environment to use this real-exoplanets pack on 1.8.1, which is almost done, not yet.


- Really soon for Christmas we will have as present again all add-ons outdated for 1.9.0, but once the changes will not be so severe like in 1.8 I hope a smoother addon adaptation, so trying to concentrate on this release, 1.8.1 for now.

I would like to upload my ship pack/solution used to this challenge, but for that I need to release somehow, a kind of pmborg "addon" to support the ship.

- The ship that I have done, to win this challenge, don’t have any cheats, just have some changes in several mods, those changes are related with:

  •   No mod support for 1.8.1 yet for some mods, but I forced the support for parts that I want/need for the ship.
  •   Some parts I need them bigger, and just tweak the tweak scale even more here and there.
  •   Actually @allistahave done a great job adding some of my tweaks already a big Hangar for the space plane.
  •   @FreeThinkerThere are also some tweaks that I have done in KSPI, in big spheres and in the engine to scale them from 40 to 45, let me know if you are interested in update KSPI with it or if I keep this addon upgrade, later on I can share the details if needed.
Edited by pmborg

Share this post


Link to post
Share on other sites

Hello @FreeThinker the update was on these files:

Updated:
K:\SteamLibrary\steamapps\common\Kerbal Space Program\GameData\WarpPlugin\Parts\Engines\Bussard2\Bussard.cfg

    MODULE
    {
        name = TweakScale
        type = stack_square
        defaultScale = 2.5
        scaleFactors = 2.5, 3.75, 5, 7.5, 10, 15, 20, 30, 45
    }


K:\SteamLibrary\steamapps\common\Kerbal Space Program\GameData\InterstellarFuelSwitch\Parts\bigSphereTank\SphereTank.cfg

    MODULE
    {
        name = TweakScale
        type = stack
        defaultScale = 2.5
        scaleFactors = 0.613, 0.95, 1.13, 1.875, 2.5, 3.75, 5.0, 7.5, 10, 15, 20, 30, 45
    }

 

 

Share this post


Link to post
Share on other sites

Finally all set, what so you think about my addon pack in 1.8.1?

f2I0FXe.png

HIy7eQg.png

 

Edited by pmborg

Share this post


Link to post
Share on other sites
1 hour ago, pmborg said:

Finally all set, what so you think about my addon pack in 1.8.1?

f2I0FXe.png

HIy7eQg.png

 

It looks weird, how can the surface be pitch black while the surface is lighted as if in the moorning?

Share this post


Link to post
Share on other sites
12 minutes ago, FreeThinker said:

It looks weird, how can the surface be pitch black while the surface is lighted as if in the moorning?

It's not black, it's just an illusion of seeing it from a big overview at night with real Moon light:

NIGHT:

6CdSe96.png

DAY:

opAXyWV.png

Edited by pmborg

Share this post


Link to post
Share on other sites
2 hours ago, FreeThinker said:

Well in that case the moon light is much too bright

I think that this is the accumulated light with sunset also.

At full night:

RwsIJiD.png

With space plane lights on:

V39wlKD.png

Share this post


Link to post
Share on other sites

@pmborg I'd seriously not recommend using REX in a version of ksp that kopernicus doesn't support. Also, you should NOT disable REX_RSSVE and REX_RSS. Those are very important files and you will encounter issues if you disable them.

Share this post


Link to post
Share on other sites
11 hours ago, AndrewDraws said:

@pmborg I'd seriously not recommend using REX in a version of ksp that kopernicus doesn't support. Also, you should NOT disable REX_RSSVE and REX_RSS. Those are very important files and you will encounter issues if you disable them.

The problem is not 1.8.1.

If I install by the book 1.7.3 and 1.8.1 just with REX the results are 100% equal.

The problem is the adding some more planet and star packs, I have 83 addons, that some how are raising that problem of excess of light, thanks for your concerns I understand them.

I believe that I found the solution, fixing the other mod pack and keep those both files.

Thanks!

Edited by pmborg

Share this post


Link to post
Share on other sites
1 hour ago, pmborg said:

The problem is not 1.8.1.

If I install by the book 1.7.3 and 1.8.1 just with REX the results are 100% equal.

The problem is the adding some more planet and star packs, I have 83 addons, that some how are raising that problem of excess of light, thanks for your concerns I understand them.

I believe that I found the solution, fixing the other mod pack and keep those both files.

Thanks!

I still do not recommend using kopernicus in a version of KSP that it doesn't support. That's just generally a bad idea and will cause problems for you.

Also, there being "excess light" isn't really a thing unless the makers of those mods didn't make the stars' light curves correctly.

Share this post


Link to post
Share on other sites
1 hour ago, AndrewDraws said:

I still do not recommend using kopernicus in a version of KSP that it doesn't support. That's just generally a bad idea and will cause problems for you.

Also, there being "excess light" isn't really a thing unless the makers of those mods didn't make the stars' light curves correctly.

The Kopernicus team is supporting not officially this release as you can see here, in a close loop:

https://github.com/Kopernicus/Kopernicus/issues

  • About the "excess light" yes that's exactly the problem, I will solve this issue today later on, the idea is to setup the environment for another set of tests using KSPI, in the interstellar travels.
  • I plan also update the SpacePlane of the Ship to increase the stall speed with the new canards.
  • I will also do some travels to REX with a new version InterStellar Ship: Alfa1_8StellarShuttle-v5-9F in revision to  Alfa1_8StellarShuttle-v5-10 for this Alpha Centauri and others.

1lLutan.png

@FreeThinker you asked before, you were wondering about the time needed using this Ship, for those in REX, according to my calculation extrapolation from last InterStellar demo the other start will take like is described in image 18, 21, 26, 37 and 78 years (earth years) to reach each star from Kerbin or Earth.

Edited by pmborg

Share this post


Link to post
Share on other sites
39 minutes ago, pmborg said:

@FreeThinker you asked before, you were wondering about the time needed using this Ship, for those in REX, according to my calculation extrapolation from last InterStellar demo the other start will take like is described in image 18, 21, 26, 37 and 78 years (earth years) to reach each star from Kerbin or Earth.

Damn, 78 years  is too long! For mission success it is critical to take no longer than 50 years, which will ensure that a 20 years old cadet still lives (at 70 years old) when arriving. Electronics lifespane also becomes problematic after 50 years of operation. We have to push harder!

19 hours ago, pmborg said:

Hello @FreeThinker the update was on these files:

Updated:
K:\SteamLibrary\steamapps\common\Kerbal Space Program\GameData\WarpPlugin\Parts\Engines\Bussard2\Bussard.cfg

    MODULE
    {
        name = TweakScale
        type = stack_square
        defaultScale = 2.5
        scaleFactors = 2.5, 3.75, 5, 7.5, 10, 15, 20, 30, 45
    }


K:\SteamLibrary\steamapps\common\Kerbal Space Program\GameData\InterstellarFuelSwitch\Parts\bigSphereTank\SphereTank.cfg

    MODULE
    {
        name = TweakScale
        type = stack
        defaultScale = 2.5
        scaleFactors = 0.613, 0.95, 1.13, 1.875, 2.5, 3.75, 5.0, 7.5, 10, 15, 20, 30, 45
    }

 

 

The Logical steps would be 40 and 60, not 45

Edited by FreeThinker

Share this post


Link to post
Share on other sites
9 minutes ago, FreeThinker said:

Damn, 78 years  is too long! For mission success it is critical to take no longer than 50 years, which will ensure that a 20 years old cadet still lives (at 70 years old) when arriving. Electronics lifespane also becomes problematic after 50 years of operation

I can build faster ships, based on this Bussard engines that I have in mind... the problem is that I don't have the parts that I need to construct them in a way that keep them more robust.

I have a version of this ship that do 0.9c but once I turn on the engines... all blow away. For now this one that do 0.41c cruise is the most stable one, actually is very stable.

Edited by pmborg

Share this post


Link to post
Share on other sites
4 minutes ago, pmborg said:

I have a version of this ship that do 0.9c but once I turn on the engines... all blow away. For now this one that do 0.41c cruise is the most stable one, actually is very stable.

We have to figure out what makes them more stable. A possible explanation would be to increase  breakingForce and breakingTorque on parts or add struts

Edited by FreeThinker

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.