Galileo

[KSP 1.6.1] Stock Visual Enhancements [v1.4.1] [20 March 2019]

Recommended Posts

Just now, Galileo said:

Reinstall both. 

Will do, thanks.

Share this post


Link to post
Share on other sites
12 minutes ago, Jognt said:

Will do, thanks.

Actually, you may have inadvertently stumbled across an EVE bug. Looks like everything looks good in flight mode and in the tracking station, but it looks super overexposed in map view... Ill have to report this to the EVE dev

 

  • Like 1

Share this post


Link to post
Share on other sites
17 minutes ago, Galileo said:

Actually, you may have inadvertently stumbled across an EVE bug. Looks like everything looks good in flight mode and in the tracking station, but it looks super overexposed in map view... Ill have to report this to the EVE dev

Keep in mind that only one of those two screenshots is in map view. the other is in the flight scene.

I've just reinstalled SVE+EVE. Might see a slightly less purple kerbin in the flight scene but I'm not sure whether that's due to clouds or my imagination. Picture added: https://imgur.com/a/cnjGh

 

 

Share this post


Link to post
Share on other sites
13 minutes ago, Jognt said:

Keep in mind that only one of those two screenshots is in map view. the other is in the flight scene.

I've just reinstalled SVE+EVE. Might see a slightly less purple kerbin in the flight scene but I'm not sure whether that's due to clouds or my imagination. Picture added: https://imgur.com/a/cnjGh

Flight scene looks as intended, but map view is overexposed and looks discolored a little and that is out of my hands at the moment. 

 

You also made me look into something a little more closely and helped me fix another bug that has been a thorn in my side for a long time now

So thanks

Edited by Galileo
  • Like 1

Share this post


Link to post
Share on other sites
1 minute ago, Galileo said:

You also made me look into something a little more closely and helped me fix another bug that has been a thorn in my side for a long time now

So thanks

Sorry :P

Share this post


Link to post
Share on other sites

Would there be a way to get the settings Astronomer's Visual Pack uses to give the Mun, Minmus, and other moons the thin cloud layer/dust and put them into SVE?

  • Like 1

Share this post


Link to post
Share on other sites

It's not too hard to set up with a little practice. You'd just need to go in an build a custom config using the effects definitions you want. You'd have to look at the layers you want to use and import them to your SVE config or your custom config. The cloud layers are usually called something like "dust" or "sandstorm" so they shouldn't be too hard to find. After you've got the wording copied over into your new config you'll need to change the texture paths so that they work with SVE's textures or just delete everything but the needed AVP textures.

Share this post


Link to post
Share on other sites
4 hours ago, Doc Shaftoe said:

It's not too hard to set up with a little practice. You'd just need to go in an build a custom config using the effects definitions you want. You'd have to look at the layers you want to use and import them to your SVE config or your custom config. The cloud layers are usually called something like "dust" or "sandstorm" so they shouldn't be too hard to find. After you've got the wording copied over into your new config you'll need to change the texture paths so that they work with SVE's textures or just delete everything but the needed AVP textures.

Thanks for the advice! I was able to get it working, and I'm enjoying the new view already

https://imgur.com/a/3xfKJ

Share this post


Link to post
Share on other sites
4 hours ago, CodeFantastic said:

Would there be a way to get the settings Astronomer's Visual Pack uses to give the Mun, Minmus, and other moons the thin cloud layer/dust and put them into SVE?

 

4 hours ago, Doc Shaftoe said:

It's not too hard to set up with a little practice. You'd just need to go in an build a custom config using the effects definitions you want. You'd have to look at the layers you want to use and import them to your SVE config or your custom config. The cloud layers are usually called something like "dust" or "sandstorm" so they shouldn't be too hard to find. After you've got the wording copied over into your new config you'll need to change the texture paths so that they work with SVE's textures or just delete everything but the needed AVP textures.

I've tried this and I just couldn't get it to work, mostly because I've never figure out what all the options and settings do in EVE

Personally, I'd love to see the mists added on the icy moons (Minmus and Vall especially). And the surface red dust on Duna was awesome. If anyone gets these effects working, I'd appreciate them sharing the config files.

Share this post


Link to post
Share on other sites
1 minute ago, LameLefty said:

 

I've tried this and I just couldn't get it to work, mostly because I've never figure out what all the options and settings do in EVE

Personally, I'd love to see the mists added on the icy moons (Minmus and Vall especially). And the surface red dust on Duna was awesome. If anyone gets these effects working, I'd appreciate them sharing the config files.

I got the glow to work, I can try getting the mist thing to work

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, LameLefty said:

 

I've tried this and I just couldn't get it to work, mostly because I've never figure out what all the options and settings do in EVE

Personally, I'd love to see the mists added on the icy moons (Minmus and Vall especially). And the surface red dust on Duna was awesome. If anyone gets these effects working, I'd appreciate them sharing the config files.

Is this the misty Minmus you're looking for? https://imgur.com/a/OUMo5

I got the Astronomer dust layers to work :)

Share this post


Link to post
Share on other sites
1 minute ago, CodeFantastic said:

Is this the misty Minmus you're looking for? https://imgur.com/a/OUMo5

I got the Astronomer dust layers to work :)

YES!!! :o 

Please post the config file you used! 

Share this post


Link to post
Share on other sites
Just now, LameLefty said:

YES!!! :o 

Please post the config file you used! 

Give me about 10 minutes, I only edited it for Minmus so I need to go back and add the others. Do you want the glow as well or just the dust?

Share this post


Link to post
Share on other sites
Just now, CodeFantastic said:

Give me about 10 minutes, I only edited it for Minmus so I need to go back and add the others. Do you want the glow as well or just the dust?

Just the dust. That's what I really miss from Astronomer's Pack, especially on Minmus and Duna. It really adds a lot of "feel" to being on the surface.

Share this post


Link to post
Share on other sites
9 minutes ago, LameLefty said:

Just the dust. That's what I really miss from Astronomer's Pack, especially on Minmus and Duna. It really adds a lot of "feel" to being on the surface.

Okay, I'm going to explain how to do this the best I can. I highly recommend downloading Notepad+, it makes editing these files easier

1. Download the congfig here https://www.dropbox.com/s/9ert8yi0brqxhzm/SVE_duststorms.cfg?dl=0 , then download the needed particle effect from AVP here https://www.dropbox.com/s/8hvmnfwxsn2gtl3/rgb2.dds?dl=0

2. Move the particle file (should be called rgb2) to GameData/StockVisualEnhancements/Textures/particle

3. Open the SVE_duststorms file, and you will see configs for most of the planets. Choose the configs you want (in your case, Minmus-Dust and Vall-dust), and copy them into the SVE_Clouds file located in GameData/StockVisualEnhancements/SVE_Configs

4. Okay, this part is important. The order in which you place the configs within the file matters. For the Minmus-dust, you want to put the under the Kerbin-MainClouds section. For the Val config, you want to put that under Laythe-MainClouds.

 

Doing the same for Duna should work, but you need the AVP Duststorm textures for them to work which I didn't get around to doing. 

Hope this helps!

 

  • Like 2

Share this post


Link to post
Share on other sites
6 minutes ago, CodeFantastic said:

Okay, I'm going to explain how to do this the best I can. I highly recommend downloading Notepad+, it makes editing these files easier

[SNIP]

Hope this helps!

Fantastic. Thanks for the step-by-step. Uncharacteristcally, I’ve gotta work all day tomorrow but I’ll give this a go tomorrow evening and let you know how it goes!

Share this post


Link to post
Share on other sites
Spoiler

8kxc4lr.jpg

Is everything working properly? It looks overexposed, at least center part does.

Quote

SVE
SVT
EVE
Scatterer
Kopernicus
ModuleManager 3.0.6

These are the only mods installed. All downloaded from the link posted here.

Edited by fsbd190504

Share this post


Link to post
Share on other sites
56 minutes ago, fsbd190504 said:
  Hide contents

8kxc4lr.jpg

Is everything working properly? It looks overexposed, at least center part does.

These are the only mods installed. All downloaded from the link posted here.

It looks overexposed on the center because you are looking directly at a desert, which reflects light more than the darker green areas. Everything looks fine.

Share this post


Link to post
Share on other sites

I've just realised that there was a spam in the console about the OPM planets about hires tectures.

 

Spoiler

unknown.png

 

 

Share this post


Link to post
Share on other sites
2 minutes ago, Quoniam Kerman said:

I've just realised that there was a spam in the console about the OPM planets about hires tectures.

 

  Hide contents

unknown.png

 

 

That’s not spam. That’s just KSP telling you that OPM does not have a “High Terrain Detail Preset” which it doesn’t. It defaults to “default”. This happens with every planet pack currently. Nothing is wrong, it’s just letting you know.

  • Like 1

Share this post


Link to post
Share on other sites
21 hours ago, CodeFantastic said:

Okay, I'm going to explain how to do this the best I can. ...
 

 

21 hours ago, LameLefty said:

Fantastic. Thanks for the step-by-step. Uncharacteristcally, I’ve gotta work all day tomorrow but I’ll give this a go tomorrow evening and let you know how it goes!

Success! Thanks! :)

K0J7OnO.png

Share this post


Link to post
Share on other sites
4 hours ago, Galileo said:

That’s not spam. That’s just KSP telling you that OPM does not have a “High Terrain Detail Preset” which it doesn’t. It defaults to “default”. This happens with every planet pack currently. Nothing is wrong, it’s just letting you know.

OK thanks, I thought they were textures in your last SVE release, that's why I asked. So that means there is no 'High over x' in science reports?

 

BTW the gas giants now look gorgeous. Tekto at last looks as if it had an atmosphere. (overexposed in map view though, but very nice in flight view)

Edited by Quoniam Kerman

Share this post


Link to post
Share on other sites
3 hours ago, Quoniam Kerman said:

OK thanks, I thought they were textures in your last SVE release, that's why I asked. So that means there is no 'High over x' in science reports?

 

BTW the gas giants now look gorgeous. Tekto at last looks as if it had an atmosphere. (overexposed in map view though, but very nice in flight view)

No, what it means is that in your graphic settings, if you have the terrain detail slider set to “high”, KSP looks for a “high” setting for OPM too, which doesn’t exist. So it automatically sets those bodies to “default”. 

Mad for the overexposed clouds, I have already brought it up with the EVE dev. Hopefully a fix comes soon. We will see

Share this post


Link to post
Share on other sites

It is only in map view. Unfortunately it is not only planets with atmospheres but all of them with some clear colors on them, Thatmo appears very bright in map view, almost blindingly bright... When you switch to flight mode, the white just switches to a light grey. I think it is the glow that gives the map view such brightness. But it is not breaking the game either.

Edited by Quoniam Kerman
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now