Jump to content

[KSP 1.6.1] Stock Visual Enhancements [v1.4.1] [20 March 2019]


Recommended Posts

Tried running SVE 1.2.5.0 /w scatterer 0.0320b on a new ksp 1.3.0 install and it causes Scatterer to always use Laythe config, regradless of the celestial body. This gives a planets a blue tint and breaks the terminator/sunset on Kerbin. Scatterer on its own works fine.

Relevant screenshots: https://imgur.com/a/jFvyu

output log: https://www.dropbox.com/s/rpqnrmdtwiatnme/output_log.txt?dl=0

Can't figure out what could be causing this, it seems it rewrites the Laythe config file in the Scatterer folder.

Link to post
Share on other sites
43 minutes ago, Xaryen said:

Tried running SVE 1.2.5.0 /w scatterer 0.0320b on a new ksp 1.3.0 install and it causes Scatterer to always use Laythe config, regradless of the celestial body. This gives a planets a blue tint and breaks the terminator/sunset on Kerbin. Scatterer on its own works fine.

Relevant screenshots: https://imgur.com/a/jFvyu

output log: https://www.dropbox.com/s/rpqnrmdtwiatnme/output_log.txt?dl=0

Can't figure out what could be causing this, it seems it rewrites the Laythe config file in the Scatterer folder.

The terminator is like that by design on Kerbin.Scatterer using the laythe cfg is normal and isn't actually being used. It does not give planets a blue tint. It's just a bug in scatterer. Scatterer doesn't play nice with module manager, and that's a product of that. Looks like that answers your questions. 

Link to post
Share on other sites

I see, thanks for the answer. So I guess that it's no longer a thing with the orange/sunset colored clouds around the terminator(like the picture in the OP and default scatterer+EVE)? I remembered that from the last time I played ksp, which was admittedly more than a few months ago.

 

PS: This is what I meant by the blue tint, I suppose that is also by design then.

Link to post
Share on other sites
33 minutes ago, Xaryen said:

I see, thanks for the answer. So I guess that it's no longer a thing with the orange/sunset colored clouds around the terminator(like the picture in the OP and default scatterer+EVE)? I remembered that from the last time I played ksp, which was admittedly more than a few months ago.

 

PS: This is what I meant by the blue tint, I suppose that is also by design then.

Its still a thing, but with the latest Scatterer, some sacrifices had to be made to make SVEs clouds work properly. The orange sunset is visible from the surface, but its so subtle in scaled space its practically unnoticeable. The scatterer dev knows of the issues but he is taking a break from KSP, and hasnt implemented a fix yet.  I can fix it from my side, but only doing it in a way i find unattractive, so i will just wait for the fix from scatterer.

Edited by Galileo
Link to post
Share on other sites
7 hours ago, Galileo said:

Just made the Sun textures PNG because OpenGL systems did not like the sun in DDS format for whatever reason.

FWIW, I play KSP in Linux and macOS, both of which use OpenGL, and I've never had any problems with the sun (or any other) texture being DDS.  I installed the update, but the sun looks the same as it did before.

(Is it something related to Kopernicus maybe?  I think I've read that Kopernicus has problems with DDS planet textures on OpenGL systems.  I don't use Kopernicus currently, though I've used it in the past and didn't notice any texture problems.)

Link to post
Share on other sites
On 26.9.2017 at 12:45 AM, Galileo said:

Its still a thing, but with the latest Scatterer, some sacrifices had to be made to make SVEs clouds work properly. The orange sunset is visible from the surface, but its so subtle in scaled space its practically unnoticeable. The scatterer dev knows of the issues but he is taking a break from KSP, and hasnt implemented a fix yet.  I can fix it from my side, but only doing it in a way i find unattractive, so i will just wait for the fix from scatterer.

good to hear, it can also (unsightly) be fixed. I hope you will do, if Scatterer dev. don't fix it untill the end of 2017   cause I miss the colors :-)

Link to post
Share on other sites
On 9/26/2017 at 8:08 AM, Wyzard said:

FWIW, I play KSP in Linux and macOS, both of which use OpenGL, and I've never had any problems with the sun (or any other) texture being DDS.  I installed the update, but the sun looks the same as it did before.

(Is it something related to Kopernicus maybe?  I think I've read that Kopernicus has problems with DDS planet textures on OpenGL systems.  I don't use Kopernicus currently, though I've used it in the past and didn't notice any texture problems.)

It was popular belief a while ago that DDS textures and OpenGL systems didn't play nice, but I helped put that to rest a little while back by taking a page out of RSS' book. See here:

Star textures are different than normal bodies I assume, and for some reason, some people on OpenGl systems still have a hard time when they are in DDS format. ¯\_(ツ)_/¯ 

Link to post
Share on other sites
26 minutes ago, tsd said:

I rerember a long time ago that there were big snow storms on the poles of kerbin, and now there is no storm effect on poles. I thought it looked really nice, could someone please explain why they were removed?

scatterer was causing them to turn black. They will not return until scatterer updates.

Edited by Galileo
Link to post
Share on other sites

Is this mod compatible with Mac yet?

I have installed this with ExtraSolar, and it now makes Kerbin have no clouds. Same with the other bodies. Im using Lo-Res

*edit* Accidently installed the 1.2.2 EVE mod so thats what caused it :sticktongue:

Edited by Starslinger999
Link to post
Share on other sites
1 hour ago, Kerbin's Bill said:

Does Stock Visual Enhancements has dust in low gravity planets?

In this video Minmus and Moho have dust.But my game doesn't look like Hazardish's after I install SVE.How could I get those visual enhancements?

 

The that’s an old version of SVE. The dust was removed a few versions ago due to an issue with cloud color and scatterer.

Link to post
Share on other sites
28 minutes ago, MassoudGL said:

So I've been getting this a lot lately on Minmus and Tylo. Any ideas as to what could be causing it??? I can see straight through the planet. Seems to go away when I get far away.

That looks like the "floating tiles" problem, more commonly seen on Kerbin, where it's caused by having Scatterer's fancy water effects enabled.  It seems likely that Scatterer is to blame for floating tiles on other planets too, even if they don't actually have water.  (The problem probably isn't with the water itself, but with however Scatterer hooks itself into the terrain rendering when the setting is enabled.)

Link to post
Share on other sites
7 hours ago, Galileo said:

The that’s an old version of SVE. The dust was removed a few versions ago due to an issue with cloud color and scatterer.

So what version is it? And can I make some changes to SVE 1.26  to get those dust?

Edited by Kerbin's Bill
Link to post
Share on other sites
2 minutes ago, dtoxic said:

Hi all i have been out of the loop for a while, can some one tell me where do i disable the glow of planets? kinda forgot where the setting was

The glow? 

Just don’t install scatterer?

Link to post
Share on other sites
2 minutes ago, Galileo said:

The glow? 

Just don’t install scatterer?

hmmm ok, but i had scatterer installed in 1.2.2 and i remember that i could disable the glow of planets, just cant remember what i did to do so 

Link to post
Share on other sites
31 minutes ago, dtoxic said:

hmmm ok, but i had scatterer installed in 1.2.2 and i remember that i could disable the glow of planets, just cant remember what i did to do so 

Its not possible to disable the atmosphere effects and keep the other features. It has never been an option.

Link to post
Share on other sites
2 minutes ago, Galileo said:

Its not possible to disable the atmosphere effects and keep the other features. It has never been an option.

ok thx for the info, will check with my older ksp see if i am missing something, anyway thx

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...