Galileo

[KSP 1.6.1] Stock Visual Enhancements [v1.4.1] [20 March 2019]

Recommended Posts

5 minutes ago, MartGonzo said:

hmm, seems like it's massively variable, I can only assume it's bottlenecking on your chip which of course it really shouldn't be doing.

well I'm confused, no idea why that would be, sorry for jumping in.

no its all good man. That is just solidifying the fact that it may not be anything i did wrong which is a good thing.

 

Share this post


Link to post
Share on other sites

@theaveragepxtseryu

hmm odd they arent showing up. Do you have BoulderCo in your gamedata folder by chance?

The textures can be found here:

GameData/StockVisualEnhancements/EVE/Atmosphere/Textures

 

Im pretty sure i figured out the issue and will be posting a new version soon

sC52pQ2.png5EIvPdM.pngs57MoRM.png

Edited by Galileo

Share this post


Link to post
Share on other sites

Wait, I needed to install boulderco for this to work?

 

D'oh.

 

My bad, totally my fault, should've known to install it.

Share this post


Link to post
Share on other sites
1 minute ago, theaveragepxtseryu said:

Wait, I needed to install boulderco for this to work?

 

D'oh.

 

My bad, totally my fault, should've known to install it.

no i was asking because you should NOT have it! lol sorry should have been more clear

Post a screenshot of your gamedata folder and post your logs. ill take a look

for anyone that has asked for help and i havent responded i apologize. this thread is moving pretty quick today

Edited by Galileo

Share this post


Link to post
Share on other sites

I've got a GTX770 OC with the hight res pack and I've got 30-40 fps on space center. And I've got 60-70 fps when I removed the atmo layers for Kerbin.

Same with medium and low res pack.

Edited by Vandest

Share this post


Link to post
Share on other sites
4 minutes ago, Galileo said:

Im pretty sure i figured out the issue and will be posting a new version soon

Great news! I too spent the morning looking into performance, and found that even just disabling layerVolumes that are further than 10km away improves performance (especially around big space stations), but those FPS graphs look even better - and at low altitude!

Share this post


Link to post
Share on other sites
Just now, Vandest said:

I've got a GTX770 OC with the hight res pack and I've got 30-40 fps on space center. And I've got 60-70 fps when I removed the atmo layers for Kerbin.

Same with medium and low res pack.

yeah i removed those and for some reason i had my cirrus cloud layer with volumetric clouds which hurt more than it looked good so i just got rid of it

Share this post


Link to post
Share on other sites
6 minutes ago, Galileo said:

@theaveragepxtseryu

hmm odd they arent showing up. Do you have BoulderCo in your gamedata folder by chance?

The textures can be found here:

GameData/StockVisualEnhancements/EVE/Atmosphere/Textures

 

Im pretty sure i figured out the issue and will be posting a new version soon

sC52pQ2.png5EIvPdM.pngs57MoRM.png

wow that is a serious performance boost there, am i correct in assuming that those little hickups are GC ones?

Share this post


Link to post
Share on other sites
Just now, Waz said:

Great news! I too spent the morning looking into performance, and found that even just disabling layerVolumes that are further than 10km away improves performance (especially around big space stations), but those FPS graphs look even better - and at low altitude!

yeah i was pulling my hair out. its strange that the same layers that i just removed didnt have that big of an impact on previous versions. either way they weren't vital to this pack at all so i happily removed them. 

 

2 minutes ago, Jiraiyah said:

wow that is a serious performance boost there, am i correct in assuming that those little hickups are GC ones?

yeah im sure they are GC but they are sooo small the human eye cant pick up the stutter if there even is one.

Share this post


Link to post
Share on other sites

true, when i asked if they are GC, i was gonna commenting that if they are GC then that graph is perfect

Share this post


Link to post
Share on other sites
On 12/10/2016 at 11:52 PM, Waz said:

You realize that's not a real photograph of Earth, right? It's not even possible to represent how dim the auroras really are without using HDR effects. In real life, for example, they're entirely invisible during the day, but notice that with EVE/SVE, they still show up. This is because they really should be much dimmer, and the night side should be so deeply black that they show up provided you don't have the glare of the day side in view.

Unfortunately there's no real visible light photographs of aurorae on Earth because very few spacecraft appear to orbit that high with cameras. I got that pic from http://earthobservatory.nasa.gov/IOTD/view.php?id=6226&src=ve and that just tells me that it's a composite of a "Blue Marble" Earth and the actual aurora from the IMAGE satellite, so no indications of intensity. Also this http://www.nasa.gov/mission_pages/sunearth/aurora-over-the-south-pole seems to have it visible on the day side too.

 

On a more productive note, @Waz is it possible to add a quick toggle on/off button for EVE clouds/particles to boost FPS on part heavy launches?

Share this post


Link to post
Share on other sites
19 minutes ago, SleweD said:

Unfortunately there's no real visible light photographs of aurorae on Earth because very few spacecraft appear to orbit that high with cameras. I got that pic from http://earthobservatory.nasa.gov/IOTD/view.php?id=6226&src=ve and that just tells me that it's a composite of a "Blue Marble" Earth and the actual aurora from the IMAGE satellite, so no indications of intensity. Also this http://www.nasa.gov/mission_pages/sunearth/aurora-over-the-south-pole seems to have it visible on the day side too.

Which "day" side? That's the South Pole in Winter. I can see green glow on the lower rim of the atmosphere, but that looks fake from overexposure and color balancing, especially since it extends all the way to 45 degrees south over Chile (equivalent of Paris).

Quote

On a more productive note, @Waz is it possible to add a quick toggle on/off button for EVE clouds/particles to boost FPS on part heavy launches?

It's productive in the sense that aurora depicted in SVE would ideally be as realistic as possible while still being interesting. Players learn a lot from playing KSP, and I think we have some duty to not be too misleading.

The Auroras in the config I'm pretty sure should have _MinLight = 1 (it's currently 0.5) then be dimmed/brightened in _Color to whatever looks good, as this means *no* Diffuse lighting is done to them (which would be physically correct, as they're entirely Emissive).

As for a quick toggle, that would be another possible workaround. Let's see what Galileo and I can come up with actually fixing the problem first :-). Certainly it's easy to add.

 

Edited by Waz

Share this post


Link to post
Share on other sites
13 minutes ago, theaveragepxtseryu said:

@Galileo http://imgur.com/a/wYw5W

What part of the logs do you need, specifically?

 

It's just spamming the debug with something about an error with sun flares..

And Boulderco is NOT inside SVE

ok may i ask why you changed StockVisualEnhancements folder name to SVE? That is why EVE cant find the textures BTW :) change it back to StockVisualEnhancements and you will be good

Share this post


Link to post
Share on other sites

Hey @Galileo, have you ever though about adding a screenshot album or two in the OP of both this thread and SVT? Would give people a bit of a chance to see what they're getting before they get it. I mean, I don't think I've ever seen what Duna looks like with this installed as I personally don't have the mod. Just a suggestion. Keep up the good work. 

Share this post


Link to post
Share on other sites

I'm all for FPS as the next guy but I generally like to cap my FPS at around 35. This may be old-school thinking though, so I'd like to ask if it is still worth capping FPS for the sake of better CPU performance now that GPUs are way more of a thing. In other words, the less FPS the more time there is for other stuff, and KSP being CPU-intensive I like to give it all the extra time I can each second. I guess tho this is really a moot question since even if I set the FPS limiter in the config to 35 I still always get 60FPS max instead...

Share this post


Link to post
Share on other sites
4 minutes ago, Drew Kerman said:

I'm all for FPS as the next guy but I generally like to cap my FPS at around 35. This may be old-school thinking though, so I'd like to ask if it is still worth capping FPS for the sake of better CPU performance now that GPUs are way more of a thing. In other words, the less FPS the more time there is for other stuff, and KSP being CPU-intensive I like to give it all the extra time I can each second. I guess tho this is really a moot question since even if I set the FPS limiter in the config to 35 I still always get 60FPS max instead...

i personally dont see a reason to cap the fps but it really depends on your cpu. if you have an i5 or i7, i wouldnt cap it because it wouldnt make a difference in terms of CPU usage because KSP doesnt multi thread. 

Share this post


Link to post
Share on other sites
23 hours ago, fourfa said:

Rad.  Next question if it's not too much - the default atmospheric opacity on Kerbin surface in the new 1.2 pack is a little... smoggy for my taste.  I'd like to adjust it to more of a crisp wilderness vista feel, like having a clear view of the mountains from KSC.  Is that an option to play with in Scatterer?  In the SVE configs?

I looked for a Scatterer FAQ or manual - can't make head or tail of the innumerable options there.  If this is better posted in the Scatterer thread, that's fine

I took what you said and played around with the post processing. Although I dont think its as clear as you wanted, you can see a big difference and i included it in my latest version.

 

Original Scatterer settings
hS89oO4.png

New Scatterer settings
FuFYosq.png

 

Edited by Galileo

Share this post


Link to post
Share on other sites

Not sure if this has already been reported, but the download link on the first post is broken.  I'm no expert but I think your GitHub repository is missing a whole bunch of stuff, and a a side-effect it broke my CKAN.

Share this post


Link to post
Share on other sites
13 minutes ago, Fwiffo said:

Not sure if this has already been reported, but the download link on the first post is broken.  I'm no expert but I think your GitHub repository is missing a whole bunch of stuff, and a a side-effect it broke my CKAN.

yes, probably because of this :)

PERFORMANCE UPDATE

1.1.1

  • Complete performance overhaul of all celestial bodies with clouds sans Jool
  • Changed the post processing on Kerbin. Now the atmosphere isnt so "smoggy"
  • Updated to the new and improved EVE.

If you are still experiencing any lag from the volumetric clouds, open the EVE GUI (alt+0) and look for the cloud layer you want to change in the cloud manager. Scroll down until you find the layerVolume section of the GUI and change the visibleRange value from 10,000 to a lower number i.e. 8,000/5,000/2,000 until you get the performance you are looking for. Thank you @Waz for this wonderful feature



**DO NOT INSTALL EVE SEPERATELY, EVERYTHING IS BUNDLED IN THIS DOWNLOAD**

 

Download Link

 xO68iAc.jpg

 

GIVE ME SOME FEEDBACK ON PERFORMANCE. 

Edited by Galileo

Share this post


Link to post
Share on other sites
5 minutes ago, Galileo said:

yes, probably because of this

Ah, cool!

'Ya might want to leave old release zip's around for CKAN's sake (at least until your updates propagate through to it...)

Share this post


Link to post
Share on other sites
8 minutes ago, Fwiffo said:

Ah, cool!

'Ya might want to leave old release zip's around for CKAN's sake (at least until your updates propagate through to it...)

I didnt even realize SVE was still on CKAN! my bad... @politas sorry if I'm inadvertently making your life harder! not my intention

Edited by Galileo

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.