Galileo

[KSP 1.6.1] Stock Visual Enhancements [v1.4.1] [20 March 2019]

Recommended Posts

2 hours ago, SkippydaHippie said:

figured it out. EVE and Kopernicus not getting along

Strange. I'm running it just fine right now.

Share this post


Link to post
Share on other sites
6 hours ago, SkippydaHippie said:

figured it out. EVE and Kopernicus not getting along

If you are not seeing clouds in the main menu,  that's normal and a known bug. Actually go into the game and you will see the clouds are there. 

Edited by Galileo

Share this post


Link to post
Share on other sites
3 hours ago, Galileo said:

If you are not seeing clouds in the main menu,  that's normal and a k own bug. Actually go into the game and you will see the clouds are there. 

See I tried and the clouds weren't there.. That was one of my first install attempts though so Ill try again.

Edit: Well it worked when I got up this morning! I don't know what I did but I'll take it.

Edited by SkippydaHippie

Share this post


Link to post
Share on other sites

I couldn't make it run this mod properly. Installed all the required and recommended mods as described in 6 steps. However, when I play there is no visual changes. It plays as if there is no mod installed. I tried to re-install them a few times, still no change. 

I'm using late 2013 15" MacBook Pro w/ GT 750M gpu.

Share this post


Link to post
Share on other sites
16 hours ago, SkippydaHippie said:

I've tried carefully following the install instructions three times now and I can't get the clouds to show up at all. I have gotten to work on previous versions of ksp just fine but this all says 1.2 compatible so I'm doing something wrong... Anyone have an idea of what dumb thing I've done to cause this?

For some reason the clouds don't show up in the title screen but they will show up in game, if that helps.

Share this post


Link to post
Share on other sites

Just wondering what's your average FPS like with the high resolution version of SVE + Stock Visual Terrain? I have an overclocked GTX1080 and a i7 4690K running at 4.4 GHz and I'm getting around 40 FPS at KSC (main scene/Launchpad).

Share this post


Link to post
Share on other sites
7 minutes ago, Jashin said:

Just wondering what's your average FPS like with the high resolution version of SVE + Stock Visual Terrain? I have an overclocked GTX1080 and a i7 4690K running at 4.4 GHz and I'm getting around 40 FPS at KSC (main scene/Launchpad).

Give me a second and ill take some screen shots showing my FPS. do note that i dont have any other mods besides SVT and SVE and the recommended mods. Part packs crush FPS even if they arent being utilized in game. Just having the part pack in your GameData folder causes performance drop.

Share this post


Link to post
Share on other sites

Thanks Galileo! I'll test my fully modded install and I'll set another install up with only SVE and SVT to measure the difference between the two. I have many parts mods and I'm now at a point where I try to optimize my config so the game doesn't crash too much and I can have a reliable experience.

Edit: from what I've seen so far, I'm getting 60+ FPS with a vanilla install and only SVE + SVT, compared to about 40 with my heavy modlist.

Edited by Jashin

Share this post


Link to post
Share on other sites

@Jashin this is what my fps look like. The screenshot got cutoff a little but its at about 73 fps. They average roughly 70-75 fps with what you see here.

I am currently using a GTX 980 OC'd and have an i54690k OC'd to 4.1 ghz

It would not surprise me if multiple part packs bring you down to about 40 fps. Thats actually not bad. What i usually do with my part packs is go through them and remove all of the parts i know i wont use and I use procedural parts to replace all the tanks.  This frees up enough for me to average 60fps with about 90 other mods installed... Only 2 or 3 part packs though.

6HKZ8KM.png37aIP2f.png

Edited by Galileo

Share this post


Link to post
Share on other sites

Thanks @Galileo ! There begins my quest for optimization and performance! I'll see what mods/parts I can shear. Right now, the FPS is not the biggest of my concerns since the games tends to crash a lot due to the huge memory allocation (more than 8 Gb, prone to crashing on scene change).

Just a last question: do you use the default DirectX9 or do you force DX11? I tried OpenGL with -force-glcore but it seems to break Scatterer completely.

Share this post


Link to post
Share on other sites
On 23/10/2016 at 2:20 PM, Galileo said:

What should I do next time to make putting it on ckan easier for you guys? I was kind of working blind last time and went off of my assumptions of how CKAN works. Sorry if it was a pain in the butt.  

1.1.4's restructure should make things much smoother going forward for SVE on CKAN. What took time was undoing all the tricky stuff we had for the old config and reorganising all the dependencies and new downloads. The separate download for the Scatterer stuff will reduce the excess downloads (HR + LR), too.

The Snow download will need some further investigation to figure out, so that hasn't been added, yet. Might ask for some minor changes there in the future, but I'll get back to you.

Share this post


Link to post
Share on other sites

Whenever I try to update or uninstall this mod via ckan it just crashes.

CKAN.ModuleNotFoundKraken: Cannot install EngineLighting, module not available
   at CKAN.CkanModule.FromIDandVersion(IRegistryQuerier registry, String mod, KspVersion ksp_version)
   at CKAN.RelationshipResolver.<RelationshipResolver>c__AnonStorey0.<>m__0(String name)
   at System.Linq.Enumerable.WhereSelectListIterator`2.MoveNext()
   at System.Collections.Generic.List`1..ctor(IEnumerable`1 collection)
   at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)
   at CKAN.RelationshipResolver..ctor(IEnumerable`1 module_names, RelationshipResolverOptions options, IRegistryQuerier registry, KspVersion kspversion)
   at CKAN.MainModList.ComputeConflictsFromModList(IRegistryQuerier registry, IEnumerable`1 change_set, KspVersion ksp_version)
   at CKAN.Main.<UpdateChangeSetAndConflicts>c__async1.MoveNext()

The module above also changes to a different one if i remove that first before trying again. I can update all other mods, just not this one :/

Share this post


Link to post
Share on other sites
35 minutes ago, John007qwe said:

Whenever I try to update or uninstall this mod via ckan it just crashes.

CKAN.ModuleNotFoundKraken: Cannot install EngineLighting, module not available
   at CKAN.CkanModule.FromIDandVersion(IRegistryQuerier registry, String mod, KspVersion ksp_version)
   at CKAN.RelationshipResolver.<RelationshipResolver>c__AnonStorey0.<>m__0(String name)
   at System.Linq.Enumerable.WhereSelectListIterator`2.MoveNext()
   at System.Collections.Generic.List`1..ctor(IEnumerable`1 collection)
   at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)
   at CKAN.RelationshipResolver..ctor(IEnumerable`1 module_names, RelationshipResolverOptions options, IRegistryQuerier registry, KspVersion kspversion)
   at CKAN.MainModList.ComputeConflictsFromModList(IRegistryQuerier registry, IEnumerable`1 change_set, KspVersion ksp_version)
   at CKAN.Main.<UpdateChangeSetAndConflicts>c__async1.MoveNext()

The module above also changes to a different one if i remove that first before trying again. I can update all other mods, just not this one :/

You might find better help in the according thread of CKAN.

 

Seeing Engine Lighting as a mod in your log I'd doubt this interferes with anything inside SVE so you better look at the thread I linked above :)

Share this post


Link to post
Share on other sites
24 minutes ago, nebuchadnezzar said:

@Galileo Is it possible to have a all-in-one install again for all of us non CKAN users? I miss having it all in one go and it sure made it easier to install!

Ill see what i can do

Share this post


Link to post
Share on other sites

Haha, great! Just two minutes after I downloaded and installed each part at a time.:D Kismet, won't stop me enjoying it anyway!

Thank you very much @Galileo for your great work!

 

Share this post


Link to post
Share on other sites

I think it's good to have the long way described, if only as a reference for all the ways you can wreck the install by going out of order?

Share this post


Link to post
Share on other sites
12 minutes ago, fourfa said:

I think it's good to have the long way described, if only as a reference for all the ways you can wreck the install by going out of order?

Well going forward I will distribute SVE in 2 packs, one for ckan and one that is completely bundled for easy installation.  My hope is for the long way to become obsolete  because nobody should be downloading the ckan version to do a manual install. 

@politas let me know if doing it this was creates a headache or if I just need to make a new repo for the ckan format sve

Edited by Galileo

Share this post


Link to post
Share on other sites

Quite satisfied with latest build regarding scatterer configs. Not too aggressively applied so Kerbin looks more blue than greyish from orbit. I do however believe I will copy config point 6 over to point 5 to get the termination a bit sooner.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.