Jump to content

[KSP 1.6.1] Stock Visual Enhancements [v1.4.1] [20 March 2019]


Recommended Posts

If you had to give a "recommended/minimum" GPU spec for running SVE what would you suggest? 
I love this mod but I start suffering from poor FPS with anything other than small craft (running the latest, low res version of SVE). I've got a GTX 760 (4GB DDR5), which I know isn't the newest or shiniest graphics card, but I would have thought it could handle this better.  
Is there anything I can do to optimize SVE for better performance? 

Link to post
Share on other sites
38 minutes ago, katateochi said:

If you had to give a "recommended/minimum" GPU spec for running SVE what would you suggest? 
I love this mod but I start suffering from poor FPS with anything other than small craft (running the latest, low res version of SVE). I've got a GTX 760 (4GB DDR5), which I know isn't the newest or shiniest graphics card, but I would have thought it could handle this better.  
Is there anything I can do to optimize SVE for better performance? 

I used to run it very well with a gtx 960 but that's the lowest end graphics card I have run it with. 

To optimize it,  you could disable Scatterer's ocean shaders.  That is easily the most performance heavy piece of SVE.  

 

Link to post
Share on other sites

So, i was flying a rocket and noticed that the atmosphere gradient (or the atmosphere itself isn't appearing, it's just pitch plack.Also from map view, Kerbin is covered by pink. I followed and double checked if installed it correctly.Here is the log and screenshots:

https://mega.nz/#!woNQwYSD!vNTXIThPemBoGZAK2R_CS9o08ub_C9VYvdnM2cXZP8I

Spoiler

rtlqgo.png

11wfwxg.png

 

Link to post
Share on other sites

Updated Scatterer for those that don't use eclipses.

7 hours ago, Speadge said:

hey Galileo,

 

do u think its possible that u add some kind of lens-scratches like proot did in his KSPRC? (if he's fine with that):

74ZVMnt.jpg

If i do that, it will be in my sun flare pack, not on SVE. Some people don't like it so i don't want to force it on em, ya know? 

Link to post
Share on other sites
12 minutes ago, Galileo said:

Updated Scatterer for those that don't use eclipses.

If i do that, it will be in my sun flare pack, not on SVE. Some people don't like it so i don't want to force it on em, ya know? 

yeah, was just an idea. Since i know how to add it for myself, it was just for others to share :)

Link to post
Share on other sites

Hello, I have used SVE and EVE and Scatterer for a long time now since around 1.1.2, and it is now not working for me for an unknown reason. 

I'm using:

- SVE HR 1.1.4

- Latest EVE Configs and EVE Release files

- Latest Scatterer

- In addition to many other mods

I compared my new modded 1.2.1586 install to my 1.1.3 (which works perfectly with SVE) and found that I was missing the BoulderCo folder in my (working) 1.1.3, so I tried deleting that and it still doesn't work

Here's a screenshot of Kerbin in my Modded 1.2 with EVE, SVE, Scatterer installed:

Modded%20install_zpskb7i2bqy.png

 

So I tried it with a clean vanilla install of 1.2 and it still doesn't seem to be working properly. Here's a screenshot of the vanilla with the SVE installed (looks like I'm just missing the clouds?:

Clean%20Install_zpsrzzpqnly.png

Here is a shot of the mods installed on the clean version:

Capture_zps2jb4jifw.png

 

Here is a link to my output.log (in my modded version of 1.2):

https://1drv.ms/t/s!AvUWxjgM4SuQhbY1oYiZxmSH7XbDTg

Please let me know if there is anything that you need in order to help you help me.

Edited by Voodoo8648
Link to post
Share on other sites
20 minutes ago, Voodoo8648 said:

Hello, I have used SVE and EVE and Scatterer for a long time now since around 1.1.2, and it is now not working for me for an unknown reason. 

I'm using:

- SVE HR 1.1.4

- Latest EVE Configs and EVE Release files

- Latest Scatterer

- In addition to many other mods

I compared my new modded 1.2.1586 install to my 1.1.3 (which works perfectly with SVE) and found that I was missing the BoulderCo folder in my (working) 1.1.3, so I tried deleting that and it still doesn't work

Here's a screenshot of Kerbin in my Modded 1.2 with EVE, SVE, Scatterer installed:

Modded%20install_zpskb7i2bqy.png

 

So I tried it with a clean vanilla install of 1.2 and it still doesn't seem to be working properly. Here's a screenshot of the vanilla with the SVE installed (looks like I'm just missing the clouds?:

Clean%20Install_zpsrzzpqnly.png

Here is a shot of the mods installed on the clean version:

Capture_zps2jb4jifw.png

 

Here is a link to my output.log (in my modded version of 1.2):

https://1drv.ms/t/s!AvUWxjgM4SuQhbY1oYiZxmSH7XbDTg

Please let me know if there is anything that you need in order to help you help me.

You should not be using BoulderCo.  Do a fresh install without it. 

Link to post
Share on other sites
Just now, Galileo said:

You should not be using BoulderCo.  Do a fresh install without it. 

I deleted BoulderCo folder and it still didn't work... BTW here is a side by side look at the working 1.1.3 compared to my fresh vanilla install of 1.2

Capture_zpsyjfiv3x0.png

2 minutes ago, Galileo said:

You should not be using BoulderCo.  Do a fresh install without it. 

Should I install ANYTHING from the EVE mod?

Link to post
Share on other sites
7 minutes ago, Voodoo8648 said:

I deleted BoulderCo folder and it still didn't work... BTW here is a side by side look at the working 1.1.3 compared to my fresh vanilla install of 1.2

Capture_zpsyjfiv3x0.png

Should I install ANYTHING from the EVE mod?

The sun reflection is broken in the latest scatterer.  Blackrack has fixed it in the experimental version but unfortunately that version doesn't not work with SVE at the moment.  So the sun reflection looks like that for now

Link to post
Share on other sites
3 minutes ago, PickledTripod said:

 

I installed a FRESH version of 1.2 and copied in the mods from the RAR (not from the prev gamedata folder) and it's still not working properly.... It seems as though that I am missing the clouds and the High reflectivity as seen in my above side by side post.

 

3 minutes ago, Galileo said:

The sun reflection is broken in the latest scatterer.  Blackrack has fixed it in the experimental version but unfortunately that version doesn't not work with SVE at the moment.  So the sun reflection looks like that for now

what about the missing clouds?

Link to post
Share on other sites
2 minutes ago, Voodoo8648 said:

I installed a FRESH version of 1.2 and copied in the mods from the RAR (not from the prev gamedata folder) and it's still not working properly.... It seems as though that I am missing the clouds and the High reflectivity as seen in my above side by side post.

 

what about the missing clouds?

Clouds work

Link to post
Share on other sites
2 minutes ago, Galileo said:

Then you must be installing wrong.  Are you using the version of EVE included in the download? 

Here is what my Gamedata folder looks like with the new clean fresh install:

Capture_zpsk8qob7iq.png

Here is what my currenly open game looks like as of right now:

Capture_zps0hm344em.png

8 minutes ago, Galileo said:

Then you must be installing wrong.  Are you using the version of EVE included in the download? 

Here's my Output Log:

https://1drv.ms/t/s!AvUWxjgM4SuQhbY4DWrHDN_0tjgcbA

Link to post
Share on other sites
6 minutes ago, Voodoo8648 said:

Here is what my Gamedata folder looks like with the new clean fresh install:

Capture_zpsk8qob7iq.png

Here is what my currenly open game looks like as of right now:

Capture_zps0hm344em.png

No,  that's note how it should look. You don't even have StockVisualEnhancements folder in your gamedata.

OK,   Here are some simple instructions. 

1. Download this.  https://github.com/Galileo88/StockVisualEnhancements/releases/tag/v1.1.4

2. Choose what resolution you want.  

3. Open the GameData file and move everything into your gamedata folder. 

4. Enjoy. 

 

 

Edited by Galileo
Link to post
Share on other sites
10 minutes ago, Galileo said:

No,  that's note how it should look. You don't even have StockVisualEnhancements folder in your gamedata.

OK,   Here are some simple instructions. 

1. Download this.  https://github.com/Galileo88/StockVisualEnhancements/releases/tag/v1.1.4

2. Choose what resolution you want.  

3. Open the GameData file and move everything into your gamedata folder. 

 

Ok, the download in the All-in-one package and it did WORK. Thank you.... but after seeing that it worked, I wanted to find out what I was doing wrong, so I installed yet another fresh copy of 1.2 and installed the LATEST individual mod versions (separately)  to duplicate the correct installation and they do not work. That method of installing it is missing the clouds.

Again, I downloaded the latest versions of Distant Object, EVE (no BoulderCo install), Scatterer, and SVE.

Installed these on a fresh install of 1.2 and the clouds don't work

Capture_zpsgpf5itsc.png

19 minutes ago, Galileo said:

No,  that's note how it should look. You don't even have StockVisualEnhancements folder in your gamedata.

OK,   Here are some simple instructions. 

1. Download this.  https://github.com/Galileo88/StockVisualEnhancements/releases/tag/v1.1.4

2. Choose what resolution you want.  

3. Open the GameData file and move everything into your gamedata folder. 

 

I just deleted the Scatterer folder and installed the scatterer folder from the SVE/Scatterer.cgf.zip and that does not affect the missing clouds either

Link to post
Share on other sites
3 minutes ago, Voodoo8648 said:

Ok, the download in the All-in-one package and it did WORK. Thank you.... but after seeing that it worked, I wanted to find out what I was doing wrong, so I installed yet another fresh copy of 1.2 and installed the LATEST individual mod versions (separately)  to duplicate the correct installation and they do not work. That method of installing it is missing the clouds.

Again, I downloaded the latest versions of Distant Object, EVE (no BoulderCo install), Scatterer, and SVE.

Installed these on a fresh install of 1.2 and the clouds don't work

Capture_zpsgpf5itsc.png

It does work but the installation is a bit more involved and can be messed up easily as you just found out first hand. From the way you had it installed earlier,  I would have to bet you just installed it incorrectly.  That version that is all split up for ckan only. 

Edited by Galileo
Link to post
Share on other sites
2 minutes ago, Galileo said:

It does work but the installation is a bit more involved and can be messed up easily as you just found out first hand. From the way you had it installed earlier,  I would have to bet you just installed it incorrectly.  That version that is all split up for ckan only. 

I understand now. Honestly the installation process and lack of clear instructions has always been a bit confusing in my personal experience. I went back to the download link and found that for some reason the "Latest Release" (all in one) is not at the top, so I missed that. anyway, It works now... Hopefully they release a version of scatterer with the highly reflective sunlight off of the water that is compatible with SVE... perhaps I might try an older version of scatterer

Thank you SOOOO much for the help!!! great work on this mod!

Link to post
Share on other sites
4 minutes ago, Voodoo8648 said:

I understand now. Honestly the installation process and lack of clear instructions has always been a bit confusing in my personal experience. I went back to the download link and found that for some reason the "Latest Release" (all in one) is not at the top, so I missed that. anyway, It works now... Hopefully they release a version of scatterer with the highly reflective sunlight off of the water that is compatible with SVE... perhaps I might try an older version of scatterer

Thank you SOOOO much for the help!!! great work on this mod!

An older version of scatterer won't work.  There is an update for Scatterer in the works that will fix the issue

The all in one isn't at the top because it's a different branch than the one for ckan.  I'll try to fix this in the future

Edited by Galileo
Link to post
Share on other sites
8 minutes ago, Galileo said:

An older version of scatterer won't work.  There is an update for Scatterer in the works that will fix the issue

The all in one isn't at the top because it's a different branch than the one for ckan

Ahhh, ok! Glad to hear there is an update for Scatterer coming! I'm going to look into switching to CKAN

Edited by Voodoo8648
Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...