CobaltWolf

[1.2.1] Mini Sample Return Capsule - Bring your experiments home safe! (v1.2 9/Nov/2016)

Recommended Posts

16 minutes ago, Jso said:

Nope. I fiddled with this a bit and made it more to my liking. The science results transfer bit is at the bottom.

Always looking out for me <3

Share this post


Link to post
Share on other sites
On 7/9/2016 at 1:03 AM, CobaltWolf said:

Hello all! I have another new mod for you. A couple weeks ago, the incredibly handsome @AlbertKermin asked me if I was interested in making a mini-mod. Inspired by the OSIRIS-Rex mission, he wanted a small sample return capsule that could be loaded with experiments and safely return.

kR5eT3n.png

The mod contains two parts, a command/parachute and heatshield/cargobay. It is currently 2AM, so I don't want to write more, but I wanted to post this in time for the weekend!

DLfromSpaceDock.png

Compatibility:

RemoteTech configs are included.

Known Issues:

There is no data storage in the command module. It will be added soon.

Future Plans:

lol. Accept compatibility patches, keep it working with future KSP updates.

Credits:

@AlbertKermin - Configs, compatibility, balance
@CobaltWolf - Models, textures, Unity
@Deimos Rast - Compatibility configs

License:

This work is presented under a Simplified BSD license.

88x31.png

Art assets used in Mini Sample Return Capsule were made by Matthew (CobaltWolf) Mlodzienski and are licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License.

All source files for the mod, including uncompiled textures and models, are available upon request.

 

CobaltWolf, I found a bug with the parachute module on the return capsule. The parachute deploys without you deploying it, meaning it is active and deployed in mid flight on launch. There is no way to cut it or stow it. There is also no way to deploy/pack it. Let me show you a screenshot of the issue:

8l5nD2B.png

 

 

Share this post


Link to post
Share on other sites
On 7/9/2016 at 1:03 AM, CobaltWolf said:

Hello all! I have another new mod for you. A couple weeks ago, the incredibly handsome @AlbertKermin asked me if I was interested in making a mini-mod. Inspired by the OSIRIS-Rex mission, he wanted a small sample return capsule that could be loaded with experiments and safely return.

kR5eT3n.png

The mod contains two parts, a command/parachute and heatshield/cargobay. It is currently 2AM, so I don't want to write more, but I wanted to post this in time for the weekend!

DLfromSpaceDock.png

Compatibility:

RemoteTech configs are included.

Known Issues:

There is no data storage in the command module. It will be added soon.

Future Plans:

lol. Accept compatibility patches, keep it working with future KSP updates.

Credits:

@AlbertKermin - Configs, compatibility, balance
@CobaltWolf - Models, textures, Unity
@Deimos Rast - Compatibility configs

License:

This work is presented under a Simplified BSD license.

88x31.png

Art assets used in Mini Sample Return Capsule were made by Matthew (CobaltWolf) Mlodzienski and are licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License.

All source files for the mod, including uncompiled textures and models, are available upon request.

 

The parachute is also broken; it does not slow it down and cannot deploy.

Share this post


Link to post
Share on other sites
On 11/19/2016 at 10:12 AM, Jso said:

 

Nope. I fiddled with this a bit and made it more to my liking. The science results transfer bit is at the bottom.

  Reveal hidden contents


@PART[SampleReturnCapsule_Parachute]
{
	// Help it fly heatshield first
	%CoPOffset = 0.0, 0.155, 0.0
	%CenterOfBuoyancy = 0.0, 0.155, 0.0
	
	// Displacement about 65 kg. Mass 100 kg + 20 kg mp.
	@buoyancy = 1.85
	!buoyancyUseSine = delete
	
	// Just like squad chutes...
	%buoyancyUseCubeNamed = PACKED
	!maximum_drag = delete
	!minimum_drag = delete
	@angularDrag = 3
	
	// Tags are buried down in the middle of the config
	//tags = mercury herms 0.625 .625 625 rcs parachute mono monopropellant
	@tags = 0.625 .625 625 rcs parachute mono monopropellant
	
	// Lower thruster power. 2kN is a lot of thrust for this
	@MODULE[ModuleRCSFX]
	{
		@thrusterPower = 0.25
		%rcsEnabled = False
	}
	
	@MODULE[ModuleParachute]
	{
		// These do nothing. Use ModuleDragModifier setting.
		//semiDeployedDrag = 
		//fullyDeployedDrag = 
		
		// Slow down deployment. Lower = slower.
		@deploymentSpeed = 0.12
	}
	
	// Less drag on the main chute
	@MODULE[ModuleDragModifier],1
	{
		//name = ModuleDragModifier
		//dragCubeName = DEPLOYED
		@dragModifier = 5
	}
	
	// There appears to be a bug in KSP where putting ModuleCommand/ModuleDataTransmitter on a
	// parachute part (with or without ModuleParachute) causes the comm system to not properly
	// start up resulting in limited probe control. The same thing happens when you add this to
	// a stock Mk-16. Only happens when this is the only ModuleCommand on the craft.
	// Allow hibernation
	@MODULE[ModuleCommand]
	{
		hasHibernation = True
		hibernationMultiplier = 0.001
	}
	
	// Switch to the standard internal probe transmitter. It doesn't transmit science, but
	// why should it.
	!MODULE[ModuleDataTransmitter] {}
	MODULE
	{
		name = ModuleDataTransmitter
		antennaType = INTERNAL
		packetInterval = 1.0
		packetSize = 2
		packetResourceCost = 12.0
		requiredResource = ElectricCharge
		antennaPower = 5000
		optimumRange = 2500
		packetFloor = .1
		packetCeiling = 5
	}
	
	// Remove. Doesn't go on probe cores
	!MODULE[ModuleScienceContainer] {}
}

@PART[SampleReturnCapsule_CargoBay]
{
	// Size0 nodes
	@node_stack_top2 = 0.0, 0.2188, 0.0, 0.0, -1.0, 0.0, 0
	@node_stack_bottom2 = 0.0, 0.0424, 0.0, 0.0, 1.0, 0.0, 0
	
	@node_stack_top = 0.0, 0.2305, 0.0, 0.0, 1.0, 0.0, 0
	@node_stack_bottom = 0.0, -0.08, 0.0, 0.0, -1.0, 0.0, 0
	
	// Displacement about 95 kg. Mass 75 kg + 50 kg ablator. I'm guessing floats = buoyancy > mass / displacement
	@buoyancy = 2.15
	!buoyancyUseSine = delete
	
	// Vertical center of part 0.07525
	@CoPOffset = 0.0, 0.2, 0.0
	@CoLOffset = 0.0, 0.0, 0.0
	@CenterOfBuoyancy = 0.0, 0.2, 0.0
	@CenterOfDisplacement = 0.0, 0.0, 0.0
	
	// 0.2 is very heavy. 1.25m service bay is 0.1. Make the bay 0.5 plus the heatshield structure 0.25. The ablator adds another 0.05
	@mass = 0.075
	
	// Size0 part
	@bulkheadProfiles = size0
	
	
	// Allow tranferring science to/from container without crew
	@MODULE[ModuleScienceContainer]
	{
		canBeTransferredToInVessel = True
		canTransferInVessel = True
		showStatus = True
	}
}

 

 

I saw the bug with the radio too. I even tried adding the same radio module to the bottom half and it still doesn't work. That's so odd

Share this post


Link to post
Share on other sites
2 minutes ago, tjt said:

I saw the bug with the radio too. I even tried adding the same radio module to the bottom half and it still doesn't work. That's so odd

I've just stopped being surprised with the strange behavior of the stock modules and started ignoring it instead.

Share this post


Link to post
Share on other sites
20 hours ago, CobaltWolf said:

I've just stopped being surprised with the strange behavior of the stock modules and started ignoring it instead.

Right. The point at which you stop being surprised at some code and just deal with it marks the border to a true high quality software. :D:P

Share this post


Link to post
Share on other sites
On 20.11.2016 at 5:07 PM, InfiniteAtom said:

CobaltWolf, I found a bug with the parachute module on the return capsule. The parachute deploys without you deploying it, meaning it is active and deployed in mid flight on launch. There is no way to cut it or stow it. There is also no way to deploy/pack it. Let me show you a screenshot of the issue:

8l5nD2B.png

 

 

Is there any chance you a mod called shadow works installed?

Share this post


Link to post
Share on other sites
6 hours ago, NeoFatalis said:

Is there any chance you a mod called shadow works installed?

I do NOT have shadow works installed.

Share this post


Link to post
Share on other sites
12 hours ago, InfiniteAtom said:

I do NOT have shadow works installed.

oh , had the same problem when I had shadow works installed and it happened because of some weird real chute config ,try to check your mods and delete the real chutes config if they have one and see if it happens again:rolleyes:

Edited by NeoFatalis

Share this post


Link to post
Share on other sites
14 hours ago, NeoFatalis said:

oh , had the same problem when I had shadow works installed and it happened because of some weird real chute config ,try to check your mods and delete the real chutes config if they have one and see if it happens again:rolleyes:

I do NOT know what realchute configs to delete.

Share this post


Link to post
Share on other sites
2 hours ago, InfiniteAtom said:

I do NOT know what realchute configs to delete.

Back them up, delete them one at a time until you delete the right one. Once you have it narrowed down, restore the others.

Share this post


Link to post
Share on other sites
7 hours ago, Spike88 said:

Back them up, delete them one at a time until you delete the right one. Once you have it narrowed down, restore the others.

Some time ago on IRC, someone had the good idea of deleting about half of the mods at a time. That way you can do it way faster.

If the issue disappears after deleting half of the mods, you know it was in the deleted half. If not, you know it was in the remaining part.

Share this post


Link to post
Share on other sites

Using stock comms (No RT) I can't get full control using the top (probe) part of this, even landed at the KSC. If I place just the two parts that come with this mod, partial control. If I add an external antennae, still only partial control. Only if I add a stock probe core I get full control, even if I then jettison the stock core.

I'm really confused with this. I've tried it on an otherwise clean install and its still the same. I've compared the config to stock probe cores and that didn't help (Though the ModuleDataTransmitter is set to 'DIRECT', whereas the other probe cores are 'INTERNAL').

 

Scratch that I've fixed it - add 'vesselType = Probe' to the config and it works. I guess without this or any other command parts on board the game doesn't know how to treat it.

Share this post


Link to post
Share on other sites
55 minutes ago, a__gun said:

Scratch that I've fixed it - add 'vesselType = Probe' to the config and it works. I guess without this or any other command parts on board the game doesn't know how to treat it.

Huh, thanks for the heads up. I'll try and upload a hotfix to Spacedock tonight.

Share this post


Link to post
Share on other sites

Hi, 

Just found this mod and really like it!
Made some tweaks like the ones above and it's perfect now.

There is just one thing that I can't seem to fix which is bothering me... and that is the re-entry.

I'm noting 2 things:

- no entry effects... the parachute part just starts glowing a little bit and that's it...
- very fast de-accelleration upon hitting the atmosphere (at 69.999m it starts slowing down really fast to the point it's only a few 100ms at 62k from a mun return trajectory with a 62k periapsis)

any clue on how to change the atmospheric drag on re-entry.

 

As a side note: I also had no control over the craft in career or science mode (sandbox was fine) and the craft was labeled as "debris" on the launchpad.
adding "vesselType = Probe" like mentioned above fixed this.

 

Edited by davidjacobs

Share this post


Link to post
Share on other sites
3 hours ago, davidjacobs said:

any clue on how to change the atmospheric drag on re-entry.

Sounds like the drag cube needs to be tweaked but that's outside of my world short of just goofing with the numbers...

Share this post


Link to post
Share on other sites
7 hours ago, davidjacobs said:

~snip~

Thank you! I hadn't realized that those fixes hadn't been included. I'll see if I can push an update out with them ASAP - things are a bit busy for me at the moment. :)

Share this post


Link to post
Share on other sites

Alright, the vesselType = Probe fix is in and Spacedock has been updated. Sorry for dragging my feet on that.

Share this post


Link to post
Share on other sites

Chute pre-deply comes out upside down. /sigh  worked before. i think i got this after realchute added.  Needed a way to deploy on mars and stock can not.

fortunately the chute does work. Just looks really strange.

Share this post


Link to post
Share on other sites

I created (well, copy and pasted) a new part for this mod. Is replaces the CargoBay module with a ScienceBox module. It would be great if you publish it with the mod.

 

PART
{
	name = SampleReturnCapsule_ScienceBox
	module = Part
	author = CobaltWolf and AlbertKermin
	
	MODEL
	{
		model = SampleReturnCapsule/Parts/SampleReturnCapsule_CargoBay
	}

	rescaleFactor = 1

	node_stack_top = 0.0, 0.2305, 0.0, 0.0, 1.0, 0.0, 1
	node_stack_bottom = 0.0, -0.08, 0.0, 0.0, -1.0, 0.0, 1
	TechRequired = survivability
	entryCost = 1000
	cost = 500
	TechRequired = landing
	entryCost = 1000
	cost = 500
	category = Science
	subcategory = 0
	title = BDB/AKI-001EDL Sample Return Device - Science Descent Segment
	manufacturer = Bluedog Design Bureau and Albert Kermin Industries
	description = After Bill tried to return some vital samples to Kerbin by "tossed (it) out aft airlock", Werner asked the engineers at AKI and BDB to come up with a small, reliable sample return capsule. This is what they came up with instead. (This is the heat shield and science box module)
	attachRules = 1,0,1,1,0
	mass = 0.2
	dragModelType = default
	maximum_drag = 0.2
	minimum_drag = 0.3
	angularDrag = 2
	crashTolerance = 14
	bulkheadProfiles = size1
	maxTemp = 2900
	heatConductivity = 0.04
	thermalMassModifier = 5.0 
	emissiveConstant = 0.95
	tags = bus contain heat hollow protect (stor therm
	
	MODULE
	{
		name = ModuleAnimateGeneric
		animationName = openBay
		actionGUIName = Toggle
		startEventGUIName = Open
		endEventGUIName = Close
		allowAnimationWhileShielded = False
		allowManualControl = False
		actionAvailable = False
		eventAvailableEditor = False
		eventAvailableFlight = False
		eventAvailableEVA = False
		eventAvailableEVA = False
	}
	
	MODULE
	{
		name = ModuleScienceContainer
		
		reviewActionName = Review Stored Data
		storeActionName = Store Experiments
		evaOnlyStorage = True // i.e. can nearby regular vessels also do this, or EVA only
		storageRange = 1.3
		canBeTransferredToInVessel = True
		canTransferInVessel = True
		showStatus = True
	}

	MODULE
	{
		name = ModuleConductionMultiplier
		modifiedConductionFactor = 0.001
		convectionFluxThreshold = 500
	}
	
	MODULE
	{
		name = ModuleJettison
		jettisonName = fairing
		bottomNodeName = bottom
		isFairing = True
		jettisonedObjectMass = 0.5
		jettisonForce = 15
		jettisonDirection = 0 0 1
		stagingEnabled = False
		checkBottomNode = True
	}	
	
	MODULE
	{
		name = ModuleAblator
		ablativeResource = Ablator
		lossExp = -7500
		lossConst = 0.1
		pyrolysisLossFactor = 6000
		reentryConductivity = 0.01
		ablationTempThresh = 500
	}
	
	RESOURCE
	{
		name = Ablator
		amount = 50
		maxAmount = 50
	}	
}

 

This is the same as ModManager Patch:

+PART[SampleReturnCapsule_CargoBay]
{
	@name = SampleReturnCapsule_ScienceBox
	
	-MODULE[ModuleCargoBay], {}
	-node_stack_top2 = dummy
	-node_stack_bottom2 = dummy

	@category = Science
	@title = BDB/AKI-001EDL Sample Return Device - Science Descent Segment
	@description = After Bill tried to return some vital samples to Kerbin by "tossed (it) out aft airlock", Werner asked the engineers at AKI and BDB to come up with a small, reliable sample return capsule. This is what they came up with instead. (This is the heat shield and science box module)
	
	@MODULE[ModuleAnimateGeneric]
	{
		allowManualControl = False
		actionAvailable = False
		eventAvailableEditor = False
		eventAvailableFlight = False
		eventAvailableEVA = False
		eventAvailableEVA = False
	}
	
	MODULE
	{
		name = ModuleScienceContainer
		
		reviewActionName = Review Stored Data
		storeActionName = Store Experiments
		evaOnlyStorage = True // i.e. can nearby regular vessels also do this, or EVA only
		storageRange = 1.3
		canBeTransferredToInVessel = True
		canTransferInVessel = True
		showStatus = True
	}
}

 

Share this post


Link to post
Share on other sites
On 7/18/2017 at 9:50 AM, LordOfMinecraft99 said:

Is this planned to be updated to 1.3?

It should work fine (it's a pure part pack)

Share this post


Link to post
Share on other sites

I think it has a really big collision box, after "splashing down" it floated/hovered above the water several meters.

Share this post


Link to post
Share on other sites
4 hours ago, Gordon Dry said:

I think it has a really big collision box, after "splashing down" it floated/hovered above the water several meters.

There's been something odd about the part that I haven't been able to track down. I've seen the following issue many times:

I build a sampler to send around the Mun/Iota. I pop it into orbit using F12 and deorbit to test its descent and it works fine. I then launch the real mission and send the sampler out to the moon. It returns to Kerbin/Gael and when I start deorbiting it rapidly slows to below 100m/s when it's still around 50km up and it slowly 'sinks' down to ground level. 

I spent hours trying to figure out what was wrong, but I'm not really a part modeler, so after lots of trial and error I just gave up. The only way to test it was to fly entire missions.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.