• 0
Sign in to follow this  
FusionItalian

T. Flight HOTAS X Controller issues

Question

Before I go into my issue, here are the specs of my machine and KSP install:

Spoiler

Computer:

Core I7-740QM

8GB RAM

Windows 10 Pro 64-bit

AMD Mobility Radeon HD 5800

T.Flight HOTAS X flight controller (With latest driver)

KSP:

1.1.3.1289 (x64)

Mods: (I have yet to update DMagic orbital science yet)

KSP: 1.1.3 (Win64) - Unity: 5.2.4f1 - OS: Windows 10  (10.0.0) 64bit
Toolbar - 1.7.12
USI Tools - 0.5.3
Zero-Point Inline Fairings - 1.0.2
AtmosphereAutopilot - 1.5.6
B9 Part Switch - 1.4.3
Chatterer - 0.9.90.1289
Color Coded Canisters - 1.5.1
Community Resource Pack - 0.5.4
Connected Living Space - 1.2.2
Contract Configurator - 1.14
DMagic Orbital Science - 1.3.0.1
CapCom Mission Control On The Go - 1.0.2.3
Contract Parser - 1.0.4
Contracts Window Plus - 1.0.6.4
Progress Parser - 1.0.5
DraggableMenu - 1.1
DraggableMenu - 1.1
Easy Vessel Switch - 1.0.2
EVA Enhancements - 1.1.1
EVA Struts - 1.0.2
EVA Transfer - 1.0.4
Firespitter - 7.3
Haystack Continued - 0.5.1
Kerbal Attachment System - 0.5.9
Kerbal Engineer Redux - 1.1.1
Kerbal Konstructs - 0.9.5
Kerbal Inventory System - 1.2.12
KSP-AVC Plugin - 1.1.6.1
Lithobrake Exploration Technologies - 0.3.6
ModularFlightIntegrator - 1.1.6
Docking Port Alignment Indicator - 6.4
NearFutureConstruction - 0.6.4
NearFutureElectrical - 0.7.5
NearFuturePropulsion - 0.7.3
NearFutureSolar - 0.6.2
NearFutureSpacecraft - 0.5.1
EVAHandrailsPackContinued - 0.2.1.1
Part Angle Display - 0.3.1.1
QuickContracts - 1.0.5
RCS Build Aid - 0.8
RealChute - 1.4.1.1
SafeChute - 2.0
ShipManifest - 5.1.1.1
SpaceY Expanded - 1.1.10
SpaceY Lifters - 1.13
StageRecovery - 1.6.4
StationPartsExpansion - 0.4
Surface Mounted Stock-Alike Lights for Self-Illumination - 1.2.4
TAC Fuel Balancer - 2.8
TarsierSpaceTechnology - 6.4
Kerbal Alarm Clock - 3.7.1
Alternate Resource Panel - 2.8.1
Transfer Window Planner - 1.5.1
TweakScale - 2.2.13
USI Core - 0.0.1
Asteroid Recycling Tech - 0.8.4
USI Exploration Pack - 0.5.4
Freight Transport Tech - 0.5.4
Karibou - 0.2.4
Kolonization Core - 0.2.4
UKS - 0.31.12
Konstruction - 0.1
USI Survivability Pack - 0.5.4
UKS - 0.40.4
Waypoint Manager - 2.5.3
WernherChecker - 0.4.1
[x] Science! - 4.0

And as far as the issue goes:

I go into the "Input" settings and set all my joystick controls appropriately, however when I go into a game and try to fly my craft, the throttle (when the throttle is centered out) the game is showing that the ships throttle is maxed out.  Then when I push my throttle to max, the ships throttle goes to slightly below 50%, and when I pull the throttle back the ship goes to 100% throttling.  Even when I inverse the controls, I am not able to go from 0% - 100% throttle.  Does anyone know how to properly configure this joystick without having to inverse the controls, and so it goes from 0% to 100%?

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

I use the stick myself.

First off all, you do need to invert the thrust axis, and I don't understand why you don't like the idea.

Second, problem with 0-100 ranging is usually fixed by standard Windows joystick calibration tools, you can google those easily. Also, making sure that you have zero deadzone and standard 1.0 sensitivity for thrust axis in KSP input settings may help.

Edited by Boris-Barboris

Share this post


Link to post
Share on other sites
  • 0
41 minutes ago, Boris-Barboris said:

I use the stick myself.

First off all, you do need to invert the thrust axis, and I don't understand why you don't like the idea.

Second, problem with 0-100 ranging is usually fixed by standard Windows joystick calibration tools, you can google that easily. Also, making sure that you have zero deadzone and standard 1.0 sensitivity for thrust axis in KSP input settings may help.

So how did you do the input in the settings area?  I have tried starting with my throttle all the way towards me, and then pushing it forward and accepting and applying the settings; As well as starting from the throttle centered and then just pushing it forward and saving those settings, I have tried starting with it all the way forward and pulling it back, and again saving that setting.  With the sensitivity at 1.0 and a zero deadzone.   But to no avail have I been able to get it to where my throttle controller will properly throttle my craft up/down (0-100) properly.  Also to note, I have calibrated my controller within the calibration tool, to where the Z-axis is green on the bottom half and white on the top half, and to where that properly shows the exact position that I have my controller in.  Should I try using AFBW?

Share this post


Link to post
Share on other sites
  • 0

My bad, I've got sensitivity on 0.84 and deadzone at 0.00. Axis is inverted.

Well, maybe AFBW may help, but I personally don't experience issues you describe. Moving the axis is irrelevant for KSP settings, it simply detects the axis afaik and binds to it, it does not perform any form of calibration on it's own.

Share this post


Link to post
Share on other sites
  • 0
46 minutes ago, Boris-Barboris said:

My bad, I've got sensitivity on 0.84 and deadzone at 0.00. Axis is inverted.

Well, maybe AFBW may help, but I personally don't experience issues you describe. Moving the axis is irrelevant for KSP settings, it simply detects the axis afaik and binds to it, it does not perform any form of calibration on it's own.

Thanks for the information.  After I installed AFBW, and callibrated that, and then set a throttle preset, with they Joy 2 axis, and then inverted it, I am able to properly use my flight stick.  

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this