Jump to content

Normalmaps and mipmapping


Recommended Posts

So I finally got my normalmaps to work correctly but I'm noticing that it's very "pixelated"  for lack of a better word. More like a scrambled TV at certain angles. I don't know if I need to use the mipmap fade option (Or mipmaps at all) or if I need to just tone down the detail of my normalmaps and turn up the blur slightly.  I plan on trying out what I can but if someone can point me in the right direction I would greatly appreciate it.  @NathanKell I have seen your name pop up in a few Google searches related to normalmaps and such. Have any pointers that could help me and potentially other out? 

Edited by Berlin
Link to comment
Share on other sites

1 hour ago, nli2work said:

use higher res for normal maps. 1024 at least. you can get away with 512 if there aren't much small details. Keep thin lines parallel or horizontal will help with the aliasing a lot.

All of the normalmaps are 1024 and all lines are horizontal and vertical. Would blurring the NRM help? Or turning down the detail? 

Link to comment
Share on other sites

Just now, CobaltWolf said:

You could try reducing the severity of the normal maps (ie bringing the contrast down and bringing things closet to 50% gray)

What do you mean? They export as grayscale for me and not a lot of contrast.  The only I can think of is my textures are too detailed which means little vertical and horizontal lines which cause aliasing

Link to comment
Share on other sites

Just now, Berlin said:

What do you mean? They export as grayscale for me and not a lot of contrast.  The only I can think of is my textures are too detailed which means little vertical and horizontal lines which cause aliasing

Can you post your normal map?

Link to comment
Share on other sites

4 minutes ago, nli2work said:

did you use Unity's generate normal from gray scale option? If so that would explain what you're getting and how you fixed it.

No I'm using Nvidias dds plugin for photoshop 

Link to comment
Share on other sites

22 hours ago, Kartoffelkuchen said:

In Unity, when setting the texture to "normal map"; there's a checkbox below, saying something like "create from blablabla". Uncheck that and you'll be fine.

Thanks I was wondering that myself.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...