Galileo

[KSP 1.4.2] Stock Visual Terrain [v2.1.4] [01 April 2018]

Recommended Posts

Just now, OhioBob said:

OPM has its own visual enhancement mod:

 

Only for atmospheric effects I thought

Share this post


Link to post
Share on other sites
Just now, nsgallup said:

Only for atmospheric effects I thought

Oh, maybe.  If so, then never mind.

Share this post


Link to post
Share on other sites
3 minutes ago, 4x4cheesecake said:

Textures for OPM in Stock Visual Terrain? I would be quiet surprised ;)

Stock Visual Effects has it.

Share this post


Link to post
Share on other sites
2 hours ago, nsgallup said:

Any plans to include textures for OPM?

OPM already uses CTTP which is almost exactly like SVT.

Share this post


Link to post
Share on other sites

Eyy, Galileo. I was thinking about touching up the texturemap used for Gregox's Duna Restoration Project to be "SVT-Styled" so to speak, so I was just wondering if the detailmaps baked into the planet textures were used separately as bumpmaps in the files. I don't know how to articulate wording that any better.

Share this post


Link to post
Share on other sites
10 hours ago, sugarblood said:

Eyy, Galileo. I was thinking about touching up the texturemap used for Gregox's Duna Restoration Project to be "SVT-Styled" so to speak, so I was just wondering if the detailmaps baked into the planet textures were used separately as bumpmaps in the files. I don't know how to articulate wording that any better.

I don't know the answer to your question but I imagine looking inside SVT's folders, textures, and configs for the answer would be fruitful.

Share this post


Link to post
Share on other sites
53 minutes ago, GregroxMun said:

I don't know the answer to your question but I imagine looking inside SVT's folders, textures, and configs for the answer would be fruitful.

It's a question unnecessary to be answered anyways - I made a sufficient looking map/orbit texture. The only problem now is figuring out making the terrain itself - SVT runs off of PQSLandControl, and Duna Restoration off of Vertex heightmaps.

Edited by sugarblood

Share this post


Link to post
Share on other sites
54 minutes ago, sugarblood said:

It's a question unnecessary to be answered anyways - I made a sufficient looking map/orbit texture. The only problem now is figuring out making the terrain itself - SVT runs off of PQSLandControl, and Duna Restoration off of Vertex heightmaps.

They both use both, my dude.

Share this post


Link to post
Share on other sites
Just now, GregroxMun said:

They both use both, my dude.

Ok yeah, I get that. What I meant to say was that SVT runs "removePQSMods" on PQSlandcontrol, while your work does so on the vertexes.

Trying to just put in both clauses and stitch the land control like frankenstein's monster is well proven not to work, as it causes multiple Bad Things (trademark) including the atmosphere being annihilated, suborbital trajectories skipping around when onrails-warped, and the abyss opening up to devour your astronaut's spacecraft and lock it's rate of speed in place when procedural terrain stars to load in.

Share this post


Link to post
Share on other sites

Hi! I have an issue with Kerbin ground texture, it's black. https://i.imgur.com/OKFY8io.jpg

How should I fix this? Other celestial bodies have no such issues.

My modlist:

https://i.imgur.com/jLiZTER.jpg

https://i.imgur.com/cgSlAcE.jpg

Share this post


Link to post
Share on other sites

@Runolite Try this  :

Edit this file with text editor : SVT\configs\Kerbin.cfg

At the end of the file, change this :

SpaceCenter
{
	groundColor = 0.444,0.494,0.294,0.23
	groundTexture = SVT/textures/PluginData/grass00.dds
}

to this :

%SpaceCenter
{
	groundColor = 0.444,0.494,0.294,0.23
	groundTexture = SVT/textures/PluginData/grass00.dds
}

If this doesn't work, please open your "ModuleManager.ConfigCache" file with a text editor, search for the "SpaceCenter{...}" node and post it here.

Also do you have Sigma Dimensions installed ? There is known issue with it.

Edited by Gotmachine

Share this post


Link to post
Share on other sites

    @Gotmachine

Thanks, but unfortunately it didn't worked.

Module Manager Cache:

Quote

SpaceCenter
            {
                groundColor = 0.444,0.494,0.294,0.23
                groundTexture = SVT/textures/PluginData/grass00.dds
            }

And yes, I'm using Sigma Dimensions with 4x rescale.

Share this post


Link to post
Share on other sites

@Runolite Ok so forget about the first edit, revert it to the initial syntax.

The bug with Sigma Dimensions is a silly one : SigDim should be applied after SVT, but since the loading order is alphabetical things get screwed up. The fix should come from SigDim but Sigma88 is waiting for BlowFish to implement a :LAST ModuleManager feature so he can fix this.

What you need to do is open ALL *.cfg files in the SVT\configs folder and edit the first line : change the "[SVT]" label to "[RSVT]".

Share this post


Link to post
Share on other sites

@Gotmachine

 

Quote

What you need to do is open ALL *.cfg files in the SVT\configs folder and edit the first line : change the "[SVT]" label to "[RSVT]".

I did than an now Kopernicus sents me this and none of my savegames loads neither I can start a new game, just an infinite loading screen.

6Lh0fcW.jpg

 

Edited by Runolite

Share this post


Link to post
Share on other sites

compatible with 1.5.1?

 

 

  • Like 2

Share this post


Link to post
Share on other sites

Seems like this doesn't work on 1.5.1 with the latest version of Kopernicus, or maybe I just installed it wrong, but I'm pretty sure everything is in it's place

  • Like 1

Share this post


Link to post
Share on other sites

I am running EVE, SVE, Kopernicus, and SVT together. I've narrowed it down to SVT strangely after spending hours. Everytime SVT is installed the city lights disappear or create this weird white blocky images. When I remove it then the city lights go back to normal. I can't even find where SVT would be affecting the city lights unless it's Kopernicus has an issue and it only shows up when it is actually being used (by  SVT). Any ideas?

Share this post


Link to post
Share on other sites

For me SVT features simply don't appear in 1.5.1 with most current version installed. I'm not experiencing any other bugs from it. But I would REALLY appreciate a 1.5 update :) fingers crossed! 

  • Like 1

Share this post


Link to post
Share on other sites
On 11/21/2018 at 7:39 AM, avalancha said:

For me SVT features simply don't appear in 1.5.1 with most current version installed. I'm not experiencing any other bugs from it. But I would REALLY appreciate a 1.5 update :) fingers crossed! 

did you installed kopernicus? if not you need to.

for me in 1.5.1 its kind of working
that means that the textures from planets and moons get applied and look ok
the mountains at KSC look very ugly so i think we need to have to wait for an update.
the city lights from kerbin are gone.
not sure if its an kopernicus or svt issue

Edited by mrvice

Share this post


Link to post
Share on other sites
41 minutes ago, mrvice said:

... i think we need to have to wait for an update...

 

Exactly.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now