linuxgurugamer

[1.8.x] Hullcam VDS Continued

Recommended Posts

21 minutes ago, Kreetcha said:

I am sure there are plenty of knowledgeable people on this forum that would love to help you! All you have to do is ask.

There are a lot of us out there that consider this mod very necessary to play the game from inside the cockpit with RPM or for cinematic use, and we all really appreciate the hard work you are doing to keep this and all the other wonderful mods you have adopted alive!

Thanks and good luck! ^.^

I already have asked

Share this post


Link to post
Share on other sites
On 10/18/2016 at 9:44 PM, linuxgurugamer said:

I already have asked

Thanks to @Ser, I have a working version of HullcamVDS. Testing now, expect a release Soon (™)

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

One question. How do two mods interact with eachother. As I do remember "HullCamVDS" had first person view, but what happens if you add "Through The Eyes Of A Kerbal (1st person EVA) continued" to the mix? Can they coexist? I persume that there should be no conflict (C button and clicking on kerbal). But you can never be too sure. I'll check it probably, but perhaps some of you may already know the answer.

Share this post


Link to post
Share on other sites
6 hours ago, Ald said:

One question. How do two mods interact with eachother. As I do remember "HullCamVDS" had first person view, but what happens if you add "Through The Eyes Of A Kerbal (1st person EVA) continued" to the mix? Can they coexist? I persume that there should be no conflict (C button and clicking on kerbal). But you can never be too sure. I'll check it probably, but perhaps some of you may already know the answer.

That is a very interesting question, and I'm eagerly awaiting your checking this :D

 

Share this post


Link to post
Share on other sites
6 hours ago, Ald said:

One question. How do two mods interact with eachother. As I do remember "HullCamVDS" had first person view, but what happens if you add "Through The Eyes Of A Kerbal (1st person EVA) continued" to the mix? Can they coexist? I persume that there should be no conflict (C button and clicking on kerbal). But you can never be too sure. I'll check it probably, but perhaps some of you may already know the answer.

Given that @Ser rebooted that mod and helped get this mod back up and running, any conflicts between the two would be rather ironic

@linuxgurugamer the download is bundled weird, the OP still says "(for 1.1.3)" in the download link and it has two different MM files in it but no ReadMe. Are you saying it's still working under 1.1.3 and you just have to be sure to use the relevant MM file?

Edited by Drew Kerman

Share this post


Link to post
Share on other sites
12 minutes ago, Drew Kerman said:

Given that @Ser rebooted that mod and helped get this mod back up and running, any conflicts between the two would be rather ironic

@linuxgurugamer the download is bundled weird, the OP still says "(for 1.1.3)" in the download link and it has two different MM files in it but no ReadMe. Are you saying it's still working under 1.1.3 and you just have to be sure to use the relevant MM file?

No, it's a 1.2 download

I'll have to fix that

12 minutes ago, Drew Kerman said:

Given that @Ser rebooted that mod and helped get this mod back up and running, any conflicts between the two would be rather ironic

@linuxgurugamer the download is bundled weird, the OP still says "(for 1.1.3)" in the download link and it has two different MM files in it but no ReadMe. Are you saying it's still working under 1.1.3 and you just have to be sure to use the relevant MM file?

Umm, I just downloaded it from Spacedock, I only see a single MM file in it.  Unless I'm looking at something different, can you be a bit more specific?

and I just updated the OP

7 minutes ago, linuxgurugamer said:

No, it's a 1.2 download

I'll have to fix that

Umm, I just downloaded it from Spacedock, I only see a single MM file in it.  Unless I'm looking at something different, can you be a bit more specific?

and I just updated the OP

Oh, I see.  The earlier one will be ignored, but I'll get that fixed

Edit:  New version up: 0.1.2.1 with extra MM dll removed

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites
28 minutes ago, Drew Kerman said:

Given that @Ser rebooted that mod and helped get this mod back up and running, any conflicts between the two would be rather ironic

I haven't tested what @Ald is asking about but I can assume that there surely will be conflicts between the two mods if their 1st person modes are activated simultaneously but they will possibly work fine if only one of them is in the 1st person mode.

Share this post


Link to post
Share on other sites

Awesome stuff, thank you for updating this. This mod, along with Rasterpropmonitor, really make IVA flight doable. It's at the top of my mod list. :)

Share this post


Link to post
Share on other sites
17 hours ago, linuxgurugamer said:

1.2 released for 1.2

Thanks to @Ser for some assistance

Woohooo!  Thanks linuxgamer! :D

Share this post


Link to post
Share on other sites

That is strange, but I have no way to activate these cameras. But they show some pictures in RPM displays.

Trying to figuring out what is wrong I looked into zip file and can't see any plugin dll here. Is it missing?

 

EDIT: Found it in previous release Zip on GitHub. But looks like "latest/current" doesn't have on on GitHub or SpaceDock.

Edited by ThirdOfSeven

Share this post


Link to post
Share on other sites
4 hours ago, ThirdOfSeven said:

That is strange, but I have no way to activate these cameras. But they show some pictures in RPM displays.

Trying to figuring out what is wrong I looked into zip file and can't see any plugin dll here. Is it missing?

 

EDIT: Found it in previous release Zip on GitHub. But looks like "latest/current" doesn't have on on GitHub or SpaceDock.

Bad build, look for an update in a few minutes:  0.1.2.2

Share this post


Link to post
Share on other sites

You have no idea how happy I am to see that HullcamVDS is up and running! This is one of my favorite mods for immersion and screenshots, it just adds so much especially in conjunction with RasterPropMonitor. Thanks a million @linuxgurugamer and @Ser !

Just a quick question: I'd like to remap the keys used to cycle the cameras and I understand I have to edit the CFG file in the mod folder. However, I don't know the syntax used in KSP for key bindings, is there any documentation I could check to know what to write? I have an AZERTY keyboard, being French, and it gets quite tricky without a keymap of sorts. Thanks in advance :)

Share this post


Link to post
Share on other sites

On my keyboard, that would be the set of two keys right under the default ones (which I use to switch between active vessels). On my AZERTY keyboard, they are labelled ^ and $.

Here's a link to my mapping 2000px-Azerty_fr_laptop.svg.png

You can see the two keys between the letter P and Enter. I don't know what they are called in the game syntax :)

Share this post


Link to post
Share on other sites

Hi @linuxgurugamer, thanks for keeping this mod up to date!

I'm currently having the same problem that was reported a month or so back by @Beeso3

KSP: 1.2.0.1586 MacOSX 64bit

Problem: Certain cameras that require shaders only show as a black screen when switched to; other cameras operate as normal

Mods installed:

Hullcam VDS Continued 0.1.2.2

Module Manager 2.7.2

Reproduction steps:

Using a NavCam, BoosterCam, Kazzelblad 500 or NightvisionCam in the flight scene

Log:

https://www.dropbox.com/s/sobitg69hpflt8c/Player.log.zip?dl=0

 

I understand that it is more likely a problem with me running the game on Mac, so I'm not expecting you to just simply resolve it. Thank you for all of your mod work man :)

Share this post


Link to post
Share on other sites

Hey @linuxgurugamer, Ive found an issue with some of cameras when used with RPM.

KSP: 1.2.0.1586 (WindowsPlayer x64)

Problem: The following cameras have issues when trying to view them from within RPM:

Wide Angle Cam = black screen (within the RPM screen that is)

Kazzelblad 500 = no option to assign a camera ID from right click menu and RPM does not appear to recognize it as a camera

Nightvisioncam = gives two Camera IDs and two sets of ID + / ID -.  Only the first one appears to work.  The image is also plain (ie not green)

NavCam = image is plain and no fisheye effect

BoosterCam = only one Camera ID and One set of ID +/-.  The dashed lines that normally run down the center of the image in both the horizontal and vertical direction do not show (not that im complaining.  never particularly cared for those lines myself)

KerbPro = image in RPM is rotated by 90 degrees counter clockwise

Mods installed:

HullCameraVDS 0.1.2.2

RasterPropMonitor 0.28.0.29319

Reproduction steps:

View any of the above cameras from within RPM (was only tested at the launch pad)

Log:

https://drive.google.com/file/d/0BzsZI1NOlHQpSTlhZllCNnYxQk0/view?usp=sharing

Extra Notes:

This was not a clean install.  All mods were deleted from the gamedata folder except the Squad and the single modulemanager.2.7.2.dll file.  HullCameraVDS and RasterPropMonitor were both redownloaded and installed for this test.

All of the cameras worked via the parts own right click menu and/or the cycle camera hotkeys (not in RPM... just to be clear)

Only the Mk1-2 command module was used and all cameras were attached to a  Modular Girder Segment XL or the command module itself.

***Thanks again @linuxgurugamer for keeping all of these mods alive.  I dont know how you do it honestly.  Are you the one stealing all the NASA engineered Wheaties :wink:?

Share this post


Link to post
Share on other sites

It actually seems to be a problem in RPM.  It's RPM which puts the Camera ID on the camera.

I haven't tested with RPM, since it's still in beta.  I'll post this in the RPM forums

Pinging @MOARdV

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites
1 hour ago, linuxgurugamer said:

It actually seems to be a problem in RPM.  It's RPM which puts the Camera ID on the camera.

I haven't tested with RPM, since it's still in beta.  I'll post this in the RPM forums

Pinging @MOARdV

Found most of the problem in a cfg included with Hullcam

Share this post


Link to post
Share on other sites

Just released new version:  0.1.3:

    Copied patch from RPM 
    Fixed patches for cameras in RPM
    Fixed Telescopes
    Fixed various offsets and rotations
    fixed names in files, so that L-Tech will now have the same camera name as Hullcam
    Got all cameras working with RP

Share this post


Link to post
Share on other sites

HullcamVDS is perfect for launch pad and 'riding the booster' cinematics :)
 

 

Share this post


Link to post
Share on other sites

Maybe I am completely lost for no reason, but how does one even enter the camera views? They have no action groups, and when right-clicked in flight the only options are "aim camera", "autostrut", and camera ID (+ or -). As far as I can tell, there is no button or control (not even on this page description) to tell one how to enter the camera mode. Please help.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.